Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

DHCP Relay Agent funktioniert nicht

Frage Netzwerke LAN, WAN, Wireless

Mitglied: Valexus

Valexus (Level 2) - Jetzt verbinden

13.01.2015, aktualisiert 13:09 Uhr, 1565 Aufrufe, 12 Kommentare

Hallo an alle Administratoren,

ich bin gerade in der Umstellung des DHCP Servers von unserem Router auf einen Windows Server 2012R2.
Leider habe ich aktuell noch ein Problem mit der Einrichtung von DHCP Relay auf dem Router.
Aktuell gibt es bei uns 3 VLANS (40,42,60) welche von einem Windows Server 2012R2 mit DHCP versorgt werden.
Dazu wurden auf dem Server 3 virtuelle Schnittstellen mit den dazu gehörigen VLAN-IDs konfiguriert, damit dieser in jedes Netz kommt.

Übersicht:
0d0157020371f5057bd3e23bdb05abca - Klicke auf das Bild, um es zu vergrößern

Das is natürlich unschön, deshalb möchte ich das über ein DHCP Relay am Router lösen.
Dazu habe ich die Interfaces für VLAN40 und VLAN42 am Server deaktiviert um alles über die 192.168.60.250 zu vergeben.
Leider bekommen mein Clients an einem Untagged VLAN40 Port am Switch dann keine IP Adresse mehr.

Ich habe mich an folgende "Anleitung" direkt von DrayTek gehalten:
How to Use DHCP Relay over LAN?

Hab ich irgend etwas falsch verstanden in Bezug auf DHCP Relay oder wo liegt mein Fehler?

Vielen Dank vorab!

VG
Valexus
Mitglied: SlainteMhath
13.01.2015 um 10:54 Uhr
Moin,

Hab ich irgend etwas falsch verstanden in Bezug auf DHCP Relay oder wo liegt mein Fehler?
DHCP arbeite mit Broadcasts... wenn du die Interfaces deaktivierst bekommen die Clients auch keine IP Adressen zugewiesen.

Dazu habe ich die Interfaces für VLAN40 und VLAN42 am Server deaktiviert um alles über die 192.168.60.250 zu vergeben.
Das verstehe ihc nicht ganz... die Clients sollen doch sicher immer eine IP Adresse aus dem Subnetz/VLAN bekommen in dem sie sich gerade befinden, oder?

lg,
Slainte
Bitte warten ..
Mitglied: emeriks
13.01.2015 um 11:08 Uhr
Hi,
Zitat von Valexus:
Leider bekommen mein Clients an einem Untagged VLAN40 Port am Switch dann keine IP Adresse mehr.
Die Gegenprobe hast Du gemacht? Also ein tagged Client in VLAN40 bekommt eine Adresse vom DHCP?
Falls ja, dann muss das am Router liegen.
Falls auch nein, dann sniffer mal am DHCP-Server, ob da überhaupt entsprechene Anfragen ankommen.

Die Scopes auf dem DHCP-Server sind aber ok? Also Adressbereich + Maske je Scope?
Und der DHCP Server ist an das Interface im LAN60 gebunden?

E.
Bitte warten ..
Mitglied: Valexus
13.01.2015 um 11:09 Uhr
Hallo Slainte,

DHCP arbeite mit Broadcasts... wenn du die Interfaces deaktivierst bekommen die Clients auch keine IP Adressen zugewiesen.
Das ist mir bewusst, jedoch müsste ja dann in diesem Fall das Relay, sprich der Router, mit dem DHCP Server kommunizieren oder?

Das verstehe ihc nicht ganz... die Clients sollen doch sicher immer eine IP Adresse aus dem Subnetz/VLAN bekommen in dem sie sich gerade befinden, oder?
Genau! Ich kann am Router für jedes VLAN einen DHCP Server sowie eine Agent IP konfigurieren, damit der DHCP weis von welchem VLAN/Subnetz die Anfrage kommt.
So hab ich das Thema DHCP Relay zumindest verstanden.

VG
Valexus
Bitte warten ..
Mitglied: Valexus
13.01.2015 um 11:14 Uhr
Hallo emeriks,

Die Gegenprobe hast Du gemacht? Also ein tagged Client in VLAN40 bekommt eine Adresse vom DHCP?
Falls ja, dann muss das am Router liegen.
Falls auch nein, dann sniffer mal am DHCP-Server, ob da überhaupt entsprechene Anfragen ankommen.
Nein hab leider keine Clients die ich tagged testen kann.
Hast du eine kurze Anleitung zu dem Thema DHCP Sniffen?

Die Scopes auf dem DHCP-Server sind aber ok? Also Adressbereich + Maske je Scope?
Und der DHCP Server ist an das Interface im LAN60 gebunden?
Dürfte passen ja, bzw. funktioniert es ja auch wenn der Server direkt mit einem Interface in den VLANs ist.

VG
Valexus
Bitte warten ..
Mitglied: Pjordorf
LÖSUNG 13.01.2015, aktualisiert 28.04.2015
Hallo,

Zitat von Valexus:
Hast du eine kurze Anleitung zu dem Thema DHCP Sniffen?
Mit Wireshark ein Capture auf die UDP Ports 67 (Server / DHCP Relay) und UDP 68 (Client) machen. Dem DHCP Server kannst du aber auch noch Protokolle entnehmen sofern eingestellt.

Gruß,
Peter
Bitte warten ..
Mitglied: Valexus
13.01.2015 um 11:50 Uhr
Hallo Pjordorf,

Mit Wireshark ein Capture auf die UDP Ports 67 (Server / DHCP Relay) und UDP 68 (Client) machen. Dem DHCP Server kannst du aber
auch noch Protokolle entnehmen sofern eingestellt.
Ich sehe leider nur "DHCP Discover Transactions" und somit keine Antwort vom Relay

Ist denn der Grundgedanke von mir Richtig? Slainte hat mich da jetzt etwas verwirrt...

VG
Valexus
Bitte warten ..
Mitglied: SlainteMhath
LÖSUNG 13.01.2015, aktualisiert um 13:09 Uhr
Ok nochmal langsam.

Du musst...
... am Server für jedes VLAN einen Scope mit korrekter Subnetzmaske konfigueiren.
... am Router für jedes VLAN einen Agent konfigurieren der auf den DHCP Server "zeigt"

/EDIT: Die IP des Relay Agents muss dabei aus dem gleichen Subnetz stammen wie die IPs die vergeben werden sollen.

Nur dann bekommen die Clients in den VLAN ihre (korrekten) IPs zugewiesen.
Bitte warten ..
Mitglied: emeriks
LÖSUNG 13.01.2015, aktualisiert um 13:09 Uhr
Slainte hat mich da jetzt etwas verwirrt...
Ja, mich auch ....

Ist denn der Grundgedanke von mir Richtig?
Ja.
Ich kenne jetzt diesen Draytek nicht, aber ich vermute, er wird wirklich nur innerhalb des jeweiligen VLAN DHCP Relay spielen.

Dabei fällt mir ein:
Was meinst Du eigentlich mit ...?
an einem Untagged VLAN40 Port
Hast Du den Port jetzt fest einem VLAN zugeordnet oder meinst Du, dass die Zuweisung über die am Client eingetragene VLAN-ID erfolgen soll?

E.
Bitte warten ..
Mitglied: Valexus
13.01.2015 um 12:48 Uhr
Du musst...
... am Server für jedes VLAN einen Scope mit korrekter Subnetzmaske konfigueiren.
... am Router für jedes VLAN einen Agent konfigurieren der auf den DHCP Server "zeigt"

/EDIT: Die IP des Relay Agents muss dabei aus dem gleichen Subnetz stammen wie die IPs die vergeben werden sollen.

Nur dann bekommen die Clients in den VLAN ihre (korrekten) IPs zugewiesen.
Also ich hab folgendes Eingestellt:

Windows Server 2012R2:
VLAN40
IPs: 192.168.40.11-100
GW: 192.168.40.10
SN: 255.255.255.0
NS: 192.168.60.250

VLAN42
IPs: 192.168.42.11-100
GW: 192.168.42.10
SN: 255.255.255.0
NS: 192.168.60.250

VLAN60
IPs: 192.168.60.11-20
GW: 192.168.60.10
SN: 255.255.255.0
NS: 192.168.60.250

DrayTek:
Relay VLAN40
DHCP Server Location VLAN60
DHCP Server IP: 192.168.60.250
DHCP Relay Agent IP: 192.168.40.1

Relay VLAN42
DHCP Server Location VLAN60
DHCP Server IP: 192.168.60.250
DHCP Relay Agent IP: 192.168.42.1

Dabei fällt mir ein:
Was meinst Du eigentlich mit ...?
> an einem Untagged VLAN40 Port
Hast Du den Port jetzt fest einem VLAN zugeordnet oder meinst Du, dass die Zuweisung über die am Client eingetragene VLAN-ID
erfolgen soll?
Der Port ist am Switch fest dem VLAN40 zugeordnet, nur eben untagged damit jeder Client dort funktioniert.

Das Gateway in allen VLANs ist bei mir der Netgear Switch, damit das VLAN Routing funktioniert. Dieser kann aber kein DHCP Relay.
Könnte es sein, dass es damit Probleme gibt und ich dafür einen Layer3 Switch benötige?

VG
Valexus
Bitte warten ..
Mitglied: Valexus
13.01.2015, aktualisiert um 13:08 Uhr
Verdammt ich hab das Problem gefunden!

Wenn das GW auf dem DHCP Server sowie in den DHCP-Bereichsoptionen auf den Switch gestellt ist, dann funktioniert es nicht.
Stelle ich das GW in beiden fällen auf den Router funktioniert es...
Leider funktioniert dann das VLAN Routing nicht mehr und der ganze Traffic zwischen den VLANs wird über den Router geleitet

Dann komme ich wohl nicht um einen zentralen Layer3 Switch herum.
Bitte warten ..
Mitglied: SlainteMhath
13.01.2015 um 13:10 Uhr
Evtl. hat der Switch "Schutz"Funktionen gg. DHCP spoofing oder ähnliches? oder er hat selbst einen DHCP Agent/Helper?
Bitte warten ..
Mitglied: Valexus
13.01.2015, aktualisiert um 13:48 Uhr
Hat er prinzipiell, diese waren aber deaktiviert, eine DHCP Relay Funktion hat er leider nicht.
Sobald der DHCP Server als GW den Switch eingetragen hat ist keine IP Vergabe über den Router möglich.
Da werde ich mit meinen 3 Virtuellen Interfaces in jedes VLAN erstmal leben müssen und in Zukunft einen Cisco SG300 kaufen.
Danke für eure Antworten und Hilfe!
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Netzwerkmanagement
gelöst HP 1920 24G Switch QOS-Problem bei Portzuweisung mit DHCP Relay (2)

Frage von farbschmelz zum Thema Netzwerkmanagement ...

LAN, WAN, Wireless
gelöst Kein DHCP-Relay am Sub-Switch HP (20)

Frage von westberliner zum Thema LAN, WAN, Wireless ...

Netzwerke
gelöst Accesspoint an Fritzbox funktioniert nicht ohne eigenen DHCP Server (5)

Frage von max-funk zum Thema Netzwerke ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...