Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

DHCP Server vergibt falschen DNS Server.

Frage Microsoft Windows Netzwerk

Mitglied: Schupa

Schupa (Level 1) - Jetzt verbinden

28.05.2013 um 08:21 Uhr, 8231 Aufrufe, 18 Kommentare, 2 Danke

Guten Tag zusammen,

ich habe vor kurzem unsere Domäne (Server 2003) einen weiteren DC ( 2008 R2 ) hinzugefügt.
Beide Server agieren als DHCP & DNS Server, gleiches Netz unterschiedlicher Adressraum.
Bezieht ein Client vom neuen DC nun eine Netzwerkkonfiguration, so werden alle Parameter richtig übergeben,
nur nicht der DNS Server, dort wird der des alten DC eingetragen. Obwohl expliziet in der DHCP Konfiguration der neue DNS Server hinterlegt ist. Die Konfiguration des DNS Servers über die GPOs konnte bereits ausgeschlossen werden,
vielleicht hat ja jemand einen Tipp

- Patrick
Mitglied: Hakketas
28.05.2013, aktualisiert um 08:39 Uhr
DHCP -> IPv4 -> Serveroptionen -> DNS-Server
DHCP -> IPv4 -> Bereich -> Bereichsoptionen -> DNS-Server
Alle IPs richtig eingetragen?

Evtl. auf den betroffenden Clients ein ipconfig /flushdns und /renew durchführen
Bitte warten ..
Mitglied: certifiedit.net
28.05.2013 um 09:17 Uhr
Hallo,

logisch, die Basics sagen, dass ein DHCP Server eine fixe IP haben muss. Diese beinhaltet, gerade bei einem DNS Server auch immer ein Verweis auf sich selbst.

Grüße
Bitte warten ..
Mitglied: diekoenigs
28.05.2013 um 09:20 Uhr
Ich denke dann ist das gelöst.. oder? ;)

Gruß
Alex
Bitte warten ..
Mitglied: Schupa
28.05.2013 um 16:22 Uhr
Ja, der DHCP Server ist richtig konfiguriert. Obwohl im DHCP der richtige DNS Server hinterlegt ist, vergibt er beim Lease die IP Adresse des alten DNS Server.
Bitte warten ..
Mitglied: Schupa
28.05.2013 um 16:23 Uhr
Der DHCP Server hat eine feste IP-Adresse und auch der DNS Verweis wurde richtig gesetzt.
Bitte warten ..
Mitglied: certifiedit.net
28.05.2013 um 16:27 Uhr
Dann poste mal ein ipconfig /all
Bitte warten ..
Mitglied: certifiedit.net
28.05.2013 um 16:42 Uhr
nur text, bitte.
Bitte warten ..
Mitglied: diekoenigs
28.05.2013 um 16:56 Uhr
IP address "129.10.10.9" is located @ United States Massachusetts Boston

Oha... ick hör dir trapsen..
Bitte warten ..
Mitglied: Schupa
28.05.2013 um 17:14 Uhr
Mir ist folgendes aufgefallen,
nachdem ich /release /renew & /flushdns ausgeführt habe, so hat der Client kurzzeitig die richtig Konfiguration:

Windows-IP-Konfiguration

Hostname . . . . . . . . . . . . : xxx
Primäres DNS-Suffix . . . . . . . :
Knotentyp . . . . . . . . . . . . : Hybrid
IP-Routing aktiviert . . . . . . : Nein
WINS-Proxy aktiviert . . . . . . : Nein
DNS-Suffixsuchliste . . . . . . . : intern.xxx.de

Ethernet-Adapter LAN-Verbindung:

Verbindungsspezifisches DNS-Suffix: intern.xxx.de
Beschreibung. . . . . . . . . . . : vmxnet3 Ethernet Adapter
Physikalische Adresse . . . . . . : 00-50-56-B6-58-23
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
Verbindungslokale IPv6-Adresse . : fe80::2cd3:677d:1f1e:6eb5%11(Bevorzugt)
IPv4-Adresse . . . . . . . . . . : 129.10.10.158(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
Lease erhalten. . . . . . . . . . : Dienstag, 28. Mai 2013 16:58:25
Lease läuft ab. . . . . . . . . . : Dienstag, 28. Mai 2013 17:58:33
Standardgateway . . . . . . . . . : 129.10.10.3
DHCP-Server . . . . . . . . . . . : 10.151.80.11
DHCPv6-IAID . . . . . . . . . . . : 234901590
DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-19-2C-DA-22-00-50-56-B6-58-23

DNS-Server . . . . . . . . . . . : 10.151.80.11 <----------------- richtiger DNS Server
NetBIOS über TCP/IP . . . . . . . : Aktiviert

Tunneladapter isatap.intern.xxx.de:

Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix: intern.xxx.de
Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter
Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja

Tunneladapter 6TO4 Adapter:

Verbindungsspezifisches DNS-Suffix: intern.xxx.de
Beschreibung. . . . . . . . . . . : Microsoft-6zu4-Adapter
Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja
IPv6-Adresse. . . . . . . . . . . : 2002:810a:a9e::810a:a9e(Bevorzugt)
Standardgateway . . . . . . . . . : 2002:c058:6301::c058:6301
DNS-Server . . . . . . . . . . . : 10.151.80.11
NetBIOS über TCP/IP . . . . . . . : Deaktiviert



Wenige Sekunden später, dann wieder den falschen DNS Server:

Windows-IP-Konfiguration

Hostname . . . . . . . . . . . . : xxx
Primäres DNS-Suffix . . . . . . . :
Knotentyp . . . . . . . . . . . . : Hybrid
IP-Routing aktiviert . . . . . . : Nein
WINS-Proxy aktiviert . . . . . . : Nein
DNS-Suffixsuchliste . . . . . . . : intern.xxx.de

Ethernet-Adapter LAN-Verbindung:

Verbindungsspezifisches DNS-Suffix: intern.xxx.de
Beschreibung. . . . . . . . . . . : vmxnet3 Ethernet Adapter
Physikalische Adresse . . . . . . : 00-50-56-B6-58-23
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
Verbindungslokale IPv6-Adresse . : fe80::2cd3:677d:1f1e:6eb5%11(Bevorzugt)
IPv4-Adresse . . . . . . . . . . : 129.10.10.158(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
Lease erhalten. . . . . . . . . . : Dienstag, 28. Mai 2013 16:58:25
Lease läuft ab. . . . . . . . . . : Dienstag, 28. Mai 2013 17:58:32
Standardgateway . . . . . . . . . : 129.10.10.3
DHCP-Server . . . . . . . . . . . : 10.151.80.11
DHCPv6-IAID . . . . . . . . . . . : 234901590
DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-19-2C-DA-22-00-50-56-B6-58-23

DNS-Server . . . . . . . . . . . : 129.10.10.9 <----------------- falscher DNS Server
NetBIOS über TCP/IP . . . . . . . : Aktiviert

Tunneladapter isatap.intern.xxx.de:

Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix: intern.xxx.de
Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter
Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja

Tunneladapter 6TO4 Adapter:

Verbindungsspezifisches DNS-Suffix: intern.xxx.de
Beschreibung. . . . . . . . . . . : Microsoft-6zu4-Adapter
Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja
IPv6-Adresse. . . . . . . . . . . : 2002:810a:a9e::810a:a9e(Bevorzugt)
Standardgateway . . . . . . . . . : 2002:c058:6301::c058:6301
DNS-Server . . . . . . . . . . . : 129.10.10.9
NetBIOS über TCP/IP . . . . . . . : Deaktiviert
Bitte warten ..
Mitglied: Schupa
28.05.2013 um 17:47 Uhr
@diekoenigs, dein Misstrauen ist mir nicht verständlich. So lautet nunmal das lokale Netz, das habe ich mir nicht einfallen lassen.
Bitte warten ..
Mitglied: Arch-Stanton
28.05.2013 um 20:33 Uhr
Deine Netznummer solltest Du schleunigst überarbeiten, dafür sind ja die privaten ranges erfunden worden...

Gruß, Arch Stanton
Bitte warten ..
Mitglied: Schupa
29.05.2013, aktualisiert um 10:13 Uhr
Dessen bin ich mir bewusst, der Unfug ist nicht auf meinem Mist gewachsen. Ich möchte die Sache jetzt bereinigen, aber das sollte jetzt ja auch nicht Gegenstand des Themas sein.

Einen Hinweis oder eine Idee zu meinem geschildertem Problem hat anscheinend niemand.
Bitte warten ..
Mitglied: certifiedit.net
29.05.2013 um 10:30 Uhr
Mach mal bitte einen schematischen Plan. Wenn du selbst nicht in der Lage bist das Netzwerk zu überblicken in der Hinsicht "woher kommt dieses DHCP Lease", wie sollen wir das dann mit ein paar Zeilen hinbekommen?

Soll den der alte DHCP Server rausgeschmissen werden?

Die KOnstellation IP im alten Bereich, DNS Server im neuen Bereich macht auch wenig Sinn. Wenn der DNS Server (wenn das ipconfig Protokoll davon stammt, ist ja alles etwas undurchsichtig) im alten Netz ist wird er nicht auf sich selbst als DNS Server im Neuen Netz verweisen können.

Deswegen einfach mal die Frage: Ist der neue DNS Server überhaupt pingbar?
Bitte warten ..
Mitglied: Schupa
29.05.2013, aktualisiert um 11:57 Uhr
So sieht es derzeitig aus.

http://imageshack.us/f/546/29052013111633.jpg/

Der alte DHCP Server soll auf kurz oder lang rausgeschmissen werden, damit wir das 129.10.10.0 Netz entfernen können.
Die Netze sind in VLANs unterteilt, VLAN50 altes LAN 129.10.10.0 / VLAN80 LAN4Servers 10.151.80.0, ein DHCP Relay vom VLAN 50 zum DHCP Server 10.515.80.11 wurde angelegt. Die Clients aus dem Netz 129.10.10.0 beziehen ja auch von diesem DHCP Server (10.151.80.11) ihre Konfiguration, aber merkwürdigerweise den falschen DNS Server 129.10.10.0, obwohl dieser nicht so im DHCP Server (10.151.80.11) konfiguriert ist. Die VLANs werden untereinander geroutet, somit ja, der DNS Server ist pingbar.
Nein der Auszug vom ipconfig kommt von einem Client, einer VM mit Windows 7 die ich mir zu Testzwecken angelegt hatte.
Bitte warten ..
Mitglied: Schupa
29.05.2013 um 14:51 Uhr
Fehler gefunden, um die Funktionalität des neue DHCP Servers zu überprüfen habe ich den entsprechenden Adressbereich auf dem alten DHCP deaktviert, damit dieser keine Leases mehr vergibt und somit der neue tätig wird. Wenn man aber anscheinend nur den Scope deaktiviert und nicht den DHCP Dienst unter services.msc, vergibt diese wohl noch die DNS Konfiguration. Erst nachdem der Dienst deaktiviert wurde, wurde der richtige DNS Server beibehlaten. Ich bedanke mich trotzdem bei allen für ihre Mühen.
Bitte warten ..
Mitglied: certifiedit.net
29.05.2013 um 14:54 Uhr
Ja, i.d.r werden Einstellungen beim DNS erst nach einem Neustart des Dienstes komplett übernommen.

Grüße
Bitte warten ..
Mitglied: Schupa
29.05.2013 um 14:56 Uhr
Der Dienst wurde ja nicht neugestartet, sondern lediglich richtig beendet.
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(2)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Windows Server
gelöst Keine DNS-Einträge vom DHCP-Server im Windows Server 2012 R2 (8)

Frage von jeschero zum Thema Windows Server ...

Debian
Debian DHCP mit windows 2012 DNS Server verbinden (4)

Frage von SpeakerST zum Thema Debian ...

Windows Server
gelöst Unter SBS2011 DNS, DHCP-Server deaktivieren, IMAP-Connecter für Exchange 2013 (8)

Frage von maniacmacpain zum Thema Windows Server ...

Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (15)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...