Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

DHCP über unterschiedliche VLANs am HP 2626

Frage Netzwerke Router & Routing

Mitglied: gimble

gimble (Level 1) - Jetzt verbinden

12.01.2011, aktualisiert 18.10.2012, 6770 Aufrufe, 11 Kommentare

Ich möchte an verschiedenen VLAN's den DHCP von einem bestimmten Port

Hallo ich habe eine Problem,

ich habe an unserem Switch, einem HP ProCurve 2626 (J4900B) zwei VLAN's eingerichtet.
VLAN 100 (AMT) und VLAN 101 (Internet) an dem Port 24 ist eine FritzBox 7270 mit DHCP Server angeschlossen.
Die FritzBox hat die IP 192.168.178.1.
Wenn ich an den Ports 20 und 23 einen PC anschließe welche keine statische IP haben, weist die Fritzbox diesen eine IP zu und ich kann im Internet surfen.
Jetzt möchte ich mit Hilfe von ip helper-addressen die DHCP IP-Vergabe auf dem VLAN 100 routen.
Das heißt wenn ich einen PC an Port 21 anschließe soll dieser auch eine IP vom DHCP Server an Port 24 zugewiesen bekommen.
Leider funktioniert das nicht, was mache ich falsch? Könnt Ihr mir helfen?

Hier ist die aktuelle Konfiguration des HP 2626 (J4900B)
...das hdcp-replay ist aktiviert.

ip default-gateway 192.168.178.1
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-19,25-26
ip address 192.168.102.201 255.255.255.0
no untagged 20-24
exit
vlan 100
name "AMT"
untagged 21-22
ip address 192.168.112.201 255.255.255.0
ip helper-address 192.168.178.1
exit
vlan 101
name "Internet"
untagged 20,23-24
ip address 192.168.178.201 255.255.255.0
exit
Mitglied: aqui
13.01.2011, aktualisiert 18.10.2012
Das ist mit einer Fritzbox als DHCP Server technisch nicht möglich, denn für dein 2tes VLAN müsstest du einen 2ten Bereich (Scope) einrichten, was auf der FB nicht supportet ist.
Ersetze die FB mit etwas anderem dann klappt es wunderbar auf Anhieb:
Entweder mit einem Server der DHCP macht oder mit einem Router der diese Option supportet:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
Bitte warten ..
Mitglied: gimble
14.01.2011 um 10:59 Uhr
Hallo vielen Dank für die Antwort. Ich dachte mir so etwas schon.
Ich werd die Variante mit dem Mikrotik versuchen.

Aber jetzt noch eine andere Frage ich versuche gerade zwischen VLAN 100 und VLAN 101 eine statische Route einzufügen aber ich bekomme es nicht gebacken.
Mein Zielgerät ist ein
PC
am Port 20 (VLAN 101)
IP 192.168.178.2
GW 192.168.178.201

Meine Quelle ein Laptop
am Port 21(VLAN 100)
IP 192.168.112.2
GW 192.168.112.201

Wenn ich jetzt die Route schreibe, kommt folgende Antwort:
ProCurve Switch 2626(config)# ip route 192.168.178.2 255.255.255.0 192.168.178.201
192.168.178.201 can not be switch IP address and route gateway at the same time

Kannst Du mir sagen wo mein Denkfehler ist?
Danke...
Bitte warten ..
Mitglied: aqui
22.01.2011, aktualisiert 18.10.2012
In einer Route gibt man Netzwerke an und keine Hosts !!! Da liegt dein Problem !!
Richtig müsste es also heissen:
ip route 192.168.178.0 255.255.255.0 192.168.112.201

Eine statische Route ist aber völliger Blödsinn, denn dein Router KENNT doch beide IP Netze da sie ja direkt an ihm angeschlossen sind.
Die Route ist also völliger Unsinn und zudem auch noch kontraproduktiv.
Damit du es verstehst lies dir bitte einen Paketweg durch so einen Router einmal genau durch !!!
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...


Wenns das denn war bitte
http://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Mitglied: gimble
27.01.2011 um 13:31 Uhr
Danke...
Du hast mir sehr geholfen ich werd mir jetzt erst mal eine Microtik Dingens kaufen
Bitte warten ..
Mitglied: gimble
07.02.2011 um 11:23 Uhr
Hallo, ich bin es wieder.
Ich habe mir jetzt den MikroTik Router kommen lassen und habe Ihn so konfiguriert wie oben besprochen (habe Ihn allerdings nicht resetet).
Er hängt direkt an einer Fritzbox und hat eine IP zugewiesen bekommen. An dem Port 2 ist mein Switch angebunden.
Meinen Switch habe ich wie folgt konfiguriert:

ip default-gateway 192.168.88.1
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-19,25-26
ip address 192.168.102.201 255.255.255.0
no untagged 20-24
exit
vlan 100
name "AMT"
untagged 21-22,24
ip address 192.168.100.201 255.255.255.0
ip helper-address 192.168.88.1
exit
vlan 88
name "Internet"
untagged 20,23
ip address 192.168.88.201 255.255.255.0
exit

DHCP relay Funktion ist auch aktiviert.

An dem Port 20 hängt der Mikrotik an Port 23 ein Laptop dieser bekommt einen IP zugewiesen (192.168.88.252) und ich kann ins Internet.

Wenn ich an Port 21 einen PC anschließe funktioniert das nicht. Warum? Wenn ich dem PC manuell die Adresse 192.168.100.202 zusweise kann ich den Mikrotik oder den Laptop an Port 23 nicht einmal anpingen. Woran kann das liegen?

Bitte gebt mir einen Denkanstoß. Danke...
Bitte warten ..
Mitglied: aqui
07.02.2011 um 21:36 Uhr
Deine Konfig ist ein bischen sinnlos.... dein Switch ist ein L3 Switch, kann also routen zw. den VLANs. Das problem ist das der DHCP Server der FB nicht mit mehreren Scopes klarkommt er supportet das nicht.
Der Mikrotik ist eigentlich überflüssig. Wenn du ekien server im Netz hast der DHCP mit mehreren Scopes supportet, dann missbrauchst du den Mikrotik halt als DHCP Server.
Hier musst du für jedes LAN (VLAN) einen DHCP Server aktivieren. Denk dran das als Geatway IP der Mikrotk nicht seine eigenen IPs verwenden darf sondern zwingend die IP Adressen der Switch VLAN Interfaces, denn der soll ja routen.
Letztlich ist das eine Frickelei... Entweder schaltest du das Routing am Switch ab und routest über den Mikrotik was aber unsinnig wäre da der Switch das besser kann oder die richtest den Mikrotik als nur DHCP ein was auch doof ist da du dann dort das Routing deaktivieren musst um nicht in Gefahr eines backdoor Routers zu rennen bei dir... Eigentlich alles Frickelei.
Am besten ist Routing über den Switch und einen zentraklen Multi Scope fähigen DHCP zu verwenden. Wenn du kein MS Server hast kann das ein simpler Billigrouter mit DD-WRT sein...der supportet sowas. Ob der Mikrotik das auch kann müsste man mal im handbuch nachsehen....oder dog fragen.
Bitte warten ..
Mitglied: gimble
08.02.2011 um 08:58 Uhr
Aber genau das ist es was ich mache möchte, ich habe schon verstanden das die FritzBox nicht in der Lage ist Scopes zu unterstützen.
Darum soll ja der MikroTik sich eine IP geben lassen (DHCP Client Port 1) um dann wiederrum selber als Multiscope DHCP Server (Port 2) zu fungieren.
Der soll dann über einen Tagged Link an den Switch und dort die VLAN's versorgen. Ich finde das klingt doch ganz logisch... nicht sinnlos?
Bitte warten ..
Mitglied: aqui
08.02.2011, aktualisiert 18.10.2012
OK, das ist dann ganz einfach: Definiere einfach über die Winbox für jeden deiner Subnetze einen DHCP Server auf dem Mikrotik:
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...
bzw.:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
Der Mikrotik kann kein Multiscope in dem Sinne aber du kannst n mal DHCP Server für jedes Subnetz einrichten. Von der Funktion ist das also letztlich das gleiche und führt ebenso zum Erfolg !

Du solltest die VLAN Variante vorziehen, denn damit kannst du den Mikrotik mit einem simplen einzelnen Kabel an den Switch anschliessen ! Nur um DHCP Server zu spielen reicht das allemal !!
Denk dran das der Mikrotik die Switch IP Adressen als Gateway vergeben muss, denn der Switch soll ja routen !
Bitte warten ..
Mitglied: gimble
09.02.2011 um 16:14 Uhr
Hallo aqui,
ich bin echt am Verzweifeln...ich bekomme es nicht hin.

Ich habe den MT komplett resetet.
Habe den ether1 als DHCP-Client konfiguriert. Dieser bekommt von der FritzBox auch eine IP zugewiesen. Wunderbar.
Dann habe ich dem ether2 als DHCP-Server konfiguriert.

Am HPSwitch habe ich ein VLAN ID88 eigerichtet aber alle Ports des VLAN's auf untagged gestellt.
An einem Port ist ein Laptop und an dem anderen der MikroTik angeschlossen.
Der Laptop bezieht auch ganz artig seine IP vom DHCP Server des MikroTik.
Bis dahin ist alles Gut.

Aber wie richte ich jetzt den MikroTik ein das er die Verbindung zur FritzBox respektive Internet herstellt.
Und du weißt mich darauf hin das ich dem MikroTik die Switch IP Adresse als Gateway geben soll.
Aber wo bitte mache ich das?

Irgendwie stehe ich absolut auf dem Schlauch!
Bitte warten ..
Mitglied: gimble
10.02.2011 um 14:44 Uhr
Freude ich habe es...

Also ich habe nochmals das ganze Gerät resetet. Habe einen DHCP Client Port eingerichtet. Funktioniert. Dann habe ich 2 VLAN DHCP Server eingerichtet die über einen physikalischen Port gehen. Zu guter letzt habe ich die ganze Sache ge"NAT"et. Am Switch habe ich beide VLAN's eingerichtet und in jedem VLAN den Port an dem der Mikrotik hängt tagged gesetzt. So funktioniert es.

Danke für eure Mühen.
Bitte warten ..
Mitglied: aqui
10.02.2011 um 17:49 Uhr
Alles wird gut ! Allerdings ist das NATen kontraproduktiv und solltest du besser bleiben lassen !

Bedenke aber das du nach einem Reset per Terminal auf dem Mikrotik immer folgendes machst:

/system reset-conf skip-backup=yes no-defaults=yes

Dann rebootest du den Router einmal (stromlos machen)
Damit schaltest du die Default NAT Konfig und 4 Port Switch Konfig an Port 5 und den restlichen Ports ab und machst einen sauberen transparenten Router mit 5 gleichwertigen Ports aus der Box !!
Das ist für dein Szenario zwingend erforderlich, da du sonst permanent in NAT Probleme am Port 5 rennst !
Steht auch ganz groß so in BEIDEN Tutorials das man es eigentlich NICHT übersehen kann ?!

Vermutlich hat dir das all die Probleme bereitet !
Bitte warten ..
Neuester Wissensbeitrag
Festplatten, SSD, Raid

12TB written pro SSD in 2 Jahren mit RAID5 auf Hyper-VServer

Erfahrungsbericht von Lochkartenstanzer zum Thema Festplatten, SSD, Raid ...

Ähnliche Inhalte
Netzwerkmanagement
gelöst HP 1920 24G Switch QOS-Problem bei Portzuweisung mit DHCP Relay (2)

Frage von farbschmelz zum Thema Netzwerkmanagement ...

LAN, WAN, Wireless
gelöst Kein DHCP-Relay am Sub-Switch HP (20)

Frage von westberliner zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...