Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

DHCP verteilt keine Adressen mehr (W2K8R2)

Frage Microsoft Windows Server

Mitglied: comfreak

comfreak (Level 1) - Jetzt verbinden

28.04.2012, aktualisiert 14:02 Uhr, 5927 Aufrufe, 21 Kommentare

Hallo zusammen,

wir haben 2 DCs mit W2K8R2, auf DC1 war ein DHCP installiert, welcher nun keine Adressen mehr verteilt. Ich habe nun auf dem DC2 die DHCP Rolle installiert und die Daten aus C:\Windows\System32\dhcp auf dem DC2 ersetzt - funktioniert!

Ich habe bereits die DHCP Rolle auf DC1 deinstalliert, die Daten aus C:\Windows\System32\dhcp gelöscht und die Rolle neu konfiguriert, nichts!

Ich habe den Traffic bei einem Client und DC1 mal per Wireshark mitgeschnitten. Dort sehe ich, dass das DISCOVER beim DC1 angekommt, er ein OFFER zurückschickt, aber das nicht mehr beim Client ankommt. Beim DC2 funktioniert das ganze Spiel, so wie es soll.

DC1
Client mit DC1

DC2
Client mit DC2

Am besten nach "bootp" filtern.


Etwas zum Netzaufbau:

"ipconfig" und "netstat -r" DC1
"ipconfig" und "netstat -r" DC2


DHCP Konfiguration:

DHCP Adressen sollen von 192.168.212.1-192.168.212.233 verteilt werden.

DHCP Eventlogs:
Eventlog DC1
Eventlog DC2

Ich bin da seit Tagen dran, aber finde den Fehler bzw. das Problem nicht und bin daher für jede kleine Idee und jeden Vorschlag dankbar!

Sollten noch Informationen fehlen, dann bitte schreien!


Grüße
Mitglied: Dani
28.04.2012 um 14:03 Uhr
Moin,
du hast aber die Autorisierung am jedesmal konfiguiert bzw. wieder aufgehoben bevor du Tests gemacht hast?!


Grüße,
Dani
Bitte warten ..
Mitglied: comfreak
28.04.2012 um 14:05 Uhr
Äh, was habe ich wo gemacht? Was macht diese Autorisierung?
Bitte warten ..
Mitglied: Dani
28.04.2012 um 14:08 Uhr
In einem Subnetz darf immer nur ein DHCP-Server Adressen verwalten/verteilen.
Wenn du nun auf DC2 die Rolle "DHCP" installiert hast, ist standardmäßig der DHCP auf DC1 authorisiert da er der erste im Netzwerk war.
Bei der Installation auf DC2 wurdest du sicher gefragt, ob dieser nun authorisiert wird. Somit ist DHCP auf DC1 raus.

Kannst du ganz einfach prüfen, einfach in die DHCP-Rolle gehen, Servername markieren und via Rechtsklick siehst du ob du ihn autorisieren (aufheben) kannst.


Grüße,
Dani
Bitte warten ..
Mitglied: comfreak
28.04.2012 um 14:15 Uhr
Wenn ich versuche auf DC1 und DC2 die Autorisierung aufzuheben bekomme ich den Fehler "Ein solches Objekt ist auf dem Server nicht vorhanden". Wenn die Dienste gestoppt sind, kann ich Autorisieren klicken, bekomme die Meldung "Die angegebenen Server sind bereits im Verzeichnisdienst vorhanden".

Hab auch probiert, wenn nur ein DHCP Dienst auf einem Server läuft und der andere auf dem anderen Server gestoppt ist.

Edit: Achja mir fällt ein, vor ein paar Tagen war der DC1 aus irgendeinem Grund kein richtiger Domänencontroller mehr (Authentifizierung mit der AD ging nicht mehr). Ich habe dann nach einer Anleitung im Internet den Eintag im ADSI-Editor unter DC=Domain,DC=local => OU=Domain Controllers => Eigenschaften des DCs => UserAccountControl den Wert 532480 eingetragen (so wie es bei DC2 ist) und dann lief es wieder. DANACH habe ich aber erst den DHCP auf dem DC2 installiert...
Bitte warten ..
Mitglied: 60730
29.04.2012 um 00:43 Uhr
Moin,

Zitat von comfreak:
Ich habe bereits die DHCP Rolle auf DC1 deinstalliert, die Daten aus C:\Windows\System32\dhcp gelöscht und die Rolle neu konfiguriert, nichts!
Äh, was habe ich wo gemacht? Was macht diese Autorisierung?
Edit: Achja mir fällt ein, vor ein paar Tagen war der DC1 aus irgendeinem Grund kein richtiger Domänencontroller mehr
(Authentifizierung mit der AD ging nicht mehr). Ich habe dann nach einer Anleitung im Internet den Eintag im ADSI-Editor unter
DC=Domain,DC=local => OU=Domain Controllers => Eigenschaften des DCs => UserAccountControl den Wert 532480 eingetragen
(so wie es bei DC2 ist) und dann lief es wieder. DANACH habe ich aber erst den DHCP auf dem DC2 installiert...

ganz ganz ehrlich?

Besorg dir einen, der das wirklich kann, denn diese Zeilen da oben verheissen nichts gutes...

Vor allem, wenn man es mit den Zeilen aus deiner anderen Frage verbindet...
Ich bin bereits auf das Tool gpmc von Microsoft gestoßen, aber bei der Installation wird mir gesagt, dass dies nur für XP und W2k3 ist.
Ah, dass man sich von einem Client aus verbinden kann, wusste ich nicht, danke.
Hmmmm....und seit wann gibts Gpresult oder warum gibts die gpmc für xp, wenn xp doch bei Fritzboxxern als Server durchgeht?

Wirklich, so ne AD ist (wenn man es richtig macht) ganz leicht und da stolpert man auch ganz leicht in irgendwelche Fallen rein,
Wenn du jetzt noch weiter rumfreakelst, dann ist die ratzfatz im Eimer und dein Chef fragt sich, wozu die ganze Kohle reinblasen, wenn die W2k0 Kiste(n) sauber liefen?

Du mußt da noch etwas lernen, nur sowas lernt man in über Frage und Antort im Netz und übt schon garnicht am Live System.

N8
Bitte warten ..
Mitglied: comfreak
29.04.2012 um 03:10 Uhr
Moin!

Zitat von 60730:
Moin,

> Zitat von comfreak:
> ----
> Ich habe bereits die DHCP Rolle auf DC1 deinstalliert, die Daten aus C:\Windows\System32\dhcp gelöscht und die Rolle neu
konfiguriert, nichts!
>> Äh, was habe ich wo gemacht? Was macht diese Autorisierung?
> Edit: Achja mir fällt ein, vor ein paar Tagen war der DC1 aus irgendeinem Grund kein richtiger Domänencontroller
mehr
> (Authentifizierung mit der AD ging nicht mehr). Ich habe dann nach einer Anleitung im Internet den Eintag im ADSI-Editor
unter
> DC=Domain,DC=local => OU=Domain Controllers => Eigenschaften des DCs => UserAccountControl den Wert 532480
eingetragen
> (so wie es bei DC2 ist) und dann lief es wieder. DANACH habe ich aber erst den DHCP auf dem DC2 installiert...

ganz ganz ehrlich?

Gerne!


Besorg dir einen, der das wirklich kann, denn diese Zeilen da oben verheissen nichts gutes...

Sehe ich genau so. In der AD mit solch einem Editor rum zu fuchteln finde ich auch nicht prickelnd, aber es hat bisher geholfen.


Vor allem, wenn man es mit den Zeilen aus deiner anderen Frage verbindet...
> Ich bin bereits auf das Tool gpmc von Microsoft gestoßen, aber bei der Installation wird mir gesagt, dass dies
nur für XP
und W2k3 ist.
> Ah, dass man sich von einem Client aus verbinden kann, wusste ich nicht, danke.
Hmmmm....und seit wann gibts Gpresult oder warum gibts die gpmc für xp, wenn xp doch bei Fritzboxxern als Server
durchgeht?


Sorry, aber ich bin seit noch nicht mal 1 Jahr aus der Ausbildung (FISI) raus und bin der, der in der Firma am meisten von dem Kram versteht und muss ca. 120 User am Arbeiten halten. Wenn ich meinem Chef sage, dass er mal für einen Ordner rekursiv die Rechte für den Apache-User unter Linux vergeben soll, stößt er an seine Grenzen... -.- Für mich ist das auch keine einfache Situation, dennoch gebe ich mein Bestes und arbeite (so wie gerade) unbezahlt von zu Hause. Ja, ich weiß, das gehört zu meinem Job dazu und ich mache meinen Job wirklich gerne und beschwere mich auch nicht darüber, aber ich möchte hier nur klar stellen in welcher Situation ich stecke. Dazu möchte ich nach meinem Jahresvertrag auch weiterhin angestellt bleiben, weil ich so viel Zeit und Leidenschaft in die Infrastruktur gesteckt habe und diese auch nicht einfach so aufgeben möchte (ja, Kollegen und das Geld steckt auch dahinter...).

Leider hilft mir dein Beitrag keinen Schritt weiter. Ich habe es leider selbst im Gefühl, dass ich in keiner guten Situation mit den DCs stehe, genau deswegen habe ich ja hier im Forum ein Thread eröffnet. Wir sind kein IT-Dienstleister, wo eine IT-Schulung "mal eben" bewillig wird. Ich möchte auch so viel es geht lernen, denn jeder hat mal klein angefangen und Fehler gemacht!

Ich möchte hier keine Diskussion aufkommen lassen, was ich hätte besser machen können oder wie un-/ berechtigt dein Beitrag war, sondern Tipps haben, wie ich nun am Besten fortfahren soll, bzw. in Zukunft besser machen kann und eine solche Diskussion hier nicht hingehört. Einen IT-Dienstleister zu beauftragen kommt nicht in Frage, dafür fehlt das Geld.


Wirklich, so ne AD ist (wenn man es richtig macht) ganz leicht und da stolpert man auch ganz leicht in irgendwelche Fallen rein,
Wenn du jetzt noch weiter rumfreakelst, dann ist die ratzfatz im Eimer und dein Chef fragt sich, wozu die ganze Kohle reinblasen,
wenn die W2k0 Kiste(n) sauber liefen?

Naja, die W2K0 Kisten liefen laut DCDIAG so gerade noch...und eine Modernisierung (inkl. Virtualisierung) der bestehenden Server war so oder so geplant, mit oder ohne mich - aber nun stecke ich drin. Die Anspielung auf meinen Namen finde ich auch nicht so toll, denn irgend ein Pseudonym musste ich mir ja ausdenken und da ich diesen seit Jahren habe, verwende ich diesen auch weiter...tut auch im Moment nichts zur Sache.


Du mußt da noch etwas lernen, nur sowas lernt man in über Frage und Antort im Netz und übt schon garnicht am Live
System.

Verständlich. Verständlich war mir aber nicht, dass der DC auf einmal nicht mehr als DC erkannt wurde. Nachdem ich über ADSI-Edit den Eintag geändert habe, war das Thema erstmal für mich erledigt, es lieft ja anscheinend alles, bis ich "mal eben" eine IP haben wollte.


N8

N8


Edit: Rechtschreibfehler etc.
Bitte warten ..
Mitglied: Dani
29.04.2012 um 08:55 Uhr
Es stimmt definitiv am ADS etwas nicht...

1) Sichere in der Ereignisanzeige bitte die Kategorien "Anwendung" und "System". Danach beide leeren und die beiden DCs neustarten.
2) Ereignisanzeige auf Fehler- /Wanmeldungen prüfen
3) dcdiag auf beiden DC's ausführen
4) Sind beide Server DC (kannst du in der AD Site überprüfen)
5) SChau nach welcher DC die FSMO-Rollen, etc... aktiv hat (NETDOM QUERY FSMO)


Grüße,
Dani
Bitte warten ..
Mitglied: 60730
29.04.2012 um 10:28 Uhr
Moin,

Leider hilft usw.?

Doch sollte er und muss er auch, denn jeder macht alles anders, ich wuerde zum beispiel so den 1) von dani nicht unterschreiben.
Die kisten wissen auch ohne das leeren des eventlogs, dass da was nicht stimmt und ein dcdiag bringt auch bei nem sauberen system einen fehler, wenn einer von den dcs mal ne stunde aus war. ( je nachdem welche repl. Dauer die eingestellt haben)

Nochmal ehrlich und ohne gebashe...

Jetzt ist die ad wohl nur angeschlagen, und wenn du jetzt die richtigen schritte in der falschen reihenfolge, oder die falschen schritte machst, ist die nachher ein fall fuer rien ne va plus.

Z.b haettest du vor der adsiedit baustelle hier auch fragen koennen, denn wenn du zwei dc hast und einer komisch ist, dann haette wenn und aber ich den komplett aus der ad geworfen und dem nicht wieder per manipulation des status dc gegeben.

Din dcdiag wird dir zu 99% einen kcc vorwerfen und den bekommst du nicht so einfach wieder weg.

Aber wie, dazu muss man vor den kisten sitzen, sowas kann man nicht in einem forum erklaeren.
Und von daher, mach das mit dem rauswerfen des dcs bloss nicht, denn ob das jetzt wirklich die beste zeit dafuer ist, kann man aus der ferne nicht sagen.

Denn da sind so kleinigkeiten, wie uhrzeit, dns ausfloesung extrem wichtige details und von denen gibt es ein paar mehr.
(oder welchen grund koennte es geben, dass yusuf dazu nich nie,als nie nix geschrieben hat und der schreibt viel, wenn der tag kurz ist)
Zumindestens hat er das, bevor er fester redmonter geworden ist.


Gruss
Bitte warten ..
Mitglied: comfreak
29.04.2012 um 12:10 Uhr
Moin,

was sind denn deiner Meinung nach die richtigen Schritte? Wonach sollte ich mal schauen?

Ich kann verstehen, dass man in der Regel vor den Kisten sitzen muss, aber wir wissen alle, dass dies nicht möglich ist...

Ja ich hätte vorm ADSI-Edit hier fragen können, aber die Leute konnten nicht mehr arbeiten und habe eine schnelle Lösung gesucht, was bei DCs auch nicht schön ist (i know...).

Der DC1 war in der AD noch unter dem Punkt "Domänen Controllers" in der AD Site aufgelistet - hat sich nur nicht mehr so verhalten.

Weisst du, ich lese viel in Foren, um meine Probleme in den Griff zu bekommen. Leider lese ich auch viel Mist, so dass z.B. Leute direkt angegriffen werden, weil das doch ein ein dummes Problem ist, sich nicht richtig verhalten wurde oder die Frage zum 1000. mal schon gestellt worden ist und man doch die Suchfunktion bitte vorher nutzen solle. Dann ist erst auch meistens die 5. Antwort etwa eine Vernünftige - und darauf habe ich ehrlich gesagt keine Lust und schreibe deswegen erst spät in Foren rein.

1) Die DCs habe ich jetzt nicht neu gestartet, die Eventlogs aber hochgeladen, gefiltert nach Warnungen, Fehler und Kritischen:

DC1 Log Anwendung
DC1 Log System
DC2 Log Anwendung
DC2 Log System

2) DCDIAG:

DC1 DCDIAG
DC2 DCDIAG

3) Ja beide DCs sind in der AD-Site "Domänen Controllers".

4) Laut "NETDOM QUERY FSMO" hat der DC1 alle FSMO-Rollen

5) Uhrzeit ist auf die Sekunde synchron.


Gruß
Bitte warten ..
Mitglied: 60730
29.04.2012 um 20:09 Uhr
Moin,

Eigentlich mach ich sowas ja nie...

Deine beiden dcdiags sehen gut aus, das haette ich nicht gedacht, den rest kann man garnicht ansehen.
Wenn dir jemand weiterhelfen soll dann schreib das hier in code type plain tags rein.

Und nochmal kurz und knapp, was ist das problem?
Dhcpserver der geloescht wurde ist noch in der ad drin und du bekommst keinen anderen rein?

Was sagt denn
  • Netsh DHCP show server

Was passiert denn, wenn du das manuelamaessig machst?
  • Netsh DHCP add server ServerFQDN ServerIP address

Du kannst den so rauskicken:
  • Netsh DHCP delete server ServerFQDN ServerIPaddresse

Aber nochmal, das sind sachen, die du machen kannst und wo du drauf hoffen musst, das ich ohne mir ein echtes bild machen zu koennen den richtigen rat gebe. Auch wenn ich das schon laenger mache, ein restrisiko sehe ich da trotzdem und ich lege da nicht dienhand ins feuer, vor allem nicht ihne zu wissen, dass ich ein funktionierendes backup der beiden kisten haette.


Passt die repl wirklich verbinde dich in der usrs&groups mmc mit einem server, aender die telefonnummer oder anderen killefitz eines bestehenden account und nach 16 minuten verbidest du dich mitmdem anderen und schaust das nach.
Und damitmdie ueit schneller vorbei geht, zimmerst du ene test.ini ins netlogon von dc2 und achaust ob die auf dc1 angekommen ist.
Bitte warten ..
Mitglied: comfreak
29.04.2012 um 21:58 Uhr
Zitat von 60730:
Moin,

Eigentlich mach ich sowas ja nie...

Deine beiden dcdiags sehen gut aus, das haette ich nicht gedacht, den rest kann man garnicht ansehen.
Wenn dir jemand weiterhelfen soll dann schreib das hier in code type plain tags rein.

Das DCDIAG ok, aber wie soll ich die Eventlogs sinnvoll hier in code type plain tags reinschreiben?


Und nochmal kurz und knapp, was ist das problem?
Dhcpserver der geloescht wurde ist noch in der ad drin und du bekommst keinen anderen rein?

Der DHCP auf DC1 hat irgendwann aus irgendeinem Grund keine IPs mehr verteilt. Ein DISCOVER vom Client kommt an, er schickt das OFFER zurück, kommt aber beim Client nicht mehr an. Auf dem DC2 habe ich für den Übergang den DHCP mit den Daten (wegen den Leases) des DC1 installiert. DHCP ist bereits auf DC1 neu installiert und funktioniert immer noch nicht, wenn der DHCP-Dienst auf DC2 gestoppt ist. Ich kann die Autorisierung der DHCPs nicht aufheben, Fehler ist "Ein solches Objekt ist auf dem Server nicht vorhanden".


Was sagt denn
  • Netsh DHCP show server

C:\Users\pwheinz>Netsh DHCP show server 
 
4 Server im Verzeichnisdienst gefunden: 
 
        Server [server_mdc.meta-1.local] Adresse [192.168.213.176] Verzeichnisdienststandort: cn=server_mdc.meta-1.local 
 
        Server [server_pdc.meta-1.local] Adresse [192.168.213.212] Verzeichnisdienststandort: cn=server_pdc.meta-1.local 
 
        Server [server_test.meta-1.local] Adresse [192.168.213.14] Verzeichnisdienststandort: cn=server_test.meta-1.local 
 
        Server [pdc.meta-1.local] Adresse [192.168.213.234] Verzeichnisdienststandort: cn=pdc.meta-1.local 
 
 
Der Befehl wurde erfolgreich ausgeführt.
Ich frage mich, wo die 2 DHCPs "server_test.meta-1.local" und "pdc.meta-1.local" herkommen...kann ich die mit "Netsh DHCP delete server ServerFQDN ServerIPaddresse" rauskicken?


Was passiert denn, wenn du das manuelamaessig machst?
  • Netsh DHCP add server ServerFQDN ServerIP address

Ist das nötig, wenn diese doch schon installiert sind?


Du kannst den so rauskicken:
  • Netsh DHCP delete server ServerFQDN ServerIPaddresse

Aber nochmal, das sind sachen, die du machen kannst und wo du drauf hoffen musst, das ich ohne mir ein echtes bild machen zu
koennen den richtigen rat gebe. Auch wenn ich das schon laenger mache, ein restrisiko sehe ich da trotzdem und ich lege da nicht
dienhand ins feuer, vor allem nicht ihne zu wissen, dass ich ein funktionierendes backup der beiden kisten haette.

Klar, verstehe ich.



Passt die repl wirklich verbinde dich in der usrs&groups mmc mit einem server, aender die telefonnummer oder anderen killefitz
eines bestehenden account und nach 16 minuten verbidest du dich mitmdem anderen und schaust das nach.
Und damitmdie ueit schneller vorbei geht, zimmerst du ene test.ini ins netlogon von dc2 und achaust ob die auf dc1 angekommen
ist.


Ja funktioniert beides ohne 16 Minuten Wartezeit, so gesehen sofort.
Bitte warten ..
Mitglied: 60730
29.04.2012 um 22:29 Uhr
Ich frage mich, wo die 2 DHCPs "server_test.meta-1.local" und "pdc.meta-1.local" herkommen...
  • zur testkikste -schau, wann der gabaut wurde - siehst du anhand der boot.ini - wenn die keiner angefasst hat und frag nach, wer das war.

Netsh DHCP add server ServerFQDN ServerIP address
Ist das nötig, wenn diese doch schon installiert sind?

Auch hier - Dani schrubs doch installieren <> autorisieren!
yupp sonst hätt ichs doch nicht geschrieben..

Denn und soviel zum davorsitzen und Forenwissen. (oder 1) von Dani - viele Köche verderben den Brei - hast du schon gesalzen? schütt schütt)
wobei ich nochmal ganz deutlich dazuschreibe "falsch" war der Tipp nicht, aber ich würde das halt so nicht machen.... anyway

Du speichst teilweise in rätseln dc1 pdc mdc da blickt doch keiner durch...
Welche der 4 kisten gibt es, welche der 4 kisten sind die zwei, die es sein sollen?

kann ich die mit "Netsh DHCP delete server ServerFQDN ServerIPaddresse" rauskicken?
können ja, aber ob sollen?

Nochmal frag in deiner bude ob und wer oder ob das die ollen W2k0 Kisten waren - raus/weggeworfen ist schnell, rein im Zweifel.....
Bitte warten ..
Mitglied: comfreak
30.04.2012 um 12:26 Uhr
Zitat von 60730:
> Ich frage mich, wo die 2 DHCPs "server_test.meta-1.local" und "pdc.meta-1.local" herkommen...
  • zur testkikste -schau, wann der gabaut wurde - siehst du anhand der boot.ini - wenn die keiner angefasst hat und frag nach, wer
das war.

>> Netsh DHCP add server ServerFQDN ServerIP address
> Ist das nötig, wenn diese doch schon installiert sind?

Auch hier - Dani schrubs doch installieren <> autorisieren!
yupp sonst hätt ichs doch nicht geschrieben..
01.
C:\Users\pwheinz>netsh dhcp add server server_pdc.meta-1.local 192.168.213.212 
02.
 
03.
Server server_pdc.meta-1.local, 192.168.213.212 wird hinzugefügt. 
04.
Die angegebenen Server sind bereits im Verzeichnisdienst vorhanden.
01.
C:\Users\pwheinz>netsh dhcp add server server_mdc.meta-1.local 192.168.213.176 
02.
 
03.
Server server_mdc.meta-1.local, 192.168.213.176 wird hinzugefügt. 
04.
Die angegebenen Server sind bereits im Verzeichnisdienst vorhanden.

Denn und soviel zum davorsitzen und Forenwissen. (oder 1) von Dani - viele Köche verderben den Brei - hast du schon gesalzen?
schütt schütt)
wobei ich nochmal ganz deutlich dazuschreibe "falsch" war der Tipp nicht, aber ich würde das halt so nicht
machen.... anyway

Du speichst teilweise in rätseln dc1 pdc mdc da blickt doch keiner durch...
Welche der 4 kisten gibt es, welche der 4 kisten sind die zwei, die es sein sollen?

DC1=server_pdc, DC2=server_mdc

server_test gibt es nicht mehr, keiner weiß wo dieser abgeblieben ist.

pdc war glaube ich nur temporär vor der Migration ein anderer Name + IP für den server_pdc, gibt es also auch nicht mehr (bzw. ist nun server_pdc mit der IP 213.212). Die 213.234 hat nämlich nun ein Client.


kann ich die mit "Netsh DHCP delete server ServerFQDN ServerIPaddresse" rauskicken?
können ja, aber ob sollen?

Naja server_test und pdc sind meiner Meinung nach Leichen und könnten eigentlich gelöscht werden, nicht?


Nochmal frag in deiner bude ob und wer oder ob das die ollen W2k0 Kisten waren - raus/weggeworfen ist schnell, rein im
Zweifel.....
Bitte warten ..
Mitglied: 60730
01.05.2012 um 08:00 Uhr
Moin,

Also nochmal...

Die ad repliziert
Der dhcp ist installiert und authorisiert

Die range erstellt und aktiviert?
Und trotzdem kriegen die keine ip?
Bitte warten ..
Mitglied: comfreak
01.05.2012 um 19:01 Uhr
Moin,

alles korrekt. Die MAC-Adressen Filter sind auch deaktiviert.
Bitte warten ..
Mitglied: comfreak
02.05.2012 um 12:15 Uhr
Mittlerweile wird es noch kurioser, 2 Testclients (beides Physikalische) haben nun eine Adresse bekommen, 2 Test VMs nicht und ein weiterer physikalischer Rechner auch nicht...
Bitte warten ..
Mitglied: Dani
02.05.2012 um 21:20 Uhr
Hmm... also an der Stelle würde ich mir Experten ins Haus holen. Weil das sieht für mich langsam so als würde es nicht nur am DHCP scheitern, sondern noch andere Komponenten reinspielen.


Grüße,
Dani
Bitte warten ..
Mitglied: comfreak
02.05.2012 um 23:26 Uhr
Moin,

nach dem heutigen Arbeitstag und viel rumgesuche konnte ich nun folgendes feststellen:

Stecke ich mich mit einem Notebook an den selben Switch, wo auch der DHCP dran hängt, funktioniert alles tadellos. Stecke ich mich an einen Switch, der etwas weiter weg ist, dauert es schon mal 3-4 DISCOVER, bis es funktioniert. Stecke mich an einen Switch, der physikalisch weit weg ist, funktioniert es nicht.

Das kann ich auch mit eine VM reproduzieren, die funktioniert, wenn sie auf dem selben Host wie der DHCP läuft. Läuft sie auf einem Host, welcher weiter entfernt ist, geht es nicht mehr. Das ganze Spiel sieht genau so mit einem Linux DHCP aus! Meiner Meinung nach heute ist nun, dass der Windows DHCP in Ordnung ist und ich wo anders suchen muss.

Was mich nun verwirrt ist, das dies plötzlich auftritt - Änderungen am Backbone sind mir nicht bekannt.
Bitte warten ..
Mitglied: 60730
03.05.2012 um 10:17 Uhr
Hast du Vlans?
IPhelper Adresse vergeben?
auch die richtige - was ich bezweifel, wenn der DHCP umgezogen ist?

Wie schon geschrieben, ein Profi geht dahin - sieht das auf den ersten/zweiten/dritten Blick und kostet im Endeffekt weniger, als da tage/Wochenlang per Trial & error.....

Gruß
Bitte warten ..
Mitglied: comfreak
03.05.2012 um 11:59 Uhr
Keine VLANs
IPhelper Adressen? Sagt mir nichts, Kollegen auch nicht. Ist das ein CISCO-Eigener Kram? Wenn ja, wir haben ausschließlich Netgear Switche (bis auf Desktop-Switche).

So wie es aussieht habe ich nun den Fehler gefunden: 2 Switche verhalten sich anscheinend nicht so wie sie sollen. Als kaputt würde ich sie nicht direkt bezeichnen, weil anderer Traffic ohne Probleme drüber ging und ich diese daraufhin noch testen möchte. Evtl. auch, weil das alles TCP und keine UDP Pakete wie bei DHCP sind und deswegen nicht aufgefallen ist. Einen Switch habe ich nun ausgetauscht und seitdem funktioniert die Adressvergabe für die VMs wieder. Bei 2 Clients habe ich das Problem noch, aber die hängen beide am selben Switch. Der wird heute Abend neu gestartet und wenn das nicht hilft ausgetauscht. Antwort folgt.


Gruß
Bitte warten ..
Mitglied: comfreak
08.05.2012 um 14:48 Uhr
So, wir haben nun die 2 Switche auf Factory-Defaults gesetzt und wieder konfiguriert. Nun funktioniert es wieder. Wenn die sich noch einmal so komisch verhalten, fliegen die raus.

Trotzdem danke für eure Hilfe!


Gruß
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Netzwerkgrundlagen
gelöst Zwei FritzBoxen mit DHCP im selben Netzwerk. Vergabe der IP Adressen? (7)

Frage von 125525 zum Thema Netzwerkgrundlagen ...

LAN, WAN, Wireless
gelöst IP Adressen in DMZ von DHCP in LAN (9)

Frage von 118080 zum Thema LAN, WAN, Wireless ...

Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...