Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Div. Fileserver sollen nach Anmeldung automatisch gemountet werden

Frage Microsoft Windows Server

Mitglied: r.obert

r.obert (Level 1) - Jetzt verbinden

12.07.2013, aktualisiert 13.07.2013, 3347 Aufrufe, 24 Kommentare

Hallo Zusammen, ich habe ein Problem mit netlogon, das mit GPOs auf verschiedene OUs angewendet wird. Leider ändern sich nicht mehr die Laufwerke, sobald ich in der zeichnungen.cmd-Datei die Pfade und Laufwerksbuchstaben geändert habe. Die Volumes blerigen die Alten, auch wenn ich sie aus dem Skript gelöscht habe. Ein Programm braucht aber expliziet den Laufwerksbuchstaben "S" um die Dateipfade richtig zu erkennen, dieser widerum ist aber mit einem LW belegt, das aber nicht mehr gebraucht wird. Nun meine Frage, wie kann ich die GPO und das Skript so ändern, dass nur noch aktuelle LW mit dem passenden LW-Buchstaben nach Neustart erscheinen?

Wir haben zwei DC, zum replizieren.
Eine Domäne.


Das steht im Script:
49122069173e304cfffe4684364d77eb - Klicke auf das Bild, um es zu vergrößern

Da liegt das Script:
d2a0d89d35c4a3c987ddfd5e5012f306 - Klicke auf das Bild, um es zu vergrößern

Vielen Dank für Eure Hilfe

r.obert
Mitglied: Bitboy
12.07.2013 um 14:33 Uhr
Hi,

was steht denn bis jetzt in dem Script drin?

Wurden die Laufwerke früher über net use ... /PERSISTENT:NO gemappt oder nicht?
Die alten Laufwerke könnteste du mit net use /delete .... löschen lassen bevor die neuen gemappt werden.
Bitte warten ..
Mitglied: templier
12.07.2013, aktualisiert um 17:35 Uhr
Hallo

Ich würde zuerst mal schauen ob die aktuelle GPO überhaupt gezogen (aktualisiert) wird - Ggf. erstmal einen refresh fahren und die GPO´s nochmal ziehen - CMD Fenster am betreffenden Client öffnen und: "gpupdate /force" eingeben. Schreib doch bitte mal, ob das funktioniert.

Habt ihr mehrere Domänencontroller, oder nur einen? Wenn ihr mehrere habt kann es dann natürlich auch sein das die "neue" GPO noch nicht in der Active Directory durchrepliziert wurde und Du bei Deiner Anmeldung immer auf einen DC stösst der noch nicht aktualisiert wurde. Denke daran das am Client der letzte DC, wo man sich erfolgreich angemeldet hat, gespeichert wird. Ist dieser nicht verfügbar - Wird erst der nächste DC aufgesucht, usw, und so fort. Hier dann auch bitte erst mal eine Active Directory Replikation manuell anstossen, damit Dir auch sicher sein kannst das die neue GPO überall innert der Domäne wirklich zur Verfügung steht.

Viele Grüsse
Ralph
Bitte warten ..
Mitglied: r.obert
14.07.2013 um 10:34 Uhr
Hi bitboy, ich habe meinen Eintrag mit zwei screenshots ergänzt.

viele Grüße r.obert
Bitte warten ..
Mitglied: templier
14.07.2013 um 10:44 Uhr
Da würde ich für jedes Laufwerk mal "/PERSISTENT:NO" ergänzen.
Bitte warten ..
Mitglied: r.obert
14.07.2013 um 13:04 Uhr
Hallo Ralph,
die Zeile lautet z.B. nun:

net use M: "\\18\Zeichnungsarchiv /PERSISTENT:NO"

it das richtig, oder muss ich eigene Anführungen machen?


Gruß
R.obert
Bitte warten ..
Mitglied: templier
14.07.2013 um 13:21 Uhr
Hallo Robert,

was mir eben, nach Deinem letzten Beitrag, auch in Deinem ursprünglichen Script aufgefallen ist - Warum setzt Du eigentlich den Pfad (der keine Leerzeichen enthält) in Hochkomma? Das brauchst Du doch gar nicht?

Ich würde es so Schreiben, ohne Hochkommas:

net use M: \\18\Zeichnungsarchiv /PERSISTENT:NO

Viele Grüsse
Ralph
Bitte warten ..
Mitglied: r.obert
14.07.2013 um 13:54 Uhr
Hi Ralph,
ich habe es jetzt umgeschrieben. Bin schon gespannt auf morgen!
Was bewirkt der Zusatz /persistent:no eigentlich?

Viele Grüße

Robert
Bitte warten ..
Mitglied: templier
14.07.2013, aktualisiert um 19:05 Uhr
Hallo Robert,

das die Laufwerkszuordnung, bei dem betreffenden Benutzer, nicht (wie sonst oft üblich) dauerhaft in der Registry gespeichert wird. Und somit, die Laufwerkszuordnung, bei jedem Abmelden des Benutzers, aus der Registry wieder herausgelöscht wird.

In der GUI wäre das übrigens, wenn man sich mit einem Netzlaufwerk verbinden möchte, der Haken: "Verbindung bei Anmeldung wiederherstellen". Wenn man den nicht anklickt, dann ist die Verbindung sozusagen: "PERSISTENT:NO"

Viele Grüsse
Ralph

Tante EDITH:
Stolperfalle: Wenn Du hier jetzt gewisse Laufwerke geändert hast, und vorher die Benutzer die Laufwerke OHNE "PERSISTENT:NO" bekommen haben, bleiben die ggf. erhalten, weil sie ja in dem Moment für den Benutzer "dauerhaft" in der Registry hinterlegt wurden. Lasse also am besten zuerst nochmal das "alte" Script, mit dem ergänztem Parameter, vorher laufen, bis sich alle Benutzer einmal angemeldet haben! Und somit die alten Einträge in der Registry erst einmal Überschrieben wurden. Danach kannst Du das neue Script zum Einsatz bringen.
Bitte warten ..
Mitglied: java667
15.07.2013 um 10:49 Uhr
Ich glaube das PERSISTENT:NO spielt hier keine Rolle. In seinem Script werden alle Laufwerk immer erst gelöscht und erst dann werden die Laufwerke verbunden. Lässt sich aber leicht prüfen, einfach das Script ausführen und kucken ob es tut, was es soll.

Ansonsten, wie oben schon geschrieben, mal prüfen ob die GPO überhaupt gezogen wird.
Bitte warten ..
Mitglied: templier
15.07.2013, aktualisiert um 10:51 Uhr
Das "Delete" hat er erst nachträglich eingefügt, nach dem ersten Eintrag von "bitboy" hier. Zumindest, soweit ich das Verstanden habe.
Bitte warten ..
Mitglied: r.obert
15.07.2013 um 11:53 Uhr
Hallo Ralph,
jetzt habe ich die Datei direkt auf meinem Rechner ausgeführt. Folgendes ist mir dabei aufgefallen:
Wenn ich die vorhandenen Laufwerke manuell trenne, und dann das Skript starte, erscheint alles was ich im Skript hinterlegt habe. Wenn ich die LW nicht trenne, das Skript ausführe, ergänzt er mir nur ein paar LW. Die alten vergebenen LW-Buchstaben bleiben mit dem alten nicht mehr benötigtem LW verknüpft! Das Skript löscht nicht die ersten Verknüpfungen, nach jedem Anmelden erscheint immer der alte Mist. Die GPo greift habe ich mit GPedit getestet.

Viele Grüße

R.obert
Bitte warten ..
Mitglied: templier
15.07.2013, aktualisiert um 12:02 Uhr
Siehe dazu meinen Post von gestern - Du machst einen Denkfehler und musst erst das "alte" Script nochmal ausrollen, ergänzt mit dem Parameter: PERSISTENT:NO , weil die Laufwerke doch durch das alte Script quasi hart "verdrahtet" wurden, das musst du jetzt erst wieder korrigieren:

Siehe meinen Post oben:
Tante EDITH:
Stolperfalle: Wenn Du hier jetzt gewisse Laufwerke geändert hast, und vorher die Benutzer die Laufwerke OHNE "PERSISTENT:NO" bekommen haben, bleiben die ggf. erhalten, weil sie ja in dem Moment für den Benutzer "dauerhaft" in der Registry hinterlegt wurden. Lasse also am besten zuerst nochmal das "alte" Script, mit dem ergänztem Parameter, vorher laufen, bis sich alle Benutzer einmal angemeldet haben! Und somit die alten Einträge in der Registry erst einmal Überschrieben wurden. Danach kannst Du das neue Script zum Einsatz bringen.
Bitte warten ..
Mitglied: templier
15.07.2013, aktualisiert um 12:13 Uhr
Step by step:

Altes Script anpassen: Bei jeder Laufwerkszuweisung PERSISTENT:NO ergänzen

Altes Script nochmal zum Einsatz bringen, damit bei jedem Benutzer (bei seiner Anmeldung) die Laufwerkszuordnung(en) auf "temporär" gesetzt wird. Indem diese in der Registry umgeschrieben werden.

Erst danach, (wenn jeder Benutzer sich einmal angemeldet hat) neues Script in die Runde werfen
Bitte warten ..
Mitglied: Pjordorf
15.07.2013 um 12:54 Uhr
Hallo,

Zitat von templier:
Altes Script anpassen: Bei jeder Laufwerkszuweisung PERSISTENT:NO ergänzen
Das ist alle nicht nötig. Ein
net use * /Delete / Yes
löscht alle gespeicherte Verbindungen aus der Registrierung sodass diese beim nächsten Anmelden nicht mehr Verbunden werden.

Altes Script nochmal zum Einsatz bringen
Auch nicht nötig.

Erst danach, (wenn jeder Benutzer sich einmal angemeldet hat) neues Script in die Runde werfen
Blödsinn.

@ r.obert
Stell in deiner Batchdatei mal ein net use sowie ein pause rein, und mit der Option zum Anzeigen von Scripts (Benutzerkonfiguration - Administrtive Vorlagen - System - Skripts - Anmeldeskripts sichtbar ausführen) wirst du dann sehen was bei dir passiert oder eben nicht passiert.

Im Script als erstes mal ein net use um festzustellen was alles womit verbunden ist. Damit du es Lesen kannst, kommt ein Pause dahinter.
@echo off 
Echo Folgende Laufwerke sind verbunden: 
net use 
pause 
 
rem Laufwerke Loeschen, alle und immer. 
Echo Alle Laufwerke Loeschen 
net use * /delete /yes 
 
rem Schauen ob alles geloescht wurde 
Echo Es sollten keine Laufwerke mehr vorhanden sein 
net use 
pause 
 
rem Benoetigte Laufwerke Verbinden 
Echo Verbinden von Laufwerken: 
net use M: "\\18\Zeichnungsarchiv" 
net use N: "\\18\Maschinenbau"           /Persistent:no 
net use O: \\18\Automobiltechnik         /Persistent:yes 
net use P: \\18\Post 
net use Q: "\\18\CAD-Archiv"             /Persistent:yes 
net use S: "\\152\SolidWorks"            /Persistent;yes 
net use R: "\\18\Konstruktionsbilder"    /Persistent:yes 
 
REM Schauen onb alle Verbunden wurden sofern ich den Meldungen beim Verbinden nicht traue 
Echo Verbunden sind: 
net use 
pause 
 
REM ab hier weitere Skripts
Das stellen der Uhrzeit ist in einer Domäne so nicht nötig. Alle Clients holen sich (per Standard) die Zeit vom DC. Wenn nicht, habt ihr noch andere Probleme in eurer Domäne.

Zu Net Use einfach mal hier http://technet.microsoft.com/en-us/library/gg651155(v=ws.10).aspx schauen. Da ist auch der Schalter Persistent und seine Funktion erläutert. Und was Persistent noch so für bedeutungen hat kannst du hier http://www.dict.cc/?s=persistent nachlesen

Auch was das Benutzen von Anführungszeichen Betrifft ist es, wie du oben sehen kannst, wurscht solange du eben keine Leerzeichen im Pfadnamen drin stehen hast. Solange kannst du mit oder ohne Arbeiten.
Vorteil - kommen Leerzeichen vor ist alles OK und es gibt keinen Fehler
Nachteil - Du musst 2 zeichen mehr eintippen.

Empfehlung: Immer mit in Batchdateien Arbeiten. Ein Vergessen gibt es dann nicht.

Gruß,
Peter
Bitte warten ..
Mitglied: DerWoWusste
15.07.2013, aktualisiert um 12:55 Uhr
Hi.

Ich habe eine Anmerkung zu der letzten Zeile: net time...
Die Uhrzeit kannst Du nicht mit einem Logonskript synchronisieren, denn das erfordert Adminrechte. Du müsstest diese Zeile also in ein Startskript schreiben. ergo: das lief NOCH NIE. Teste immer aus, was Du konfigurierst und auch nicht mit Adminrechten, sondern mit normalen Nutzerrechten.
Bitte warten ..
Mitglied: r.obert
17.07.2013 um 07:50 Uhr
Hallo zusammen,
nachdem ich nun drei Tage testen ließ, muss ich sagen, dass alles nicht funktioniert. Wenn ich das cmd manuell ausführe, löscht er alle gemappten und mappt neue Volumes. Leider macht er das nicht standardmäßig nach jedem boot. Wenn ich aber das Skript ausführe, und danach reboote funktioniert es. Hat jemand noch eine Idee?

Viele Grüße

Robert
Bitte warten ..
Mitglied: Pjordorf
17.07.2013 um 10:45 Uhr
Hallo,

Zitat von r.obert:
ich nun drei Tage testen ließ
Warum hast nicht du selbst getestet?

muss ich sagen, dass alles nicht funktioniert.
Das hilft dir hier nicht und uns auch nicht wenn du Pauschal sagst alles geht nicht. Damit kann hier keiner etwas anfangen. Fehlermeldung sehen anders aus. U nd auch im obigen Skript erzeugt jede zeile eine entsprechende Fehlermeldung wenns denn ein Fehler ist, oder eine entsprechende Ausgabe wenn der befehl eben keine Fehler auslöst. Im obigen Script sind alleine 3 malPause drin, welche zwingend einen Tastendruck seitens eines Bedieners erfordert um weiterzuarbeiten, und die dort dann stehenden Ausgabe auf den Monitor ermögöichen schon eine Analyse von dem was da gerade passiert ist. Dort steht aber nie nie niemals Alles ghet nicht.

Wenn ich das cmd manuell
Dann kommt meistens ein C:\...\> Wobei die drei Punkte einen Pfad deines Systems darstellt, abhängig deiner Umgebung deines OSes. Wenn nicht, wurde entweder am System rumgeschraubt odre es wurde kein CMD eingegeben odre dein OS ist kein Windows.

ausführe, löscht er alle gemappten und mappt neue Volumes
Aha, da tut alos etwas das so wie du es erwartetst, oder können wir sagen da geht doch etwas? Fragt sich nur was!

Leider macht er das nicht standardmäßig nach jedem boot
Klar, ohne Anmeldung wird er da ja nicht weitergehen, oder? Booten <> Anmelden. Beim Booten kennt er deinen Benutzer noch gar nicht und somit auch nicht dessen Rechte. Dafür ist ja das Anmelden zuständig. Aber du redest jetzt auch nicht von Startup Skripts, sondern schon von Anmeldeskripts, oder?

Wenn ich aber das Skript ausführe
Welches?

und danach reboote funktioniert es
Durch den Reboot machst du aber alles zunichte was dein Skript gerade gemacht hat. Somit gilt nur das was seit dem Neustart gemacht wurde. Vergiss dann was dein Skript vorher gemacht gemacht hat, das ist nämlich da schon geschichte.

Hat jemand noch eine Idee?
Nur wenn du un s eine oder mehere Logische und aufeinander folgende Fehlermeldungen rüberschiebst, kann dir weitergeholfen werden. Wenn du aber hier nichts an uns weitergibst, irgend etwas testen lässt was wir alles nicht kennen, dann kannst du nicht erwarten das wir mit unserer Kristallkugel uns auf deinen Bildschirm aufschalten und sehen was du alles siehst. Wir wissen nur das was du uns sagst, nicht was du uns nicht sagst. Und denken können wir es uns auch nicht.

Poste mal was das obige Skript den beim Anmelden liefert (nachdem zum 3ten mal das pause alles anhält).

Gruß,
Peter
Bitte warten ..
Mitglied: java667
17.07.2013 um 10:46 Uhr
Bau dir mal mehrere Scripte und teste diese jeweils als Anmelde-Script:

1. Lass dir anzeigen welche Laufwerke verbunden sind
anzeigen.bat
01.
@echo off  
02.
Echo Folgende Laufwerke sind verbunden:  
03.
net use  
04.
pause 
Wenn das korrekt durchgeführt wird:

2. Trennen aller Laufwerke und anzeigen ob es geklappt hat.
trennen.bat
01.
rem Laufwerke Loeschen, alle und immer.  
02.
Echo Alle Laufwerke Loeschen  
03.
net use * /delete /yes  
04.
  
05.
rem Schauen ob alles geloescht wurde  
06.
Echo Es sollten keine Laufwerke mehr vorhanden sein  
07.
net use  
08.
pause 
Klappt das auch zuverlässig:

3. Laufwerke verbinden
verbinden.bat
01.
rem Benoetigte Laufwerke Verbinden  
02.
Echo Verbinden von Laufwerken:  
03.
net use M: \\18\Zeichnungsarchiv 
04.
net use N: \\18\Maschinenbau          
05.
net use O: \\18\Automobiltechnik 
06.
net use P: \\18\Post  
07.
net use Q: \\18\CAD-Archiv 
08.
net use S: \\152\SolidWorks 
09.
net use R: \\18\Konstruktionsbilder 
10.
  
11.
REM Schauen ob alle verbunden wurden, sofern ich den Meldungen beim verbinden nicht traue  
12.
Echo Verbunden sind:  
13.
net use  
14.
pause 
Wenn alle drei Scripte laufen, fügst du diese zusammen und nimmst den Befehl Pause raus.
Kleiner Tipp: finger nicht im alten Script rum, sondern erstelle drei neue Batch Files.
Bitte warten ..
Mitglied: Pjordorf
17.07.2013, aktualisiert um 11:13 Uhr
Hallo,

Zitat von java667:
Bau dir mal mehrere Scripte und teste diese jeweils als Anmelde-Script:
Welchen Vorteil soll dies haben das ich 3 verschiedene Skriptdateien einbinden muss gegenüber einer Datei un ddamit meine Fehlerquelle verdreifache? Hoffst du das der TO, weil jetzt 3 Dateien, er deshalb das tut was er nicht tut? Von einen Informationsgewinn kann hier obwohl eine verdreifachung der Dateianzahl vorliegt wohl nicht gesprochen werden

Gruß,
Peter
Bitte warten ..
Mitglied: templier
17.07.2013, aktualisiert um 11:16 Uhr
Zitat von Pjordorf:
Wir wissen nur das was du uns sagst, nicht was du uns nicht sagst. Und denken können wir es uns auch nicht.
Das ist wohl wahr Peter - Ins "Blaue hinein" kann niemand von uns vernünftige Ratschläge erteilen

Liebe Grüsse
Ralph

Tante Edith: Das scheint aber hier ein generelles Problem zu sein - Das sich die Leute, bei Ihrem "Problem", einfach unqualfiziert ausdrücken. Selbst nach mehrmaligem Nachhaken, kommen die wichtigsten Informationen viel zu spät. Mein persönlicher Klassiker: "Ich habe vergessen zu erwähnen....."
Bitte warten ..
Mitglied: r.obert
17.07.2013 um 11:34 Uhr
Getestet habe ich es am User, bei unserer Gruppe der Konstrukteure.

Also, das ist mein skript:
@echo off
echo Folgende Laufwerke sind verbunden:

net use
pause

rem Laufwerke loeschen, alle und immer.
Echo Alle Laufwerke Loeschen

net use * /delete /yes

rem Schauen ob alles geloescht wurde
Echo Es sollten keine Laufwerke mehr vorhanden sein
net use
pause



Rem Benoetigte Laufwerke Verbinden
Echo Verbinden von Laufwerken:
net use M: \\18\EDV /PERSISTENT:NO
net use N: \\18\Maschinenbau /PERSISTENT:NO
net use O: \\18\Automobiltechnik /PERSISTENT:NO
net use P: \\18\Post /PERSISTENT:NO
net use Q: \\18\Controlling /PERSISTENT:NO
net use R: \\222\Multimedia /PERSISTENT:NO
net use S: \\152\SolidWorks /PERSISTENT:NO
net use U: \\222\Autohaus /PERSISTENT:NO
net use W: \\150\WerWiSo /PERSISTENT:NO

rem Schauen ob alle verbunden wurden sofern ich den Meldungen nicht traue
Echo Verbunden sind:
net use
end

Das funktioniert, wenn ich es manuell betätige!
Hingegen in der GPO funktioniert es nicht, wenn ich den Rechner boote, und mich danach an der Domäne anmelde.
Ich habe gpupdate /force ausgeführt, um sie zu aktualisieren. Verbunden werden die LW mit de o.g. Skript manuell. Wenn ich nun neustarte, und mich wieder an der Domäne anmelde sind die LW immer noch da.
Fehlermeldung gibt es keine, es fehlen nur die Laufwerke, wenn das Skript über die GPO ausgeführt wird.

Client Betriebssystem Windows 7
Server Windows 2003
Bitte warten ..
Mitglied: Pjordorf
17.07.2013 um 11:51 Uhr
Hallo,

Zitat von r.obert:
Getestet habe ich es
OK.

Also, das ist mein skript:


Das funktioniert, wenn ich es manuell betätige!
D.h. auch das was vor Pause kommt ist korrekt und es muss 3 mal Pause bestätigt werden damit das Skript zu ende läuft?

Hingegen in der GPO funktioniert es nicht, wenn ich den Rechner boote, und mich danach an der Domäne anmelde.
Das Skript wird erst nach dem Anmelden gestartet, denn es ist ja ein Anmeldeskript. Also vor dem Anmelden passiert hiemit Logischerweise dann eben nichts. Korrektes Verhalten eines Anmeldeskripts.

Ich habe gpupdate /force ausgeführt, um sie zu aktualisieren.
Stört kein Anmeldeskript und auch kein Startuptskript. Da werden die nicht mit ausgeführt. Denen Interesiert also dein gpudate / Force schlichtweg nicht.

Fehlermeldung gibt es keine, es fehlen nur die Laufwerke, wenn das Skript über die GPO ausgeführt wird.
Aber auch dann solltest du die 3 mal Pause bestätigen müssen weil du ja das Anmeldeskript beim Anmelden siehst (nicht nur zum testen gut). Entweder läuft dein Anmeldeskript gar nicht erst an bzw. wird überhaupt nicht ausgeführt (meine Vermutung), oder es läuft an und erzeugt Fehler.

Du hast schon gelesen das ein Anmeldeskript sichtbar beim Anmelden ausgeführt werden kann? Ohne diesem ist es nur ein Blindflug durch das Universum.

Client Betriebssystem Windows 7
Server Windows 2003
Nett das du es jetzt schon für Erwähnenswert hälst
Aber für dein Problem macht es nix ob 2K3 oder 2K8 oder 2K11 oder XP/W7. Wie du Anmeldeskripts Sichtbar ausführen kannst hast du ja in meinem http://www.administrator.de/contentid/211345#comment-855352 schon gelesen, oder?

Gruß,
Peter
Bitte warten ..
Mitglied: templier
17.07.2013 um 11:53 Uhr
Zitat von Pjordorf:
> Client Betriebssystem Windows 7
> Server Windows 2003
Nett das du es jetzt schon für Erwähnenswert hälst
*grins*
Bitte warten ..
Mitglied: java667
17.07.2013 um 11:56 Uhr
Hallo,

Zitat von Pjordorf:
Hallo,

> Zitat von java667:
> Bau dir mal mehrere Scripte und teste diese jeweils als Anmelde-Script:
Welchen Vorteil soll dies haben das ich 3 verschiedene Skriptdateien einbinden muss gegenüber einer Datei un ddamit meine
Fehlerquelle verdreifache? Hoffst du das der TO, weil jetzt 3 Dateien, er deshalb das tut was er nicht tut? Von einen
Informationsgewinn kann hier obwohl eine verdreifachung der Dateianzahl vorliegt wohl nicht gesprochen werden

Gruß,
Peter

Vielleicht etwas missverständlich ausgedrückt. Er soll nicht alle drei einbinden, sondern jedes Script einzeln. Wenn alle drei einzeln funktionieren, sollten sie auch gemeinsam funktionieren. Ausserdem kann er so einfacherer überprüfen, wo der Fehler liegt.

Mir ist klar, das es die 3 fache Menge an Arbeit ist, aber @r.obert scheint ja damit Probleme zu haben, dieses einfache Script zu überblicken.

@r.obert
/PERSISTENT:NO kannst du dir sparen, net use * /delete /yes löscht deine Laufwerk zuverlässig.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Microsoft
Keine Anmeldung mehr möglich (Server 2012 R2) (4)

Frage von Shnuuu zum Thema Microsoft ...

Verschlüsselung & Zertifikate
Fileserver Verschlüsseln (16)

Frage von Eisern zum Thema Verschlüsselung & Zertifikate ...

Microsoft Office
Registerkarte in Excel automatisch färben (10)

Frage von ralfkausk zum Thema Microsoft Office ...

Windows Server
Jnlp Endungen mit Java automatisch verknüpfen über GPO (10)

Frage von staybb zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...