Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

DNS oder AD Problem oder beides

Frage Netzwerke DNS

Mitglied: traxxas2007

traxxas2007 (Level 1) - Jetzt verbinden

16.08.2007, aktualisiert 18.10.2012, 8617 Aufrufe, 4 Kommentare

Hi Forum,

ich bin gerade dabei ein neues W2003 R2 Netwerk auzusetzen. Bisher besteht das Netzwerk aus einem PDC und einem BDC. Der PDC hat 2 NIC und BDC 1. Auf Beiden Servern sind die Dienst DNS, DHCP und WINS installiert. Die DNS Server sind AD aktiviert und Verwalten Ihre Zonen im AD. Die DHCP Server verwalten beide die gleiche Zone wobei während der Konfiguration de 80/20 Regel angewendet wurde (alse Bereichs Ausblendung).
Soweit so gut. Nach der Installation und konfiguration wurden die üblichen Tests mit den Tools „NSLOOKUP“, „PING –a“, „DCDIAG“, „NETDIAG“ audgeführt.
Nachdem alle Tests soweit keine Fehler ergeben haben, wurde von mir auf dem PDC noch zusätzlich ein Exchange 2003 Server aufgesetzt. Während de EX2003 STD Service Pack 2 bin Strikt nach den vorgaben von MS vorgegangen.
Als ich noch diverse Test durchgeführt hatte wurde ein Neustart durchgeführt. Juhu dachte ich...
Nach dem Neustart habe ich wieder mit den oben genanten Tools die üblichen Tests durchgeführt. Um sicher zugehen das alles funktioniert habe ich mir dann nochmal das Ereigniss Protokoll angesehen. Wobei mir auffiel das angeblich am DNS irgendwas nicht stimmt. Also habe ich mir nochmal die DNS konfiguration angesehen. Dabei fiel mir auf das laut DNS Überwachung (in der Konfigurations Konsole) die Auflösung von Rekursiven Abfragen nicht funktioniert. Um das Ergebniss zu verifizieren habe ich in der Commandozeile wieder diverse test´s durchgeführt. Ergebnisslos laut NSlookup, Ping –a und Netdiag funktioniert alles nicht eine Abfrage brachte eine Fehlermeldung. Das einzige was bei diesen Test rauskommt ist das es funktioniert. was aber festellbar ist, ist das in der AD Management Konsole unter System/MicrosoftDNS die Forward Lookup Zone fehlt (eingertragen ist nur die Reverse Lookup Zone die Stammserver) und das wenn der Server einmal im Internet war und danach die Verbindung zum Router wieder getrennt wird, die DNS Überwachung in der DNS Console keine Fehler mehr bei den Rekursiven abfragen mehr bringt. Kann mir hier einer weiter helfen ?

Gruss

Marko
Mitglied: Rafiki
16.08.2007, aktualisiert 18.10.2012
Hi Marko,

beachte bitte auch diesen Beitrag:
http://www.administrator.de/forum/ich-bin-zu-doof-um-unseren-dns-server ...

Was genau hast du auf dem Server geprüft? Hast du mit nslookup den Server selber gefragt oder den DNS von deinem Internetprovider?
prüfe: nslookup meinserver -> ergibt die IP adresse von deinem server.
nslookup meinefirma -> wobei meinefirma die domain ist, ergibt die IP Adressen von den beiden DomainControllern.

Wenn ich deinen Beitrag richtig verstanden habe dann hat der DC der auch Exchange hat die zwei Netzwerkkarten. Wichtig ist das bei beiden Netzwerkkarten der DNS Server 127.0.0.1 und der richtige Domainsuffix eingetragen ist. Der DNS Dienst muss eine primäre Forward Lookup Zone haben. Ich rate zu der ActiveDirectory integrierten variante.

Gruß Rafiki
Bitte warten ..
Mitglied: traxxas2007
16.08.2007 um 21:40 Uhr
Hi,

ich habe immer die beiden internen DNS Server abgefragt also:

nslookup srv02 192.168.60.1 -> Ergebniss -> 192.168.60.2

korrekt oder

nslookup srv1 -> Ergebniss -> 192.168.60.1

während den Test´s bestand keine Verbindung zu einem Router die beiden Server waren hingen zusammen mit 5 Clients an einem Switch. Beim DC ist mittlerweile eine Karte deaktiviert. In den TCP/IP Konfiguration der NIC ist die eigene IP Adresse (192.168.60.1) als DNS Server eingetragen, kann also daran wahrscheinlich auch nicht liegen. Der DNS hat eine Primäre Lookup Zone und eine Reverse Lookup Zone und er ist ActiveDirectory integriert. Die DNS Einstellungen wurden auch ohne Fehlermeldung zum BDC repliziert. Domänen Suffix ist korrekt eingetragen.

Merkwürdig finde ich aber, das wenn ich in der "Active DIrectory Benutzer und Computer" Konsole die Ansicht auf erweitert Einstelle zwar die Reverse Lookup Zone (60.168.192...) sehe aber die Forward Lookup Zone nicht eingetragen ist obwohl beide Zonen als Active Directory integriert konfiguriert sind.

Was ich fast noch vergessen hätte, es existiert in der Forward Lookup Zone zusätzlich zu meiner Domänen Zone noch eine "_msdcs" Zone die W2K3 beim einrichten des DNS Server selbst angelegt hat.

Server
-> Forward-Lookupzonen
---> msdcs
---> meinDomänenName
-> Reverse-Lookzonen
---> 60.168.192...

Sonst noch ne Idee ???

Gruss

Marco
Bitte warten ..
Mitglied: Rafiki
16.08.2007 um 22:27 Uhr
Hi Marko,

du sagst:
aber die Forward Lookup Zone nicht eingetragen ist
nslookup srv02 192.168.60.1 -> Ergebniss -> 192.168.60.2 korrekt

Wenn tatsächlich eine Forward Lookup Zone eingetragen wäre, dann würde der nslookup Befehl scheitern. Fragt sich nun warum das die MMC für den DNS dieses nicht anzeigt.

habe ich mir dann nochmal das Ereigniss Protokoll angesehen. Wobei mir auffiel das angeblich am DNS irgendwas nicht stimmt.

Welches Event hast du? Wassagt www.eventid.net dazu?

Gruß Rafiki
Bitte warten ..
Mitglied: traxxas2007
17.08.2007 um 09:54 Uhr
Hi,

vom DNS erhalte ich ausser der Meldung 4015 (ist immer nur nach einem Neustart danach nict mehr). Aaaaaaaaaaaber im Verzeichnisdienst Log habe ich jetzt was gefunden, dort erhalte ich die Event ID 2088 was laut www.eventid.net darauf hinweist das die CNAME einträge nicht gesetzt sind. Habe dies dann nochmal konntroliert, was ich festellen konnte war

in der

DNS
- Forward-Lookupzone
--- SRV01
_msdcs.MeineDomäne.de
CNAME SRV01.meineDomäne.de
CNAME SRV02.meineDomäne.de
NS SRV01.meineDomäne.de
NS SRV02.meineDomäne.de
SOA vorhanden
WINS Lookup "
MeineDomäne.de
SOA vorhanden
NS "
NS "
WINS Lookup "
zusätzlich dann noch diverse A Einträge auf die Clients.

-- Reverse-Lookupzone
192.168.60.x Subnet
SOA vorhanden
NS "
NS "

zusätzlich dann noch diverse PTR Einträge auf die Clients. Also daran kanns wahrscheinlich auch nicht liegen. Auf dem 2 DNS ist alles genauso bis auf die CNAME einträge die sind dort nicht vorhanden was nach meinem verständnis auch korrekt ist.
Was mich aber noch irritiert ist das im "Active-Directory-Benutzer und Computer" in der Erweiterten ansicht unter "System / MicrosoftDNS / 60.168.192.in-addr.arpa /" ein Eintrag
"2 dnsNode" vorhanden ist diesen gibt es aber gar nicht.
Der einzigste Grund warum er vorhanden ist, könnte sein dass ich während der Installation die 2. NIC aktiviert hat. Da die Server NÍC´s immer fixe IP Adressen bekommen hatte diese die 192.168.60.2 dies könnte den Umstand erklären. Anbei noch das Ergebniss des Test´s "DCDIAG /Test:DNS" vielleicht hilft das ja weiter (es ist kein Router angeschlossen)

C:\Dokumente und Einstellungen\Administrator>dcdiag /test:DNS

Domain Controller Diagnosis

Performing initial setup:
Done gathering initial info.

Doing initial required tests

Testing server: Standardname-des-ersten-Standorts\SRV01
Starting test: Connectivity
......................... SRV01 passed test Connectivity

Doing primary tests

Testing server: Standardname-des-ersten-Standorts\SRV01

DNS Tests are running and not hung. Please wait a few minutes...

Running partition tests on : ForestDnsZones

Running partition tests on : DomainDnsZones

Running partition tests on : Schema

Running partition tests on : Configuration

Running partition tests on : MeineDomäne

Running enterprise tests on : MeineDomäne.DE
Starting test: DNS
Test results for domain controllers:

DC: srv01.MeineDomäne.DE
Domain: MeineDomäne.DE


TEST: Forwarders/Root hints (Forw)
Error: Forwarders list has invalid forwarder: 194.25.2.129 (<n
ame unavailable>)
Error: Forwarders list has invalid forwarder: 217.237.148.49 (
<name unavailable>)
Error: Root hints list has invalid root hint server: a.root-se
rvers.net. (198.41.0.4)
Error: Root hints list has invalid root hint server: b.root-se
rvers.net. (192.228.79.201)
Error: Root hints list has invalid root hint server: c.root-se
rvers.net. (192.33.4.12)
Error: Root hints list has invalid root hint server: d.root-se
rvers.net. (128.8.10.90)
Error: Root hints list has invalid root hint server: e.root-se
rvers.net. (192.203.230.10)
Error: Root hints list has invalid root hint server: f.root-se
rvers.net. (192.5.5.241)
Error: Root hints list has invalid root hint server: g.root-se
rvers.net. (192.112.36.4)
Error: Root hints list has invalid root hint server: h.root-se
rvers.net. (128.63.2.53)
Error: Root hints list has invalid root hint server: i.root-se
rvers.net. (192.36.148.17)
Error: Root hints list has invalid root hint server: j.root-se
rvers.net. (192.58.128.30)
Error: Root hints list has invalid root hint server: k.root-se
rvers.net. (193.0.14.129)
Error: Root hints list has invalid root hint server: l.root-se
rvers.net. (198.32.64.12)
Error: Root hints list has invalid root hint server: m.root-se
rvers.net. (202.12.27.33)

Summary of test results for DNS servers used by the above domain contro
llers:

DNS server: 128.63.2.53 (h.root-servers.net.)
1 test failure on this DNS server
This is not a valid DNS server. PTR record query for the 1.0.0.12
7.in-addr.arpa. failed on the DNS server 128.63.2.53

DNS server: 128.8.10.90 (d.root-servers.net.)
1 test failure on this DNS server
This is not a valid DNS server. PTR record query for the 1.0.0.12
7.in-addr.arpa. failed on the DNS server 128.8.10.90

DNS server: 192.112.36.4 (g.root-servers.net.)
1 test failure on this DNS server
This is not a valid DNS server. PTR record query for the 1.0.0.12
7.in-addr.arpa. failed on the DNS server 192.112.36.4

DNS server: 192.203.230.10 (e.root-servers.net.)
1 test failure on this DNS server
This is not a valid DNS server. PTR record query for the 1.0.0.12
7.in-addr.arpa. failed on the DNS server 192.203.230.10

DNS server: 192.228.79.201 (b.root-servers.net.)
1 test failure on this DNS server
This is not a valid DNS server. PTR record query for the 1.0.0.12
7.in-addr.arpa. failed on the DNS server 192.228.79.201

DNS server: 192.33.4.12 (c.root-servers.net.)
1 test failure on this DNS server
This is not a valid DNS server. PTR record query for the 1.0.0.12
7.in-addr.arpa. failed on the DNS server 192.33.4.12

DNS server: 192.36.148.17 (i.root-servers.net.)
1 test failure on this DNS server
This is not a valid DNS server. PTR record query for the 1.0.0.12
7.in-addr.arpa. failed on the DNS server 192.36.148.17

DNS server: 192.5.5.241 (f.root-servers.net.)
1 test failure on this DNS server
This is not a valid DNS server. PTR record query for the 1.0.0.12
7.in-addr.arpa. failed on the DNS server 192.5.5.241

DNS server: 192.58.128.30 (j.root-servers.net.)
1 test failure on this DNS server
This is not a valid DNS server. PTR record query for the 1.0.0.12
7.in-addr.arpa. failed on the DNS server 192.58.128.30

DNS server: 193.0.14.129 (k.root-servers.net.)
1 test failure on this DNS server
This is not a valid DNS server. PTR record query for the 1.0.0.12
7.in-addr.arpa. failed on the DNS server 193.0.14.129

DNS server: 194.25.2.129 (<name unavailable>)
1 test failure on this DNS server
This is not a valid DNS server. PTR record query for the 1.0.0.12
7.in-addr.arpa. failed on the DNS server 194.25.2.129

DNS server: 198.32.64.12 (l.root-servers.net.)
1 test failure on this DNS server
This is not a valid DNS server. PTR record query for the 1.0.0.12
7.in-addr.arpa. failed on the DNS server 198.32.64.12

DNS server: 198.41.0.4 (a.root-servers.net.)
1 test failure on this DNS server
This is not a valid DNS server. PTR record query for the 1.0.0.12
7.in-addr.arpa. failed on the DNS server 198.41.0.4

DNS server: 202.12.27.33 (m.root-servers.net.)
1 test failure on this DNS server
This is not a valid DNS server. PTR record query for the 1.0.0.12
7.in-addr.arpa. failed on the DNS server 202.12.27.33

DNS server: 217.237.148.49 (<name unavailable>)
1 test failure on this DNS server
This is not a valid DNS server. PTR record query for the 1.0.0.12
7.in-addr.arpa. failed on the DNS server 217.237.148.49

Summary of DNS test results:

Auth Basc Forw Del Dyn RReg Ext
________________________________________________________________
Domain: MeineDomäne.DE
srv01 PASS PASS FAIL PASS PASS PASS n/a

......................... MeineDomäne.DE failed test DNS

C:\Dokumente und Einstellungen\Administrator>

Gruss

Marko
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Microsoft
AD Problem und VPN (4)

Frage von Yannosch zum Thema Microsoft ...

Webbrowser
DNS Problem in Browsern - Suche in Adresszeile (5)

Frage von tobivan zum Thema Webbrowser ...

Batch & Shell
gelöst AD: alle Domänen Benutzer - Problem OU CN (2)

Frage von lupolo zum Thema Batch & Shell ...

DNS
gelöst Homeserver (Zentyal) und Fritzbox DNS Problem (6)

Frage von CharlyXL zum Thema DNS ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (19)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...