Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

DNS Nicht aktuell

Frage Internet

Mitglied: cyb0rg

cyb0rg (Level 1) - Jetzt verbinden

16.04.2012 um 13:24 Uhr, 2581 Aufrufe, 11 Kommentare

Hallo zusammen,

ich habe folgende Konstellation:

1 Domain
1 Dedizierter Externer Server (Webserver) mit Linux und Plesk

Mein Problem:

wenn ich whois ausführe auf die domain, wird der DNS server richtig angezeigt. Pinge ich allerdings die domain an wird noch der alte webserver angezeigt (andere IP), erst wenn ich z.B bei meinem Client die DNS server von Google z.B 8.8.8.8 einfüge pingt es korrekt an, jedoch vom ISP ist es immernoch falsch... und das bei mehreren Providern... ich erwarte nicht eine sofortige aktualisierung jedoch... kann es nicht sein das nach 24H immernoch nicht aktuell ist, letzter test war nach 2,5 Monate immernoch nicht aktuell. Entweder mache ich etwas falsch? oder die DNS server von vielen Providern sind nicht aktuell!

was denkt ihr dazu?
Mitglied: Hitman4021
17.04.2012 um 21:25 Uhr
Hallo,

also ich gehe mal davon aus das du die Standard Fehlerquellen schon ausgeschlossen hast.

Hast du schon mal
01.
ipconfig /flushdns
versucht?

MIr ist es bei Serverwechseln schon öfter passiert das ich noch irgendwo in der Host Datei den alten hinterlegt hatte?

Nur damit ich das richtig verstanden habe:
-Du hast die IP deines Webservers geändert?
-Die NS(die bei WHOIS) sind die deines ISP's oder laufen die auf dem Webserver?
-Wenn du bei deinem Rechner
--Den eingetragenen NS abfragst bekommst du die alte IP?
--Den ISP NS abfragst bekommst du die alte IP?
--Den Google NS abfragst bekommst du die neue IP?

DNS Server von Providern sind aktuell. Bei Fehlkonfigurationen kann man keine neue Domain mit diesen NS registrieren.

Kommt bei
01.
nslookup %DEINE_DOMAIN% 195.130.198.254
die richtige IP raus?

mfg
Hitman
Bitte warten ..
Mitglied: cyb0rg
18.04.2012 um 09:21 Uhr
Hast du schon mal
01.
> ipconfig /flushdns 
02.
> 
versucht?

-> Natürlich habe ich, hinzufügen sollte ich, dass es an bestimmten standorten richtig aufgelöst wird und an andere wiederum nicht! Hab ich bereits bei Kunden vor ort versucht bei kollegen und @ home, jeweils unterschiedliche resultate! (jeweils andere DNS / ISP)

MIr ist es bei Serverwechseln schon öfter passiert das ich noch irgendwo in der Host Datei den alten hinterlegt hatte?

--> die Host datei lasse ich prinzipiell aus... nur in absoluten notfälle mache ich gebrauch davon ausserdem arbeite ich zum 70% mit Mac bzw Linux nur zu 30% mit windows ^^

Nur damit ich das richtig verstanden habe:
-Du hast die IP deines Webservers geändert?
---> Jein, ich habe mehrere Server bei verschiedenen RZ und habe 1 Domain die auf dem alten server (der noch online ist) war auf einen anderen "neueren server" umgezogen.

-Die NS(die bei WHOIS) sind die deines ISP's oder laufen die auf dem Webserver?
----> die NS von whois sind meine nicht die von irgendwelchen ISP, zufällig ist der webserver auf dem gezeigt werden soll auch gleichzeitig der NS... und lediglich 1 ist eingetragen nicht mehrere.

-Wenn du bei deinem Rechner
--Den eingetragenen NS abfragst bekommst du die alte IP?
---> Wie gesagt kommt sehr darauf an wo ich bin.

--Den ISP NS abfragst bekommst du die alte IP?
---> hmm wie machst du des?

--Den Google NS abfragst bekommst du die neue IP?
---> Bein einfügen von Google DNS server in meine konfig kommt bisher IMMER die IP die eigentlich sein soll.

DNS Server von Providern sind aktuell. Bei Fehlkonfigurationen kann man keine neue Domain mit diesen NS registrieren.
----> Davon war ich auch ausgegangen... deswegen meine Fehlersuche

Kommt bei
01.
> nslookup %DEINE_DOMAIN% 195.130.198.254 
02.
> 
die richtige IP raus?
-----> kommt drauf an wo ich bin...

Es fällt mir sehr schwer vorzustellen das die DNS server der ISP nicht aktuell sind, denn wenn ich daran denke das für webserver oft Backup server eingesetzt werden für den Fall das einer ausfällt dann würde das ja gar nicht funktionieren, ergo "kann doch nicht sein!" jedoch gleichzeitig die Frage... wieso es mit den DNS servern von google in der Konfig immer richtig ausgewertet wird?.... teufelsküche.. will verstehen wo der wurm ist was habe ich falsch gemacht...

mfg
Bitte warten ..
Mitglied: Hitman4021
18.04.2012 um 09:53 Uhr
Hallo

Zitat von cyb0rg:
> -Die NS(die bei WHOIS) sind die deines ISP's oder laufen die auf dem Webserver?
----> die NS von whois sind meine nicht die von irgendwelchen ISP, zufällig ist der webserver auf dem gezeigt werden soll
auch gleichzeitig der NS... und lediglich 1 ist eingetragen nicht mehrere.
Du musst bei der Registration der Domain 2 NS angeben?
Hast du beim Registrar die IP vom NS ändern lassen?
Ist der Nameserver ein Bind NS?

> --Den ISP NS abfragst bekommst du die alte IP?
---> hmm wie machst du des?
01.
nslookup %DEIN_DOMAIN% %NS_DEINES_ISP%
> Kommt bei
>
01.
> > nslookup %DEINE_DOMAIN% 195.130.198.254 
02.
> > 
> die richtige IP raus?
-----> kommt drauf an wo ich bin...
Nein du fragst dezidiert einen Server ab die gesamte andere Konfiguration wird nicht berücksichtigt das Ergebnis muss überall gleich sein

Gruß
Bitte warten ..
Mitglied: cyb0rg
18.04.2012 um 11:01 Uhr
Du musst bei der Registration der Domain 2 NS angeben?
Nicht zwingend, 2 sind empfohlen aber 1 wird auch angenommen

Hast du beim Registrar die IP vom NS ändern lassen?
Natürlich

Ist der Nameserver ein Bind NS?
ja der Nameserver ist ein Bind allerdings erfolgt die verwaltung nicht über die shell sondern über Plesk

nslookup %DEIN_DOMAIN% %NS_DEINES_ISP%
nach diesem befehl war es plötzlich wieder aktuell! vorher nicht!

> > nslookup %DEINE_DOMAIN% 195.130.198.254
> > die richtige IP raus?
inzwischen schon, bis jetzt kam immer domain not found....

Nein du fragst dezidiert einen Server ab die gesamte andere Konfiguration wird nicht berücksichtigt das Ergebnis muss
überall gleich sein
wo liegt dann der fehler?

cheers
Bitte warten ..
Mitglied: Hitman4021
18.04.2012 um 11:09 Uhr
Okay ich schätze das du bei en Rechnern wo du falsche Daten bekommst einen NS eingetragen hast der glaubt die Zone authoritiv delegiert zu haben.
Dadurch sieht der in seinen eigenen Zonen Files nach und fragt nicht beim delegierten Server nach.

[EDIT]
Bzw. mir ist gerade wider eingefallen, dass manche ISP wenn du über deren Website eine Domain registrierst auf Ihren NS die Zone anlegen. Wenn du nun die NS deines ISP eingetragen hast antworten die mit der alten IP. Normalerweise haben die ein Webinterface zur Verwaltung?

Versuch mal
01.
  
02.
nslookup %DEINE_DOMAIN% %NS_DER_IN DEINER KONFIG_STEHT%
Jetzt sollte in der Rückgabe "Nicht autorisierende Antwort" über der Antwort stehen?
Ist das vorhanden?
[/EDIT]


Gruß
Bitte warten ..
Mitglied: cyb0rg
18.04.2012 um 13:28 Uhr
Okay ich schätze das du bei en Rechnern wo du falsche Daten bekommst einen NS eingetragen hast der glaubt die Zone authoritiv
delegiert zu haben.
Dadurch sieht der in seinen eigenen Zonen Files nach und fragt nicht beim delegierten Server nach.
wie kann ich das ändern?

[EDIT]
Bzw. mir ist gerade wider eingefallen, dass manche ISP wenn du über deren Website eine Domain registrierst auf Ihren NS die
Zone anlegen. Wenn du nun die NS deines ISP eingetragen hast antworten die mit der alten IP. Normalerweise haben die ein
Webinterface zur Verwaltung?
die domain habe ich nicht bei einem ISP registriert, sondern bei der zuständigen nic stelle und da werden keine NS automatisch zugewiesen, sondern ich muss diese selbst angeben.

Versuch mal
01.
  
02.
> nslookup %DEINE_DOMAIN% %NS_DER_IN DEINER KONFIG_STEHT% 
03.
> 
Jetzt sollte in der Rückgabe "Nicht autorisierende Antwort" über der Antwort stehen?
Ist das vorhanden?
Jep das ist vorhanden

cheers
Bitte warten ..
Mitglied: Hitman4021
18.04.2012 um 14:09 Uhr
Zitat von cyb0rg:
> Versuch mal
>
01.
  
02.
> > nslookup %DEINE_DOMAIN% %NS_DER_IN DEINER KONFIG_STEHT% 
03.
> > 
> Jetzt sollte in der Rückgabe "Nicht autorisierende Antwort" über der Antwort stehen?
> Ist das vorhanden?
Jep das ist vorhanden
Steht die richtige IP dabei?

Gruß
Bitte warten ..
Mitglied: cyb0rg
18.04.2012 um 14:42 Uhr
> > Versuch mal
> >
01.
  
02.
> > > nslookup %DEINE_DOMAIN% %NS_DER_IN DEINER KONFIG_STEHT% 
03.
> > > 
> > Jetzt sollte in der Rückgabe "Nicht autorisierende Antwort" über der Antwort stehen?
> > Ist das vorhanden?
> Jep das ist vorhanden
Steht die richtige IP dabei?

jetzt schon aber war vorher nicht der fall

cheers
Bitte warten ..
Mitglied: Hitman4021
18.04.2012 um 14:46 Uhr
Und das ist der Nameserver der bei
01.
ipconfig /all
aufscheint?

gruß
Bitte warten ..
Mitglied: cyb0rg
18.04.2012 um 15:38 Uhr
Und das ist der Nameserver der bei
01.
> ipconfig /all 
02.
> 
aufscheint?
ja klar

cheers
Bitte warten ..
Mitglied: Hitman4021
18.04.2012 um 15:47 Uhr
Dann beobachte das mal weiter und schau ob das jetzt funktioniert?
Vl hat es echt nur ein Server viel zu lange gecached ;)

Gruß
Bitte warten ..
Ähnliche Inhalte
Hardware
gelöst APU2C2 für Pfsense noch aktuell? (2)

Frage von Fenris14 zum Thema Hardware ...

Windows Netzwerk
gelöst DNS - Weiterleitung zu DNS-Server in anderer Domain (7)

Frage von Schauer zum Thema Windows Netzwerk ...

Microsoft Office
gelöst VBA - aktuelle Kalenderwoche ermitteln (3)

Frage von Ghost108 zum Thema Microsoft Office ...

Neue Wissensbeiträge
Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(14)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

RedHat, CentOS, Fedora

Fedora 27 ist verfügbar

Information von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
Server
Bilder aus dem Web mit CSV runterladen (30)

Frage von Yannosch zum Thema Server ...

Windows Update
WSUS 4 (Server 2012 R2) - Windows 10 Updates nicht möglich (12)

Frage von c0d3.r3d zum Thema Windows Update ...

Windows Userverwaltung
gelöst Administrator hat alle Rechte verloren (10)

Frage von mrdead zum Thema Windows Userverwaltung ...