Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

DNS Auflösung sporadische Fehler

Frage Microsoft Windows Netzwerk

Mitglied: Cougar77

Cougar77 (Level 1) - Jetzt verbinden

12.10.2011 um 11:24 Uhr, 6859 Aufrufe, 10 Kommentare

Hallo,

ich habe ein ziemliches Problem, das ich aber irgendwie nicht wirklich zu fassen bekomme.

Wir haben einen Win 2003er Server als DC, DHCP und DNS.
Bei einigen Clients schlägt sporadisch die DNS-Auflösung fehl. Diese Clients sind fast ausschließlich Vista und 7-Clients. Bei XP Rechnern (die Masse der Rechner) tritt der Fehler nicht (siehe weiter unten) auf.
Der DNS-Server ist per DHCP korrekt eingestellt.
Tritt der Fehler auf, schlägt ping NAME fehl, ebenfalls NAME.Domain. nslookup hingegen funktioniert einwandfrei.
Interessanterweise funktioniert es nach einem ipconfig /renew wieder, obwohl dabei haargenau die selben Werte beibehalten werden.
Ich bin hier etwas ratlos.

Bei einem der XP-Clients tritt ein vielleicht verwandtes Problem auf, das es überhaupt nicht geben dürfte...
Wir haben mehrere Drucker (hier LP1, LP2 etc. genannt), die mit integriertem Printserver arbeiten. Diese haben demnach eine IP, fest zugeteilt und in der DNS eingetragen.
Ab und zu kommt der Client auf die Idee, LP1 mit der IP des LP2 aufzulösen. -> Druck kommt woanders raus.
Aber auch hier, ipconfig /renew --> geht.

Ein ähnliches Problem wurde hier schon mal angesprochen, aber leider gab es keine Lösung, und meine Anfrage in dem Thread ging auch unter.
Mitglied: battl1984
12.10.2011 um 11:32 Uhr
Tja.. Das ist ja ein echt schräges Problem!

Ich würde mal den DNS-Cache von Server und Clients löschen. Dann würde ich auf dem Server mal die DNS-Aufräumfunktion nutzen. Dann den Server mal rebooten (sofern das möglich ist).

Aber Sinn macht das echt keinen, was da bei dir läuft...

Probier das mal und teile das Ergebnis, bin sehr neugierig
Bitte warten ..
Mitglied: Ausserwoeger
12.10.2011 um 11:42 Uhr
Wenn du zu keiner Lösung kommst würde ich falls du die möglichkeit hast testweise einen neuen DNS einrichten auf irgendeinem Server der dazu in der lage ist und eine auflösung über diesen Server versuchen. Wichtig dabei ist keine Daten vom alten DNS zu übernehmen und die beiden unabhängig voneinander arbeiten zu lassen.

LG Andreas Ausserwöger
Bitte warten ..
Mitglied: 60730
12.10.2011 um 12:16 Uhr
Servus,

ich vermute mal wir haben 2 getrennte Baustellen...

winvista /7
dort ist IPV6 aktiv und auf dem DNS Kasten nicht.

XP & Netzwerkdrucker;:
Drucken die über IP oder über den Namen?
Sicher, dass da keiner einen Printerpool eingerichtet hat?
Was für Modelle sind das überhaupt?

Gruß
Bitte warten ..
Mitglied: winf-hst
12.10.2011 um 12:55 Uhr
Hallo,

ich würde auch mal empfehlen ipv6 zu deaktivieren falls ihr dies nicht im Unternehmen einsetzt kann es evtl. Fehler erzeugen.
Habt ihr einen alternativen DNS Server ? Vielleicht solltest du einen solchen mal einrichten?

Wie werden eure Drucker denn auf die Clients verteilt? Per IP oder per DNS?

Gruß
Bitte warten ..
Mitglied: Cougar77
12.10.2011 um 13:51 Uhr
@Timo
Ja, denke ich auch...

An IPV6 hab ich auch gedacht und habs schon bei einigen deaktiviert --> Da das Problem nur sporadisch auftritt, kann ich aber nicht sagen, ob das das Problem behebt. --> Bin mir auch ziemlich sicher, das gestern bei einem gehabt zu haben, bei dem ich V6 schon raus hatte.

Die Drucker laufen über DNS - Name (wie könnte er bei der IP sonst die falsche erwischen, gut, geht mir auch so nicht ein...).
Sollte das einer getan haben, habe ich den noch nicht gefunden... und der ders getan hätte, wäre sicherer, wenn ich IHN nicht finde, aber ich bin mir 99,99999% sicher, dass nicht.
Ein Kyocera IP2200 und ein Kyocera FS-4020.

@winf
Siehe oben.

Alternativen DNS habe ich aktuell keinen --> fehlt mir die Maschine aktuell, der ich das antun kann ^^ (ja, ist nicht viel, aber lieber nicht)

Die Clients sprechen die Drucker via DNS an.
Bitte warten ..
Mitglied: 60730
12.10.2011 um 14:02 Uhr
Salü,

Die Drucker laufen über DNS
Und schon haben wir einen möglichen Weg gefunden, warum das in die Hose geht.....

Trage im Printserver die IP ein und tausche die per DNS verteilten Drucker z.B via Loginscript gegen die IP aus.

Ein Kyocera IP2200 und ein Kyocera FS-4020.
Hab ich nicht - kenn ich nicht - daher keine weiteren Infos von mir, aber das die Nics von Druckern gerne mal schauderhaftes anstellen, dass schrieb ich dann doch noch.

Die Baustelle mit
Tritt der Fehler auf, schlägt ping NAME fehl, ebenfalls NAME.Domain. nslookup hingegen funktioniert einwandfrei.

Was pingst du denn dann an -egal was - oder nur Server; Clients / Drucker?


gruß
Bitte warten ..
Mitglied: Cougar77
12.10.2011 um 14:25 Uhr
Es wäre eine Möglichkeit, das bei den Druckern zu umgehen, richtig.

Aber der Vollständigkeit halber sei erwähnt, dass es fast ausgeschlossen ist, dass die Drucker daran Schuld haben...
Sehr selten passiert es auch, dass mal ein Server nicht erreichbar ist mit dem selben Problem.
Nur bei den Druckern wird halt bei jedem Druck und damit oft und regelmäßig die Verbindung aufgebaut, beim Server seltener und langfristiger. Daher kommt das da seltener vor.

Ich pinge dann den Drucker an, der nicht funktioniert... erstmal. Druckt nicht --> pingt auch nicht. nslookup funktioniert. Anderer Drucker/Server/whatever pingt auch. Ping mit IP geht auch.
Bitte warten ..
Mitglied: Cougar77
18.10.2011 um 08:42 Uhr
Für das eine Teilproblem könnt ich mich selber schlagen...
Tipfehler im Namen des zweiten Druckers --> damit beide den gleichen Namen und damit ist die Verwechslung möglich.

Bleibt noch das größere Problem übrig...
Bitte warten ..
Mitglied: Cougar77
28.10.2011 um 11:56 Uhr
So.. einen Schritt weiter bin ich schon mal bei dem Problem...

Wenn der Fehler auftritt, versucht das System eine Auflösung des Namens per NetBIOS. Bekommt natürlich keine Antwort, versucht aber keine DNS-Auflösung...
Die Frage ist damit nicht mehr, WAS, sondern jetzt WARUM er das tut...

Ich habe in den Einstellungen der Netzwerkverbindung netBIOS deaktiviert.
Offenbar macht das aber keinen Unterschied, da seitdem der Fehler offenbar wieder aufgetreten ist (war ich leider nicht im Haus).
Bitte warten ..
Mitglied: Cougar77
14.11.2011 um 14:01 Uhr
Und noch ein Schritt weiter...

Ist netBIOS abgeschalten tritt der Fehler wie schon gesagt trotzdem auf...
Interessanterweise tut der Client dann garnichts, keine netBIOS-Anfrage aber auch keine DNS-Anfrage.
Kann mir das einer erklären?

Das muss doch eigentlich ein Problem des Clients sein und kann mit dem Server und den Druckern nichts zu tun haben, oder?

Ich habe testweise den DNS-Client-Dienst abgeschalten an zwei betroffenen Rechnern, bisher hatte ich da noch keine Ausfälle, aber das kann ja nicht die Lösung sein.
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows Netzwerk
OpenVPN- DNS Auflösung klappt teilweise nicht (6)

Frage von mario87 zum Thema Windows Netzwerk ...

DNS
Fritz VPN keine interne DNS Auflösung (13)

Frage von krodon zum Thema DNS ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...