Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

DNS cache immer wieder fehlerhaft.

Frage Microsoft

Mitglied: Kostas

Kostas (Level 1) - Jetzt verbinden

06.07.2012 um 10:40 Uhr, 4816 Aufrufe, 8 Kommentare

Hallo Zusammen,

ich habe immer wieder das Problem dass der DNS cache bei den Cleints fehlerhaft ist.
Wenn ich ein Ping [ServerName] absetze, bekomme ich eine falsche IP zurückgeliefert. Nach einem
ipconfig /flushdns wird wieder die richtige IP geliefert. Ich bin jetzt schon so weit dass ich
im Login script ipconfig /flushdns fest einbaue. Ich weis, das kann doch nicht sein. Aber ich
kann einfach nicht feststellen wann und zu welcher Zeit oder welcher Client den cache zerschießt.
Es ist sehr sporadisch und es betrifft ausnahmslos alle Client jedoch nie gleichzeitig.

Meine Frage an die Runde:
Was kann es für Folgen haben wenn ich täglich beim Anmelden eines jeden Users über das Login script
ipconfig /flushdns aufrufe?

Gruß Kostas
Mitglied: Lochkartenstanzer
06.07.2012 um 10:43 Uhr
Hallo Kostas,

Prüf mal deien DNS-Server und checke auch WINS. ggf hast Du da irgendwo noch falsche Einträge.

lks
Bitte warten ..
Mitglied: Marcel.Stolle
06.07.2012 um 10:46 Uhr
Hallo,

habe da noch paar Fragen zum Verständnis.

Was nutzt du für Client OS?
Welches Server OS?
Active directory? - Haben die DNS Server im AD im Ereignislog irgendwelche Fehler stehen?

MFG

Marcel
Bitte warten ..
Mitglied: Kostas
06.07.2012 um 11:15 Uhr
Hallo Marcel,

die Client sind XP und Win7 gemischt.
Der Server ist ein Win 2008RC2.
ADS wird verwendet.
Im DNS-Server Log sind Einträge jedoch nicht von heute. Ich hatte heute schon einige Probleme.
Das ist ja das gemeine dass ich überhaupt kein Hinweis habe wo denn das Problem liegen könnte.

Alle Meldungen (nur Hinweise keine Fehler) sind vom gleichen Typ:
"Das Laden von Zonen im Hintergrund ist abgeschlossen. Alle Zonen sind nun für DNS-Aktualisierungen und Zonenübertragungen verfügbar, sofern ihre jeweilige Konfiguration dies zulässt."

Gruß Kostas
Bitte warten ..
Mitglied: Lochkartenstanzer
06.07.2012 um 11:31 Uhr
  • Hast Du denn mal in die Datenbank vom DNS und ggf. vom WINS geschaut, ob da die richtigen Werte drinstehen? Wenn Ihr mehrere habt, dann bei allen nachschauen.

  • Ist bei den Clients wirklich nur ein NS eingetragen oder mehrere? ggf spucken sich da mehrere gegenseitig in die Suppe.

lks
Bitte warten ..
Mitglied: Kostas
06.07.2012 um 11:41 Uhr
Hi,

wir haben nur ein DNS welcher auf dem ADS läuft. Alle Clients haben als Prim. die feste IP des Servers eingetragen.
Der alternative DNS Eintrag ist leer. Ich weis jetzt nicht genau was du meinen könntest mit "in die DB vom und WINS schauen ob die richtigen Werte drinstehen"
in der Forward-Lookupzone.[Meine Domain] sind alle user richtig eingetragen. Das wirst du vermutlich nicht meinen oder?
Wo sollte ich bitte welche Werte überprüfen?

Gruß Kostas
Bitte warten ..
Mitglied: Penny.Cilin
06.07.2012 um 12:49 Uhr
Und schau mal in die Reverse Lookup Zone.
Wie schon angemekrt schau Dir die DNS und WINS Konfiguration an.


Gruss Penny.
Bitte warten ..
Mitglied: Kostas
06.07.2012 um 13:36 Uhr
Hallo Penny,

Reverse Lookup Zone ist leer.
ABER, ich glaube jetzt habe ich einen möglichen Fehler gefunden!
Im DNS-Manager rechtsklick auf die Domäne-Eigenschaften-NamensServer
war nicht nur die IP-Adresse des Servers sondern auch eine weitere. Nämlich
genau diese die die Client beim Pinkeln den Server zurückgeliefert
haben. Wie zum Geier die IP-Adresse da hineingekommen ist, ist mir nicht bekannt. Zumindest ist das eine schlüssige Ursache. Mal sehen ob das Problem jetzt damit beseitigt ist.

Gruß Kostas
Bitte warten ..
Mitglied: Pjordorf
06.07.2012 um 18:11 Uhr
Hallo,

Zitat von Kostas:
Reverse Lookup Zone ist leer.
Warum? Was wollt ihr damit bezwecken? Welchen Grund habt ihr dafür?

Wie zum Geier die IP-Adresse da hineingekommen ist, ist mir nicht bekannt
Manuell angelegt von jemand der ....? Oder mal am DC die IP geändert? oder oder oder....

Was sagt ein DcDiag /test:DNS?

Ist euer DNS überhaupt korrekt eingerichtet? Werden DNS Einträge korrekt gesetzt? DHCP usw. alles korrekt?

Gruß,
Peter
Bitte warten ..
Ähnliche Inhalte
SAN, NAS, DAS
Cache Upgrade StorWize v3700 (2)

Frage von bud5890 zum Thema SAN, NAS, DAS ...

Windows 7
gelöst Outlook Cache Mode auf verschiedenen Geräte (5)

Frage von manuwj zum Thema Windows 7 ...

CPU, RAM, Mainboards
gelöst L1 , l2 Cache geschwindigkeiten (4)

Frage von fundave3 zum Thema CPU, RAM, Mainboards ...

Exchange Server
Problem mit Exchange 2010 und Cache Modus (1)

Frage von Leo-le zum Thema Exchange Server ...

Neue Wissensbeiträge
LAN, WAN, Wireless

Neue Cisco Catalyst-Serie 9000

Information von Kuemmel zum Thema LAN, WAN, Wireless ...

Sicherheit

Millionen Euro in den Sand gesetzt?

(3)

Information von transocean zum Thema Sicherheit ...

Heiß diskutierte Inhalte
Netzwerke
Mobile Einwahl IPSec VPN von iPhone iPad T-Mobile zur Pfsense (14)

Frage von Spitzbube zum Thema Netzwerke ...

Ausbildung
Sinnvolles Einstiegsgehalt für FiSi nach der Ausbildung (12)

Frage von nutzername1 zum Thema Ausbildung ...

LAN, WAN, Wireless
Eine Netzwerkdose im Wechsel für zwei unterschiedliche Netze (12)

Frage von kartoffelesser zum Thema LAN, WAN, Wireless ...