Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

DNS CNAME funktioniert nicht

Frage Microsoft Windows Server

Mitglied: geforce28

geforce28 (Level 1) - Jetzt verbinden

24.10.2014 um 10:48 Uhr, 1511 Aufrufe, 6 Kommentare

Hallo Leute,

ich habe einen Windows Server 2012 R2 Server, welche DC ist und DHCP + DNS macht.
Ich habe eine Forward-Lookup Zone eingerichtet
In dieser habe ich dann einen Host (A) Records, welche auch funktionieren und beim Client richtig aufgelöst werden.
Nun möchte ich aber einen Alias (CNAME) einrichten, welcher auf DC01:8080/web verweißt, sodass man dann im browser einfach nur den alias "web" eingeben muss und "web" dann auf "DC01:8080/web" verweist... !
Dies funktioniert aber nicht.

Könnt ihr mir sagen, was das eventuell sein könnte oder was bei meiner Einrichtung falsch ist ??

Gruß
Geforce28
Mitglied: KowaKowalski
24.10.2014 um 11:01 Uhr
Hi Geforce,


Du kannst dem DNS keinen Port mitgeben.

Dafür brauchst Du nen (Reverse)Proxy.



mfg
kowa
Bitte warten ..
Mitglied: geforce28
24.10.2014 um 11:13 Uhr
Aber auch wenn ich was ohne Port mache läufst nicht
Bitte warten ..
Mitglied: geforce28
24.10.2014 um 11:37 Uhr
Ich habe nun bspw. mal einen CNAME gemacht der auf die Ip von Google (173.194.112.24) weiterleiten soll.
Auch das funktioniert nicht.
Wenn ich http://173.194.112.24/ direkt in meinen Browser eingebe kommt ganz normale google.de
Wenn ich den Aliasnamen "test" einfach eingebe, also http://test/, funktioniert es nicht, Warum !?
Bitte warten ..
Mitglied: Pjordorf
24.10.2014 um 11:49 Uhr
Hallo,

Zitat von geforce28:
also http://test/, funktioniert es nicht, Warum !?
Wohin zeigt dein oben genanntes http://test/ denn (NSlookup?)? Das ist kein FQDN, oder?

Gruß,
Peter
Bitte warten ..
Mitglied: geforce28
24.10.2014 um 11:55 Uhr
Hallo,

"test" ist der Aliasname
nslookup test ergbit einfach nur folgendes:
Server: UnKnown
Address: 10.0.9.2 (Mein DC und DNS Server)

Name: test2.domain.lan (domain.lan=meine domäne)
Bitte warten ..
Mitglied: tikayevent
24.10.2014 um 13:54 Uhr
Mit CNAME-Einträgen kann man nur einen DNS-Eintrag auf einen vorhandenen DNS-Eintrag zeigen lassen. Die Sache mit dem Unterverzeichnis kann mit DNS pur nicht realisiert werden, da es eine HTTP-spezifische Sache ist.

Auf Seiten des Webservers muss aber auch ein entsprechender Namebased VHost angelegt werden, damit der eingegebene DNS-Name umgesetzt werden kann, daher funktioniert das mit Google nicht.

Um das Problem zu lösen, muss auf dem Webserver ein VHost angelegt werden, der web annimmt und auf DC01:8080/web weiterleitet. Dafür bitte die Anleitung des gewünschten Webservers konsultieren.
Bitte warten ..
Ähnliche Inhalte
Hosting & Housing
gelöst Webserver bei WIX, aber DNS Server wo anders (9)

Frage von laster zum Thema Hosting & Housing ...

DNS
DNS A und AAAA ipv6 records (2)

Frage von noise1 zum Thema DNS ...

DNS
gelöst Firmeninternen DNS Server um externe Domain erweitern (6)

Frage von Androxin zum Thema DNS ...

Neue Wissensbeiträge
Batch & Shell

Batch zum Zurücksetzen eines lokalen Profils

Tipp von Mr.Error zum Thema Batch & Shell ...

RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
VPN Tunnel aufbauen (16)

Frage von Hajo2006 zum Thema LAN, WAN, Wireless ...

Router & Routing
ASUS RT-N18U mit VPN Client hinter Fritzbox - Portforwarding (14)

Frage von marshall75000 zum Thema Router & Routing ...

Microsoft Office
Saubere HTML aus Word-Dokument (14)

Frage von peterpa zum Thema Microsoft Office ...

E-Mail
gelöst Probleme beim E-Mail Empfang (12)

Frage von TommyB83 zum Thema E-Mail ...