Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

DNS löst lokale Namen nicht auf

Frage Linux Linux Netzwerk

Mitglied: bytecounter

bytecounter (Level 2) - Jetzt verbinden

22.08.2011 um 20:28 Uhr, 8227 Aufrufe, 6 Kommentare

Umgebung:
OpenSUSE 11.3
bind 9.7
IP des Servers (statisch): 192.168.150.2

Hallo zusammen,

bei dem Rechner werden lokale DNS-Einträge nicht korrekt aufgelöst, bzw. eigentlich schon:
Da ich auf Grund der Ausgabe von dig die Konfig von bind als korrekt erachte, hier nur der Auszug der relevanten Daten:

forwarder:
Lokaler DNS (192.168.150.1)
Google DNS (8.8.8.8)

Zone: local.
DNS der Zone: ns1.local
Eintrag: ns1 A-Eintrag 192.168.150.2

Port 53 in der Firewall ist offen

So, wenn ich nun
01.
dig ns1.local
eingebe, erhalte ich korrekt:
01.
; <<>> DiG 9.7.3-P3 <<>> ns1.local A 
02.
;; global options: +cmd 
03.
;; Got answer: 
04.
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25942 
05.
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0 
06.
 
07.
;; QUESTION SECTION: 
08.
;ns1.local.                     IN      A 
09.
 
10.
;; ANSWER SECTION: 
11.
ns1.local.              172800  IN      A       192.168.150.2 
12.
 
13.
;; AUTHORITY SECTION: 
14.
local.                  172800  IN      NS      ns1.local. 
15.
 
16.
;; Query time: 24 msec 
17.
;; SERVER: 127.0.0.1#53(127.0.0.1) 
18.
;; WHEN: Mon Aug 22 20:15:14 2011 
19.
;; MSG SIZE  rcvd: 57
Versuche ich es nun über ping, wird der Name nicht aufgelöst:
ping: unknown host ns1.local

Ein
01.
cat /etc/resolv.conf 
bringt folgendes:
01.
nameserver 127.0.0.1 
02.
nameserver 192.169.150.2 
03.
nameserver 192.168.150.1 
04.
nameserver 8.8.8.8
Wo könnte das Problem liegen?

vg
Bytecounter
Mitglied: dog
22.08.2011 um 21:15 Uhr
Bitte mal in einem anderen Fenster sudo tcpdump -i any port 53 starten, dann ping starten und dann die Ausgabe hier posten.
Bitte warten ..
Mitglied: bytecounter
22.08.2011 um 21:27 Uhr
Es erfolgt interessanterweise keine Ausgabe...

vg
Bytecounter
Bitte warten ..
Mitglied: dog
22.08.2011 um 21:29 Uhr
Dann probier mal einen Namen zu pingen, den nu noch nicht versucht hast (ggf. neuen anlegen).
Wenn das nicht klappt änder mal testweise das 53 in 5353.
Bitte warten ..
Mitglied: bytecounter
22.08.2011 um 21:40 Uhr
Da kommen wir der Sache schon näher...
Also bei externen Namen (z. B. google.de) läuft der Verkehr über Port 53

Bei internen Anfragen (.local) läuft der Verkehr über Port 5353, allerdings auf eine Multicast-Adresse:
sudo tcpdump -i any port 5353
01.
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode 
02.
listening on any, link-type LINUX_SLL (Linux cooked), capture size 65535 bytes 
03.
21:33:25.595314 IP testsystem1.mdns > 224.0.0.251.mdns: 0 A (QM)? ns1.local. (27) 
04.
21:33:26.597399 IP testsystem1mdns > 224.0.0.251.mdns: 0 A (QM)? ns1.local. (27) 
05.
21:33:28.602498 IP testsystem1.mdns > 224.0.0.251.mdns: 0 A (QM)? ns1.local. (27)
Anscheinend habe ich doch einen Fehler in meiner Konfig..aber wo bzw. was?
Bitte warten ..
Mitglied: dog
22.08.2011 um 22:07 Uhr
Du versucht eine reservierte Domain mit DNS zu benutzen.
.local ist reserviert für mDNS und darf eigentlich nicht über normales DNS aufgelöst werden.
Primär wird die Technik für Bonjour von Apple benutzt.

Kann man sicher irgendwo in suse abschalten.
Bitte warten ..
Mitglied: bytecounter
23.08.2011 um 09:24 Uhr
Das war der Fehler!
Hab das nun auf localnet geändert und es funktioniert!

Vielen dank!
Bytecounter
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
DNS
Nslookup gibt falschen DNS Namen zurück (3)

Frage von ultrapottoti zum Thema DNS ...

DNS
DNS Einstellungen für lokale Website ohne WWW (4)

Frage von Goimi zum Thema DNS ...

DNS
gelöst PfSense DNS-Forwarder löst nur IPv6 auf (5)

Frage von FA-jka zum Thema DNS ...

Heiß diskutierte Inhalte
Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...