Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

DNS-Problem bei Anmeldung ohne Domäne!

Frage Microsoft Windows Server

Mitglied: 51906

51906 (Level 1)

11.08.2007, aktualisiert 26.09.2007, 6510 Aufrufe, 14 Kommentare

hallo,

ich habe vor einiger zeit eine domäne in unserer firma eingerichtet da bislang alles über eine arbeitsgruppe lief. nach und nach habe ich jetzt die rechner in die domäne eingebunden und jetzt häufen sich die proleme mit einigen firmen-notebooks. und zwar werden diese notebooks, die auch in die domäne eingebunden sind, selbsterklärend auch zu hause eingesetzt.
wenn man sich jetzt an den geräten mit dem standard-domänen-konto anmeldet, was ja generell möglich ist, auch wenn der domänencontrolller nicht erreichbar ist und sich dann zu einem privaten w-lan verbindet, geschieht es irgendwann, dass man über dieses netzwerk nicht mehr surfen darf. weder über den internet explorer noch über firefox. andere programme wie icq z.b. funktionieren fehlerfrei. daher also die vermutung, das es sich um ein dns-problem handelt.
auch die anmeldung an ein lokales benutzerkonto (domäne rechnername) ändert jetzt nichts mehr.
was für eine verteufelt versteckte einstellung kann den nun falsch sein?
ich hab schon unzählige versuche gestarten mit irgendwelchen einstellungen das problem zu beheben, leider ohne erfolg.
ich hoffe jemand kann mir dabei helfen!
auf den notebooks läuft überall win xp sp2, der domänencontroller ist ein win2003 pro. die einstellungen der w-lans ist unterschiedlich, tut aber wahrscheinlich auch nichts zur sache, da andere geräte in diesen netzwerken tallos funktionieren.
also, bitte helfen...

vielen dank schonmal...

Jan
Mitglied: cykes
12.08.2007 um 07:04 Uhr
Hi Jan,

wie werden denn die IP Adresseinstellungen bzw. TCP/IP Einstellungen bei Euch im Netz
vorgenommen? Per DHCP oder sind es statische Adressen?

Habt ihr ind er Firma eventuell einen Proxyserver in den Browsern konfiguriert, der dann im
Heimnetz (oder Hotel etc.) natürlich nicht erreichbar ist? Beim Internetexplorer stehen die Proxyeinstellungen beispielsweise unter Internetoptionen -> Verbindungen.

Gruß

cykes
Bitte warten ..
Mitglied: 51906
12.08.2007 um 12:11 Uhr
hallo cykes,

erstmal vielen dank für deine antwort. habe wohl einiges vergessen zu erwähnen.
war etwas unter zeitdruck... ;) also in der firma gehen die notebooks übers kabel ans netz, mit fester ip. so dachte, da ja übers kabel, hat das ja erstmal gar nichts mit nem heim-w-lan zu tun aber irgendwas an den firmen-einstellungen scheint ihn ja trotzdem zu stören.
einen proxy verwenden wir auch nicht. keine automatische suche der einstellungen und kein konfigurationsscript in den lan-einstellungen des ie... es liegt ja auch nicht nur am ie. der firefox und andere programme die eine namensauflösung verwenden funktionieren auch nicht (email).
die einstellungen für das firmennetzwerk: feste ip^^, standartgateway->dsl-router, erster dns->domaincontroller, zweier dns->dslrouter. den dc haben wir als erstes reingenommen, weil sonnst die anmeldung ohne oder im anderen netz 5-10 min. dauert.
die einstellungen für die heimnetze sind unterschiedlich. auf jeden fall anderer ipkreis ander gateway... also nichts was sich gegenseitig stören könnte.

mein notebook hat jetzt auch diese zicken angefangen. mit dem resultat, das ich es erstmal aus der domäne nehmen musste um überhaupt diese beiträge schreiben zu können... ;)
hinzu kommt, dass als wir am dienstag abend den domänen-server heruntergafahren haben um ihn aufzurüsten ich mit meinem kabel auch nicht mehr aufs inet zugreifen konnte. das hört sich ja erstmal normal an, da der der dns in diesem netz ja normal steht. und jetzt aber nicht gefunden werden konnte. dann hab ich das kabel abgezogen und das w-lan eingeschaltet, was in der firma auch mit dhcp läuft und dann ging es wieder... ich hab ne andere ip bekommen
und der dc war übers w-lan auch nicht mehr als dns eingetragen... aber warum funktioniert es dann nicht in anderen netzen? sehr merkwürdig...

also ich hoffe, da kann man jetzt etwas mehr mit anfangen...

Mit freundlichen Grüßen

Jan
Bitte warten ..
Mitglied: cykes
12.08.2007 um 12:31 Uhr
Was Du mal mit einem Notebook, was Probleme macht, probieren könntest wäre, die Netzwerkkarte zu Hause komplett zu deaktivieren, und dann am WLan anmelden.

Bekommt die WLan Karte bei Betrieb ausserhalb der Firma überahutp einen IP Adresse zugewiesen und wie sehen die anderen Netzwerkeinstellungen aus (Standard Gateway, DNS Server etc.)?

Läuft irgendeien Art Firewall auf den Notebooks (die windowseigene oder eine andere Desktopfirewall, eventuell im Antivirenprogramm eingebaut)?

Gruß

cykes
Bitte warten ..
Mitglied: 51906
12.08.2007 um 14:19 Uhr
also netzwerkkarte deaktivieren bringt nix, hatte ich schon versucht.
wie gesagt, die w-lans ausserhalb haben alle fast standardeinstellungen von fritzbox o.ä.
da bekommen die nb's ne ip vom dhcp im router. gateway und dns adresse sind dann die vom router. ansonsten läuft antivir pro als virenscanner und die windows-firewall.
das ausschalten der win-fw bringt auch nix, leider...
danke dir.

Mit freundlichen Grüßen

Jan
Bitte warten ..
Mitglied: 51906
13.08.2007 um 19:30 Uhr
sooo,
ich hab jetzt mal versucht, die festen ip-einstellungen von der lan-karte im firmennetzwerk zu entfernen und hab es über static-ip im dhcp eingerichtet. somit bekommt die lan-karte im firmennetzwerk den router als 1. dns. damit die anmeldung außerhalb des netzes nicht so lange dauert, habe ich die hosts-datei mit den ip-adressen der server im firmennetz gefüllt. das funktioniert auch soweit. allerdings sitze ich jetzt daheim und hab das nb wie gehabt über w-lan verbunden...
resultat: kein zugriff aufs inet bei dns-anfragen...

ich dachte ja eigentlich, da das nb jetzt im firmennetz die verbindungsdaten vom dhcp bekommt, dürfte es keine probleme mehr mit dem w-lan zu hause geben aber pustekuchen...

bitte helfen! ich verzweifel bald...

edit:
wenn ich jetzt ne vpn ins firmennetzwerk herstelle funktioniert auch der ie wieder aber sehr langsam... schätze also, er geht dann über vpn->firmennetz->internet... wassn das fürn scheiß???

danke und Mit freundlichen Grüßen

Jan
Bitte warten ..
Mitglied: cykes
14.08.2007 um 08:05 Uhr
Habt ihr in der Firma eventuell irgendeinen zentral verwaltbaren Antivirus laufen, der eventuell auch
eine Applikationsüberwachung macht (wie z.B. Kaspersky, Sophos etc.) und dort vielleicht
in den Regeln/Policies die Einstellungen bei Verbidung über Fremdnetze etwas zu hart eingestellt?
Bitte warten ..
Mitglied: 51906
14.08.2007 um 09:56 Uhr
nein, haben wir nicht... (wahrscheinlich genau aus dem grund)
Bitte warten ..
Mitglied: 51906
22.08.2007 um 10:33 Uhr
hat den keiner mehr ne idee???
also fakt ist, wenn ich zuhause wieder keine verbindung bekomme und dann ne vpn ins firmennetz aufbaue, dann funktioniert auch das surfen wieder... warum denkt der domain-server er wäre das ein und alles???
Bitte warten ..
Mitglied: cykes
22.08.2007 um 13:16 Uhr
Irgendwo ist der firmeneigene DNS fest eingetragen, da bnin ich mir nach Deinen Schilderungen zuiemlich sicher. Ist vielleicht eine alternative TCP-IP Konfiguration aktiv?
Bitte warten ..
Mitglied: 51906
22.08.2007 um 15:29 Uhr
nee, der ist nicht fest eingetragen. und ne alternative konfiguration habe ich auch nicht drinne... läuft alles über dhcp.
Bitte warten ..
Mitglied: 51906
23.08.2007 um 10:48 Uhr
hallo nochmal,
habe folgenden registry-eintrag gefunden:

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\DNSClient]
"RegistrationEnabled"=dword:00000001
"RegisterReverseLookup"=dword:00000001
"RegistrationOverwritesInConflict"=dword:00000001
"NameServer"="192.168.100.2"

das ist der einzige eintrag in der registry, wo die ip-adresse des dns-servers hinterlegt ist.
nur weiß ich leider nicht, ob das was mit meinem problem zu tun hat.
kennt jemand diese einträge und deren eigenschaften?

danke,

jan
Bitte warten ..
Mitglied: tom12
25.09.2007 um 16:50 Uhr
Hallo,

dieser Eintrag ist für Deinen Fehler bei der Verbindungsherstellung zuhause verantwortlich.

Daher sucht Dein Rechner den DNS Server 192.168.100.2 egal was lokal definiert ist, und egal was IPCONFIG/all auch angibt, was es verwenden würde.

Kommt vermutlich aus einer Gruppenrichtlinie Deiner Domäne.


-> Wir haben dasselbe Problem bei Domänennotebooks die in anderen Netzen unterwegs sind.

Habe aber leider noch keinen Weg gefunden dieses Verhalten dauerhaft zu unterbinden. Viele Wege versucht, aber noch kein dauerhafter Erfolg.
Vermutlich:
- DNS Server Einstellung (ADS integriert?)
- Reste von Gruppenrichtlinien?

Eintrag "DNS-Client" löschen => Du kommst in anderen Netzen via DHCP ins Netz
Muss immer mal wieder gelöscht werden, wenn der Rechner in Deiner Stammdomäne war.

Falls jemand eine dauerhafte Lösung weiß, wäre ich auch nicht uninteressiert
Bitte warten ..
Mitglied: 51906
26.09.2007 um 09:30 Uhr
hi,

vielen dank für deine antwort. so etwas in der art hab ich mir schon gedacht und hab auch gewisse einstellungen noch geprüft. leider ohne erfolg!
wir haben die nb's erstmal aus der domäne genommen, damit wir erstmal wieder normal arbeiten können... ;)
was mich an der ganzen sache erstaunt, ist dass es am anfang ja erst ein paar tage funktioniert mit domäne in anderen netzen. und auf einmal nix mehr... ist schon komisch aber wenn ich die lösung noch finde, werde ich sie hier hinterlassen... ;)

Mit freundlichen Grüßen

jan
Bitte warten ..
Mitglied: tom12
26.09.2007 um 10:12 Uhr
Hallo Jankay77,

habe aufgrund Deines Eintrages nocheinmal nachgeforscht. Vor allem, die Unregelmässigkeit des Auftretens dieser Reg-Einträge auf den Clients hat mich irritiert.

Habe dann auf dem sekundären DC noch eine Gruppenrichtlinie entdeckt, die die DNS Server der Domäne verteilt hat.

Erklärungsversuch:

DC1:
Festlegung Domänenrichtlinie und Domänencontrollerrichtlinie mit den DNS Servern der Domäne.
Verteilung an DC2 und Domänenrechner.
Rücknahme der Domänenrichtlinie und Domänencontrollerrichtlinie auf DC1 (Grund war meine Vermutung, dass extern arbeitende MA hierdurch evtl. Probleme bekommen könnten .

Jetzt scheint alles funktioniert zu haben, jedoch die Domänencontrollerrichtlinie auf DC2 wurde nicht aktualisiert (Grund DC1 = SBS 2003 und DC2 = W2k3 R2 => Kommunikationsproblem oder generell gewünschtes Verhalten, dass Domänencontrollerrichtlinie separat zu aktualisieren ist.)
Es scheint nun so, dass die lokale Domänencontrollerrichtlinie des DC2 manchmal an Clients weitergereicht wurde (es waren ja nicht alle Notebooks betroffen). Wohl immer dann wenn der DC1 beschäftigt oder perdu war.

Vielleicht hilft dies.
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Webbrowser
DNS Problem in Browsern - Suche in Adresszeile (5)

Frage von tobivan zum Thema Webbrowser ...

DNS
gelöst Homeserver (Zentyal) und Fritzbox DNS Problem (6)

Frage von CharlyXL zum Thema DNS ...

DNS
gelöst Server 2012 R2 DNs Problem (9)

Frage von dan0ne zum Thema DNS ...

DNS
DNS Problem im VLAN (7)

Frage von momai zum Thema DNS ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (18)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...