Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

DNS Problem bei auflösen des Servernamens

Frage Internet Server

Mitglied: oepetro

oepetro (Level 1) - Jetzt verbinden

15.09.2010 um 16:33 Uhr, 18136 Aufrufe, 10 Kommentare

Hallo,

Bin gerade damit beschäftigt einen neuen Windows Server 2008 R2 auf zusetzen. Active Directory Domänendienste, DNS Server und DHCP Server sind installiert. Beim testen der Namesauflösung am Server direkt habe ich folgendes Problem:

ping 192.168.10.11
ping wird ausgeführt für server.firma.local [192.168.10.11]
Antwort von 192.168.10.11: Bytes=32 Zeit<1ms TTL=128

ping server.firma.local
ping wird ausgeführt für server.firma.local [::1]
Antwort von ::1: Zeit<1ms

nslookup
Standardserver: server.firma.local
Address: 192.168.10.11

Forward-Lookupzonen und Revers-Lookupzonen sind im DNS eingerichtet.

Verstehe nicht, warum der ping auf den servernamen nicht die Ipadresse zurück gibt.
Mitglied: ulle2k4
15.09.2010 um 16:35 Uhr
Weil im Server 2008 R2 schon IPv& standrtmäßig enthalten und auch wenn möglich genutz wird, du bekommst die IPv6 Adresse zurück.Wenn du es abschaltest bekommst du auch wieder die "normale" Ansicht.
Bitte warten ..
Mitglied: oepetro
15.09.2010 um 16:39 Uhr
Auf der Netzwerkkarte und im DHCP Server habe ich IPv6 ausgeschaltet. Der DNS Server horcht auch nur auf der IPv4 Adresse. Wo muss es denn noch abgeschaltet werden?
Bitte warten ..
Mitglied: ulle2k4
15.09.2010 um 16:47 Uhr
Wenn du es auf der Netzwerkkarte ausschaltest sollte es eigentlich reichen.Hast du das auf Server und Client gemacht?
Bitte warten ..
Mitglied: oepetro
15.09.2010 um 16:55 Uhr
Habe es nur am Server abgeschaltet. Bis lang ist auch noch kein Client am Server eingerichtet / angemeldet. Arbeite noch direkt am Server.
Bitte warten ..
Mitglied: jayjay0911
15.09.2010 um 16:58 Uhr
Wenn noch kein Client eingerichtet ist, von wo aus pingst du dann den Server an?
Bitte warten ..
Mitglied: Pjordorf
15.09.2010 um 17:08 Uhr
Hallo,

Zitat von oepetro:
ping 192.168.10.11
ping wird ausgeführt für server.firma.local [192.168.10.11]
Antwort von 192.168.10.11: Bytes=32 Zeit<1ms TTL=128
OK.

ping server.firma.local
ping wird ausgeführt für server.firma.local [::1]
Antwort von ::1: Zeit<1ms
OK. Da wird dir eine gültige IP mitgeteilt. Das ist die v6 IP deines Localhost. (Du machst das also auf deinen Server, oder?) Um eine v4 IP anzupingen machst du einfach "ping -v4 Hostname". Ein ping /? hilft hier weiter

nslookup
Standardserver: server.firma.local
Address: 192.168.10.11
OK

Verstehe nicht, warum der ping auf den servernamen nicht die Ipadresse zurück gibt.
Falsch. Dein Server gibt dir die IP zurück. Eine IPv6 mit ::1 ist vollkomen in Ordnung. Siehe Wikipedia IPv6.
Dann etwas zur IPv6 und MS vom Cableguy. bezüglich dem abschalten von V6, prüfe zuerst welche Dienste dann nicht mehr richtig wollen. [Nachtrag] Siehe hierzu auch MSXFAQ. [Nachtrag]
http://technet.microsoft.com/en-us/network/cc987595.aspx
http://technet.microsoft.com/en-us/library/bb726944.aspx

Peter

PS. Mach mal auf Windows7 / Server 2008 rechner ping localhost
Bitte warten ..
Mitglied: oepetro
15.09.2010 um 17:09 Uhr
Den Server pinge ich von der lokalen Server Kommandozeile aus an. Hier sollte doch die Namensauflösung als erstes funktionieren, bevor es von extern versucht wird. Mein alter Server (SBS 2003) löst lokal auch sauber auf.
Bitte warten ..
Mitglied: Pjordorf
15.09.2010 um 17:17 Uhr
Hallo,

Zitat von oepetro:
Den Server pinge ich von der lokalen Server Kommandozeile aus an. Hier sollte doch die Namensauflösung als erstes
funktionieren
Tut er auch. Localhost = ::1.

>Server (SBS 2003) löst lokal auch sauber auf.
Der konnte auch kein IPv6 (per standard)

Solltest du hier einen SBS 2008 nutzen (wollen), dann sei dir angeraten IPv6 NICHT abzuschalten. Das mag der SBS 2008 nämlich gar nicht.

Peter
Bitte warten ..
Mitglied: oepetro
15.09.2010 um 17:20 Uhr
Danke, das war ein guter Tip. Mit ping -4 server.firma.local bekomme ich die erwartete Antwort.

Mich wundert es nur, das die antworten teilweise in IPv4 und dann wieder in IPv6 kommen. Dachte eigentlich IPv6 "abgeschaltet" zu haben.

Mein windows 7 rechner gibt mir bei ping localhost die loopback adresse 127.0.0.1 zurück. Bei ping -6 localhost, bekomme ich wie von dir beschrieben ::1.

Scheint mir, als müsste ich mir IPv6 mal näher anschauen.
Bitte warten ..
Mitglied: Pjordorf
15.09.2010 um 17:38 Uhr
Hi,

Zitat von oepetro:
Danke, das war ein guter Tip. Mit ping -4 server.firma.local bekomme ich die erwartete Antwort.
Klasse.

Mich wundert es nur, das die antworten teilweise in IPv4 und dann wieder in IPv6 kommen. Dachte eigentlich IPv6
"abgeschaltet" zu haben.
Du kannst IPv6 NICHT abschalten. Du kannst es nur teilweise deaktivieren. Der IP Stack in Server 2008 R2 hat beide implementiert, Und den kannst du NICHT ändern. Besser, IPv6 anlassen.

Mein windows 7 rechner gibt mir bei ping localhost die loopback adresse 127.0.0.1 zurück. Bei ping -6 localhost, bekomme ich
wie von dir beschrieben ::1.
Und das bei mir in Windows 7 Ultimate
bdca812db437ee3675cf8bc489ef771e - Klicke auf das Bild, um es zu vergrößern

Peter
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Webbrowser
DNS Problem in Browsern - Suche in Adresszeile (5)

Frage von tobivan zum Thema Webbrowser ...

DNS
gelöst Homeserver (Zentyal) und Fritzbox DNS Problem (6)

Frage von CharlyXL zum Thema DNS ...

DNS
gelöst Server 2012 R2 DNs Problem (9)

Frage von dan0ne zum Thema DNS ...

Heiß diskutierte Inhalte
Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows Server
Mailserver auf Windows Server 2012 (8)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (8)

Frage von 1410640014 zum Thema Backup ...

DSL, VDSL
DSL-Signal bewerten (8)

Frage von SarekHL zum Thema DSL, VDSL ...