Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

DNS Probleme bei Windows Server 2008 R2 (Domäne)

Frage Netzwerke DNS

Mitglied: Simon-MCP

Simon-MCP (Level 1) - Jetzt verbinden

31.08.2009, aktualisiert 14:31 Uhr, 17317 Aufrufe, 16 Kommentare

Probleme bei der Namensauflösung innerhalb und außerhalb der Domäne!

Hallo zusammen,

seit kurzem habe ich von einer 2003-Umgebung alles auf die neue 2008 R2-Umgebung umgestellt. Im großen und ganzen habe ich alles so konfiguriert wie auch schon in meiner 2003er Umgebung.
Doch leider habe ich nun ein Problem mit bei den DNS-Einstellungen!

@@+++Hier ein kurzer Überblick über meine aktuelle Umgebung:+++

Internet <--> Router --> Server & Clients

Router: (DHCP Server)
IP: 192.168.2.1
Subnetz: 255.255.255.0
Gateway: 192.168.2.1
Primary DNS: 192.168.2.2
Secondary DNS: 192.168.2.1

Server: (Domäne: local.test)
IP: 192.168.2.2
Subnetz: 255.255.255.0
Gateway: 192.168.2.1
Primary DNS: 127.0.0.1
Secondary DNS: 192.168.2.1

Client:
IP: 192.168.2.3
Subnetz: 255.255.255.0
Gateway: 192.168.2.1
Primary DNS: 192.168.2.2
Secondary DNS: 192.168.2.1


Versuche ich nun von dem Client-PC aus die Domäne local.test zu pingen, erhalte ich nicht die IP-Adresse des Servers zurück (192.168.2.2) sondern eine öffentliche externe IP-Adresse, die wie ich herausfinden konnte, von der Telekom zu sein scheint zurück!!!
Sporadisch kann es ab und zu auch wieder vorkommen, das ich die IP-Adresse meines Servers zurück erhalte...

Da ich bei den Clients die Primäre DNS Adresse auf den Server gerichtet habe sollte die Anfrage doch auch über die gehen?

Ein tracert zeigt mir aber das der Client meine Anfrage wohl über den Secondary DNS Eintrag (192.168.2.1) versendet??? Aber dann dürfte er hier eigentlich auch keine Antwort zurück erhalten, da dieser Domänen-Namen so im Internet nicht existiert!


Was habe ich hier falsch gemacht? Früher bei W2K3 hat dies so funktioniert!
Mitglied: Micki
31.08.2009 um 14:52 Uhr
Bitte mal als erstes bei Primary DNS die lookbackadresse raus und die richtige IP eintragen. So wie dus hast ist ein klassisches Nogo!
Bitte warten ..
Mitglied: Kubelkubel
31.08.2009 um 15:45 Uhr
Moin,

wozu willst du den Router als Secondery-DNS haben?

1.) Domaincontroller Primary DNS -> Auf seine IP 192.168.2.2
2.) Domaincontroller DNS-Server eine Weiterleitung einrichten die alle externen Anfragen zu einem externen DNS-Server weiterleitet.
3.) secondary DNS-Eintrag löschen
3.) Am Client den Secondary DNS-Server rausnehmen.
Bitte warten ..
Mitglied: Simon-MCP
31.08.2009 um 17:28 Uhr
Zitat von Kubelkubel:
Moin,

wozu willst du den Router als Secondery-DNS haben?

1.) Domaincontroller Primary DNS -> Auf seine IP 192.168.2.2
2.) Domaincontroller DNS-Server eine Weiterleitung einrichten die
alle externen Anfragen zu einem externen DNS-Server weiterleitet.
3.) secondary DNS-Eintrag löschen
3.) Am Client den Secondary DNS-Server rausnehmen.

Hallo zusammen,

vielen Dank für die Tipps.
Aber leider besteht das Problem immer noch, trotz der Anpassung des DNS-Eintrages am Server!

Ich möchte den Router als 2.ten DNS-Eintrag drin haben damit nicht die Anfragen erst zum Server müssen und vom Server wieder über den Router.

Zudem möchte ich den Server nicht noch mehr belasten und deshalb meinen Router für externe Anfragen verwenden...

Vielleicht sonst noch eine Idee woran dies liegen könnte?

cu
Crus
Bitte warten ..
Mitglied: Kubelkubel
31.08.2009 um 17:35 Uhr
du musst auf allen rechner den lokalen Cache löschen.
Bitte warten ..
Mitglied: Simon-MCP
31.08.2009 um 23:48 Uhr
Zitat von Kubelkubel:
du musst auf allen rechner den lokalen Cache löschen.



Wie genau mache ich das?
Reicht hierzu ein arp -d aus?

Weil selbst nach einem arp -d funktioniert es immer noch nicht!
Nur immer mal wieder sporadisch kann es sein das er mir die richtige IP-Adresse zurück gibt!!!
Bitte warten ..
Mitglied: Kubelkubel
01.09.2009 um 08:21 Uhr
Moin,

also wenn du es genau so eingestellt hast wie ich es dir beschrieben habe (also erst einmal ohne zweiten Router und mittels dns-weiterleitung), musst du eigentlich entweder - alle Workstations/Server neu durchstarten oder wenn z.B. XP dann rechte maustaste aus die netzwerkverbindung und reparieren anklicken oder
- ipconfig /flushdns
- arp -d
- nbtstat -RR
dabei ist auf groß-/kleinschreibung zu achten!!!!

Wenn du am DNS-Server bist kannst du wenn du dnsmgmt.msc eingibst und rechte maustaste auf den dnsserver machst - die option cache löschen und veraltete einträge aufrämen anklicken.

Gruß
Bitte warten ..
Mitglied: Simon-MCP
01.09.2009 um 17:20 Uhr
Zitat von Kubelkubel:
- ipconfig /flushdns
- arp -d
- nbtstat -RR
dabei ist auf groß-/kleinschreibung zu achten!!!!


Hallo,

ich habe die Befehle nun wie oben angegeben ausgeführt, doch leider besteht das Problem immer noch.
Zwar ist es nun so das nach dem Neustart ein "Ping" auf den Domänen-Namen die richtige IP-Adresse zurück geführt hat, aber ein erneuter Ping nach ca. 15 Minuten lieferte wieder eine falsche IP-Adresse...

Ich weiß absolut nicht mehr weiter und verstehe die Welt nicht mehr!
Woher zum Teufel kommt den nur die andere IP-Adresse... Das ist mir wirklich absolut unbegreiflich...

Noch irgendwelche Ideen?

EDIT:
Ein Versuch wieder ein paar Minuten später liefert dann plötzlich auch wieder die richtige IP-Adresse... Dies scheint also absolut sporadisch immer mal wieder aufzutauchen...
Bitte warten ..
Mitglied: Kubelkubel
01.09.2009 um 17:29 Uhr
Hi,

ist das nur von einem Client oder von allen?
Hast du DHCP im Netz aktiv?
Hast du die Weiterleitung am DNS-Server eingestellt und die Secondary DNS überall gelöscht?

Gruß
Bitte warten ..
Mitglied: Simon-MCP
01.09.2009 um 17:51 Uhr
Hi,

bisher habe ich nur einen Physikalischen Client am Netz. Aber in einer VM (Virtueller Computer) die auf diesem PC läuft habe ich das gleiche Phänomen feststellen können.

Ja, in meinem Netzwerk ist DHCP aktiv am Router! Aber der Client hat eine statische IP-Adresse.

Die Weiterleitung am DNS-Server habe ich nicht eingerichtet, da ich ja absolut nicht möchte, dass die Anfragen fürs Internet über meinen Server laufen. Schon alleine deshalb, weil es vorkommen kann, das der Server Nachts ausgeschaltet wird und somit das Internet an den Clients nicht mehr funktionieren würde... (Router ist immer an!)

Secondary DNS muss somit also bestehen blieben.
Bitte warten ..
Mitglied: duschi
08.09.2009 um 16:02 Uhr
Hallo,

die Weiterleitung am Windows DNS-Server muss gesetzt werden.
Der secondary DNS kann bleiben.

Sobald ein Client eine DNS Anfrage hat, schickt er diese immer an den primary DNS.
Der secondary DNS wird nur benutzt, wenn der primary DNS nicht verfügbar ist.
Bitte warten ..
Mitglied: Simon-MCP
08.09.2009 um 19:10 Uhr
Das dachte ich eigentlich auch... Aber warum funktioniert es dann nicht? ;-D
Bitte warten ..
Mitglied: Kubelkubel
08.09.2009 um 21:06 Uhr
Hi,
er sollte halt nur zwecks Minimierung der Fehlerquellen den zweiten DNS entfernen.
Ansich könnte das Problem an allem mögliche liegen...

Nimm dir mal wireshark zur hand und schau auf Protokolleben was passiert.

Gruß
Bitte warten ..
Mitglied: Simon-MCP
09.09.2009 um 06:40 Uhr
Hallo zusammen,

ich konnte nun das Problem etwas eingrenzen.
Ich erhalte nun keine dieser ominösen externen IP-Adressen mehr zurück da ich ein Feature von der Telekom das am 6. April bei allen T-Home Kunden im Kundencenter aktiviert wurde wieder deaktiviert habe. Nach der Deaktivierung dieses Feature ist nun Ruhe eingekehrt mit diesen externen Adressen.

Aber mein Problem wurde damit leider nicht gelöst. Weil ich erhielte diese externen IP-Adressen ja nur, weil wohl meine Anfrage (der ping auf meine domain) lokal nicht aufgelöst werden konnte. Und deshalb dieses neue Feature von der Telekom diese Anfrage dann an die Root-Server von der Telekom weitergeleitet hat.

Aktuell sieht es wie folgt aus: Versuche ich einen Ping auf meine Domäne zu machen erhalte ich nun die Meldung:
C:\Users\User>ping local.test
Ping-Anforderung konnte Host "local.test" nicht finden. Überprüfen Sie den Nam
en, und versuchen Sie es erneut.

Das entfernen des zweiten DNS-Eintrags würde das Problem soweit ich es testen konnte wahrscheinlich lösen, allerdings wäre dies kein "workaround" für mich.

Nun war ich schon soweit das ich sogar den DNS-Server inkl. allen Einträgen komplett gelöscht und neu aufgesetzt habe. Danach den Eintrag in der "Forward Looking Zone" für die Domäne erstellt.
Vor dem löschen des DNS-Server war in der "Forward looking Zone" noch ein zweiter Eintrag (leicht gräulich) vorhanden... Dieser existiert nun nicht mehr und ich wüsste jetzt momentan auch nicht für was man diesen braucht?

Auf jeden Fall ist das Problem immer noch das gleiche...
Alle bisherigen Versuche haben nichts gebracht!!! Ich verzweifle hier schon langsam.

Mit Wireshark wollte ich auch schon mal versuchen das ganze etwas nachzuvollziehen aber leider sagt mir das was von Wireshark alles angezeigt wird überhaupt nichts! Da kommen Unmengen von Meldungen...

Was genau meinst du damit den Wireshark im Protokoll Modus laufen zu lassen? Habe das nirgends gefunden auch unter den Filtern nicht?


Cu
Crus
Bitte warten ..
Mitglied: duschi
09.09.2009 um 07:53 Uhr
Hallo,

die Reverse Lookup Zone ist schon korrekt konfiguriert?
Giebt es in der DNS Ereignisanzeige irgendwelche Warnungen oder Fehler?
Benutz doch anstatt ein Ping mal NS Lookup, dann siehst du auch gleich, ob er den richtigen DNS Server befragt.

Gruß
Bitte warten ..
Mitglied: Kubelkubel
09.09.2009 um 08:48 Uhr
Hallo Crus,

auf Protokollebene bedeutet nichts anderes als das du die Netzwerk-Kommunikation mitschneiden sollst.
Allerdings solltest du dich mit Protokollen wie z.B. TCP etc auskennen um zu verstehen wo eventuell ein Problem vorhanden ist.

Ich kann dir anbieten per Teamviewer mal einen Blick auf eure DNS-Einstellungen zu werfen.

Gruß

R.K.
Bitte warten ..
Mitglied: Simon-MCP
09.09.2009 um 20:59 Uhr
Hallo Kubelkubel,

das mit dem "Teamviewer" finde ich einen guten Vorschlag von Dir und wäre echt super nett von Dir.

Ich werde Dir per PN mal ein paar Kontaktmöglichkeiten zukommen lassen.


cu
Crus
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...