Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

DNS-Server Funktions-Test gibt Fehler aus

Frage Netzwerke DNS

Mitglied: D1Ck3n

D1Ck3n (Level 1) - Jetzt verbinden

12.01.2015, aktualisiert 19.01.2015, 1051 Aufrufe, 3 Kommentare

Guten Tag,

ich versuche gerade einen DNS-Server mit Ubuntu aufzusetzen, aber leider funktioniert der abschließende Test nicht (Siehe Fehlermeldung). Ich hoffe, dass mir jemand dabei helfen kann.

Fehlermeldung:

01.
root@dns-server:~# dig @127.0.0.1 dns-server.domain.tld 
02.
 
03.
; <<>> DiG 9.9.5-3ubuntu0.1-Ubuntu <<>> @127.0.0.1 dns-server.domain.tld 
04.
; (1 server found) 
05.
;; global options: +cmd 
06.
;; Got answer: 
07.
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 5504 
08.
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1 
09.
 
10.
;; OPT PSEUDOSECTION: 
11.
; EDNS: version: 0, flags:; udp: 4096 
12.
;; QUESTION SECTION: 
13.
;dns-server.domain.tld    IN      A 
14.
 
15.
;; Query time: 1 msec 
16.
;; SERVER: 127.0.0.1#53(127.0.0.1) 
17.
;; WHEN: Mon Jan 12 15:59:16 CET 2015 
18.
;; MSG SIZE  rcvd: 54 
19.
 
Konfig db.150.168.192:

01.
;; db.150.168.192 
02.
;; Reverselookupzone für domain 
03.
;; 
04.
$TTL 2D 
05.
@       IN      SOA     dns-server.domain.tld. mail.domain.tld. ( 
06.
                        2015010801      ; Serial 
07.
                                8H      ; Refresh 
08.
                                2H      ; Retry 
09.
                                4W      ; Expire 
10.
                                3H )    ; NX (TTL Negativ Cache) 
11.
 
12.
@                               IN      NS      dns-server.domain.tld 
13.
 
14.
 
15.
3                               IN      PTR     dns-server.domain.tld. 
16.
2                               IN      PTR     dhcp-server.domain.tld. 
17.
4                               IN      PTR     apache-server.domain.tld. 
18.
5                               IN      PTR     proxy-server.domain.tld. 
19.
6                               IN      PTR     vpn-server.domain.tld. 
20.
7                               IN      PTR     bacula-server.domain.tld. 
21.
8                               IN      PTR     smb-server.domain.tld. 
22.
9                               IN      PTR     mail-server.domain.tld. 
23.
 
Konfig db.domain.tld

01.
 
02.
;; db.domain.tld 
03.
;; Forardlookupzone für domain 
04.
;; 
05.
$TTL 2D 
06.
@       IN      SOA     sl-dns-server.domain.tld. mail.domain.tld. ( 
07.
                        2015010801      ; Serial 
08.
                                8H      ; Refresh 
09.
                                2H      ; Retry 
10.
                                4W      ; Expire 
11.
                                3H )    ; NX (TTL Negativ Cache) 
12.
 
13.
@                               IN      NS      sl-dns-server.domain.tld 
14.
                                IN      MX      10 mailserver.domain.tld 
15.
                                IN      A       192.168.150.3 
16.
 
17.
dns-server                   IN      A       192.168.150.3 
18.
localhost                       IN      A       127.0.0.1 
19.
dhcp-server                  IN      A       192.168.150.2 
20.
apache-server                IN      A       192.168.150.4 
21.
proxy-server                 IN      A       192.168.150.5 
22.
vpn-server                   IN      A       192.168.150.6 
23.
bacula-server                IN      A       192.168.150.7 
24.
smb-server                   IN      A       192.168.150.8 
25.
mail-server                  IN      A       192.168.150.9 
26.
 
27.
 
Ich habe das nach diesem Wiki-Eintrag gemacht: http://wiki.ubuntuusers.de/DNS-Server_Bind

Server-OS: Ubuntu 14.04.1 LTS
Mitglied: Alchimedes
12.01.2015 um 17:43 Uhr
Hallo ,

wie sieht denn Deine named.conf aus ?

Gruss
Bitte warten ..
Mitglied: Gersen
LÖSUNG 12.01.2015, aktualisiert 19.01.2015
Hallo,

zunächst mal stimmen die Namen des Name Servers in Deinen Konfig-Dateien (dns-server.domain.tld/sl-dns-server.domain.tld) nicht überein.

Außerdem fehlen haufenweise Punkte (".") in den Konfigurationsdateien. Schau Dir die Beispiel-Konfigurationsdateien in Deiner Anleitung noch einmal genau an.

Zitat daraus: "Wichtig ist hierbei die genaue Einhaltung der Syntax, da BIND hier extrem pingelig ist.".

Ob BIND überhaupt sauber läuft und die Zonen lädt, siehst Du mit einem
cat /var/log/syslog|grep named
Gruß,
Gersen
Bitte warten ..
Mitglied: D1Ck3n
19.01.2015 um 13:02 Uhr
Ich habe die Lösung gefunden!

Wie du schon angemerkt hattest, fehlten an 3 Stellen die abschließenden Punkte und mir ist ein Schreibfehler unterlaufen:

zone domain.tld/IN: loading from master file /etc/bin/db.domain.tld failed: file not found

dort fehlte ein "d" bei /bind/.

Vielen Dank für euche Hilfe!

Gruß
D1Ck3n
Bitte warten ..
Ähnliche Inhalte
Off Topic
DNS-Server von regfish (4)

Frage von Chonta zum Thema Off Topic ...

DNS
gelöst Domain.de auf internem DNS Server (7)

Frage von Max-Mauser zum Thema DNS ...

Linux Netzwerk
gelöst Rdnssd DNS Server Linux (4)

Frage von NeuRechnernetze zum Thema Linux Netzwerk ...

Windows Server
gelöst Windows Server 2003 DNS Server - Ping auf Subdomain nicht möglich in windows 7 (15)

Frage von aif-get zum Thema Windows Server ...

Heiß diskutierte Inhalte
Router & Routing
Tipps für Router (ca. 100 clients, VPN) (18)

Frage von oel-auge zum Thema Router & Routing ...

TK-Netze & Geräte
gelöst Convert von TAPI auf CAPI gesucht (13)

Frage von StefanKittel zum Thema TK-Netze & Geräte ...