Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Domäne Installation Clients Software ?

Frage Microsoft

Mitglied: Zoom78

Zoom78 (Level 1) - Jetzt verbinden

09.02.2012 um 16:37 Uhr, 6833 Aufrufe, 16 Kommentare

Was ist zu beachten, was wäre am besten?

Guten Tag Freunde,

ich habe einen w2k8 SBS Standard 2011 Server aufgesetzt und dazu natürlich eine Domäne. Alles läuft wunderbar, ich möchte nun auf allen 7 Workstations, die Software installieren. Also Office, Outlook usw.

Wie sollte ich das am besten bewerkstelligen? Mich mit lokalen Admin Konto auf den Client anmelden und dann die Software installieren, die Icons für alle Benutzer des Rechners zur Verfügung stellen? Oder direkt als ein AD Benutzer das Programm auf der WS installieren?

Das beides geht ist mir klar, aber was wäre die beste Vorgehensweise?
Mitglied: Pjordorf
09.02.2012 um 16:47 Uhr
Hallo,

Zitat von Zoom78:
Oder direkt als ein AD Benutzer das Programm auf der WS installieren?
Ein Domänen Admin Konto ist da immer zu bevorzugen. Warum installierst du die Software nicht per GPO?

Gruß,
Peter
Bitte warten ..
Mitglied: Zoom78
09.02.2012 um 17:46 Uhr
Tja, das habe ich so noch nie versucht. Ist das richtig so wie ich vermute, daß man auf dem Server die Software für die Installation zuweist, die Software auf dem Server hält (Pakete, Installationsmedien), alle 7 Workstations startet und dann die Installation auf dem Server startet? Werden die Workstation von alleine die Software dann Installieren?
Bitte warten ..
Mitglied: nEmEsIs
09.02.2012 um 19:08 Uhr
Hi

das machst du mittels MSI Packeten, manche Hersteller bieten die Fertig an oder du baust se dir selber. Gibt genug Anleitungen im Netz.

Würde nicht mit dem Mist anfangen alles per Hand zu installieren und vor allem den Benutzern nicht das Recht zu geben was zu installieren... Sonst hast du ggf. irgendwann Software drauf die Probleme macht oder gegen Lizenzvereinbarungen verstößt.

Fang auch gleich an die Software in eine Datenbank einzutragen, die installiert wurde bzgl. Lizenzen, dann musst du nicht von einem Rechner zum nächsten rennen und nachschauen was installiert wurde und hast es mal eben schnell zur Hand.


Mit freundlichen Grüßen Nemesis
Bitte warten ..
Mitglied: Zoom78
11.02.2012 um 18:15 Uhr
Hi, ich habe das so versucht. Ich habe mir vorgenommen openoffice3.3 zu installieren. Habe die Datei entpackt, mit ORCA eine MST Datei erstellt und dann die Dateien in eine Freigabe geschoben. Die Freigabe ist auf "Vollzugriff für Domänencomputer und Domänenbenutzer", genauso ist es bei den NTFS Rechten.

Ich hame mit mmc einen neuen "Gruppenrichtlinienerwaltungs-Editor" erstellt, dann bei "Durchsuchen" Default Domain Policy ausgewählt und das ganze als Konsole1 gespeichert.

Dann in dem Snap-In (noch in mmc) ging ich auf Computerkonfiguration (OpenOffice soll ja per Rechner installiert werden) und auf Richtlinien -> Softwareinstallation. Dann mit Rechts Kontextmenü -> Neu -> Paket -> die MSI Datei von OpenOffice ausgewählt. Dann im neuen Fenster Opton "Erweitert", danach die MST Datei noch angewählt und gespeichert. Genauso wie hier: http://openbook.galileocomputing.de/windows_server_2008/windows_server_ ...
im Kapitel "8.4.13 Softwareverteilung mit Gruppenrichtlinien"

Nu sehe ich bei Softwareinstallation "OpenOffice.org 3.3 Version 3.3 zugewiesen \\MeinServer\Deployment$"

Auf dem Client müsste ich theoretisch - wenn alles richtig wäre - jetzt OpenOffice unter "Systemsteuerung -> Programme -> Programm vom Netzwerk installieren" sehen. Tue ich aber nicht !? Endweder muss ich was anders machen und habe selbst was übersehen oder die o.g. Anleitung ist fehlerhaft.

Die Domäne ist intakt, ich kann alle Freigaben erreichen.

Was ist passiert?
Bitte warten ..
Mitglied: nEmEsIs
11.02.2012 um 19:38 Uhr
Hi

Du musst die GPO noch einem Rechner oder einem Benutzer zuweisen.

Dann Client auch mal neustarten ...

http://www.stepone2000.de/doku/Softwareverteilung_mit_Gruppenrichtlinie ... <--- Schau dir das PDF nochmal genau an da ist alles gut erklärt.

Wenn es nicht gleich funktioniert probier mal gpupdate

Mit freundlichen Grüßen Nemesis
Bitte warten ..
Mitglied: nEmEsIs
11.02.2012 um 22:35 Uhr
Hi


Ganz vergessen du musst noch mit erhöhten Rechten installieren aktivieren ...

Findest du unter der GPO wo du deine Softwareverteilung einbebaut hast unter:

Richtlinie -> Administrative Vorlagen -> Windows Komponenten -> Windows Installer -> Immer mit erhöhten Rechten installieren auf aktivieren ...


So ich hoffe du hast dann Erfolg deinen Plan in die Tat umzusetzten

Mit freundlichen Grüßen Nemesis

PS Wenn es das dann war Plz den grünen Haken
Bitte warten ..
Mitglied: Zoom78
12.02.2012 um 12:25 Uhr
Leider noch keinen Erfolg gehabt.

Ich habe folgendes gemacht
- im SBS Servermanager bei Servermanager->Rollen->Active Directory-Domänendienste->Active Directory-Benutzer und Computer auf "meinedomäne.local" mit rechter Maustaste geklickt und "NEU->Organisationseinheit" mit den Namen "Softwareverteilung" erstellt.

- darin eine neue Gruppe "Software4all" erstellt

- dann bei START->Verwaltung->Gruppenrichtlinienverwaltung weitergemacht. Dort bei "Gesamtstruktur:meinedomain.local->Domänen->"meinedomain.local" wieder auf die domäne mit Rechts geklickt und "Gruppenrichtlinienobjekt hier erstellen und verknüpfen" ausgewählt. Dann dem Gruppenrichtlinienobjekt den Namen "OpenOffice" zugewiesen.

- in den nun geöffneten Fenster unterhalb von "Sicherheitsfilterung" die "Auth. Benutzer" entfernt und mittels "Hinzufügen" die Gruppe "Software4all" eingesetzt

- anschließend klickte ich mit rechter Maustaste auf "OpenOffice" und dann im Menü "Bearbeiten" ausgewählt

- im neuen Fenster auf "OpenOffice [MEINSERVER.MEINEDOMAIN.LOCAL] -> Computerkonfiguration -> Richtlinien -> Softwareeinstellungen -> Softwareinstallation und mit RMT "Neu->Paket" gewählt

- das OpenOffice MSI Paket gewählt, dann im kleinen Fenster "Erweitert" einige Anpassungen gemacht und gespeichert

- dann wieder zurück in den Server-Manager und bei "Software4all" die "Domänenbenutzer" als berechtigt zugewiesen

- auch die erhöhten Installationsrechte habe ich bei "OpenOffice" zugewiesen

- den Arbeitsplatzrechner habe ich mehrfach gestartet (4-mal mindestens) aber ohne Erfolg. Auch den Server neugestartet - auch nix
Bitte warten ..
Mitglied: nEmEsIs
12.02.2012 um 12:42 Uhr
Hi

Moment du widerspricht dir ja auch !!! Die Gruppenrichtlinien gibt es für Benutzer und Computer !!!

Du hast alles für Computer eingerichtet aber bei software4all muss der Rechner rein bei dem das installiert werden soll. Du schreibst das du die domainbenutzer rein hast da muss domaincomputer rein!!! Bzw der explizite Rechner.

Wenn es für Benutzer sein soll musst du die softwareverteilung in den gpo s für Benutzer setzten, dort dann unter Benutzer mit erhöhten rechten installieren setzten und dann wird das beim anmelden vom Benutzer installiert .
Bitte warten ..
Mitglied: Zoom78
12.02.2012 um 13:09 Uhr
Ich habe aber auch "Domänen Computer" genauso dort eingesetzt. Immer beide zusammen und mit gleichen Rechten (lesen, ausführen). Aber auch das funktioniert nicht.
Bitte warten ..
Mitglied: nEmEsIs
12.02.2012 um 13:15 Uhr
Hi

Hast du eine Verknüpfung der GPO mal in die OU deines Ordners gelegt, wo deine Rechner sind ???


Mit freundlichen Grüßen
Bitte warten ..
Mitglied: Zoom78
12.02.2012 um 13:30 Uhr
Das habe ich jetzt nicht verstanden was du meinst

Ich habe auf dem Client die Kommandozeile mit Adminrechten gestartet und "gpupdate /sync" eingegeben.

Dann kam sowas heraus:
01.
"Richtlinienmodus konnte nicht festgelegt werden. Fehler - Das System kann die angegebene Datei nicht finden. Abbruch..."
Bitte warten ..
Mitglied: nEmEsIs
12.02.2012 um 13:51 Uhr
Hi

Wie hast du in der GPO für die Softwareverteilung den Pfad zu der Datei die du installieren willst ausgewählt ??? Übern Arbeitsplatz oder über Netzwerk ??? Klingt so wie als ob du das über den Arbeitsplatz gemacht hättest und der Client jetzt Local nach der datei sucht, wo sie ja nicht ist.

Mit freundlichen Grüßen Nemesis
Bitte warten ..
Mitglied: Zoom78
12.02.2012 um 14:00 Uhr
Nein, ich habe dort schon den Richtigen Pfad eingetragen, also \\Servername\Freigabe\Pfad_zur_MSI_von_OpenOffice
Bitte warten ..
Mitglied: nEmEsIs
12.02.2012 um 14:09 Uhr
Hi

Dann liegt dein Problem nicht bei der Softwareverteilung sondern das deine Clients ein Problem haben die GPO zu ziehen.

Würde ich jetzt mal so sagen. Funktioniert die dns auflösung ??? Bzw. Als welcher Benutzer führst du gpudate /Sync aus ??
Als normaler Benutzer geht das nicht musst dich schon als admin am Client anmelden und es ausführen.


Mit freundlichen Grüßen
Bitte warten ..
Mitglied: Zoom78
12.02.2012 um 14:34 Uhr
Der Admin der Domäne auf dem Server ist "dadmin". Ich habe mich jetzt auch als "dadmin" auf dem client angemeldet. Da konnte ich tatsächlich die Konsole mit erhöhten Rechten starten und gpupdate /sync ausführen. Er sagte, daß eine Abmeldung für die Benutzerrichtlinien und für die Computerrichtlinien ein Neustart erforderlich ist. Ich sagte "J" - also ja. Der client startete neu, aber ich sehe jetzt in der Systemsteuerung->Programme->Netzwerkinstallation-> weiterhin garnichts. Kein OpenOffice 3.3 zum nachinstallieren. Bin weiterhin als "dadmin" angemeldet.

DNS
Der Server meldet keine DNS Probleme, der client auch nicht. Ich komme auf die "company webseite" und auch ins Internet komme ich rein.
Bitte warten ..
Mitglied: Zoom78
12.02.2012 um 15:35 Uhr
Ich habe jetzt noch genauer im Ereignisprotokoll der Workstation geschaut. Jetzt sehe ich diverse Fehlermeldungen die auf die GPO hindeuten.

01.
Ereignis-ID 10005 -> "Produkt: OpenOffice.org 3.3 -- Bitte benutzen Sie die Datei setup.exe, um die Installation zu starten." Ebene Fehler, Benutzer System, Computer Clientname.meinedomäne.local, Quelle MsiInstaller
01.
Ereingis-ID 102 -> "Die Installation der Anwendung OpenOffice.org 3.3 der Richtlinie OpenOffice ist fehlgeschlagen. Fehler: %%1603" Ebene Fehler, Benutzer System, Computer Clientname.meinedomäne.local, Quelle Application Management Group Policy
01.
Ereignis-ID 108 -> "Die Änderungen an den Softwareinstallationseinstellungen wurden nicht angewendet. Änderungen an der Software konnten nicht übernommen werden. Ein vorheriger Protokolleintrag mit Einzelheiten sollte vorhanden sein. Fehler: %%1603"  Ebene Fehler, Benutzer System, Computer Clientname.meinedomäne.local, Quelle Application Management Group Policy 
01.
Ereignis-ID 1085 -> "Fehler beim Anwenden der "Software Installation"-Einstellungen. Die "Software Installation"-Einstellungen besitzen möglicherweise eine eigene Protokolldatei. Klicken Sie auf den Link "Weitere Informationen" Ebene Warnung, Benutzer System, Computer Clientname.meinedomäne.local, Quelle GroupPolicy
01.
Ereignis-ID 1014 -> "Zeitüberschreitung bei der Namensauflösung für den Namen _kerberos._tcp.Default-First-Site-Name._sites.dc._msdcs.meinedomäne.local, nachdem keiner der konfigurierten DNS-Server geantwortet hat" Ebene Warnung, Benutzer NETZWERKDIENST, Computer Clientname.meinedomäne.local, Quelle DNS Clients Events
Diese letzte Warnung kommt aber in der Liste nur einmal vor, alle anderen kommen immer wieder.

Und noch was bei den OpenOffice "Gruppenrichtlinienobjekt" den ich in der Gruppenrichtlinienverwaltung angelegt habe - soll da die "WMI-Filterung" auf "Windows SBS Client - Win 7 und Vista" stellen?
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...