Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Eine Domäne, zwei Standorte, Softwareverteilung über GPO bei Notebooks

Frage Microsoft Windows Server

Mitglied: konus1

konus1 (Level 1) - Jetzt verbinden

03.03.2010, aktualisiert 18.10.2012, 6292 Aufrufe, 6 Kommentare

Hallo,
ich habe eine Frage zur Softwareverteilung auf Notebooks die an mehreren AD-Standorten verwendet werden.

Wir haben in unsererer Firma zwei Niederlassungen. In jeder Niederlassung gibt es einen W2k3-Server als DC. Beide Niederlassungen sind in der selben Domäne, die beiden Netze haben unterschiedliche Subnetze und sind über VPN-Wan verbunden.

Die Software wird bisher über Gruppenrichtlinien verteilt. Damit die Installationsdaten nicht über die langsame WAN-Leitung laufen, gibt es in der AD für jeden Standort eine OU(Ort), der eine ortsspezifische GPO zugeordnet ist, die jeweils auf den lokalen Fileserver verweist.

Nun habe ich einen Notebook-B enutzer, der in beiden Niederlassungen wechselseitig arbeitet. Ich hatte diesen zunächst einem Standort (A) zugewiesen und darauf gehofft, dass beim Login in Standort (B) keine Softwareinstallation durchgeführt wird. Leider funktioniert die Erkennung einer langsamen Verbindungsgeschwindigkeit wohl nur, wenn kein eigener Anmeldeserver im Netz steht. Im Ergebnis versucht der Client nach dem Login in Standort B eine Softwareinstallation mit den Paketen von Standort A.

Meine nächste Überlegung war, die GPO nicht den OU(Ort) zuzuweisen, sondern die AD-Standorte zu verwenden. Ich gehe aber davon aus, dass dann der Client versucht, jede Softwarezuweisung doppelt, also einmal pro Niederlassung auszuführen. Das wäre auch schlecht.

Meine Frage ist nun, wie mit dem Problem umgehen? Gibt es ev. die Möglichkeit über einen WMI Filter abzufragen, wo der Client eingeloggt ist? Gibt es andere Tipps, wie die Softwareverwaltung mit Gruppenrichtlinien für Laptops gestaltet werden kann?

Danke Konus
Mitglied: DerWoWusste
03.03.2010 um 16:41 Uhr
Das Problem ist einfach zu lösen. MSI-Installationen laufen nicht, wenn die Verbindung als langsam erkannt wird. Dieses "langsam" ist konfigurierbar. google nach "slow link detection". Edit: Du hattest den selben Gedanken, aber ist die Geschwindigkeit auch angepasst worden? Default ist: alles was schneller als 500 Kilobit/s ist, wird als schnell angesehen - nicht mehr ganz zeitgemäß.
Bitte warten ..
Mitglied: konus1
03.03.2010 um 17:17 Uhr
Ich habe den Schwellenwert angepasst, konnte aber aus der Ferne leider keine vollständige Testserie fahren, ohne den Benutzer dauerhaft vom Arbeiten abzuhalten.

Aber ist es nicht so, dass beim Test der Verbindungsgeschwindigkeit die Verbindung zum Anmeldeserver getestet wird? Da ich in der anderen Niederlassung auch ein Domänencontroller stehen habe, dürfte diese sehr schnell sein.

Dem User wird es dann aber zum Verhängnis, dass er in der "falschen OU" eingetragen ist und damit dann GPOs mit Softwareverteilung erhält, wo die Installquelle auf dem Server im anderen Netz liegt auf die nur über das VPN zugegriffen werden kann.

Da der User Mo und Fr in Niederlassung A und Di-Do in Niederlassung B arbeitet kann ich auch nicht jedesmal das Objekt in die andere OU verschieben....
Bitte warten ..
Mitglied: DerWoWusste
03.03.2010 um 21:01 Uhr
Du hast vermutlich Recht, dass der lokale DC das vermasselt. [Mir geht gerade durch den Kopf, wie es wäre, wenn die Installationsquelle auf 2 DFS Repliken liegen würde - würde der Client da nicht auch die schneller anzutreffende nehmen und das Problem dabei auflösen? Müsste ich mal nachlesen].
Bitte warten ..
Mitglied: konus1
04.03.2010 um 08:45 Uhr
Ich gestehe, dass ich an DFS auch schon gedacht habe. Bisher habe ich mich da nicht so richtig rangetraut, da ich damit noch keine Erfahrungen habe und es die ganze Sache noch komplexer macht. Meine Sorge wäre, dass die Replikation vom DFS die knappe Bandbreite tagsüber zusätzlich belastet. Der Vorteil meiner bisherigen Lösung ist, dass die Replikation der Softwarverzeichnisse nachts per Robocopy erfolgt.

In diesem Zusammenhang hattte ich acuh gerade die Idee den Pfad \\domänenname\ zu verwenden, da dieser scheinbar immer auf den jeweiligen Anmeldeserver zeigt (auf dem auch die Install-Dateien liegen). Bei der Eingabe des Pfades im Explorer eines Clients werden auch alle Shares des Servers angezeigt, allerdings gibt es scheinbar ein Berechtigungsproblem, die einzige Freigaben, die ich anwählen kann ist SYSVOL und NETLOGON

EDIT: vielleicht funktiniert der Pfad %logonserver%\freigabe
Bitte warten ..
Mitglied: konus1
04.03.2010 um 10:19 Uhr
Leider gelingt es mir nicht, die Variabel in dem Gruppenrichtlinieneditor als Quelle anzugeben. Sie wird sofort mit den jeweiligen Inhalt ersetzt. Hat jemand eine Idee dazu?
Bitte warten ..
Mitglied: konus1
04.03.2010, aktualisiert 18.10.2012
Rein theoretisch ist es lt diesem Posting möglich, den Pfad zur MSI nachträglich direkt in der AD-Datenbank umzubiegen. Ich habe das gerade mal ausprobiert, es scheint tatsächlich zu funktionieren.

Leider ist das Vorgehen so umständlich, dass es wohl nicht für den täglichen Gebrauch geeignet scheint.
Bitte warten ..
Ähnliche Inhalte
Windows Server
Laufwerks GPO Sinnvoll und wie aufteilen? (8)

Frage von Faranos zum Thema Windows Server ...

Exchange Server
gelöst Windows Server 2008 Domäne - Exchange Deinstallieren oder nicht (2)

Frage von jojo0411 zum Thema Exchange Server ...

Microsoft
Softwareverteilung mittels SCCM auf bestimte Clients (1)

Frage von Xarthan zum Thema Microsoft ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(2)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...