Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Domänencontroller wird sporadisch und temporär nicht gefunden

Frage Linux Linux Netzwerk

Mitglied: Schmitz

Schmitz (Level 1) - Jetzt verbinden

15.02.2008, aktualisiert 18.02.2008, 6419 Aufrufe, 5 Kommentare

Guten Tag zusammen,

ich habe ein Problem in meiner vom Vorgänger übernommenen Domäne:
hier gibt's ca. 50 WinXP-Clients, die per DHCP in einer Domäne mit einem Linux/Samba-PDC hängen.
Der DHCP-Server läuft auf der Firewall (Juniper SSG20)
Eine Anmeldung funktioniert mit installierter SignOrSeal.reg seit Monaten tadellos.

Problem:
Doch nun kommt es seit einigen Tagen vor, dass einige Clients sich nicht anmelden können. Es erscheint die Meldung: "Es kann keine Verbindung mit der Domäne hergestellt werden, da der Domänencontroller nicht verfügbar ist bzw. das Computerkonto nicht gefunden wurde"
- es sind jeden Morgen 4-8 Clients, aber nicht immer die gleichen
- nach 5-10 Minuten des Wartens funktioniert eine Domänenanmeldung.
- Nach einer lokaler Anmeldung kann ich den Server aber anpingen, Netzlaufwerke mappen und auf Samba-Shares zugreifen.
- Die meisten Clients verhalten sich normal

Lösungsversuche:
Ich habe ein Zugriffslizenzproblem vermutet, da die Anzahl der Clients stetig wächst. Doch sind ja dann irgendwann alle PCs an der Domäne angemeldet, so dass es das ja nicht sein kann.
Weiterhin hatte ich festgestellt, dass der falsche DNS-Server auf dem DHCP-Server eingetragen war, was ich korrigiert habe.
Das letzte, was mir aufgefallen war, ist, dass die eingestellte Leasegültigkeit auf 8 Stunden stand, was mir zu kurz erschien. Auch das hab ich hochgesetzt.

Leider führte nichts zur Besserung. Hat jemand eine Idee, woran es liegen könnte?
Erforderliche Daten reiche ich natürlich nach!


Vielen Dank
Thomas Schmitz
Mitglied: 39916
15.02.2008 um 13:06 Uhr
Hi Thomas,

was sagt Dein samba-Logfile? Kannst Du Virenscanner / Firewall ausschließen?

Gruß,

Martin
Bitte warten ..
Mitglied: theton
16.02.2008 um 00:11 Uhr
Zuerstmal kann es bei einem Linux-Server wohl kaum an irgendwelchen Zugriffslizenzen liegen. Allerdings kenne ich ein ähnliches Problem, da wir das bei Blog.de auch im Office immer wieder hatten. Schuld war der DHCP-Server. Die Clients bekamen nicht schnell genug eine IP und konnten daher den Samba-Server nicht erreichen, da sie ihre Anmeldung an der Domain ohne IP und somit ohne Netzwerk versuchten.
Bitte warten ..
Mitglied: Schmitz
18.02.2008 um 11:32 Uhr
Hallo Martin,

vielen Dank für Deine Antwort.

Ich habe am Freitag noch nach den lokalen Windows-Firewalls geguckt: in den meisten Fällen war sie ausgeschaltet, an einigen Rechnern war sie eingeschaltet.
Die Anmeldeprobleme traten meist, aber nicht nur bei den PCs auf, die eine eingeschaltete Firewall hatten.
Doch heute morgen hatten wieder einige Kollegen Probleme bei der Anmeldung, obwohl nun alle lokalen Firewalls ausgeschaltet sind.
An den Firewall- und Virenscannereinstellungen hat sich aber seit Wochen nichts geändert - und bis Anfang letzter Woche klappte ja auch alles reibungslos.


In welche Logdatei muss ich denn gucken? Ich habe gesehen, dass es für jeden samba-User ein eigenes gibt unter /var/log/samba


Wenn ich in ein log-File eines Users gucke, der heute keine Probleme hatte, sehe ich von der Anmeldung bis zum Start des Logonskriptes folgendes:
[2008/02/18 07:58:06, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 07:58:06, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 07:58:06, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 07:58:06, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 07:58:06, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 07:58:06, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 07:58:39, 2] smbd/server.c:exit_server(511)
Closing connections
[2008/02/18 07:59:48, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 07:59:48, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 07:59:48, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 07:59:48, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 07:59:48, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 07:59:48, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 07:59:49, 2] rpc_server/srv_samr_nt.c:_samr_lookup_domain(2050)
Returning domain sid for domain DOMAINNAME -> S-1-5-21-2158467702-2677153331-1729750058
[2008/02/18 07:59:49, 1] smbd/service.c:make_connection(636)
USERNAME0108 (192.168.1.71) connect to service netlogon as user USERNAME01 (uid=56740, gid=100) (pid 18387)
[2008/02/18 07:59:52, 2] smbd/open.c:open_file(243)
USERNAME01 opened file logon.cmd read=Yes write=No (numopen=1)
[2008/02/18 07:59:52, 2] smbd/open.c:open_file(243)
USERNAME01 opened file logon.cmd read=Yes write=No (numopen=2)
[2008/02/18 07:59:52, 2] smbd/close.c:close_normal_file(227)
USERNAME01 closed file logon.cmd (numopen=1)
[2008/02/18 07:59:52, 2] smbd/close.c:close_normal_file(227)
USERNAME01 closed file logon.cmd (numopen=0)
[2008/02/18 07:59:52, 2] smbd/open.c:open_file(243)
USERNAME01 opened file logon.cmd read=Yes write=No (numopen=1)
[2008/02/18 07:59:53, 2] smbd/close.c:close_normal_file(227)
USERNAME01 closed file logon.cmd (numopen=0)
[2008/02/18 07:59:53, 2] smbd/open.c:open_file(243)
USERNAME01 opened file logon.cmd read=Yes write=No (numopen=1)
[2008/02/18 07:59:53, 2] smbd/close.c:close_normal_file(227)
USERNAME01 closed file logon.cmd (numopen=0)
[2008/02/18 07:59:53, 2] smbd/open.c:open_file(243)
USERNAME01 opened file logon.cmd read=Yes write=No (numopen=1)
[2008/02/18 07:59:53, 1] smbd/service.c:make_connection(636)




Schaue ich in ein log-File eines Users, der Probleme hatte, sehe ich von der Anmeldung bis zum Start des Logonskriptes folgendes:
[2008/02/18 08:15:58, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 08:15:58, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 08:15:58, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 08:15:58, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 08:15:58, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 08:15:58, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 08:16:31, 2] smbd/server.c:exit_server(511)
Closing connections
[2008/02/18 08:18:15, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 08:18:15, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 08:18:15, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 08:18:26, 2] smbd/server.c:exit_server(511)
Closing connections
[2008/02/18 08:21:39, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 08:21:39, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 08:21:39, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 08:21:39, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 08:21:39, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 08:21:39, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 08:21:50, 1] smbd/service.c:make_connection(636)
USERNAME0207 (192.168.1.58) connect to service netlogon as user USERNAME02 (uid=56783, gid=56783) (pid 18761)
[2008/02/18 08:21:50, 1] smbd/service.c:close_cnum(675)
USERNAME0207 (192.168.1.58) closed connection to service netlogon
[2008/02/18 08:21:51, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 08:21:51, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 08:21:51, 1] smbd/password.c:pass_check_smb(545)
Couldn't find user 'nobody' in passdb.
[2008/02/18 08:21:51, 2] smbd/password.c:pass_check_smb(575)
pass_check_smb failed - invalid password for user [USERNAME02]
[2008/02/18 08:21:55, 1] smbd/service.c:make_connection(636)
USERNAME0207 (192.168.1.58) connect to service netlogon as user USERNAME02 (uid=56783, gid=56783) (pid 18761)
[2008/02/18 08:21:55, 2] smbd/open.c:open_file(243)
USERNAME02 opened file logon.cmd read=Yes write=No (numopen=1)
[2008/02/18 08:21:55, 2] smbd/process.c:switch_message(696)
switch_message: queueing message due to being in oplock break state.
[2008/02/18 08:21:55, 2] smbd/open.c:open_file(243)
[2008/02/18 08:21:55, 2] smbd/open.c:open_file(243)
USERNAME02 opened file logon.cmd read=Yes write=No (numopen=2)
[2008/02/18 08:21:55, 2] rpc_server/srv_samr_nt.c:_samr_lookup_domain(2050)
Returning domain sid for domain DOMAINNAME -> S-1-5-21-2158467702-2677153331-1729750058
[2008/02/18 08:21:55, 2] smbd/close.c:close_normal_file(227)
USERNAME02 closed file logon.cmd (numopen=1)
[2008/02/18 08:21:55, 2] smbd/close.c:close_normal_file(227)
USERNAME02 closed file logon.cmd (numopen=0)
[2008/02/18 08:21:55, 2] smbd/open.c:open_file(243)
USERNAME02 opened file logon.cmd read=Yes write=No (numopen=1)
[2008/02/18 08:21:55, 2] smbd/close.c:close_normal_file(227)
USERNAME02 closed file logon.cmd (numopen=0)
[2008/02/18 08:21:55, 2] smbd/open.c:open_file(243)
USERNAME02 opened file logon.cmd read=Yes write=No (numopen=1)
[2008/02/18 08:21:55, 2] smbd/close.c:close_normal_file(227)
USERNAME02 closed file logon.cmd (numopen=0)
[2008/02/18 08:21:55, 2] smbd/open.c:open_file(243)
USERNAME02 opened file logon.cmd read=Yes write=No (numopen=1)
[2008/02/18 08:21:55, 2] smbd/close.c:close_normal_file(227)
USERNAME02 closed file logon.cmd (numopen=0)
[2008/02/18 08:21:55, 2] smbd/open.c:open_file(243)
USERNAME02 opened file logon.cmd read=Yes write=No (numopen=1)
[2008/02/18 08:21:55, 2] smbd/close.c:close_normal_file(227)
USERNAME02 closed file logon.cmd (numopen=0)
[2008/02/18 08:21:55, 2] smbd/open.c:open_file(243)
USERNAME02 opened file logon.cmd read=Yes write=No (numopen=1)
[2008/02/18 08:21:55, 2] smbd/close.c:close_normal_file(227)
USERNAME02 closed file logon.cmd (numopen=0)
[2008/02/18 08:21:55, 2] smbd/open.c:open_file(243)
USERNAME02 opened file logon.cmd read=Yes write=No (numopen=1)
[2008/02/18 08:21:56, 1] smbd/service.c:make_connection(636)



Ich habe festgestellt, dass die Anmeldeprobleme zunehmen, je später es wird (also je mehr bereits angemeldet sind)

Hast Du anhand dessen einen Tipp parat?

Vielen Dank,
Thomas
Bitte warten ..
Mitglied: Schmitz
18.02.2008 um 11:39 Uhr
Hallo theton und vielen Dank für Deine Antwort,

Der Gedanke kam mir auch und nach Überprüfung hatte ich festgestellt, dass der DHCP-Server über einen zu kleinen Adresspool verfügte und die Leases auch nur 8 Stunden gültig waren. Doch irgendwann letzte Woche hatte ich den IP-Pool vergrössert und die Gültigkeit der Leases hochgesetzt. Der Samba-Server war zudem letzte Woche performancemässig am Anschlag, was die Probleme gefördert haben könnte. Doch habe ich ihn Freitag derart entlastet, dass die Prozessornutzung nun nur noch selten über 30% geht.
Leider hat sich heute an den Anmeldeproblemen heute nichts gebessert.
Weisst Du, wo ich den Prozess des IP-Adressenbezuges detailiert nachvollziehen kann? Die Logs des DHCP-Servers scheinen mir nicht so viel herzugeben.

Gruss,
Thomas


Zuerstmal kann es bei einem Linux-Server wohl
kaum an irgendwelchen Zugriffslizenzen
liegen. Allerdings kenne ich ein
ähnliches Problem, da wir das bei
Blog.de auch im Office immer wieder hatten.
Schuld war der DHCP-Server. Die Clients
bekamen nicht schnell genug eine IP und
konnten daher den Samba-Server nicht
erreichen, da sie ihre Anmeldung an der
Domain ohne IP und somit ohne Netzwerk
versuchten.
Bitte warten ..
Mitglied: theton
18.02.2008 um 13:27 Uhr
Öffne mal mittels 'tail -f logdatei' die Logdateien vom DHCP und vom Samba-Server. Dann reboote einen der Rechner der Probleme macht und schau ob der seine Fehlermeldung auswirft bevor er in den DHCP-Logs auftaucht und dort sichtlich eine IP zugeordnet bekommt. So bin ich damals dahinter gekommen. Ggf. auch einfach mal probieren ob das Problem auch dann auftritt, wenn du eine feste IP an einen der betroffenen Rechner vergibst.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Server
Dieser active directory domänencontroller schein der letzte dns (3)

Frage von homermg zum Thema Windows Server ...

Hardware
gelöst LSI MegaRAID RAID 1 wird nicht gefunden (6)

Frage von billy01 zum Thema Hardware ...

Heiß diskutierte Inhalte
Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...

Exchange Server
DNS Einstellung - zwei feste IPs für Mailserver (15)

Frage von ivan0s zum Thema Exchange Server ...