Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Domain auf eigenen Windows 2003 Server einrichten

Frage Netzwerke DNS

Mitglied: nice4sell

nice4sell (Level 1) - Jetzt verbinden

07.06.2009, aktualisiert 11:42 Uhr, 4288 Aufrufe, 3 Kommentare

Hallo alle zusammen, ich habe ein Problem bei dem Ihr mir hoffentlich helfen könnt.

Folgendes Szenario:

Bestandsaufnahme

1. Ich habe eine Domain xyz.com
2. Alice DSL mit einer statischen IP
3. Windows Enterprise Server 2003 mit IIS 6.0 und Sharepoint Portal Server 2007

Ist Zustand:

  • Die Domain xyz.com hat ein A Record mit der statischen IP Adresse des DSL anschlusses.

  • Der Router / Modem (Alice Modem 1111) der diese statische Adresse bezieht fungiert als DHCP mit einer IP Range von 192.168.1.50 - 192.168.1.100, das Gerät selbst hat die IP Adresse 192.168.1.1

  • Es ist ein Port Forwarding im Router / Modem auf der relevanten Ports ( 80; 443) auf die interne IP Adresse des Servers (192.168.1.52) eingerichtet.

  • Zwischen dem Modem/Router und dem Server hängt noch eine Fritz Box Fon WLAN 7240 die lediglich als switch und WLAN Access Point dient. die IP Adresse der Fritz Box ist die 192.168.1.50

  • Auf dem Server selbst läuft Windows Enterprise Server 2003 mit IIS 6.0 und dem Sharepoint Portal Server 2007.

  • Active Directory läuft auf dem Rechner und die Domäne is xy.com (Die gleiche wie die Domain die regestriert wurde)


Ich möchte nun Benutzern den Zugang aus em Internet auf den Sharepoint Server ermöglichen, wenn man nun die Domain in einem Browser im Externen Netzwerk eingibt kommt erst einmal die NT User Authentifizierung, der User wird aufgefordert Username und Passwort einzugeben.

Anschliessend kommt eine Fehlermeldung das die DNS einstellungen nicht funktionieren.

Der NetBIOS name des servers ist Server somit wäre der korrekte Name server.xyz.com .... wenn ic nun im Browser im Externen netzwerk die Domain durch die IP Adresse ersetze funktioniert die Portalseite des Sharepoint servers... allerdings wenn cih nun auf einen Link klicke will er natürlich auf server/sites/...../home.aspx zugreifen.

Da scheinbar der Name Server nicht in die öffentliche IP Adresse aufgelöst werden kann bekommt der User eine Fehlermeldung.


Wie kann ich das Problem beheben?


Viele Dank für Eure Hilfe

nice4sell
Mitglied: affabanana
07.06.2009 um 07:53 Uhr
Zitat von nice4sell:
Hallo alle zusammen, ich habe ein Problem bei dem Ihr mir hoffentlich
helfen könnt.

Folgendes Szenario:

Bestandsaufnahme

1. Ich habe eine Domain xyz.com
2. Alice DSL mit einer statischen IP
3. Windows Enterprise Server 2003 mit IIS 6.0 und Sharepoint Portal
Server 2007

Ist Zustand:

  • Die Domain xyz.com hat ein A Record mit der statischen IP Adresse
des DSL anschlusses.

  • Der Router / Modem (Alice Modem 1111) der diese statische Adresse
bezieht fungiert als DHCP mit einer IP Range von 192.168.1.50 -
192.168.1.100, das Gerät selbst hat die IP Adresse 192.168.1.1

Wieso nicht auf dem Server eingerichtet??

+ Es ist ein Port Forwarding im Router / Modem auf der relevanten
Ports ( 80; 443) auf die interne IP Adresse des Servers (192.168.1.52)
eingerichtet.



+ Active Directory läuft auf dem Rechner und die Domäne is
xy.com (Die gleiche wie die Domain die regestriert wurde)

Das sollte man auch nicht machen.

Immer local.xyz.com oder intra.xyz.com oder Berlin.xyz.com


Anschliessend kommt eine Fehlermeldung das die DNS einstellungen
nicht funktionieren.

Wird mit dem Internen Domänennamen zusammenhängen

Wie kann ich das Problem beheben?

Holl Dir richtige hilfe ins Haus

gruss affabanana
Bitte warten ..
Mitglied: filippg
07.06.2009 um 14:39 Uhr
Hallo,

ist denn server.xyz.com von extern auflösbar? Wenn du nur einen Record für xyz.com setzt hilfst das relativ wenig.. (ich verstehe allerdings nicht, warum eine Authentifizierungsaufforderung kommt).

Gruß

Filipp
Bitte warten ..
Mitglied: nice4sell
07.06.2009 um 23:30 Uhr
Hallo,

danke für die Antworten.

Also den Record für server.xyz.com werde ich morgen nachtragen und bescheid geben ob das Problem beseitigt wurde..

Des weiteren ist die NT User Authentifizierung gewollt und soll nur bestimmten Usern Zugang zum Sharepoint Portal Server gewähren, schliesslich gibt es auch verschiedene Usergruppen und Berechtigungsebenen.

Des Weiteren bezweifel ich das das Problem vom gleichen Domänennamen herforgerufen wird, da wenn man im externen Browser einen direkten Link eingibt (z.B. https://xyz.com/Sites/default.aspx oder auch über http://.....) die Sharepoint Seite aufgerufen wird und auch fast alle anderen Sharepoint Seiten funktionieren.

Bei denen die nicht funktionieren muss man dann das /default.aspx hinzugügen da der link lediglich auf https://xyz.com/Sites/ABC/1234/ zeigt und nicht auf https://xyz.com/Sites/ABC/1234/default.aspx.

Ich habe anschliessend einen subdomain sharepoint.xyz.com eingerichtet und eine sofortige weiterleitung auf https://xyz.com/Sites/default.aspx per html eingerichtet, allerdings funktioniert dies nicht. Wenn ich aber https://xyz.com/Sites/default.aspx in den Browser einfüge funktioniert dies.

Die Domain ist zurzeit bei Enom gehostet, sollte ich die NS einträge ändern um eine richtige auflösung zu gewährleisten. (Kenne mich mit DNS nicht besonders aus).

Vielen Dank

nice4sell
Bitte warten ..
Ähnliche Inhalte
Entwicklung
Domain einrichten
Frage von teslacoilEntwicklung4 Kommentare

Ich habe da mal eine kleine Frage an euch. Und zwar geht es darum, dass ich eine Domain erstellen ...

LAN, WAN, Wireless
IPv6 DHCP-Server in Domain einrichten
Frage von killtecLAN, WAN, Wireless9 Kommentare

Hallo zusammen, ich möchte gerne einen DHCP-Server auf IPv6 einrichten. Problem: Bisher habe ich keine IPv6 Kenntnisse. Der Server ...

Erkennung und -Abwehr
Spam mit eigener Domain
gelöst Frage von NoobOneErkennung und -Abwehr12 Kommentare

Hallo Zusammen, ihr kennt sicherlich das Problem, dass immer wieder Spam-Mails bei den Usern landen, die augenscheinlich von der ...

Exchange Server
Exchangeserver mit 1und1 Domain einrichten.
Frage von MaxilusExchange Server3 Kommentare

Hallo alle mit einander. Damit ich meine Frage stellen kann muss ich die derzeitige Situation erklären die bei unserem ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 17 StundenWindows 102 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 19 StundenSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 1 TagInternet3 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 1 TagDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
TK-Netze & Geräte
VPN-fähige IP-Telefone
Frage von the-buccaneerTK-Netze & Geräte16 Kommentare

Hi! Weiss noch jemand ein VPN-fähiges IP-Telefon mit dem man z.B. einen Heimarbeitsplatz gesichert anbinden könnte? Habe nur einen ...

Windows Server
GPO nur für bestimmte Computer
Frage von Leo-leWindows Server13 Kommentare

Hallo Forum, gern würde ich ein Robocopy script per Bat an eine GPO hängen. Wichtig wäre aber dort der ...

Windows Server
KMS Facts for Client configuration
Frage von winlinWindows Server13 Kommentare

Hey Leute, wir haben in unserem Netz nun einen neuen KMS Server. Haben Bestands-VMs die noch nicht aktiviert sind. ...

Windows Tools
Software-Tool zum Entfernen von bösartigem Windows
Frage von emeriksWindows Tools11 Kommentare

Hi, siehe Betreff hat das jemals irgendjemand schonmal sinnvoll eingesetzt? (MRT) E.