Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Domainadresse wird durch Server IP immer überschrieben, verwende Apache2

Frage Linux Apache Server

Mitglied: sparefroh

sparefroh (Level 1) - Jetzt verbinden

07.03.2013 um 14:44 Uhr, 2138 Aufrufe, 10 Kommentare

Hey Leute!


Probiere jetzt schon Stundenlang meine Domain anstatt der Server IP anzuzeigen.

Aber es wird immer wieder meine IP angezeigt :/


Hat irgendjemand eine Idee?


Danke im vorraus für eure Hilfe ;D


LG

Johannes
Mitglied: SlainteMhath
07.03.2013 um 14:55 Uhr
Moin,

Aber es wird immer wieder meine IP angezeigt :/
Verrate uns doch mal WO die IP angezeigt wird? Im Adressfeld des Browsers? in der Server Signatur? Am besten mit Screenshot.

Hat irgendjemand eine Idee?
Mehrere sogar:
CMS falsch konfiguriert?
Hardcodiert im HTML Quellcode?
Rewrite Rule falsch?
VirtualHost Konfig Falsch?

lg,
Slainte
Bitte warten ..
Mitglied: Lochkartenstanzer
07.03.2013, aktualisiert um 15:55 Uhr
Zitat von sparefroh:
Hat irgendjemand eine Idee?

PEBKAC?

lks

PS. Eine ordentliche Problembeschreibung führt oft zu zielführenden Lösungen.
Bitte warten ..
Mitglied: sparefroh
07.03.2013 um 15:54 Uhr
ja im browser wechselt die url zur ip Adresse des servers!


Detail am Rande, ich verwende Magento und die vhost config is von einem Magento installations Tutorial.

Rewrite rules habe ich in meiner vhost config von Apache keine :/

LG

Johannes
Bitte warten ..
Mitglied: SlainteMhath
07.03.2013 um 16:04 Uhr
ja im browser wechselt die url zur ip Adresse des servers!
Detail am Rande, ich verwende Magento und die vhost config is von einem Magento installations Tutorial.
ServerName/ServerAlisa/VirtualHost ist korrekt mit Name konfiguriert? Der Domainname ist auch korrekt (und in beide Richtungen) korrekt auslösbar?

Rewrite rules habe ich in meiner vhost config von Apache keine :/
Evtl. gibts eine .htaccess?

Magento kenn ich jetzt nicht, aber ich würde schätzen das da was in falsch (sprich mit IP, statt mit Hostname) konfiguriert ist. Evtl. fragst Du mal dort in der Community nach.
Bitte warten ..
Mitglied: sparefroh
07.03.2013 um 16:06 Uhr
Zitat von Lochkartenstanzer:
> Zitat von sparefroh:
> ----
> Hat irgendjemand eine Idee?

PEBKAC?

lks

PS. Eine ordentliche Problembeschreibung führt oft zu zielführenden Lösungen.


trifft zu, sonst würde ich hier nicht fragen :P


Ja das Problem ist einfach und ist wie oben schon in einem Satz erklärt:

meine domain www.aasdf.com

wird weitergeleitet auf meine server IP xx.xx.xx.xxx

ABER, jetzt steht im browser nicht wie gewünscht www.aasdf.com SONDERN xx.xx.xxx :/

Frage: Wie schaffe ich es nicht meine Server IP sondern meine Domain Adresse zu zeigen?


Danke für eure nette Hilfe!

LG

Johannes
Bitte warten ..
Mitglied: sparefroh
07.03.2013 um 16:10 Uhr
Zitat von SlainteMhath:
> ja im browser wechselt die url zur ip Adresse des servers!
> Detail am Rande, ich verwende Magento und die vhost config is von einem Magento installations Tutorial.
ServerName/ServerAlisa/VirtualHost ist korrekt mit Name konfiguriert? Der Domainname ist auch korrekt (und in beide Richtungen)
korrekt auslösbar?




Das ist ja das merkwürdige, das habe ich alles gecheckt, und es passt :/
Bitte warten ..
Mitglied: Lochkartenstanzer
07.03.2013, aktualisiert um 16:20 Uhr
Zitat von sparefroh:
> Zitat von Lochkartenstanzer:
> ----
> > Zitat von sparefroh:
> > ----
> > Hat irgendjemand eine Idee?
>
> PEBKAC?
>
> lks
>
> PS. Eine ordentliche Problembeschreibung führt oft zu zielführenden Lösungen.


trifft zu, sonst würde ich hier nicht fragen :P


Ja das Problem ist einfach und ist wie oben schon in einem Satz erklärt:

meine domain www.aasdf.com

wird weitergeleitet auf meine server IP xx.xx.xx.xxx

ABER, jetzt steht im browser nicht wie gewünscht www.aasdf.com SONDERN xx.xx.xxx :/

Frage: Wie schaffe ich es nicht meine Server IP sondern meine Domain Adresse zu zeigen?

Das ist genauso doof wie die erste Angabe.

Aber aus Deiner kommunikation mit SlainteMath konnte man zumidnest herauslesen, daß es da einen Apache gibt und auf den magento draufgesetzt wurde.

Aber:

  • Welches OS?
  • Welche OS-version?
  • Welcher apache?
  • (relevante) Auszüge aus Deiner config?

fehlt alles.

Hast Du mal versucht einfach eine statische Webseite (ein einfaches index.html mit statischenm Text) mit dem Apache zu machen um zu schauen, ob das, ohne Interferenzen von magenta funktioniert? z.B. mit einer Beispielconfig?

lks
Bitte warten ..
Mitglied: SlainteMhath
07.03.2013 um 16:18 Uhr
grep'e doch bitte mal sämtliche Configdateien nach deiner IP... sicher das die nicht irgendwo drin steht (ausser bei der ListenAdresse)? Auch in der default-config von Apache?

Ich bin ipmmer noch der Meinung das ist ein Problem von deinem CMS
Bitte warten ..
Mitglied: Lochkartenstanzer
07.03.2013 um 16:22 Uhr
Zitat von SlainteMhath:
grep'e doch bitte mal sämtliche Configdateien nach deiner IP... sicher das die nicht irgendwo drin steht (ausser bei der
ListenAdresse)? Auch in der default-config von Apache?

Ich bin ipmmer noch der Meinung das ist ein Problem von deinem CMS

Vvermute ich auch. Deshalb sollte er mal schauen, ob der Apache ohne CMS korrekt funktioniert. Dan sieht man, woher der fehler kommen könnte.

lks
Bitte warten ..
Mitglied: 16568
07.03.2013 um 23:01 Uhr
Ich muß euch Beide korrigieren:

das Ding heißt Magento und ist kein CMS, sondern ein Shopsystem...

Aber bei den anderen Vorwürfen belassen wir es mal, denn wie steht es so schön in meinem Profil:

1. Wenn Du Dir keine Mühe gibst, gebe ich mir auch keine...


Lonesome Walker
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
E-Mail
gelöst Falsche SMTP Server IP Adresse (6)

Frage von laster zum Thema E-Mail ...

Windows Server
gelöst Windows Server - IP Adressen (10)

Frage von Richard97 zum Thema Windows Server ...

Apache Server
gelöst Ubuntu und Apache2 - zwei Webanwendungen auf einem Server (4)

Frage von Yannosch zum Thema Apache Server ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...