Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Domaincontroller repliziert nach Migration in VM nicht mehr

Frage Virtualisierung

Mitglied: Formatierer

Formatierer (Level 1) - Jetzt verbinden

09.04.2008, aktualisiert 13.06.2008, 7826 Aufrufe, 6 Kommentare

Hallo,

nach einigen Tests mit Migrationen von physischen Servern in Vmware haben wir kürzlich einen Domaincontroller in eine VM übernommen. Es handelt sich hierbei um einen Windows 2000 Server, der für Terminaldienste missbraucht wird.

Nach vollendeter (problemloser) Migration hat sich nun nach einigen Tagen aber herausgestellt, dass dieser Server sich nicht mehr mit seinen Artgenossen repliziert. Das letzte Replikationsdatum wird noch aus der Zeit vor der Migration angegeben. Eine erzwungene Replikation schlägt auch Fehl, der Vmware Server wird von den physischen Servern nicht mehr gefunden und er findet die anderen auch nicht mehr. Die Vmware läuft im Bridged Netzwerkmodus, sonstige Zugriffe darauf (beispielsweise über RDP oder SMB) gehen problemlos.

Per dcpromo aus der Domäne nehmen geht freileich auch nicht mehr, es kommt die Fehlermeldung „der angegebene netzwerkname ist nicht mehr verfügbar"

Natürlich könnte ich den Domaincontroller per ntdsutil auch rauskicken aber das möchte ich wirklich nur als letzte Alternative nutzen.

Hat jemand hierzu eine Idee? Meine Vermutung geht in die Richtung dass durch die Convertierung in die VMware die ID des Servers neu generiert wurde und er deshalb nicht mehr gefunden wird. Aber es ist nur eine Vermutung die ich nicht belegen kann....


Gruß

D
Mitglied: nesQuick
09.04.2008 um 11:01 Uhr
Bei der konvertierung ändert sich die MAC Adresse eines PC's.

Kann das der fehler sein? Man kann diese aber auch nachträglich ändern. brauchst nur die *.vmx Datei anzupassen.

Mit freundlichen Grüßen
Ole
Bitte warten ..
Mitglied: Randyman
09.04.2008 um 11:13 Uhr
Hi,

sowas liegt meist am DNS. Kontrollier doch mal alle Einstellungen diesbezüglich.
Ich vermute die virtuelle Kiste ist nicht mehr sauber im DNS integriert.

Ist die Kiste selber DNS?
Worauf zeigt der erste DNS-Eintrag in der Netzerkonfig?
Wer ist Betriebsmaster?

mal folgendes ausführen:
ipconfig /flushdns
ipconfig /registerdns
net stop netlogon
net start netlogon

Einträge im DNS checken.

Win2000-Support-Tools installieren und netdiag und dcdiag ausführen ... Meldungen checken.

Viel Erfolg!

Gruss
Randy
Bitte warten ..
Mitglied: Formatierer
11.04.2008 um 01:33 Uhr
Testweise habe ich heute einen 2000er Server brandneu (also ohne Konvertierung) in eine VMware installiert. Und diese lässt sich tatsächlich auch nicht mit dcpromo zum DC machen, eben weil auch hier die Replikation fehlschlägt. Es ist also wirklich was faul hier und ich glaube nicht dass es etwas mit der vmware zu tun hat ...

Mein erster Gedankengang ging auch in Richtung DNS, ich konnte dort aber nichts auffälliges finden. Ich probiere deine Tipps aber mit dem flush und register aber trotzdem mal aus.

Achja, netdiag und dcdiag sind komplett grün!
Bitte warten ..
Mitglied: Formatierer
17.04.2008 um 23:17 Uhr
Ich habe die DNS Opionen ausprobiert, konnte aber trotzdem keine Besserung feststellen. Ich habe noch etwas rumprobiert und konnte das Problem etwas einschränken. Es tritt nur auf wenn der Vmware Server ein Domaincontroller ist. Dann ist keine RPC Kommunikation mit einem Domaincontroller möglich, der als Vmware Guest auf diesem läuft. Macht man den Vmware host per dcpromo zum Mitgliedsserver, klappt alles wieder. Das Problem tritt sowohl bei der Workstation wie auch beim Vmware Server auf. Könnte es vllt damit zusammenhängen, der wir einen brandneuen HP Server einsetzen und die Vmware nicht 100%ig mit der Netzwerkkarte klar kommt?! Ansonsten gehen mir echt die Ideen aus ....
Bitte warten ..
Mitglied: Formatierer
26.04.2008 um 16:11 Uhr
Bei weiteren Tests, auch mit anderen Systemen (Windows Server 2000, XP, 2003, etc), habe ich festgestellt, dass anscheinend grundsätzlich keine RPC Kommunikation bzw Replikation in eine VMware hinein oder heraus möglich ist. Ich habe drei verschiedene Hardware Plattformen als Vmware Host verwendet, davon 2 aktuelle Konfigurationen. Zu keinem Zeitpunkt hat die Kommunikation funktioniert... habe auch mit Vmware Server, Workstation und Player ausprobiert. Auch hier das gleiche...

Kann jemand diese Erfahrung teilen bzw kommentieren?! Komischerweise find ich in google nichts zu diesen Problemen. Ich kann doch nicht der erste sein, dem das auffällt ....
Bitte warten ..
Mitglied: FrankM
13.06.2008 um 18:56 Uhr
Hallo Formatierer,
bin heute zufällig auf Deinen Beitrag gestossen:
- gleiche Umgebung (neuer HP-Server, VMWare, Win2003 Server)

Gleiches Problem:
- W2K-Server (als Terminalserver vorgesehen) lässt sich nicht in die Domain integrieren; Fehler: der angegebene Netzwerkname ist nicht mehr verfügbar....

Mehrere Clients liessen sich problemlos hinzufügen, nur die VM nicht.

Hast Du eine Lösung gefunden oder einen Tipp für mich ?

Besten Dank im voraus !
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Hyper-V
Altaro VM Backup auf RDX

Frage von smeclnt zum Thema Hyper-V ...

Vmware
Veeam für VM Ware Backup Fehler (2)

Frage von JoergN1968 zum Thema Vmware ...

Windows Server
Lizenzierung Windows Server + 2 x W7P VM (6)

Frage von Mozzie zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (22)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...