Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Domainumleitung bei Win server 2003

Frage Microsoft Windows Server

Mitglied: visusvici

visusvici (Level 1) - Jetzt verbinden

01.12.2007, aktualisiert 03.12.2007, 3684 Aufrufe, 8 Kommentare

Hallo liebe Community,

ich habe ein Problem:

Und zwar habe ich einen Windows Server 2003 bei Strato.
Der Server wurde von einem Kollegen verwaltet, leider hat es sich ausverwaltet.

Nun stehe ich vor einem Problem und daher meine Frage:

Wie leite ich auf einem Windows root Server 2003 Domains um?
wie ich gesehen habe ist kein IIS installiert.

Xampp un Mysql Server 2005 habe ich gesehen.

Evtl. könnte mir einer bei der Erörterung weierhelfen.

Die Domainumleitung soll server Intern stattfinden. Also lediglich auf einen anderen Ordner.

Beipiel: Die Domain www.Solarium-Forum.com soll zB auf den Ornder von www.Sunal-Shop.de umgleitet werden.

also inten.

Sorry das ich nicht mehr Informationen liefern kann. Ich gleich Newb


Hoffe Ihr könnt mir helfen.
Mitglied: datasearch
01.12.2007 um 16:33 Uhr
Kommt ganz auf die Serverkonfiguration an. Im Xampp musst du eigentlich nichts weiter machen als in der apache config für die Domain einen Forwarder einzurichten.

In der config für den virtual Host www.Solarium-Forum.com musst du eigentlich nur redirect / http://www.Sunal-Shop.de eintragen und alles wird umgeleitet.

Alternativ kannst du das rewrite modul verwenden, das geht dann so:

RewriteEngine On
RewriteRule /.* http://www.Sunal-Shop.de


Als zweite Alternative lege die folgende PHP-File im webroot von www.Solarium-Forum.com ab:
index.php

<?
header('Location: http://www.Sunal-Shop.de';);
?>


Such dir eine Variante aus
Bitte warten ..
Mitglied: visusvici
01.12.2007 um 16:37 Uhr
die zweite und dritte variante fällt weg.

ich würde gerne rausfinden wie mein bekannte die Domains bisher umgleitet hat.
Und 2 und drei sind es wohl nicht.

virtual Host das wird es sein.
wie gehe ich da dann vor um die Umleitungen zu editieren?

evtl ne kurze Info bitte wo ich das finde und was das im groben ist.
Bitte warten ..
Mitglied: datasearch
01.12.2007 um 16:49 Uhr
Informationen zu virtuellen Hosts findest du hier:
http://httpd.apache.org/docs/2.0/de/vhosts/

Die Dokumentation zum alias-modul steht hier:
http://httpd.apache.org/docs/2.0/de/mod/mod_alias.html

Da ich leider nicht weiß wo dein Vorgänger die vhosts-config abgelegt hat, müsstest du selbst einmal in der httpd.conf nach dem Pfad suchen. Normalerweise liegen die in vhosts.d oder in einer Datei vhosts.config oder direkt in der https.conf.

Schau dir aber bitte die Apache Dokumentation an bevor du Änderungen vornimmst. Nicht das du deinen Server aufgrund von Konfigurationsfehlern demnächst in einem Botnetz wiederfindest.
Bitte warten ..
Mitglied: visusvici
01.12.2007 um 17:40 Uhr
Hi

ich habe eine Umleitung nun hinbekommen. Andere Domain. nicht wundern.

habe die Datei httpd-vhosts.conf gefunden und da waren die Befehle drinn.

Habe einfach die Daten geändert und auf die richtigen Ordner verwiesen. So hats geklappt.

Allerdings habe ich noch eine Datei gefunden httpd.conf_bc.txt da befinden sich auch informationen zu den Domains drinn:

<VirtualHost *:80>
ServerName www.sunal-shop.de
ServerAlias sunal-shop.de *.sunal-shop.de
DocumentRoot "D:/xamp/xampp/htdocs/sunal-shop.de"
</VirtualHost>

soll ich da auch die Daten ergänzen?
Bitte warten ..
Mitglied: datasearch
02.12.2007 um 03:30 Uhr
Das ist eine weitere Methode. Das sollte man zwar nur machen wenn man absolut keine andere Möglichkeit hat, funktioniert aber trotzdem. Das prob ist eben nur, das 2 Serverinstanzen den selben DocRoot verwenden. Versuche bitte trotzdem das über weiterleitung zu regeln.

zb. so:


<VirtualHost *:80>
RewriteEngine On
ServerName www.solarium-forum.com
ServerAlias solarium-forum.com *.solarium-forum.com
RewriteRule ^(/.*)$ http://www.sunal-shop.de$1
</VirtualHost>
Bitte warten ..
Mitglied: visusvici
02.12.2007 um 11:01 Uhr
also folgende Einträge sind vorhanden:

In Datei: httpd-vhosts.conf

<VirtualHost *:80>
ServerName www.solarium-forum.com
ServerAlias solarium-forum.com *.solarium-forum.com
DocumentRoot "D:/xamp/xampp/htdocs/solarium-forum.com"
ErrorLog "D:/xamp/xampp/apache/logs/solarium-forum.com-error.log"
CustomLog "D:/xamp/xampp/apache/logs/solarium-forum.com-access.log" common
</VirtualHost>


und

in Datei httpd.conf_bc.txt

<VirtualHost *:80>
ServerName www.uv-point.de
ServerAlias uv-point.de *.uv-point.de
DocumentRoot "D:/xamp/xampp/htdocs/sunal-shop.de"
</VirtualHost>


Frage 1:
wenn ich was ändern will dann in beiden Dateien gleich ?
Denn als ich die Änderung durchgeführt habe in der Datei: httpd-vhosts.conf hat das für die Umleitung ausgereicht. Nur weiss ich nicht ob ich noch wo anders was ändern muss.

Frage 2:
In der forum die oben von mir aufgeschrieben wurde bedeutet das was?
Nicht so gut?

Frage 3:

Kann ich einfach Deine Form so nehmen und bei mir eintragen? nur in httpd-vhosts.conf ??


PS:
Ich möchte nicht auf eine andere Domain leiten sondern auf einen Ordner oben war das nur ein Beispiel:

also die Domain www.Solarium-forum.com soll auf einen Ordner geleitet werden wo sich die jeweilige Index.php befindet.

evtl habe ich mich falsch ausgedrückt.

Denn so wi ich deine variante verstehe handelt es sich um eine Umleitung der Domain Solarium forum auf die Domain Sunal Shop. richtig?

bitte nochmals um Antwort schon mal Dankeschön
Bitte warten ..
Mitglied: datasearch
02.12.2007 um 15:31 Uhr
Denn so wi ich deine variante verstehe handelt es sich um eine Umleitung der Domain Solarium forum auf die Domain Sunal Shop. richtig?

Ja, genau das ist es auch.

Ich möchte nicht auf eine andere Domain leiten sondern auf einen Ordner oben war das nur ein
Beispiel:
also die Domain www.Solarium-forum.com soll auf einen Ordner geleitet werden wo sich die jeweilige Index.php befindet.

Also, OK. Ich dachte du möchtes due Domain xyz.de auf zyx.de umleiten. Hmm, es scheint aber, als brauchst du nur eine Möglichkeit, für ein DocumentRoot auf dem Server (zb. d:\webroot\domainspace) mehrere Domains einzurichten. LOL, irgendwas habe ich da falsch verstanden. Es reicht natürlich das selbe webroot für beide VHOSTS anzugeben.


httpd-vhosts.conf:

<VirtualHost *:80>
ServerName solarium-forum.com
ServerAlias www.solarium-forum.com *.solarium-forum.com
DocumentRoot "D:/xamp/xampp/htdocs/solarium-forum.com"
ErrorLog "D:/xamp/xampp/apache/logs/solarium-forum.com-error.log"
CustomLog "D:/xamp/xampp/apache/logs/solarium-forum.com-access.log" common
ServerAdmin webmaster@solarium-forum.com
ServerSignature Off
</VirtualHost>

<VirtualHost *:80>
ServerName uv-point.de
ServerAlias www.uv-point.de *.uv-point.de
DocumentRoot "D:/xamp/xampp/htdocs/solarium-forum.com"
ErrorLog "D:/xamp/xampp/apache/logs/uv-point.de-error.log"
CustomLog "D:/xamp/xampp/apache/logs/uv-point.de-access.log" common
ServerAdmin webmaster@uv-point.de
ServerSignature Off
</VirtualHost>


Falls du samtliche Domains auf den selben Pfad legen möchtest, kannst du für diese auf den Default-Server verwenden.
Bitte warten ..
Mitglied: visusvici
03.12.2007 um 09:22 Uhr
ja schön Danke.. das ist aber richtig wie ich das da habe oder?
denn du hast noch zwei einträge bei dir mehr im Code.

sind diese wichtig?
Und was sagen die aus ?


PS: was ist mit dieser TXT Datei ? muss ich da auch die Einträge vornehmen oder ist die unwichtig?

in Datei httpd.conf_bc.txt

da stehen bei dir diese einträge drinn:

<VirtualHost *:80>
ServerName www.uv-point.de
ServerAlias uv-point.de *.uv-point.de
DocumentRoot "D:/xamp/xampp/htdocs/sunal-shop.de"
</VirtualHost>

gruss
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(4)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Netzwerk
Windows Server 2003 SBS Netzwerk durch neuen Server Ersetzen (9)

Frage von MultiStorm zum Thema Windows Netzwerk ...

Exchange Server
gelöst Microsoft Excange Server 2007 auf Windows Server 2003 Installieren? (9)

Frage von Herbrich19 zum Thema Exchange Server ...

Windows Server
gelöst Suche Windows Server 2003 Enterprise ISO (8)

Frage von Herbrich19 zum Thema Windows Server ...

Windows Server
gelöst GPO greift unter win server 2008, unter win7 nicht (5)

Frage von sayohh zum Thema Windows Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (17)

Frage von Unwichtig zum Thema Netzwerkmanagement ...