Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Doppelte Einträge in Excel filtern

Frage Microsoft

Mitglied: roland123

roland123 (Level 2) - Jetzt verbinden

22.09.2008, aktualisiert 23.09.2008, 25122 Aufrufe, 9 Kommentare

Hallo zusammen.
Ich möchte gerne aus einer Adressenkartei in Excel alle Einträge rausfiltern, welche doppelt sind. Die Tabelle ist wie folgt aufgebaut Spalte A Vorname, B Nachname, C Straße

Ich habe folgende Formeln Probiert
{=WENN(VERGLEICH(A1&B1&C1;A$1:A$100&B$1:B$100&C$1:C$100;0)=ZEILE();"";"Duplikat")} da schreibt er nur #Wert#

=A1&B1&C1
und in E1:
=WENN(ZÄHLENWENN(D$1:D1;D1)>1;"Duplikat";"")

Es passiert nichts entweder kommt wie bei Formel 1 nur Wert oder bei Formel 2 nut Duplikat. Was ist an den Formeln falsch wo liegt mein Fehler. Kann mir jemand von euch helfen?

Die Datei umfasst 13000 Zeilen, welche abgesucht werden sollen ich habe erstmal als Test nur 100 genommen aber es haut einfach nicht hin.

Über eure Hilfe wäre ich Dankbar
Mitglied: Janni
22.09.2008 um 15:18 Uhr
In Excel prüfen, ob Einträge doppelt vorhanden sind
Sie haben eine lange Liste mit Daten in Excel und den Verdacht, daß dort einiges doppelt vorhanden ist?
Mit der folgenden Formel können Sie eine Spalte auf doppelte Werte hin überprüfen.

In Spalte A stehen also Ihre Werte, dann schreiben Sie in Zelle B1 folgendes:

=WENN(VERGLEICH(A1;A:A;0)=ZEILE();"Einzeln";"Doppelt")

Dies kopieren Sie dann nach unten und damit wird jeweils einer der doppelten Einträge angezeigt. Nun können Sie die Einträge bequem löschen. Dazu am besten den Autofilter (Menü Daten --> Filter --> Autofilter benutzen)
Bitte warten ..
Mitglied: roland123
22.09.2008 um 15:37 Uhr
hi
ja aber wenn nun 2 Leute Max heißen und mit Nachnamen Müller und der andere Meier berücksichtigt diese Formel das ja nicht.
Kann ich das noch verfeinern???
Bitte warten ..
Mitglied: Biber
22.09.2008 um 16:35 Uhr
Moin rolandhu,

an Deiner Hilfsfeldvariante in Spalten D / Visualisierung in Spalte E ist nur ein zahlenwert falsch:

Ändere von BISHER
=WENN(ZÄHLENWENN(D$1:D1;D1)>1;"Duplikat";"")
auf NEU
=WENN(ZÄHLENWENN(D$1:D$100;D1)>1;"Duplikat";"")

wenn Du die ersten 100 zeilen testen willst.

Ohne Hilfsspalte ginge es entweder mit Arrayformeln (ja, diese Dinger mit geschweiften Klammern und Strg-Enter etc) oder auch mit einer getarnten Arryformel, nämlich SUMMENPRODUKT().
==WENN(SUMMENPRODUKT( (A$1:A$100=$A1) * (B$1:B$100=$B1)*(C$1:C$100=$C1) >1);"Dup";"")
....und nach unten kopieren.

Nachteil (zumindest bei Excel 2000/2003: Du musst die Anzahl der Datensätze (in meinem Beispiel 100) schon exakt definieren.
Wenn Du pauschal einen Wert von 20000 angibst und nur 13000 Zeilen gefüllt hast, dann liefert Summenprodukt() auch in den ersten 13000 Zeilen Bullshit bzw. #WERT.

Falls Du schon Excel 2007 haben solltest. Dort ist neu dabei die ZÄHLENWENNS()-Funktion, die ganze Zeilen verwursten kann.

Grüße
Biber
Bitte warten ..
Mitglied: roland123
22.09.2008 um 16:51 Uhr
hi
ich verwende Excel 2003. Deine Formel ==WENN(SUMMENPRODUKT( (A$1:A$100=$A1) * (B$1:B$100=$B1)*(C$1:C$100=$C1) >1);"Dup";"") wird nicht funktionieren du hast bei allen Zeichen das $ vorgesetzt, d.H. die Zelle beziehen sich nur immer auf die Zellen Reihe 1 a b und c und die anderen Zellen 2,3,4,5,6, werden nicht errechnet verstehst du was ich meine???
Bitte warten ..
Mitglied: Biber
22.09.2008 um 16:56 Uhr
Moin rolandhu,
verstehst du was ich meine???
Ich denke schon....
Magst Du es trotzdem einfach mal ausprobieren?
Und dann nochmal schauen, wo ich $-Zeichen gestreut habe und wo nicht?

Grüße
Biber
Bitte warten ..
Mitglied: roland123
23.09.2008 um 11:06 Uhr
hi biber,
jop habe ich versucht geht aber immer noch nicht. Es passiert nichts die Zellen bleiben Leer. Ich habe mit Absicht einige Duplikate in die Tabelle eingebaut aber die findet er nicht. =$A1 läuft in der Zeile weiter A2 A3 usw. Aber er zeigt nichts an.
Bitte warten ..
Mitglied: roland123
23.09.2008 um 11:51 Uhr
hi Biber,
vielleicht ist mein vorgenen ja auch falsch. Ich habe meine Tabelle in A stehen die Vornamen in B die Nachnamen und in C die Straße mit Hausnummer. Eigentlich würden die Spalten A und B schon reichen. So nun kopiere ich deine Formel in Zeile D1 und ziehe diese runter. Aber er erkennt keine doppelten Einträge. z. B. in Zeile 1 ist eintrag Test und ist Zeite 15 wieder dann muss er doch spätestens bei Zeile 15 ausschlagen oder???
Bitte warten ..
Mitglied: Biber
23.09.2008 um 13:20 Uhr
Mea culpa, mea culpa, rolandhu,

Du hast Recht - die Summenproduktvariante funktioniert NICHT.
Nehme alle zurück.

Dann lass uns bitte zurück auf die "einfache Variante mit
  • der Hilfsspalte D (alle Felder links davon mit "&" verkettet)
  • und in E
=WENN(ZÄHLENWENN(D$1:D$205;D1)>1;"Dup? " & D1;"")

Grüße und sorry
Biber
Bitte warten ..
Mitglied: roland123
23.09.2008 um 15:20 Uhr
Hallo Biber
nun verstehe ich gar nichts mehr. Deine Formel bezieht sich doch auf die Zeile D da ist doch gar nichts drin. Ich habe nur die Spalten A B und C welche untereinander abgeglichen werden sollen.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...

Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...