Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Doppelte ja-nein Übergabe in der Batch

Frage Microsoft Windows Tools

Mitglied: turbojet

turbojet (Level 1) - Jetzt verbinden

10.04.2014 um 20:28 Uhr, 1386 Aufrufe, 2 Kommentare

Hallo Leute,
da wir immer mal einige Rechner haben, die beim nächsten Neustart keine neuen und geänderten Gruppenrichtlinien erkennen, sondern erst nach dem gpupdate /FORCE, wollte ich einen Task in der Aufgabenplanung erstellen.
Mittels Batch:

echo n | gpupdate /FORCE

kommt am Ende noch eine zweite Abfrage mit J/N, ob man sich abmelden möchte.


Wie kann man also ein zweites N (Nein) übergeben, sodass er es sauber beendet und nicht im Hintergrund rumhängt?


Beste Grüße
turbojet
Mitglied: colinardo
10.04.2014, aktualisiert um 20:49 Uhr
z.B. so
echo n | gpupdate /target:user /force 
echo n | gpupdate /target:computer /force
(Zur Info die Richtlinien werden vom Client auch regelmäßig im Hintergrund angewendet, ich würde hier eher nach der Ursache forschen warum die Clients die Richtlinien nach einem Neustart nicht erhalten)

Grüße Uwe
Bitte warten ..
Mitglied: turbojet
10.04.2014 um 20:56 Uhr
Ah stimmt, ich kann das ja zwei mal aufteilen

Ja die Ursachen zu erforschen finde ich für schwierig. Ich hätte z.B keine Ansätze, wo ich anfangen würde. Auch heute wieder an einem PC gemerkt, da war "uralt-Mist" drauf, gpupdate drübergejagt und da hat er nach dem Neustart erstmal angefangen vier Softwarepakete zu installieren.
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Batch & Shell
Verschachtelte For Schleife für Batch Neuling (3)

Frage von yperiu zum Thema Batch & Shell ...

Batch & Shell
gelöst Alle Ordner bis auf die letzten 3 per Batch löschen (5)

Frage von Stefan2733 zum Thema Batch & Shell ...

Batch & Shell
gelöst Fenstertitel von anderen Tasks per batch auslesen (3)

Frage von NetMare zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (20)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...