Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

DOS-Anwendung auf Terminal-Server 2k3 SP2 reagiert langsam

Frage Microsoft Windows Server

Mitglied: maltetreutner

maltetreutner (Level 1) - Jetzt verbinden

31.07.2008, aktualisiert 01.08.2008, 4230 Aufrufe, 6 Kommentare

Hallo,

ich habe ein kleines Problem mti einer DOS-Anwendung auf einem Terminal Server.
Diese Anwendung soll im Fenstermodus laufe, klar geht ja auf dem TS nicht anders...

Sie wird von einem Netzlaufwerk (Y) gestartet. Das Läuft auch alles wunderbar.
Nur reagiert das Programm auf die Befehle sehr langsam. Gibt es hier Einstellungen oder Parameter die man anpassen kann oder muss, damit das Programm flüssig läuft?
Bei einer lokalen Installation läuft die Anwendung normal...

Über Tipps wäre ich dankbar...

Malte
Mitglied: tropical
31.07.2008 um 15:21 Uhr
Es gibt eine config.nt, welche mit der alten config.sys vergleichbar ist. Hast du diese für das Programm angepasst. Außerdem würde ich den Kompatiblitätsmodus für Windows 98 aktivieren.

Gruß
Bitte warten ..
Mitglied: 60730
31.07.2008 um 15:23 Uhr
Servus,
was meinst du mit lokaler Installation?
Läuft es da auch auf y:\ ?
Sind evtl. einige variablen - die lokal vorhanden sind auf dem TS nicht da?

Hast du es schon mit dem "Kompatibilitätsmode für Win 95" versucht?
Bitte warten ..
Mitglied: greyhound
31.07.2008 um 19:03 Uhr
Hallo Malte,

ich erinnere mich dunkel, dass wir vor Urzeiten mal ein ähnliches Problem hatten, allerdings unter NT4.0 mit Citrix metaframe. Dort war es nach meiner Erinnerung so, dass die DOS-box versucht hatte, sich möglichst alle Rechnerressourcen zu krallen (100% Last auf dem zugeteilten Prozessor). Dies hatte das ganze I/O extrem verlangsamt. Zudem war es so, dass alle möglicherweise laufenden DOS-Programme auf dem Terminal-Server in einer einzigen DOS-box abliefen. In unserer Konfiguration haben wir das damals über eine gezielte Begrenzung der zugeteilten Ressourcen für das Dos Fenster gelöst.

Aber wie gesagt, unser Programm lief damals unter NT4. Keine Ahnung ob das bei 2k3 auch noch so funktioniert. Aber nachdem DOS schon lange nicht mehr weiterentwickelt wurde könnte ich mir vorstellen,dass das heute immer noch das gleiche Problem ist.

Vielleicht hilft's Dir ja weiter

Gutes Gelingen
Greyhound
Bitte warten ..
Mitglied: maltetreutner
31.07.2008 um 19:29 Uhr
hallo,

vielen dank zunächst... was würde ich in der config.nt denn verändern müssen? ich weiß das es da früher irgendwelche sachen gab an denen man etwas rumschrauben kann...

vielen dank für die antwort...
Bitte warten ..
Mitglied: maltetreutner
31.07.2008 um 19:31 Uhr
hallo,

als vergleich zum terminal server habe ich die installation auf einem lokalen rechner mit dem selben netzlaufwerk nachgestellt...
das mit den variablen ist ein guter hinweis, werde ich morgen mal klären..
aber ich denke wenn da etwas wirklich falsch wäre, dann würde das prog ja gar nicht laufen... was es aber tut...

den kompatibilitätsmodus kann ich auf dem ts für diese verknüpfung irgendwie nicht hinterlegen. alle felder sind grau hinterlegt...

danke
Bitte warten ..
Mitglied: maltetreutner
01.08.2008 um 09:10 Uhr
hallo,

danke für die antwort... nun konnte ich feststellen das auch auf dem 2003 server die cpu last bei laufender dos-anwendung auf bis zu 70% hoch geht.

hat jemand hierzu noch einen anderen lösungsansatz?

vielen dank
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...