Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Aus DOS-Programm drucken-Umleitung von LPT1 mit net use behindert durch Geisterverbindungen

Frage Microsoft

Mitglied: synack

synack (Level 1) - Jetzt verbinden

28.07.2010 um 13:19 Uhr, 6905 Aufrufe, 4 Kommentare

Nach langem Googlen und dem Durchsuchen vieler Forenbeiträge hier habe ich nun einen Account erstellt um meine Frage zu stellen. Es gibt ja anscheinend viele kompetente hilfbereite Menschen hier, aber bisher noch keine Lösung für mein Problem
In meiner Abteilung einer großen Firma benutzen wir immer noch das Datenbankprogramm OpenAccess 4 (ca. 1992) für einen Teil der Datenverwaltung. Leider wird sich das auch so schnell nicht ändern. Unsere Rechner sind eigtl. alle Windows XP SP3.

Zum Drucken aus diesem Programm benutzen wir schon länger die Umleitung des LPT1 auf einen Netzwerkdrucker. mittels
net use lpt1 \\printserver\druckername /persistent:yes
Das funktioniert auch auf einigen Rechnern. Auf manchen allerdings kommt die Meldung
"Systemfehler 85 ist aufgetreten. Der lokale Gerätename wird bereits verwendet" obwohl man nicht drucken kann und z.B. dir > lpt1 in der Eingabeaufforderung nicht funktioniert (Die Datei wurde nicht gefunden).
Soweit so gut, das Internet sagt mir nun
net use lpt1 /delete
zu verwenden. Allerdings bekomme ich dann die Meldung, dass die Ressource nicht gefunden wurde. Eine Auflistung der Verbindungen mit net use zeigt auch keine Verbindung für LPT1 an. Bei einem Rechner, bei dem das Drucken funktioniert, wird die Verbindung für LPT1 angezeigt, mit dem Status getrennt, funktioniert aber trotzdem.

Ich habe schon viele Sachen ausprobiert, registry-Einträge durchforstet, überprüft ob der LPT1 nicht doch in der Systemsteuerung vorhanden ist etc. Ich bin mit meinem Latein am Ende.
Meine Vermutung ist, das irgendwo in den Tiefen von Windows eine Verbindung gecached wurde, die zwar nirgends mehr angezeigt wird, aber dennoch dazwischenfunkt. Daher ist eine Frage:

Kennt jemand einen solchen Cache und weiß, wie man ihn löscht?

Dagegen spricht aber, dass ich dasselbe Problem mit lpt2 und lpt3 habe, obwohl die aller Wahrscheinlichkeit nach nie verbunden wurden.
Eine Lösung mit einem kostenpflichtigen Programm kommt leider auch nicht in Frage (wie Dos2Usb etc.).
Ich wäre dankbar für jegliche Hilfe, habe schon zuviele Stunden für dieses Problem verwendet und es steht natürlich auch meine Ehre als IT-Zuständiger in meiner Abteilung auf dem Spiel

Vielen Dank schonmal,
syn/ack
Mitglied: aleksandar
28.07.2010 um 14:19 Uhr
Hallo

ist der Drucker über USB Direkt an den Rechner angeschlossen? Wenn ja dann kannst du einen Trick die ich mir ausgedacht habe (wahrscheinlich steht es auch irgendwo im Internet) ausprobieren:

Bei dem Drucker > Schnittstelle markierst du einmal den USB Anschluss und einmal den LPT1 oder LPT2 Anschluss. Wenn du nun auf den LPT Druckt wird über USB Ausgedruckt. Zumindest bei unseren Dos Programm
hat es funktioniert.

Problem mit net use haben wir auch öfters, habe z.B. festgestellt das net use sich nicht verbinden wenn irgendwelche Drucker Aufträge in der Warteschlange stehen.


Vieleicht hilft dir das

Grüß Aleksandar
Bitte warten ..
Mitglied: synack
28.07.2010 um 17:02 Uhr
Hi Aleksandar,
Der Drucker ist nur über das Netzwerk verbunden. Allerdings könnte ich das mit den Schnittstellen trotzdem ausprobieren, einen Versuch wäre es wert. Die TCP/IP-Schnittstelle ist ja da auch aufgelistet.
Die Sache mit der Druckerwarteschlange war mir auch völlig unbekannt, das ist ein genialer Tipp Werde ich gleich morgen ausprobieren, vielleicht ist es ja das... Gibts da eine extra DOS- bzw. LPT1-Warteschlange oder beinhaltet die Windows-GUI-Warteschlange alle Druckaufträge die es gibt?

Danke und viele Grüße,
syn/ack
Bitte warten ..
Mitglied: synack
29.07.2010 um 11:05 Uhr
So, jetzt mal beides getestet: Die Schnittstellen lassen sich nicht anhaken, wahrscheinlich weil es ein Netzwerkdrucker ist. Die Druckwarteschlange, zumindest in Windows, ist auch leer. Ist schon zum wahnsinnig werden... Trotzdem danke für die Tipps!
Bitte warten ..
Mitglied: aleksandar
29.07.2010 um 12:36 Uhr
Hi
habe mit noch mal unsere Drucker angekuckt, eine Sache habe ich vergessen. Du musst noch den Hacken "Druckerpool aktivieren" setzen.
Und was du noch machen solltest, was zum Problemen bei net use führen kann, nehme den Hacken Bidirektionale Ünterstüzung raus.

Grüß Aleksandar
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Batch & Shell
NET USE LPT1 (4)

Frage von MiSt zum Thema Batch & Shell ...

Windows 7
Net use Befehl -Eingabe ungültig nach System-Neustart (8)

Frage von lderigo zum Thema Windows 7 ...

Visual Studio
gelöst VB.Net - Problem mit Umleitung der Standard-Ausgabe (4)

Frage von emeriks zum Thema Visual Studio ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (18)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...