Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Dos-Scroll-Problem

Frage Entwicklung Batch & Shell

Mitglied: bLuE--GaMeR

bLuE--GaMeR (Level 1) - Jetzt verbinden

09.07.2009, aktualisiert 21:37 Uhr, 9762 Aufrufe, 11 Kommentare

Hey...

Ich steh mal wieder auf dem Schlauch und bräuchte eure Hilfe! ;)

Habe einen Laptop mit Windows Vista und habe neulich mit den Eigenschaften des Dos Fensters (cmd.exe) rumgespielt.... was ein Fehler war...

Denn seit dem kann ich mit der Scrollbar nicht mehr bis ganz oben scrollen sondern nur noch ein paar reihen... zum beispiel bei dem befehl ipconfig -all werden mir nur die letzten 10 adapter angezeigt anstatt alle...

Denke mal das ich bei den Pufferwerten irgendetwas verstellt habe...weiß aber die standardwerte nicht...

Wär echt super wenn ihr mir auf die Sprünge helfen könntet....

Danke schonmal

bLuE -- GaMeR
Mitglied: 80220
09.07.2009 um 20:34 Uhr
Vista hat kein DOS-Fenster, nur ein Konsolenfenster. Nicht alles, das schwarz daherkommt, ist DOS.

Rechtsklick auf die "Eingabeaufforderung" -Verknüpfung oder auf die Titelzeile der Konsole, da kannst du einstellen.
Bitte warten ..
Mitglied: bLuE--GaMeR
09.07.2009 um 20:41 Uhr
ok entschuildigung wenn ich die beiden sachen durcheinandergebracht habe....

mir ist schon klar WO ich die werte ändern soll... nur nicht so ganz WELCHE Werte ich einstellen soll....

hab das nicht darüber gemacht sondern über irgendeinen befehl.. daher weiß ich die standardwerte nicht...

Hier sind meine derzeitigen einstellungen:

Cursorgröße: klein
Befehlsspeicher
->Puffergröße: 300
->Anzahl der Puffer: 300
Alte Duplikate löschen: nein

Bearbeitungsoptionen: alle 3 aktiviert....

so jetzt noch die registerkarte "Layout":

Fensterpuffergröße:
->Breite: 300
->Höhe: 300

Fenstergröße:
->Breite: 80
->Höhe: 25

Fensterposition:
->Automatisch


so hoffe ihr könnt mir helfen!
Bitte warten ..
Mitglied: 80220
09.07.2009 um 20:46 Uhr
Einstellungen musst du unter Layout vornehmen.
Bitte warten ..
Mitglied: bLuE--GaMeR
09.07.2009 um 20:49 Uhr
ja ne.. das war mir auch klar... (trotzdem danke für deine bemühungen)

mein problem ist, dass der scrollbalken nicht "länger" wird... egal ob ich die werte erhöhe oder senke... ich kann immer gleich weit nach oben scrollen...
Bitte warten ..
Mitglied: bLuE--GaMeR
09.07.2009 um 20:54 Uhr
und nochwas ist mir aufgefallen...

hab in den einstellungen eigentlich festgelegt das die schriftfarbe eine andere ist.. wenn ich über ausführen cmd starte klappt das auch...

habe allerdings gerade über ausführen "netstat" gestartet und siehe da ich hab ein dos fenster in dem ich scrollen kann und in dem die schriftfarbe auch standard ist...
Bitte warten ..
Mitglied: 51705
09.07.2009 um 21:11 Uhr
Hallo bLuE -- GaMeR,

wenn du die Eingabeaufforderung startest und links oben im Fensterrahmen auf das Symbol klickst, findest du die 'Standardwerte'. Vielleicht hilft das weiter.

Grüße, Steffen
Bitte warten ..
Mitglied: Biber
09.07.2009 um 21:13 Uhr
Moin bLuE--GaMeR,

egal wie viel oder wenig wir von den Redmondern halten mögen - auch die können nur einen Buffer-Bereich für ein EXE-Programm reservieren (in diesem Fall für CMD.exe), wenn das Programm (neu) geladen wird.
Also wenn Du deine "Layout"-Werte abspeicherst und auf die Frage
"Sollen diese Werte nur für das aktuelle... oder für alle Fenster mit diesem Namen gelten?"
mit "Ja " antwortest....

Dann wird das nächste CMD-Fenster, das Du z.B. über Start->Ausführen->cmd öffnest, einen längeren oder kürzereren Scrollbalken haben.

Und die Redmonder haben doch sogar ein ?-Knöpfchen in diesem Eigenschaftenfenster hinterlegt.
Du musst doch eigentlich nur den Wert bei "Fensterpuffergröße" ->"Höhe" auf 327 stellen, wenn Du 327 durchgelaufenene Zeilen sehen können willst.

Da ist doch nichts mit Umrechnen in Oktal oder Subnetz-Arithmetik..

[Edit]
Upps... vielleicht doch... wenn ich Deinen Kommentar oben lese.
Wenn Du Dein sichtbares Fenster auf eine Breite von 80 Zeichen beschränkst, musst Du nicht unbedingt die Fensterbreite des gepufferten Fensters auf 300 stellen.
250 würden auch reichen *gg
[/Edit]


Grüße
Biber
Bitte warten ..
Mitglied: bLuE--GaMeR
09.07.2009 um 21:18 Uhr
wenn ich auf standardwerte klicke komm ich nur auf die normalen werte (also die die ich jetzt eingestellt habe)... allerdings egal was ich da änder das fenster übernimmt diese einstellungen nicht...

allerdings alle anderen anwendungen die im konsolenfenster gestartet werden allerdings nicht aus cmd ausgeführt werden...werden in einem fenster angezeigr, welches genau mit meinen einstellungen übereinstimmt...

also:

wenn ich "ausführen" ->"netstat" mache, habe ich das fenster wie es sein soll (schrift weiß, hintergrund schwarz und größe und puffer wie ich es eingestellt habe...

aber wenn ich "ausführen" -> "cmd"-> "Netstat" eingebe wird cmd mit grüner schrift (hab ich irgendwann mal in den einstellungen eingestellt) und netstat auch mit falschem layout gestartet... also das ich nicht scrollen kann und so ein sick...
Bitte warten ..
Mitglied: bLuE--GaMeR
09.07.2009 um 21:20 Uhr
jaaa das habe ich auch gedacht.. aber siehe meinen letzten post (war noch dabei ihn zu schreiben bevor ich deinen gelesen hab)


erstens werde ich gar nicht gefragt ob ich das für alle fenster oder nur temporär haben möchte... auch wenn ich auf ok drücke ändert sich im fenster nix....
Bitte warten ..
Mitglied: 51705
09.07.2009 um 21:22 Uhr
dann hast du die Einstellungen für den Link geändert, denk ich mal.
Bitte warten ..
Mitglied: bLuE--GaMeR
09.07.2009 um 21:24 Uhr
aaah ich habs!

ich trottel habe die falschen einstellungen geändert *vor die stirn klatsch*

letztendlich hat mich srmerlin auf den richtigen weg gelenkt...

ich hab die werte immer unter "Standardwerte" anstatt unter "eigenschaften" geändert xD

ich weiß selbst nicht warum... aber jetzt gehts auf alle fälle...

ich könnt mich in den hintern beißen...

Danke für eure Hilfe... war nur eigene Dummheit...

Bis bald

bLuE -- GaMeR
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
DSL, VDSL
Problem mit variernder Internetgeschwindigkeit (12)

Frage von schaurian zum Thema DSL, VDSL ...

Windows Netzwerk
gelöst Problem mit PSexec64 von Sysinternals (8)

Frage von MaxMoritz6 zum Thema Windows Netzwerk ...

Windows Server
gelöst Problem nach DC-Installation unter Server 2012 R2 (9)

Frage von manuel1985 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...