Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

DrayTek 2960 VPN Probleme

Frage Netzwerke Router & Routing

Mitglied: Rolf-Hanka.ITD

Rolf-Hanka.ITD (Level 2) - Jetzt verbinden

17.11.2014 um 10:37 Uhr, 4080 Aufrufe, 9 Kommentare, 2 Danke

Hallo Leute,

ich habe mal ein Problem.

Zum Setup:

1x DrayTek Vigor 2960 Router ( aktuellste Firmware )
1x SBS 2011 Server ( DHCP, DNS und Exchange )
1x Standard 2008 Server ( Betriebsprogramm )
mehrere Notebook Clients

Zum Szenario:

Die Clients sollen sich von außen via SSL VPN in dem Netz einwählen und auf das Exchange sowie auf das Betriebsprogramm zugreifen können.


Zum Problem:

Die VPN Verbdingung wird mit dem SmartVPN Client von Drytek aufgebaut. Die Clients bekommen auch eine IP Adresse und ein DNS Server zugewiesen. Auffallen tut jetzt schon das die Subnetzmask 255.255.255.255 lautet, wobei sie eigentlich ja 255.255.255.0 lauten sollte.
Ich kann wenn die Verdingung aufgebaut ist die IP´s der beiden Server an pingen. Ich kann sie auch via FQDN an pingen, aber nicht mit dem normalen DN. Also der Client weis einfach nicht welche Domain Suffix er an den Namen hängen muss.
Netzwerkfreigaben ( über den FQDN ) bekomme ich vom Server sporadisch auf, vom SBS jedoch nicht. Das Exchange bekomme ich mit dem Outlook nicht angesprochen und auch das Betriebsprogramm ( Werbas eine KFZ Software ) baut keine Verbindung auf.


Es wirkt alles doch sehr komisch. Der Support von DrayTek lässt sehr zu wünschen übrig, am Telefon geben Sie für solche Szenarien keinen Support und via Mail antwortet niemand ( seit einer Woche ). Der Distributor TwoCom an den man sich wenden soll weiß zu diesem Problem auch keinen Rat und verweist auf den DrayTek Support.

Vielleicht kann mir ja hier jemand von euch helfen das Problem zu lösen, vielleicht hat jemand einen solchen Router auch im Einsatz und hat ein paar Tipps für mich.

Ich würde mich sehr freuen.

Beste Grüße
Mitglied: 114757
17.11.2014, aktualisiert um 17:35 Uhr
Moin,
wie immer würdest du uns einen großen Gefallen tun, indem du mal Screenshots deiner VPN-Config des Draytek und die der VPN-Clientsoftware posten würdest Dann müssen wir dir nicht alles aus der Nase ziehen. Wir wissen ja noch nicht mal um was für ein VPN es sich handelt (L2TP/IPSec/PPTP/SSTP/....)

Schon mal testweise einen anderen VPN-Client benutzt (Shrew)?

Gruß jodel32
Bitte warten ..
Mitglied: Rolf-Hanka.ITD
17.11.2014 um 17:39 Uhr
Hallo,

danke erstmal für deine Antwort.
Kennst du diesen Vigor Router? Es gibt leider nicht die eine VPN Einstellungsseite bei diesem Router. in fast allen menüpunkten gibt es dafür Einstellungen das macht die Sache nicht gerade leichter.

Als anderen VPN Client habe ich erstmal versucht das ganze über PPTP mit Windows hinzubekommen, leider aber der selbe Fehler.

Zum Beispiel gibt in dem ganzen Router keine offensichtliche Einstellung um die Subnetzmaske für die VPN User zu definieren.
Bitte warten ..
Mitglied: 114757
17.11.2014, aktualisiert um 18:05 Uhr
Zitat von Rolf-Hanka.ITD:
Kennst du diesen Vigor Router?
yes
Es gibt leider nicht die eine VPN Einstellungsseite bei diesem Router. in fast allen
menüpunkten gibt es dafür Einstellungen das macht die Sache nicht gerade leichter.
na klasse das hilft uns hier jetzt sehr weiter ...aber wenn du keine Hilfe willst, dein Problem!
Als anderen VPN Client habe ich erstmal versucht das ganze über PPTP mit Windows hinzubekommen, leider aber der selbe Fehler.
Dann hast du einen Grundlegenden Fehler beim Setup gemacht
Zum Beispiel gibt in dem ganzen Router keine offensichtliche Einstellung um die Subnetzmaske für die VPN User zu definieren.
hä??, quatsch ...

1509f10a574d29daa821b45fc376ef38 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: Rolf-Hanka.ITD
18.11.2014 um 10:00 Uhr
Doch natürlich möchte ich Hilfe, sonst würde ich nicht schreiben.

Ich habe ( Info kamm vom Distributor von DrayTek ) die User nur unter dem User Management angelegt und dann gesagt wie sie zugreifen dürfen.

650be0b27e8bc15859218254149cca43 - Klicke auf das Bild, um es zu vergrößern

Die User Konfig sieht dann so aus.

73b5a7b01b12a486421c55b3453b0d51 - Klicke auf das Bild, um es zu vergrößern

Hier habe ich die PPPTP Einstellung angepasst.

55c7ebd59b36df2294b20b40697f2437 - Klicke auf das Bild, um es zu vergrößern

Und hier noch die allgemeinen LAN Settings.

432ee3fe08c023747bf817234ba6842d - Klicke auf das Bild, um es zu vergrößern

e331cc10ea415b1da103a29d5af6f3b7 - Klicke auf das Bild, um es zu vergrößern

Vielleicht erkennst du dabei ja schon den Fehler und kannst mir helfen, würde mich freuen.
Bitte warten ..
Mitglied: aqui
18.11.2014 um 10:10 Uhr
Du schreibst oben SSL VPN. Sagst unten aber das du den Smart Client benutzt der aber IPsec verwendet ?!? Welches Protokoll ist es denn nun wirklich ?!
Bitte warten ..
Mitglied: Rolf-Hanka.ITD
18.11.2014, aktualisiert um 10:23 Uhr
Soweit ich das bei dem SmatVPN Client von DrayTek richtig deute benutze ich den SSL Tunnel.

e511f9998da3a999c1ef12b2b01cbdb9 - Klicke auf das Bild, um es zu vergrößern

Die Verbindung selbst funktioniert ja auch, wie schon geschrieben.

Die Subnetzmaske wird nur falsch übermittelt und der Domain Suffix wird gar nicht übermittelt. Obwohl die IP Adressen augenscheinlich vom DHCP Server kommen der zeitgleich der DNS ist.
Zu mindestens werden die vergebenen IP Adressen im DHCP Server aufgezeigt.
Bitte warten ..
Mitglied: 114757
18.11.2014 um 11:18 Uhr
Soweit ich das bei dem SmatVPN Client von DrayTek richtig deute benutze ich den SSL Tunnel.
Erster Fehler, der VPN-Client von Draytek ist vollkommener Mist, damit hab ich mir schon mal einen ganzen Rechner so versaut das jegliche VPN-Client-Software nicht mehr lief, also besser Finger weg !! Nehm den in Windows integrierten Client oder besser noch Shrew.

Und konfiguriere die Verbindung mal als IPSec-Tunnel oder L2tP o. IPSec und nicht das proprietäre SSL-VPN von Draytek.

Poste auch mal die Ausgaben von route print und ipconfig /all, wenn der Tunnel aufgebaut ist.
Bitte warten ..
Mitglied: Rolf-Hanka.ITD
18.11.2014 um 11:48 Uhr
Shrew erschlägt mich gerade ein klein wenig was die Einstellungen angeht und die Windows Geschichte kann ja "nur" L2tP over IPSec und kein reinen IPSec Tunnel oder? Hast du für Shrew vielleicht ne Anleitung was man wie einstellen muss?

Die Verbindung über IPSec zu steuern war auch der Grundgedanke, da diese aber auch nicht funktioniert und der Support dafür auch keinerlei Infos rausrückt haben wir das wieder verworfen. Fehler dabei war das der SmartVPN Client sagt man sei via IPSec verbunden und unter den Connection Managements im Router sieht man auch das eine Verbindung besteht, aber da klappt nicht einmal ein Ping.
Bitte warten ..
Mitglied: Rolf-Hanka.ITD
06.01.2015 um 09:49 Uhr
Also an einem Client lag mein Fehler nicht.

Der Router war ganz einfach defekt, nun funktioniert es über L2TP over IPsec mit einer Windows VPN Verbindung.

Falls jemand mal ein ähnliches Problem hat.
Bitte warten ..
Neuester Wissensbeitrag
DSL, VDSL

Telekom blockiert immer noch den Port 7547 in ihrem Netz

(3)

Erfahrungsbericht von joachim57 zum Thema DSL, VDSL ...

Ähnliche Inhalte
DSL, VDSL
gelöst VPN-Probleme (CISCO AnyConnect) in Zusammenhang mit Router "Vodafone EasyBox" (7)

Frage von donnyS73lb zum Thema DSL, VDSL ...

Netzwerkmanagement
2 Standorte VPN Probleme mit Bandbreite (4)

Frage von fnatic zum Thema Netzwerkmanagement ...

Router & Routing
gelöst VPN Probleme bei Hostname Auflösung (3)

Frage von 118080 zum Thema Router & Routing ...

Windows 10
gelöst VPN Verbindung Probleme (7)

Frage von Yeter2 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...