Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Drucker mit net use umleiten... es kommt eine Loginabfrage

Frage Microsoft Windows Server

Mitglied: woopinwolfman

woopinwolfman (Level 1) - Jetzt verbinden

10.03.2005, aktualisiert 11.03.2005, 41938 Aufrufe, 6 Kommentare

Ich habe in meinem Loginscript folgenden Befehl eingebunden

net use lpt1: \\server\HP500

Beim abarbeiten des Scripts fragt er ausser beim Admin nach dem Login und Passwort. Wie kann ich im Script ein L ogin und Passwort übermitteln? Allerdings wundert es mich mit der Abfrage. Die Freigabe ist ein Printserver der SMB unterstützt. Der Drucker ist nirgends eingebunden. Ich muss die Umleitung für ein 16 Bit Programm haben. Hat jemand einen Tipp?

mfg. Wolfgang
Mitglied: meinereiner
10.03.2005 um 14:48 Uhr
mit "net help use" gibts die Hilfe zu net use, und da stehts auch drin.
Haken an der Sache ist, dass das Passwort unverschlüsslt mitgeht..
Bitte warten ..
Mitglied: woopinwolfman
10.03.2005 um 15:07 Uhr
Die Syntax bekomme ich noch nicht hin.

net use lpt1: \\server\hp500 /user:name:passwort ???????

ist es möglich das Login mit folgender Zeile zu übergeben??

net use lpt1: \\server\hp500 >>login.txt

Wie muss dann der Inhalt der login.txt von der Syntax her lauten?

Danke für das Bemühen
Bitte warten ..
Mitglied: meinereiner
10.03.2005 um 15:23 Uhr
net use lpt1: \\server\hp500
/user:name:passwort ???????


net use x: \\server\freigabename /user:Domänenname\username Passwort


net use lpt1: \\server\hp500
>>login.txt

da schreibst du die Ausgabe in die Datei login.txt
Bitte warten ..
Mitglied: Spyder
11.03.2005 um 13:42 Uhr
Hallo Wolfgang,

unter XP/2000 können normale Benutzer keinen LPT ? port mit ?net use? umleiten

Lösung:
Um Benutzern die Umleitung von LPT1 zu ermöglichen, deaktiviert man im Gerätemanager die LPT1-Schnittstelle:

-Starten des Gerätemanagers (z.B. in Systemsteuerung - Verwaltung - Computerverwaltung).

-Öffnen "Anschlüsse" und die "Eigenschaften" von "LPT1" anzeigen.

-Reiter "Allgemein" Drop-Down-liste "Geräteverwendung" die Option "Gerät nicht verwenden (deaktivieren)" einstellen.

Dadurch wird LPT1 von Windows 2000/XP als logischer Port und nicht mehr als physikalischer Port erkannt - und damit kann jeder Benutzer den Umleitungsbefehl absetzen.

Gruß Spyder
Bitte warten ..
Mitglied: woopinwolfman
11.03.2005 um 14:39 Uhr
Ich habe das mit dem deaktivieren ausprobiert. Leider kein Erfolg. Wenn ich als Benutzername den Admin angebe bekomme ich als Meldung " Systemfehler 5 aufgetretten"

"Zugriff verweigert".

Nur am SB-Server selber bekomme ich ein OK und kann im FOX ( 16Bit Applikation ) drucken. Ich finde mit gpedit.msc keinen Eintrag wie "Installation von Druckern, die Kernelmodustreiber verwenden,nicht zulassen" deaktiveren oder Ähnliches nicht. Es muss wohl eine vorkonfigurierte Richtlinie sein im Small Buiseness Server 2003. Ich weiss nicht wo man jetzt noch suchen soll. Hat noch jemand einen Tipp??

Danke Wolfgang
Bitte warten ..
Mitglied: Spyder
11.03.2005 um 17:00 Uhr
Ich hatte das selbe Problem, bei mir gehts aber so!
Mann kann noch ausprobieren, das man den Benutzer bei dem das Umgeleitet werden soll lokal als Hauptbenutzer einträgt
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
NET USE LPT1 (4)

Frage von MiSt zum Thema Batch & Shell ...

Exchange Server
gelöst Exchange: Mail abfangen und verändert umleiten (2)

Frage von Koschie zum Thema Exchange Server ...

Microsoft
gelöst Drucker Über Powershell installieren (13)

Frage von Asker06 zum Thema Microsoft ...

VB for Applications
VB.net Combobox databinding langsam (4)

Frage von ForgottenRealm zum Thema VB for Applications ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(2)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...