Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

DSL Failover Konfiguration auf Cisco 1841

Frage Netzwerke DSL, VDSL

Mitglied: 1x1speed

1x1speed (Level 1) - Jetzt verbinden

19.05.2013, aktualisiert 08:39 Uhr, 2259 Aufrufe, 2 Kommentare

Hallo zusammen,

ich habe ein Problem bei einer DSL Failover Konfiguration auf einem 1841er Cisco. An dem Standort gibt es zwei DSL einen DSL384 und einen DSL 2000 mit RAM Technik. Der 1841 ist mit Fa0/0 an eine Fritzbox DSL2000 und über Fa0/0/0 (1Fe HWIC) an DSL384 an ein Speedport 501v angeschlossen.
Bei nachfolgender Konfig funktioniert der Failover sobald entweder Fritzbox oder Speedport ausgeschaltet werden. Ich habe aber keine Idee den DSL Status zu überwachen. Wenn ich versucht habe bei den IP SLA jeweils ein Telekom DNS einzutragen kommt keine Verbindung zustande, da ja der Next-Hop erst gesetzt wird, wenn das IP-SLA Kriterium erfüllt ist. Da die beiden DSL Anschlüsse keine Feste IP haben, habe ich auch keine direkte Gateway Adresse am DSL. Den Dialer auf den Router legen kann ich auch nicht, da über die Fritzbox noch das W-LAN genutzt wird.

01.
track 10 ip sla 1 reachability 
02.
delay down 1 up 1 
03.
04.
track 20 ip sla 2 reachability 
05.
delay down 1 up 1 
06.
07.
08.
interface FastEthernet0/1 
09.
 ip policy route-map PBR 
10.
11.
12.
ip route 0.0.0.0 0.0.0.0 192.168.100.1 track 10 
13.
ip route 0.0.0.0 0.0.0.0 192.168.200.1 track 20 
14.
15.
16.
ip nat inside source route-map NAT-DSL-PRIMARY interface FastEthernet0/0 overload 
17.
ip nat inside source route-map NAT-DSL-SECONDARY interface FastEthernet0/0/0 overload 
18.
19.
20.
ip sla 1 
21.
 icmp-echo 192.168.100.1 source-interface FastEthernet0/0 
22.
 threshold 1000 
23.
 timeout 1000 
24.
 frequency 1 
25.
 ip sla schedule 1 life forever start-time now 
26.
ip sla 2 
27.
 icmp-echo 192.168.200.1 source-interface FastEthernet0/0/0 
28.
 threshold 1000 
29.
 timeout 1000 
30.
 frequency 1 
31.
ip sla schedule 2 life forever start-time now 
32.
33.
access-list 10 permit 192.168.0.0 0.0.255.255 
34.
ip access-list extended ACL_NAT_PRIMARY 
35.
 deny   ip 192.168.0.0 0.0.255.255 10.10.0.0 0.0.255.255 
36.
 permit ip any any 
37.
ip access-list extended ACL_NAT_SECONDARY 
38.
 deny   ip 192.168.0.0 0.0.255.255 10.10.0.0 0.0.255.255 
39.
 permit ip any any 
40.
41.
42.
route-map NAT-DSL-PRIMARY permit 10 
43.
 match ip address ACL_NAT_PRIMARY 
44.
 match interface FastEthernet0/0 
45.
46.
route-map NAT-DSL-SECONDARY permit 10 
47.
 match ip address ACL_NAT_SECONDARY 
48.
 match interface FastEthernet0/0/0 
49.
50.
route-map PBR permit 10 
51.
 match ip address 10 
52.
 set ip next-hop verify-availability 192.168.100.1 1 track 10 
53.
route-map PBR permit 20 
54.
 match ip address 10  
55.
 set ip next-hop verify-availability 192.168.200.1 2 track 20 
56.
 

Mitglied: aqui
19.05.2013 um 14:01 Uhr
Du musst die SLA mit einem PBR Statement konfigurieren und einer passenden Hostroute mit next Hop im PBR setting. Dann kannst du die SLAs auf die beiden Inetrfaces verteilen und sie so überwachen.
Ein PBR Beispiel findest du hier:
http://www.administrator.de/articles/detail.php?id=103423
Umgesetzt hast du das ja schon richtig, musst nur noch ein Match Entry für die zu pingenden SLA Server auf den jeweiligen Outbound Interfaces machen.
Bitte warten ..
Mitglied: 1x1speed
19.05.2013, aktualisiert um 19:37 Uhr
Hi Aqui,

danke für deine Antwort. Hab mir das Beispiel angesehen. Grundsätzlich ist das mit dem PBR klar. Jedoch check ich noch nicht so ganz was du mit "SLA mit einem PBR Statement konfigurieren" meinst.

Ich hab nun mal folgendes konfiguriert:

194.25.2.129/130 (beide DNS der Telekom) wenn DSL2000 nicht mehr läuft dann ist 194.25.2.129 über Fa0/0 ja nicht mehr erreichbar und der DSL384 sollte übernehmen wenn 194.25.2.130 über Fa0/0/0 SLA2 erreichbar ist.
Für 194.25.2.129 und 194.25.2.130 habe ich eine seperate Route eingetragen, da die Default Route noch nicht eingetragen ist wenn die SLA1 und SLA2 jeweils die IPs nicht erreichen können.

01.
ip route 194.25.2.129 255.255.255.255 192.168.100.1 
02.
ip route 194.25.2.130 255.255.255.255 192.168.200.1 
03.
04.
ip sla 1 
05.
 icmp-echo 194.25.2.129 source-interface Fa0/0 
06.
 threshold 2000 
07.
 timeout 2000 
08.
 frequency 2 
09.
ip sla schedule 1 life forever start-time now 
10.
ip sla 2 
11.
 icmp-echo 194.25.2.130 source-interface Fa0/0/0 
12.
 threshold 2000 
13.
 timeout 2000 
14.
 frequency 2 
15.
ip sla schedule 2 life forever start-time now
Sobald diese Config drin ist ist kein Internet Connect da, die Default Route ist auch bei
01.
sh ip route
nicht vorhanden. Ein Source-Ping mit:

01.
ping 194.25.2.129 source Fa0/0
und

01.
ping 194.25.2.130 source Fa0/0/0


läuft auch nicht obwohl die Route drin ist. Eine die NAT-ACL lässt doch nach meinem Verständnis auch alles durch.

Irgendwie muss ich ja aber über die SLA überwachen, ob eine Verbindung zum Internet und nicht zum Next-Hop, was hier bei mir FB oder Speedport ist, vorhanden ist.
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Wie funktioniert DNAT mit einem Cisco 1841
gelöst Frage von Garibaldi69Router & Routing4 Kommentare

Hallo zusammen. Ich habe ein Problem mit der Konfiguration von NAT. Mein Problem sieht so aus: Router A (Cisco ...

Sonstige Systeme
Cisco 1841, dhcp Client keine Adresse
gelöst Frage von rudeboySonstige Systeme33 Kommentare

Mahlzeit! Habe einen Cisco-Router 1841 zum "spielen" bekommen. Erste "Aufgabe" war das secret zurückzusetzen, aber da gibt es ja ...

Cluster
Failover Cluster Haproxy falsche Konfiguration?
Frage von akadawaCluster5 Kommentare

Hallo, ich habe nach verschiedensten Konfigurationen des Haproxy, keine funktionierende Lösung gefunden. Knoten1:11.40.51.38 Knoten2:11.40.55.98 HAproxy:11.40.55.99 Proxy:ja Auf den Knoten ...

LAN, WAN, Wireless
Cisco 2960-S, kein Failover in Etherchannel
gelöst Frage von thaefligerLAN, WAN, Wireless6 Kommentare

Hallo zusammen Ich habe ein Problem mit einem Etherchannel zwischen zwei Cisco 2960-S Switchen. Zwischen den beiden Switchen besteht ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 4 StundenWindows 10

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 6 StundenSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 20 StundenInternet3 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 1 TagDSL, VDSL1 Kommentar

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement21 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Windows Server
Anmeldung direkt am DC nicht möglich
Frage von ThomasGrWindows Server16 Kommentare

Hallo, ich habe bei unserem Server 2016 Standard ein Problem. Keine Ahnung wie das auf einmal passiert ist. Ich ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...

TK-Netze & Geräte
VPN-fähige IP-Telefone
Frage von the-buccaneerTK-Netze & Geräte15 Kommentare

Hi! Weiss noch jemand ein VPN-fähiges IP-Telefon mit dem man z.B. einen Heimarbeitsplatz gesichert anbinden könnte? Habe nur einen ...