Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Durchsatz schlecht mit Switch

Frage Netzwerke LAN, WAN, Wireless

Mitglied: fump2000

fump2000 (Level 1) - Jetzt verbinden

09.01.2011, aktualisiert 18.10.2012, 8494 Aufrufe, 11 Kommentare

Hallo zusammen,

ich habe mir einen neuen Switch gekauft einen TP-Link Netzwerk Switch 1000Mbps (8x Gigabit LAN Ports). Dazu hab ich mir einige 3 Meter lange Cat 6 LAN Kabel und ein 15 Meter langes Cat 6 LAN Kabel gekauft.
Hier der Amazon Link zu dem Switch: http://www.amazon.de/gp/product/B000N9B688/ref=oss_product

Heute habe ich dann den Switch hinter mein Fernsehboard gelegt dort die kurzen und das lange Kabel angeschlossen. Am Fernsteher steht mein Media PC, eine D-Link Boxee und ne PS3. Alles drei haben einen LAN Anschluss. Die Boxee hat 100Mbit der Media PC und die PS3 haben Gigabit Anschlüsse.

Das lange Kabel fürt zu einem Linksys WRT 350N, ebenfalls mit Gigabit Switch.

Vorher lag für den Media PC ein eigenes Kabel.

Mein Notebook ist auch per LAN Kabel am Linksys angeschlossen.

Nun das eigenliche Problem.

Vor dem Umbau hatte ich einen Durchsatz von gut 40 MB/Sek. zwischen Notebook und Media PC. Jetzt sind es nur noch 8-14 MB/Sek.

Verstehe nicht warum das so ist. Sollte der Durchsatz nicht eigentlich gleich bleiben?

Kann das am zusammenspiel von Switch und Linksys Router liegen? Was kann das für Gründe haben?

Am Switch habe ich den Router an Port 1 angeschlossen, den Media PC an 2, Boxee an 3 und die PS3 an 4. Das sollte ja eigentlich keine Rolle spielen.

Da ich mit dem Linksys immer mehr probleme auch in sachen WLAN habe tausche ich diesen aus.
Wie der Zufall so will ist der neue Router auch ein Gerät der Firma TP-Link, genau dieser hier: TP-Link TL-WR1043ND.

Leider ist dieser noch nicht da. Ich werde dort dann direkt DD-WRT einspielen um den USB Port für den Printer nutzbar zu machen.

Ich hoffe das hier jemand einen Tipp hat.

Vielen Dank im Voraus!

MfG
Fump
Mitglied: Duro
09.01.2011 um 10:48 Uhr
Halllo,
Schließe mal testweise einen anderen switch an, der nicht von TP-Link ist und teste dann.
Gruß
Bitte warten ..
Mitglied: fump2000
09.01.2011 um 15:28 Uhr
Habe leider keinen ander Switch da zum testen.
Bitte warten ..
Mitglied: aqui
10.01.2011, aktualisiert 18.10.2012
Dann das hier machen:
http://www.administrator.de/forum/netzwerkgeschwindigkeit-vom-server-zu ...
und Ergebnisse hier posten. Relevant ist ein "Back to Back" Test OHNE Switch mit einem Crossover Kabel als Referenz !!
Bitte warten ..
Mitglied: fump2000
19.01.2011 um 02:35 Uhr
Hallo! Sorry das ich mich jetzt erst melde.

Folgendes ist in der zwischenzeit passiert:

Ich habe mir statt des TP-Link Switch einen von Cisco bestellt und getestet aber das gleiche Ergebnis. Daher habe ich diesen wieder eingepackt und zurück geschickt.
Dann habe ich nach einiger Recherche eine neue NIC bestellt und zwar eine Intel EXPI9301CTLK GBLan PCIex und habe diese in meinem Fileserver eingebaut.
Beim Notebook meiner Frau ist es so das Sie nun wieder ca. 30 MB schafft. Ich dagegen komme leider nur auf 10-15 MB.

Hier mal der NetIO Auszug zwischen Server und meinem Notebook (Acer Aspire 7740G):

TCP connection established.
Packet size 1k bytes: 11.66 MByte/s Tx, 22.56 MByte/s Rx.
Packet size 2k bytes: 12.76 MByte/s Tx, 12.71 MByte/s Rx.
Packet size 4k bytes: 16.20 MByte/s Tx, 28.58 MByte/s Rx.
Packet size 8k bytes: 16.37 MByte/s Tx, 31.89 MByte/s Rx.
Packet size 16k bytes: 16.47 MByte/s Tx, 39.17 MByte/s Rx.
Packet size 32k bytes: 17.65 MByte/s Tx, 33.39 MByte/s Rx.
Done.

Verbaut ist eine Broadcom NetLink (TM) Gigabit Ethernet, die Aktuellsten Treiber habe ich runtergeladen und Installiert.

Ich versteh es einfach nicht mehr. Habe neue Kabel gekauft und verlegt und dennoch das gleiche Ergebnis.

Bitte helft mir weiter. Ich verzweifel hier da ich den Fehler nicht erkenne und auch nicht verstehe...

Hier der NetIO Auszug vom Notebook meiner Frau aus (Acer Aspire 6930G):

TCP connection established.
Packet size 1k bytes: 16.36 MByte/s Tx, 26.58 MByte/s Rx.
Packet size 2k bytes: 17.39 MByte/s Tx, 27.68 MByte/s Rx.
Packet size 4k bytes: 18.23 MByte/s Tx, 37.39 MByte/s Rx.
Packet size 8k bytes: 19.05 MByte/s Tx, 43.50 MByte/s Rx.
Packet size 16k bytes: 19.66 MByte/s Tx, 46.19 MByte/s Rx.
Packet size 32k bytes: 19.65 MByte/s Tx, 47.52 MByte/s Rx.
Done.

Hier ist ein Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller verbaut.

Wie man sieht, nicht viel aber doch etwas mehr Leistung.

Jumbo Frames können leider nicht genutzt werden da mein Notebook dies nicht unterstützt.

Wie gesagt vor dem Einsatz des neuen Switches hatte ich immerhin gute 40 MB mit dem neuen nicht mehr, allerdings kann es daran eigentlich nicht liegen denn alle Rezesionen besagten das volle Leitung kein Problem wäre. Mittlerweile habe ich auch einen neuen Router ebenfalls von TP-Link aber das ändert nichts.

Insgesammt ist die Leistung nicht der eines Gigabit Lan Netzwerkes würdig. Irgendwo muss hier also der Hund begraben sein.

Ich blick hier echt nicht mehr durch.

Vielen Dank für eure Zeit!

MfG
Fump
Bitte warten ..
Mitglied: aqui
20.01.2011 um 19:03 Uhr
Respekt ! Sagenhafte 240 Mbit auf einem Gigabit Netzwerk. Einsamer Minusrekord. Da sind ja sogar die berühmt berüchtigten Realtek Chipsätze noch Klassen schneller....
Irgendwas stimmt da in der tat nicht. Auch wen Acer Billigware ist im Endgeräte Sektor sollten die Werte mindestens 50% also 400 bis 500 Mbit schaffen.
Der Frau Rechner zeigt das ja Ansatzweise.

Was wirklich interessant und zudem sinnvoll wäre hast du aber leider NICHT geliefert und das wäre ein Test der beiden Geräte Back to Back ohne Switch direkt mit einem Crossover Kabel !!
Die NetIO Daten zu diesem Szenario wären spannend zum Vergleich ??!!
Mal abgesehen von der Tatsache das man damit den Switch sofort als bösen Buhmann entlarven könnte oder nicht !
Das du beide Rechner mit den Treibern von der Chipsatz herstellerseite auf den allerneusesten Stand gebracht haben solltest setzen wir hier mal voraus !
Bitte warten ..
Mitglied: fump2000
21.01.2011 um 12:24 Uhr
Hallo,

habe gestern das bestellte Crossover Kabel erhalten und werde deinem Wunsch nachkommen. Werde auch mal mit Linux testen.

Hoffe wir kommen dem Fehler auf die Schliche.

MfG
fump
Bitte warten ..
Mitglied: fump2000
23.01.2011 um 02:58 Uhr
Hallo erneut,

habe ein zweites Windows installiert und erneut getestet.

Hier das Ergebnis:

TCP connection established.
Packet size 1k bytes: 12.53 MByte/s Tx, 22.87 MByte/s Rx.
Packet size 2k bytes: 13.88 MByte/s Tx, 21.39 MByte/s Rx.
Packet size 4k bytes: 18.84 MByte/s Tx, 35.98 MByte/s Rx.
Packet size 8k bytes: 19.66 MByte/s Tx, 31.89 MByte/s Rx.
Packet size 16k bytes: 20.68 MByte/s Tx, 31.27 MByte/s Rx.
Packet size 32k bytes: 20.71 MByte/s Tx, 31.99 MByte/s Rx.
Done.

Wie man sieht, keine Änderung...

Boote ich ein Knoppix und teste komme ich auf 40-55 MB Rx.

Den Test via Crossover mache ich noch.

Wollte nur mal den Stand der dinge bekannt geben

MfG
fump
Bitte warten ..
Mitglied: aqui
25.01.2011 um 18:16 Uhr
Riecht dann verdächtig nach dem Winblows Treiber. Falls du ein XP nutzt hast du das hier:
http://www.psc.edu/networking/projects/tcptune/
und das
http://www.heise.de/netze/TCP-IP-Tuning--/artikel/97619
gelesen ??
Ohne das du die Windowsize anpasst wird das dann nix. Bei Vista oder 7 entfällt das.

Wichtig ist aber in jedem Falle der Crossover Test um den Switch ausschliessen zu können (...oder nicht ausschliessen zu können !!)
Bitte warten ..
Mitglied: brammer
25.01.2011 um 22:21 Uhr
Hallo,

neben dem Verdacht von aqui das wieder mal der Windows Treiber hier rumzickt, könntest du mal die Switch konfig und deine Netzwerkeinstellungen posten
damit wir ausschliessen können das du dir da drin nicht noch irgendwo ein Ei gelegt hast.

brammer
Bitte warten ..
Mitglied: fump2000
28.02.2011 um 00:30 Uhr
Hallo!

Bitte entschuldigt die lange abwesenheit.

Ich kann nur sagen das meine Schwierigkeiten nun behoben sind. Ich habe den Server komplett neu instaliert. Frische aktuelle Treiber installiert und siehe da der Durchsatz ist gestiegen auf satte 65 MB.

Ist nicht die volle Gigabit Leistung aber mehr als ich erwartet habe

Ich danke euch sehr für die Hilfen!

MfG
Fump
Bitte warten ..
Mitglied: aqui
28.02.2011 um 11:41 Uhr
Bitte dann auch
http://www.administrator.de/index.php?faq=32
nicht vergessen !!
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
10 GBbits Switch mit echten 10 Gbits Durchsatz
Frage von dgrebnerLAN, WAN, Wireless17 Kommentare

Guten Tag, ich suche nach einem Switch für KMU, der nicht nur 10 GBit/s Interfaces hat sondern auch in ...

LAN, WAN, Wireless
Durchsatz bei Accesspoint durch zwei LAN-Kabel
gelöst Frage von tweety3LAN, WAN, Wireless17 Kommentare

Hallo, eine wohl dumme Frage, aber kann man den Datendurchsatz bei einem Accesspoint durch Anschluß eines weiteren LAN-Kabels erhöhen? ...

Windows Server
Schlechte Netzwerkverbindungen zu VM
Frage von heineaWindows Server3 Kommentare

Ich habe einen Server mit MS Server 2012R2 HyperV. Auf diesem laufen verschiedene Windows Server als VM. Leider ist ...

LAN, WAN, Wireless
Alternativen für VPN bei schlechter Internetverbindung
Frage von HamsertLAN, WAN, Wireless9 Kommentare

Hallo liebe Kollegen, folgendes Problem: Unsere Mitarbeiter greifen mit ihren Firmennotebooks von zu Hause auf das Firmennetzwerk (bzw. eigentlich ...

Neue Wissensbeiträge
Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 2 StundenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 3 StundenSicherheit5 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 4 StundenSicherheit4 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Sicherheit

Meltdown und Spectre: Die machen uns alle was vor

Information von Frank vor 4 StundenSicherheit12 Kommentare

Aktuell sieht es in den Medien so aus, als hätten die Hersteller wie Intel, Microsoft und Co den aktuellen ...

Heiß diskutierte Inhalte
Windows 10
Netbook erkennt Soundkarte nicht - keinerlei Info zum Hersteller und Modell vom Netbook und Hardware bekannt
Frage von 92943Windows 1031 Kommentare

Guten Tag, meine Schwester reist in einigen Wochen für ein paar Monate ins Ausland und hat sich dafür ein ...

Batch & Shell
Anmeldevorgang für Informatikraum (Schule) unter Windows
gelöst Frage von IngenieursBatch & Shell29 Kommentare

Hey zusammen, ich werde in naher Zukunft den Informatik Raum meiner jetzigen Schule von dem aktuellen Betreiber übernehmen (Vertrag ...

Netzwerkgrundlagen
Welches Modem für VDSL 50000 der T-Com
Frage von Windows10GegnerNetzwerkgrundlagen19 Kommentare

Hallo, ein Kollege von mir will sich VDSL50000 von der T-Com holen, um daran einen Server zu betreiben. Ich ...

Batch & Shell
AD-Abfrage in Batchdatei und Ergebnis als Variable verarbeiten
gelöst Frage von Winfried-HHBatch & Shell19 Kommentare

Hallo in die Runde! Ich habe eine Ergänzungsfrage zu einem alten Thread von mir. Ausgangslage ist die Batchdatei, die ...