Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Dynamisches Traffic Shaping bzw. QoS - lastabhängige Aufteilung (z.B. mit RouterOS)

Frage Netzwerke Netzwerkmanagement

Mitglied: garlic

garlic (Level 1) - Jetzt verbinden

19.10.2014 um 20:02 Uhr, 1944 Aufrufe, 4 Kommentare

Zwei Parteien teilen sich einen Internetzugang, sagen wir 100Mbit/s. Da die Gesamtauslastung eher gering ist, wäre es Unsinn direkt jeden auf 50MBit/s zu begrenzen - außerdem ist so, dass nicht immer die 100MBit/s von dem Provider bereitgestellt werden. Manchmal sind es nur 60...

Mit Traffic Shaping bestimmte Pakete zu markieren (Mangle) und zu priorisieren ist eine Möglichkeit, kann aber auch dazu führen, dass ein Großteil der Bandbreite bei einem Client landet, je nachdem wer welche Applikationen betreibt.

Ich suche daher eine dynamische Bandbreitenbegrenzung. Sprich: Client 1 ist nicht aktiv, dann darf Client 2 ruhig die volle Bandbreite nutzen. Client 1 geht nun plötzlich online, dann sollte er Bandbreite "abbekommen" und zwar 50%, wenn er diese zumindest "möchte".
Darüber könnte man dann noch die einzelnen Pakete ja nach Protokoll priorisieren, aber quasi als Schritt 2.

Leider finde ich dazu in RoterOS bisher keine Möglichkeit. Geht das irgendwie?

Danke!
Mitglied: garlic
20.10.2014 um 20:49 Uhr
Danke - ich habe mir das angeguckt und wie folgt umgesetzt:

/queue type add name="PCQ_download" kind=pcq pcq-rate=100M pcq-classifier=dst-address
/queue type add name="PCQ_upload" kind=pcq pcq-rate=100M pcq-classifier=src-address

/queue simple add name=test queue=PCQ_upload/PCQ_download target=192.168.0.0/24,192.168.178.0/24

Nun habe ich aber noch 3 Fragen dazu:

1) Ich habe zwei verschiedene Subnets. Null und 178. Ich habe beide spezifiziert, wird nun für jedes Subnet die Aufteilung separat erfolgen, denkt er also jedes Subnet bekommt 100M oder kann er das insgesamt managen?
2) Woran erkennt er, dass ein zweiter Client online ist? Bekommt dieser sofort die Bandbreite reserviert, sprich: Verliert Client 1 direkt seine 100MBit und sinkt auf 50Mbit obwohl Client 2 vielleicht nur viel weniger Bandbreite nutzt? Oder nur eine kleine Abfrage gesendet hat - und wie lange ist die Bandbreite reserviert?
3) Nice to have: Man hat ja leider nicht immer voller Bandbreite. Er teilt jetzt die 100Mbit auf - was aber, wenn gerade nur 60MBit zur Verfügung stehen? Was bewirkt dann die 50-50 Teilung respektive 25-25-25-25 usw.

Danke und VG, Garlic
Bitte warten ..
Mitglied: 114757
21.10.2014, aktualisiert um 14:12 Uhr
Zitat von garlic:
1) Ich habe zwei verschiedene Subnets. Null und 178. Ich habe beide spezifiziert, wird nun für jedes Subnet die Aufteilung separat erfolgen, denkt er also jedes Subnet bekommt 100M oder kann er das insgesamt managen?
Es ist in diesem Fall nur ein Queue den sich beide Subnets teilen
2) Woran erkennt er, dass ein zweiter Client online ist? Bekommt dieser sofort die Bandbreite reserviert, sprich: Verliert Client 1 direkt seine 100MBit und sinkt auf 50Mbit obwohl Client 2 vielleicht nur viel weniger Bandbreite nutzt? Oder nur eine kleine Abfrage gesendet hat - und wie lange ist die Bandbreite reserviert?
Der erste User sinkt um den Anteil den der andere benötigt wenn dieser kleiner als die Hälfte ist, benötigt der andere User mehr als die Hälfte des Traffics bekommen beide 50%, usw.
3) Nice to have: Man hat ja leider nicht immer voller Bandbreite. Er teilt jetzt die 100Mbit auf - was aber, wenn gerade nur
60MBit zur Verfügung stehen? Was bewirkt dann die 50-50 Teilung respektive 25-25-25-25 usw.
Setze pcq-rate auf 0 dann wird immer die verfügbare Bandbreite aufgeteilt.
http://wiki.mikrotik.com/wiki/Manual:Queues_-_PCQ

Gruß jodel32
Bitte warten ..
Mitglied: garlic
21.10.2014 um 20:06 Uhr
Danke dir!

Ich habe die pcq-rate auf 0 gesetzt, dafür aber das Max-Limit auf 100M, da bei dem Wiki-Link stand, eins von beiden sollte man setzen. Das lief aber gar nicht gut, da habe ich dann bei allen Clients eine seltsame Aufteilung bekommen.

Soll ich beide auf 0 bzw. unlimited setzen?
Bitte warten ..
Ähnliche Inhalte
Switche und Hubs
HP Procurve 1910-24G - Konfiguration von QoS und Traffic Shaping sowie STP
gelöst Frage von dermeikSwitche und Hubs4 Kommentare

Moin Moin, ich möchte mich kurz fassen. Wir haben bei uns im Unternehmen die o.g. Switche zugelegt. Meine Aufgabe ...

DSL, VDSL
Vodafone: Traffic Shaping und Drossel oder Netz mies?
Frage von DDoS85DSL, VDSL7 Kommentare

Hallo Leute, nach dem ich nun eine Woche bei meinem neuen Arbeitgeber die Legacy von einem nicht ITler übernommen ...

LAN, WAN, Wireless
Aufteilung der Netzwerkanschlüsse
Frage von petereLAN, WAN, Wireless3 Kommentare

Hallo, ich befinde mich als Gast in einem Netzwerk, welches mir wenig bis gar keine Rechte gewährt. Die lokalen ...

Peripheriegeräte
Aufteilung von Hardware
gelöst Frage von eisbeinPeripheriegeräte25 Kommentare

Werte Kollegen! Ich beschreibe mein Freitagsproblem wie folgt: Unsere Geschäftsleitung schenkt der IT-Abteilung 17 Stk. Server und diese sollen ...

Neue Wissensbeiträge
Microsoft Office

Office 2010 Starter erneut auf einer frischen Windows-Version installieren

Tipp von Lochkartenstanzer vor 20 StundenMicrosoft Office8 Kommentare

Moin, vor ein paar Tagen schlug bei mir ein Kunde auf, der sein Widnows 7 geschrottet und es inklusive ...

Datenbanken

Upgrade MongoDB 3.4 auf 3.6

Erfahrungsbericht von Frank vor 22 StundenDatenbanken

Seit kurzem gibt es das 3.6 Update für die MongoDB: Sicherheit, das Sortieren, Aggregation und auch die Performance wurde ...

SAN, NAS, DAS

Backdoor Zugang und Upload-Bug in vielen Western Digital MyCloud Geräten

Information von Frank vor 23 StundenSAN, NAS, DAS2 Kommentare

James Bercegay von der Firma Gulftech hat die Fehler an Western Digital gemeldet und das Unternehmen stellt bereits ein ...

Microsoft Office

Outlook 2016 - Beim Weiterleiten keine PDF Anhänge mehr - KB4011626 entfernen

Erfahrungsbericht von Deepsys vor 1 TagMicrosoft Office3 Kommentare

Wenn ihr feststellt das ihr beim Weiterleiten von E-Mails keine PDF Anhänge mehr versendent, dann dankt Microsoft. Diese tolle ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke23 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

iOS
Einladung vom iphone kalender
Frage von jensgebkeniOS15 Kommentare

Hallo Gemeinschaft, folgendes Problem - immer wenn ich von meinem Iphone einen Termin einztrage und diesem Termin Teilnehmer zuweise, ...

Windows Netzwerk
Drucker isolieren in Windows Domäne
gelöst Frage von lcer00Windows Netzwerk14 Kommentare

Hallo zusammen, habe eine Windows-AD (2012R2) in der es einen Druckerserver gibt. Mittlerweile verliere ich das Vertrauen in die ...

Drucker und Scanner
Gesucht DIN A3 Drucker
Frage von NebellichtDrucker und Scanner13 Kommentare

Hallo, ich möchte einen neuen DIN A3 Drucker kaufen. Um ab und zu, ca. 1 mal die Woche Farbausdrucke ...