Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

e-Mail-Versand - Verflixt und zugenäht

Frage Microsoft Exchange Server

Mitglied: MJSmith

MJSmith (Level 1) - Jetzt verbinden

17.12.2004, aktualisiert 30.12.2004, 8959 Aufrufe, 30 Kommentare

SBS2003 und Exchange 2003 - Newbie am Verzweifeln

Hallo Zusammen,

habe ordnungsgemäß SBS2003 installiert, alle Assistenten ausgeführt, etc.

eMails kann ich von außen empfangen, nach innen versenden, an externe leider nicht.

Nach geraumer Zeit kommt Verzögerungsmeldung und Zustellungsfehler. Hänge an Standleitung und möchte über Server direkt Mails versenden, Ports alle freigeschalten.

Wo könnte hier mein Fehler liegen? Erbitte eure Hilfe, in der Recherche komme ich nicht richtig weiter...
30 Antworten
Mitglied: linkit
17.12.2004 um 12:18 Uhr
Hallo MJSmith....


verflixt und zugenäht... grins... interessante Formulierung für einen Hilferuf... aber ich kann das schon verstehen.... mit Exchange kann man die Haare verlieren... vorallem wenn mal alles futsch ist....

Kannst du ein bißchen mehr über den Server erzählen.... wie ist die Anbindung ans Internet ? Zweite Netzwerkkarte ? Router ? ISA-Server ?

Falls ISA ? Hsat du den Mailserver veröffentlicht ?

Verschick doch mal eine Mail nach draußen über eine IP-Adresse... löse den Namen zuerst auf udn schick dann die Maill..... beispielsweise max.mustermann@123.456.789.012, vielleicht klappt die Auflösung bei dir nicht richtig.

Verwaltest du deine Internetdomain und E-Mails selber oder ist ein Provider dazwischengeschaltet ? Setzt du Techniken ein wie hiddenprimaryDNS etc. ? DMZ oder ähnliches ?

Hast du einträge im Ereignisprotokoll ?
Bitte warten ..
Mitglied: MJSmith
17.12.2004 um 12:55 Uhr
Hallo Christian,

vielen Dank für Deine Antwort. Also, ich versuche jetzt mal alles zu beantworten, wozu ich in der Lage bin.

Aktiv ist am Server eine Netzwerkkarte, eine zweite deaktiviert mit automatischer IP Zuweisung, der Server selbst, in keiner DMZ hat die interne IP 192.168.x.xx, externe IP ist 212.60.252.124.

Das Ganze Konstrukt befindet sich vor einem Router, Zugang erfolgt über eine Standleitung mit der Telekom als Provider.

Die Domain siamoa.net ist bei schlundtec gehostet, A-Record und MX-Record habe ich auf o.g. IP umgeleitet. Im DNS-Management habe ich die Domain mit Host(A) www und mail sowie mit einem Mail-Exchanger (MX) eingetragen. D.h. ich verwalte meine Domain und eMails selbst, oder? Ebenso brauche ich keinen Smarthost, wenn ich das bis jetzt richtig umrissen habe.

ISA ist nicht vorhanden, der Versuch, eine Mail an eine eMail-Adresse in Form von name@ip zu senden, schlug auch fehl...

Welches Ereignisprotokoll meinst Du bzw. wo finde ich es...?

Was mir auffällt ist, dass unter Überwachung und Status im Bereich Status die Eigenschaften des Servers aussagen, dass die Microsoft Exchange Standarddienste mit kritischem Zustand beendet wurden. Klicke ich die Meldung aber an, sehe ich, dass die einzelnen Dienste, MTA-Stacks bis SMTP und WWW-Publishingdienst ausgeführt werden.

Meldung verwirrt etwas...
Bitte warten ..
Mitglied: 7217
17.12.2004 um 14:27 Uhr
Mit Ereignisprotokoll meint er das Ereignisprotokoll von Windows, in der Verwaltung zu finden.

Wäre es zuviel verlangt, wenn du mal eine solche Fehlermail hier posten würdest? Dann könnte man anhand der Fehlermeldungen mal orakeln, was bei dir nicht richtig läuft.

Gruß, Mupfel
Bitte warten ..
Mitglied: MJSmith
17.12.2004 um 14:39 Uhr
Hallo Mupfel,

vielen Dank. Welche Anzeige soll ich nehmen? Anwendung, Sicherheit, System, Verzeichnisdienst, DNS-Server, Dateireplikationsdienst...
Bitte warten ..
Mitglied: MJSmith
17.12.2004 um 14:42 Uhr
Hier eine Fehlermeldung aus dem DNS-Server-Log...

Vielleicht hat das ja damit zu tun?

DNS-Server hat die eigenen Host-Einträge (A) aktualisiert. Um sicherzustellen, dass die verzeichnisdienstintegrierten Peer-DNS-Server mit diesem Server replizieren können, wurde versucht, diese mit dem neuen Eintrag mittels dynamischer Aktualisierung zu aktualisieren. Dabei ist ein Fehler aufgetreten. Die Daten enthalten den Fehlercode.

Wenn dieser DNS-Server keine verzeichnisdienstintegrierten Peers
besitzt, sollte dieser Fehler ignoriert werden.

Wenn die Replikationspartner des Active Directorys für diesen DNS-Server nicht die richtige IP-Adresse(n) für diesen Server haben, können sie nicht mit ihm replizieren.

Führen Sie folgende Schritte aus, um sicherzustellen, dass die Replikation ordnungsgemäß durchgeführt wird:
1) Suchen Sie die Replikationspartner des Active Directory für diesen Server, die den DNS-Server ausführen.
2) Öffnen Sie den DNS-Manager und verbinden Sie sich der Reihe nach mit jedem der Replikationspartner.
3) Überprüfen Sie auf jedem der Server die Hostregistrierung (A-Eintrag) für DIESEN Server.
4) Löschen Sie alle A-Einträge, die NICHT IP-Adressen für diesen Server entsprechen.
5) Falls keine A-Einträge für diesen Server vorhanden sind, müssen Sie mindestens einen A-Eintrag entsprechend einer Adresse auf diesem Server hinzufügen, die der Replikationspartner ansprechen kann. (Mit anderen Worten: Falls es mehrere IP-Adressen für diesen Server gibt, müssen Sie mindestens eine hinzufügen, die sich im selben Netzwerk wie der DNS-Server des Active Directory befindet, den Sie aktualisieren möchten.)
6) Es ist nicht notwendig, ALLE Replikationspartner zu aktualisieren. Es ist lediglich erforderlich, dass alle Einträge mit genügend Replikationspartnern verbunden sind, so dass jeder Server, der mit diesem Server repliziert, die neuen Daten (mittels Replikation) erhält.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.


Und hier eine Warnmeldung:

Der DNS-Server hat ein an ihn selbst adressiertes Paket auf IP-Adresse 192.168.1.70 ermittelt. Das Paket ist für den DNS-Namen "_ldap._tcp.pdc._msdcs.SIAMOA.local.". Das Paket wird verworfen. Diese Situation weist in der Regel auf einen Konfigurationsfehler hin.

Überprüfen Sie folgende Bereiche auf Konfigurationsfehler, die die Selbstadressierung erklären:
1) Weiterleitungsliste. (DNS-Server dürfen an sich selbst keine Weiterleitung richten.)
2) Masterliste sekundärer Zonen.
3) Benachrichtigungslisten primärer Zonen.
4) Delegierungen von Teilzonen. Dürfen keinen NS-Eintrag für diesen DNS-Server enthalten, es sei denn, die Teilzone befindet sich ebenfalls auf diesem Server
5) Stammhinweise.

Beispiel für Selbstdelegierung:
-> Der DNS-Server "dns1.beispiel.microsoft.com" ist der primäre für die Zone "beispiel.microsoft.com".
-> Die Zone "beispiel.microsoft.com" enthält eine Delegierung von "bar.beispiel.microsoft.com" zu "dns1.beispiel.microsoft.com"
(bar.beispiel.microsoft.com NS dns1.beispiel.microsoft.com),
-> ABER die Zone "bar.beispiel.microsoft.com" befindet sich NICHT auf diesem Server.

Beachten Sie, dass diese Delegierungsüberprüfung (mit "nslookup" oder mit dem DNS-Manager) auf diesem DNS-Server und auf den Servern, auf die die Teilzone delegiert wurde, ausgeführt werden sollte. Es ist möglich, dass die Delegierung korrekt ausgeführt wurde, aber die primäre DNS der Teilzone einen ungültigen NS-Eintrag besitzt, der auf den Server zurückverweist. Sollte dieser ungültige NS-Eintrag auf diesem Server zwischengespeichert werden, dann werden Pakete durch den Server an sich selbst gesendet. In diesem Fall sollte der DNS-Serveradministrator für diese Teilzone den fehlerhaften NS-Eintrag entfernen.

Sie können das Debug-Protokollierungsprogramm des DNS-Servers dazu verwenden, die Ursache dieses Problems ausfindig zu machen.

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.
Bitte warten ..
Mitglied: linkit
17.12.2004 um 14:44 Uhr
MJSmith:


Für den Anfang Anwendung, System und Verzeichnisdienst, DNS-Server und dort die Fehler.

Wenn das alles zuviel ist, dann kannst du ja alle Ereignisprotokolle löschen und dann mal einen Tag laufen lassen oder, falls du einen Webserver oder Webspace hast, Ereignisprotokolle exportieren, als ZIP packen und bereitstellen. Adresse hier posten.....


Dann schau mal im Exchangeverzeichnis bzw. darunterliegend, dort gibt es ein Verzeichnis Badmail.... schau mal was dort zu finden ist.
Bitte warten ..
Mitglied: MJSmith
17.12.2004 um 14:52 Uhr
Hallo Christian,

die Logs sind unter http://www.siamoa.net/anwendung.zip zu finden...
Bitte warten ..
Mitglied: MJSmith
17.12.2004 um 14:59 Uhr
Dort finde ich einen ganzen Haufen Dateien mit Endung *.bad, *.bdp, *.bdr

MJSmith:



Dann schau mal im Exchangeverzeichnis bzw.
darunterliegend, dort gibt es ein
Verzeichnis Badmail.... schau mal was dort
zu finden ist.

Bitte warten ..
Mitglied: linkit
17.12.2004 um 16:11 Uhr
Dann schau dir einfach mal mit dem Editor deren Inhalt an.....oft stehen dort sehr hilfreiche Informationen.....
Bitte warten ..
Mitglied: MJSmith
17.12.2004 um 16:19 Uhr
Guter Tipp, folgendes ist zu lesen...

Reporting-MTA: dns;siamoa.net

Final-Recipient: rfc822;andreas@rusnjak.com
Action: failed
Status: 5.5.0
Diagnostic-Code: smtp;530 Authentication required
X-Display-Name: andreas@rusnjak.com

---

Reporting-MTA: dns;siamoa.net

Final-Recipient: rfc822;andreas@rusnjak.com
Action: failed
Status: 5.5.0
Diagnostic-Code: smtp;530 Authentication required
X-Display-Name: andreas@rusnjak.com

---

bdp- und bdr-Dateien kann ich nicht öffnen. Hat aber den Anschein, dass alles mit einem Fehlercode 530 und Authentification zu tun hat...! Aber warum soll ich mich authentifizieren, wenn ich mit meinem eigenen Server Mails verteile und keinen Smarthost benutze...
Bitte warten ..
Mitglied: Samtpfote
18.12.2004 um 00:11 Uhr
Hallo Andreas!
Ich würde sagen, Dein DNS löst nicht richtig auf. (Die Fehlermeldungen würden auch darauf hindeuten) Bist Du Dir sicher, daß er mit Roothints konfiguriert wurde oder einen Forwarder eingetragen hat? (Vielleicht hast Du den Forwarder auf sich selbst konfiguriert?)
Check mal folgendes:
1. Läuft auf Deinem Server mit Exchange auch ein DNS?
2. Ist dieser DNS in der TCP/IP Konfiguration als DNS eingetragen? (---> überprüfen mit ipconfig /all in der Commandshell)
3. Hat der DNS Roothints oder einen Forwarder? (--> überprüfen in Verwaltung-DNS Rechte Maus auf den DNS und Eigenschaften ---> Stammhinweise (grusl... es lebe die Fehlübersetzung!) und Weiterleitungen Was steht da?
4. Teste mal in der Command-shell (Start-Ausführen-CMD) eine Auflösung, zB tracert www.focus.de ---> kann er www.focus.de richtig auflösen oder bekommst Du eine Fehlermeldung?

wird schon klappen, check das mal
A.
Bitte warten ..
Mitglied: MJSmith
18.12.2004 um 00:23 Uhr
Hallo Samtpfote,

also, tracert auf www.focus.de bringt Zeitüberschreitung, mit ipconfig /all bekomme ich als DNS den Server 192.168.x.11, in der Lan-Verbindung ist unter TCP/IP Eigenschaften als DNS aber 192.168.x.70, d.h. dieser Server eingetragen...

Der Server ist ein Small Business Server, d.h. der DNS läuft hier auch mit drauf...

Was kann ich hier tun?

Danke für Deine nächtliche Info...

Andreas
Bitte warten ..
Mitglied: MJSmith
18.12.2004 um 00:29 Uhr
Hi Samtpfote, noch mal ich...,

sorry, die Angabe mit der DNS stimmte nicht so ganz. Eine Netzwerkkarte ist aktiv, die andere nicht. Die DNS mit der Endung 8 war die der inaktiven Karte. Die aktive benutzt die IP des Servers.

Ich habe es mittlerweile mit dem Smarthost smtp.1und1.com versucht, dort ein Postfach angelegt und die Authentifizierungsdaten angegeben. Der Remote-SMTP-Dienst hat die Authentifizierung aber leider zurückgewiesen...

Das Mistding bringt mich echt noch ins Grab...
Bitte warten ..
Mitglied: Samtpfote
18.12.2004 um 00:34 Uhr
na wer sagts denn.... Dein Problem ist nicht der Exchange sondern der DNS.
So... dann wollen wir mal richtig auflösen:

1. Stell sicher, daß der DNS läuft. (Start-Programme-Verwaltung-DNS)
sieht das irgendwie so aus, als ob er nicht laufen würde?

2. Wenn er läuft ---> bitte sicherstellen, daß unter Weiterleitung nichts drinsteht
3. Wenn er läuft ---> bitte sicherstellen, daß unter Stammhinweise eine Liste eingetragen ist

---> wenn nicht---> bitte schreien.

lass das mit smarthost bleiben. DNS ist das Rückgrat der ganzen Kommunikation; wenn er nicht auflösen kann, ist er gelähmt. Also helfen wir ihm zunächst mal wieder auf bevor er laufen lernt...
Bitte warten ..
Mitglied: MJSmith
18.12.2004 um 00:41 Uhr
OK, alle Weiterleitungen wurden entfernt und die Stammhinweise enthalten eine ellenlange Liste, nach dem Muster m.root-servers.net, l.root-servers.net, etc....

Mails verlassen den Server aber immer noch nicht...
Bitte warten ..
Mitglied: Samtpfote
18.12.2004 um 00:43 Uhr
Wenn Du IPconfig /all eingibst, was kommt da?
IP 192.168.1.70 ?
Mask 255.255.255.0 ?
Gateway?
DNS 192.168.1.70

Wie ist Deine Internetanbindung? Router? Anwahl? DSL-Modem? Kommst Du von diesem Computer aus überhaupt ins Internet?
Bitte warten ..
Mitglied: MJSmith
18.12.2004 um 00:48 Uhr
IP Adresse: 192.168.1.70
Mask: 255.255.255.0
Standardgateway: 192.168.1.8
DNS-Server: 192.168.1.70 und 4.2.2.1

Internetanbindung ist eine Standleitung, dazwischen hängt ein Router, der permanent dranhängt. Ich kann vom Computer aus sowohl die Seiten im WAN öffnen, als auch die Domains, die auf dem DNS liegen, z.B. eine Homepage...
Bitte warten ..
Mitglied: MJSmith
18.12.2004 um 00:51 Uhr
Mir hängt das Thema echt schon zum Hals raus...! Falls Du Lust hast, kann ich Dir auch Remote-Zugriff anbieten. Muss dann halt nur mal schnell einen Benutzer im AD anlegen, der Admin und Remote-Rechte hat bzw. muss ich mal schauen, wie ich einem User Remote-Rechte einräumen kann...!
Bitte warten ..
Mitglied: Samtpfote
18.12.2004 um 00:51 Uhr
kannst Du jetzt ein tracert zu www.focus.de machen? (Es ist nämlich so: solange Deine Namensauflösung nicht richtig funktioniert, kann der Mailversand nicht funktionieren; in Deinem Logfile steht nämlich daß er über DNS auflöst und versendet)
Bitte warten ..
Mitglied: Samtpfote
18.12.2004 um 00:53 Uhr
wow... ich würde keinem unter seniler Bettflucht leidendem online-freak so vertrauen...
mache ich gern, schick die Daten als Privatmessage
Bitte warten ..
Mitglied: MJSmith
18.12.2004 um 00:54 Uhr
Merkwürdig, immer noch Zeitüberschreitung...

Ich finde es höchst merkwürdig, dass Microsoft es nicht schafft, so was durch einen Assistenten zu regeln bzw. das Teil idiotensicher zu machen, wobei ein Exchange auch nicht für Idioten gemacht ist..., das gebe ich schon zu
Bitte warten ..
Mitglied: MJSmith
18.12.2004 um 00:57 Uhr
Ich war etwas voreilig, der zehnte Eintrag von tracert ergab folgendes:

26ms 26ms 26ms focus.msn.de [193.01.12.55]
Bitte warten ..
Mitglied: Samtpfote
18.12.2004 um 00:59 Uhr
Fein!
Dann tu jetzt den Smarthost raus und versuch ein Mail zu schicken.
Wenn es nicht klappt ---> schick mir per PM die Zugriffsdaten und ich überrede Deinen Exchange von Frau zu Frau daß er nicht so rumzickt.
Bitte warten ..
Mitglied: Samtpfote
18.12.2004 um 01:00 Uhr
und mach bitte vorher ein ipconfig /flushdns
Bitte warten ..
Mitglied: MJSmith
18.12.2004 um 01:11 Uhr
Klappt leider nicht..., hoffe, dass eben meine PM durchging...

Andreas
Bitte warten ..
Mitglied: Samtpfote
18.12.2004 um 01:14 Uhr
nope.
Bitte warten ..
Mitglied: MJSmith
18.12.2004 um 01:16 Uhr
Jetzt abba...
Bitte warten ..
Mitglied: MJSmith
19.12.2004 um 20:18 Uhr
Problem dank Samtpfote gelöst.

Vielen Dank noch einmal...
Bitte warten ..
Mitglied: Annacopy
30.12.2004 um 00:17 Uhr
Ich habe das gleiche Problem, könntet Ihr mir bitte die Lösungweg nennen.
Bitte warten ..
Mitglied: Samtpfote
30.12.2004 um 00:23 Uhr
Hallo Annacopy!
Sein Problem hatte multiple Ursachen; der Hauptgrund war die falsche Konfiguration des DNS und ein paar Kleinigkeiten im Feintuning des Exchange Servers.
Möchtest Du Dein Problem nochmal genau schildern? (Vielleicht in einem neuen Thread, der hier ist etwas unübersichtlich geworden)
A.
Bitte warten ..
Neuester Wissensbeitrag
Batch & Shell

Batch Script Editor - Programmvorstellung des Entwicklers

(11)

Tipp von wowItsDoge zum Thema Batch & Shell ...

Ähnliche Inhalte
Exchange Server
Mail Versand zu T-Online nicht möglich (13)

Frage von HeinrichM zum Thema Exchange Server ...

Exchange Server
gelöst E-Mail Versand an Gmail Adressen nicht mehr möglich (13)

Frage von Zippo97 zum Thema Exchange Server ...

Exchange Server
E-Mail Versand über Strato via Smarthost bzw. MX Record (3)

Frage von Bibster90 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Server
Anmeldung an neuen Windows Domäne Client nicht möglich (15)

Frage von FlorianN zum Thema Windows Server ...

Speicherkarten
gelöst Verschlüsselte USB-Sticks (14)

Frage von rudeboy zum Thema Speicherkarten ...

Windows Server
SBS2008 AD funktioniert nur im LAN mit bestimmter IP. wie ändern? (12)

Frage von tomeknfr zum Thema Windows Server ...

Batch & Shell
gelöst PowerShell Transpose Objects und Memoryleak (11)

Frage von agowa338 zum Thema Batch & Shell ...