Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Echange 2013 und Outlook 2010 - Massive Probleme mit Cache Modus - Was tun

Frage Microsoft Exchange Server

Mitglied: PhobosX

PhobosX (Level 1) - Jetzt verbinden

16.04.2013 um 10:08 Uhr, 9524 Aufrufe, 15 Kommentare

Hallo zusammen.
Wir haben hier folgende Umgebung:

Server 2012 DC
Server 2012 Domainmitglied & Exchange 2013 (mit StartSSL Zertifikat für Outlook Anywhere)

Clients: Domainmitglied und Outlook 2010 und teilweise iPhone/Android Mail


Wenn man einen Client einrichtet, wird Outlook standardgemäß im Cache-Modus eingerichtet, was von MS aus ausdrücklich als empfohlende Variante gilt.

Nun gab es Klagen, dass Mails nie angekommen sind. Beim Prüfen waren die Mails im "Gesendete Objekte".

Nun habe ich bei den Clients den Cache-Modus rausgenommen und siehe da, die Mails tauchen auf einmal im Postausgang auf.

Man konnte sie auch nicht mehr versenden. Als Workaround habe ich dann die Mailadresse in ein txt-File kopiert, eine neue E-Mail erstellt und den Inhalt dort eingefügt und die Adressen dann wieder aus den txt-File kopiert und dann versendet. Sie gingen dann raus.


Wieso hängen Mails im Postausgang? Und warum sieht man das im Cached Modus nicht?

Die Mitarbeiter waren deswegen ziemlich verärgert.


Ich hoffe ihr könnt mir weiterhelfen, wie ich den Fehler finden und beseitigen kann.


Danke und Grüße
Mitglied: tonyscooby
16.04.2013 um 10:17 Uhr
Immer das gleiche Thema, das MS einfach nicht zur Zufriedenheit lösen kann.
Auch wenn 2013 nur noch RPC via HTTP unterstützt würde ich den Cache Mode via GPO deaktivieren.
Mit Terminaktualisierungen ist es genau so problematisch...

Läst das Sizing der MSX Struktur es zu dann schalte den Exchange Cache aus.

Gruss

tonyscooby
Bitte warten ..
Mitglied: PhobosX
16.04.2013 um 10:21 Uhr
Hmm...aber wieso funktioniert das denn nicht zuverlässig?

Was zudem extrem ärgerlich war: Ein User hat (noch im cached Modus) Kontakte eingepflegt.

Beim Umschalten in den non-cached/online-Modus waren allesamt weg. D.h. sie haben den Exchange nie erreicht, sondern sind lokal liegengeblieben und wurden dann natürlich durch das Umschalten und Löschen der OST-Datei entfernt.

Sehr ärgerlich einfach.

Also der Geschäftsführer hat ein 9GB Postfach. Da ist der Cached Mode wohl schon sinnvoller.
Bitte warten ..
Mitglied: tonyscooby
16.04.2013 um 10:24 Uhr
9GB ist harmlos ich habe hier 2 MB mit > 25Gb ohne Cached mode.
Die Grösse ist nicht so relevant eher die Anzahl der Objekte.

Cache aus ist keine Lösung, aber ein nötiger Workaround...
Bitte warten ..
Mitglied: tonyscooby
16.04.2013 um 10:28 Uhr
Wieviele Mailboxen sind bei den betreffenden Usern eingebunden?
Bitte warten ..
Mitglied: PhobosX
16.04.2013 um 10:35 Uhr
Nur das eigene (und bei zwei Usern noch ein zusätzliches Postfach).

Ich habe eben auch mails (intern) geschrieben...sie sind im "Gesendete Objekte", kommen aber nicht an.

Da ist irgendwo ein riesen Wurm drin ^^

Weißt du wie ich den Cached Mode per GP aus im Exchange 2013 ausschalten kann?



Grüße und danke.
Bitte warten ..
Mitglied: tonyscooby
16.04.2013 um 10:58 Uhr
User Configuration --> Policies --> Administrative Templates --> Microsoft Outlook 20xx --> Account Settings-->Exchange-->Cached Exchange Mode-->Disabled

Bitte warten ..
Mitglied: tonyscooby
16.04.2013, aktualisiert um 11:05 Uhr
Mal was ganz anderes:
Kannst Du bitte mal im Active Directory (auf einem DC) die Advanced Features unter view einschalten.
Dann bitte einen der betroffenen User öffnen und unter dem Reiter Attribut Editor schauen ob unter msExchDelegateListLink was drinne steht.
Wenn dem so ist einfach den Eintrag löschen.
Outlook neu starten mit CTRL rechtsclick auf Outlook beim Client Verbindungsstatus und reconnect.
Bitte warten ..
Mitglied: tonyscooby
16.04.2013 um 11:06 Uhr
Zitat von tonyscooby:
User Configuration --> Policies --> Administrative Templates --> Microsoft Outlook 20xx --> Account
Settings-->Exchange-->Cached Exchange Mode-->Disabled



Das ist eine Client Policy für Outlook nicht auf dem MSX
Bitte warten ..
Mitglied: PhobosX
16.04.2013, aktualisiert um 11:26 Uhr
3ca902648faa95d8d81fdfcbb2835a26 - Klicke auf das Bild, um es zu vergrößern


Ist nicht definiert. Für das ist der Eintrag genau zuständig?


Wo genau finde ich das?
User Configuration --> Policies --> Administrative Templates --> Microsoft Outlook 20xx --> Account
Settings-->Exchange-->Cached Exchange Mode-->Disabled

Du meinst eine Gruppenrichtlinie erstellen, oder? Ich finde den Eintrag nämlich grad nicht.

Grüße


EDIT:

Ich habe in der Warteschlange 2 Mails, die wieder nicht rausgehen. Wie kann ich das näher prüfen?

25091f020b0c650d67e9d129c442b504 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: tonyscooby
16.04.2013 um 11:26 Uhr
Der Eintrag DelegateListLink wurde als Bug ausgefüllt sobald man SendAs Rechte auf eine Mailbox vergibt.
Effekt dabei war das nur das Objekt unter DelegateListLink senden konnte auf dem Konto.
Bei allen anderen blieb die Mail in der Outbox stecken.

GPO editieren gpmc.msc

Bitte warten ..
Mitglied: PhobosX
16.04.2013 um 11:50 Uhr
Mit GPO kann ich den Eintrag "Microsoft Outlook" eben nicht finden (oder ich bin wahrscheinlich blind ^^).

04c9c467962eab009896cc31f9c41485 - Klicke auf das Bild, um es zu vergrößern


Weißt du zufällig wie man sich in Exchange 2013 Postfächer von anderen Usern einbinden kann? Im Exchange 2010 war das ja leicht über Vollzugriffsrechte einzubinden (und dann über Postfach hinzufügen in Outlook). Das geht im Exchange 2013 nicht mehr. Man kann irgendwie nur noch Freigabepostfächer erstellen und einbinden.
Bitte warten ..
Mitglied: tonyscooby
16.04.2013 um 12:13 Uhr
http://support.sherweb.com/Faqs/Show/how-to-add-another-persons-mailbox ...

zu GPO liegen dort die ADM / ADMX Vorlagen?

\\domäne\SYSVOL\domäne\Policies\PolicyDefinitions Wenn nicht besser runterladen und ablegen.


Du musst die gpmc.msc aus den RSAT Tools auf einem identischen Client PC als Domainadmin starten.

Auf einem Client sollten die Vorlagen da sein.
Bitte warten ..
Mitglied: PhobosX
16.04.2013, aktualisiert um 14:42 Uhr
Okay, das mit dem Postfachzugriff funktioniert nun. Hatte ich vorher auch schon so gemacht, nur "Senden als" nicht beachtet. Danke für den Link.

Die Vorlagen muss ich dann noch runterladen und ablegen.


Gibts denn irgend eine Möglichkeit zu sehen, ob im Cached-Modus eine Mail im Postausgang hängt? Das würde das Problem ja schon sehr eingrenzen.

Oder lässt sich irgendwie eine Synchronisierung zwischen OST-Datei und Exchange erzwingen? Das würde das Problem mit verloren gegangen Kontakten ebenfalls umgehen.


VG


EDIT: Es bleiben auch diverse Mails im Online-Modus "stecken".

Was kann ich tun?
Bitte warten ..
Mitglied: tonyscooby
16.04.2013 um 15:01 Uhr
Sorry das ist dann ein HUB / Transport Thema wo ich aus der Ferne nicht helfen kann.
Müsste man sehen.
Bitte warten ..
Mitglied: PhobosX
16.04.2013 um 15:26 Uhr
Also ich habe jetzt den Server neugestartet und bis jetzt tuts schnell und bisher zuverlässig.

Danke auf jeden Fall für die Hilfe.

Ich habe jetzt den Cache Modus bei den Clients händisch ausgeschaltet. Hoffe der schaltet sich nicht wieder "von selbst" ein.


Kann es auch ein DNS Problem (gewesen) sein? Ich habe intern den alten DNS Server abgelöst und die DNS Rolle auf dem neuen DC 2012 installiert.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...

Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...

Windows Server
Suche passender Treiber (12)

Frage von stolli zum Thema Windows Server ...