Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Eclipse-Problem beim Einbinden von Bildern beim Deploy von JAR-file

Frage Entwicklung Java

Mitglied: pi314

pi314 (Level 1) - Jetzt verbinden

17.09.2005 um 11:08 Uhr, 7619 Aufrufe

Hallo,

mein Eclipseproblem stellt sich folgendermaßen dar:

In einem Projekt sind Bilder integriert. Diese befinden sich im Pfad de. ... . gfx. In der Entwicklungsumgebung funktioniert auch alles einwandfrei, die Bilder werden ohne Probleme angezeigt.

Der Aufruf zum Laden der Bilder sieht so aus:
<font class="code">icon = new ImageIcon( myself.getClass( ).getResource( SessionManager.getConfigurationBean( ).getGfxPackagePath( ) + name ) );
Als Konstante für getGfxPackagePath ist "..\\gfx\\" hinterlegt.
</font>

Nun brauche ich aber ein jar-file. Hier sind alle Dateien auch im richtigen Pfad, aber er findet die Bilder nicht!!!
Ich habe bereits Pfad hardcoded hinterlegt, z.B. unter c:\gfx, das geht aber auch nicht!!

Ist das ein reines Eclipse-Problem oder habe ich einfach irgendetwas vergessen?
Welche Parameter verwendet Eclipse beim Deploy?
Beim J-Builder hat das nämlich auch mal ohne Probleme funktoniert.
Ähnliche Inhalte
Java
gelöst Netbeans - Wie kann externe Dateien in JAR File einbinden (4)

Frage von reissaus73 zum Thema Java ...

Windows Userverwaltung
Erfahrungen mit PDQ Deploy? (4)

Frage von WinLiCLI zum Thema Windows Userverwaltung ...

Windows Installation
gelöst Irfanview - silent deploy - Argumente für Syntax (3)

Frage von Graven zum Thema Windows Installation ...

Windows 10
Windows 10 deployen (2)

Frage von goerte zum Thema Windows 10 ...

Neue Wissensbeiträge
Windows Installation

Unorthodoxer Weg, um an einen Offline-Installer für Adobe Flash zu kommen

(8)

Tipp von beidermachtvongreyscull zum Thema Windows Installation ...

Datenschutz

Gefährdeter Datenschutz: Firefox löscht lokale Datenbanken nicht

Information von BassFishFox zum Thema Datenschutz ...

Firewall

PfSense OpenVPN beschleunigen

Tipp von Dobby zum Thema Firewall ...

Utilities

CCleaner 5.33 mit Malware infiziert

(27)

Information von SeaStorm zum Thema Utilities ...

Heiß diskutierte Inhalte
Utilities
CCleaner 5.33 mit Malware infiziert (27)

Information von SeaStorm zum Thema Utilities ...

Festplatten, SSD, Raid
gelöst Problem mit DELL 815R Server und Windows Bluescreen (24)

Frage von Leo-le zum Thema Festplatten, SSD, Raid ...

Windows Systemdateien
Windows bootet nicht mehr Fehlermeldung 0xc0000098 (19)

Frage von franzgoerlich zum Thema Windows Systemdateien ...

Windows Netzwerk
Dateien mit Intelligenz per GPO ins Programmverzeichnis (14)

Frage von erwin.t zum Thema Windows Netzwerk ...