Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

EDNS-Problem mit Ubuntu und Bind9

Frage Linux Ubuntu

Mitglied: miggel13

miggel13 (Level 1) - Jetzt verbinden

17.10.2010, aktualisiert 12:37 Uhr, 5187 Aufrufe, 5 Kommentare

(OS: Ubuntu 9.04, DNS: Bind9)

Hallo,
seit kurzem habe ich in meiner syslog sehr viele Einträge über einen EDNS-Fehler.
Bei mir werden normalerweise DNS-Anfragen an meinen Linux-Server gerichtet, der auch im LAN eine eigene Zone verwaltet. Kann der DNS-Server eine Anfrage nicht beantworten, so werden die Anfragen an meinen DSL-Router (fritzbox) weitergeleitet. Dies passierte bisher immer über eine WIRED-Verbindung (LAN-Kabel am DSL-Router). Nun habe ich den Server-Standort verändert und der Server ist mit WLAN verbunden. Seit dieser Änderrung habe ich nun in meiner syslog bei jeder DNS-Anfrage (die nicht meine Zone betrifft) folgende Einträge:


Oct 17 09:59:28 weiz named[2571]: too many timeouts resolving 'zb.akadns.org/A' (in 'akadns.org'?): disabling EDNS
Oct 17 09:59:28 weiz named[2571]: too many timeouts resolving 'zc.akadns.org/A' (in 'akadns.org'?): disabling EDNS
Oct 17 09:59:28 weiz named[2571]: too many timeouts resolving 'zd.akadns.org/A' (in 'akadns.org'?): disabling EDNS
Oct 17 09:59:28 weiz named[2571]: too many timeouts resolving 'za.akadns.org/A' (in 'akadns.org'?): disabling EDNS
Oct 17 09:59:28 weiz named[2571]: too many timeouts resolving 'zb.akadns.org/AAAA' (in 'akadns.org'?): disabling EDNS
Oct 17 09:59:28 weiz named[2571]: too many timeouts resolving 'za.akadns.org/AAAA' (in 'akadns.org'?): disabling EDNS
Oct 17 09:59:28 weiz named[2571]: too many timeouts resolving 'zd.akadns.org/AAAA' (in 'akadns.org'?): disabling EDNS
Oct 17 09:59:28 weiz named[2571]: too many timeouts resolving 'zc.akadns.org/AAAA' (in 'akadns.org'?): disabling EDNS
Oct 17 10:00:01 weiz /USR/SBIN/CRON[5432]: (root) CMD ([ -x /usr/sbin/update-motd ] && /usr/sbin/update-motd 2>/dev/null)
Oct 17 10:00:01 weiz /USR/SBIN/CRON[5434]: (root) CMD ([ -x /usr/sbin/update-motd ] && /usr/sbin/update-motd hourly 2>/dev/null)
Oct 17 10:00:12 weiz named[2571]: too many timeouts resolving 'www.freeware.de/A' (in 'freeware.de'?): disabling EDNS
Oct 17 10:00:13 weiz named[2571]: too many timeouts resolving 'ns1.hans.hosteurope.de/A' (in 'hosteurope.de'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:13 weiz named[2571]: too many timeouts resolving 'ns1.hans.hosteurope.de/AAAA' (in 'hosteurope.de'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:13 weiz named[2571]: too many timeouts resolving 'ns2.hans.hosteurope.de/A' (in 'hosteurope.de'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:13 weiz named[2571]: too many timeouts resolving 'ns2.hans.hosteurope.de/AAAA' (in 'hosteurope.de'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:47 weiz named[2571]: too many timeouts resolving 'www.google.com/A' (in 'google.com'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:55 weiz named[2571]: too many timeouts resolving 'www.linuxmint.com/A' (in 'linuxmint.com'?): disabling EDNS
Oct 17 10:00:57 weiz named[2571]: too many timeouts resolving 'ns1.servage.net/A' (in 'servage.net'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:57 weiz named[2571]: too many timeouts resolving 'ns1.servage.net/AAAA' (in 'servage.net'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:57 weiz named[2571]: too many timeouts resolving 'ns3.servage.net/A' (in 'servage.net'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:57 weiz named[2571]: too many timeouts resolving 'ns2.servage.net/A' (in 'servage.net'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:57 weiz named[2571]: too many timeouts resolving 'ns4.servage.net/A' (in 'servage.net'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:57 weiz named[2571]: too many timeouts resolving 'ns2.servage.net/AAAA' (in 'servage.net'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:57 weiz named[2571]: too many timeouts resolving 'ns3.servage.net/AAAA' (in 'servage.net'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:57 weiz named[2571]: too many timeouts resolving 'ns4.servage.net/AAAA' (in 'servage.net'?): reducing the advertised EDNS UDP packet size to 512 octets



Kann es sein das es über meinen WLAN-Adapter Probleme mit der Packet-Größe auftreten können? Ich habe nämlich bereits sämtliche Firewalls gecheckt und diese auch ausgeschaltet, jedoch ohne Erfolg.

Meine WLan-Information:


root@weiz:~# ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 00:09:5b:ec:ef:a0
inet addr:192.168.77.3 Bcast:192.168.77.255 Mask:255.255.255.0
inet6 addr: fe80::209:5bff:feec:efa0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2308 errors:0 dropped:0 overruns:0 frame:0
TX packets:2460 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2067899 (2.0 MB) TX bytes:516232 (516.2 KB)




root@weiz:~# iwconfig wlan0
wlan0 IEEE 802.11bg ESSID:"meine_ssid"
Mode:Managed Frequency:2.457 GHz Access Point: BC:05:43:16:54:88
Bit Rate=54 Mb/s Tx-Power=20 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:BCA[...]34AA [3] Security mode:open
Power Management:off
Link Quality=48/100 Signal level:-75 dBm Noise level=-106 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0



Eine Auswirkung dieses EDNS-Problems ist es, dass die Anfragen teilweise sehr lange dauern können. Deshalb habe ich die Clients aktuell auf den DNS-Server der fritzbox umgeschaltet. Würde aber gerne von den vorzügen meiner DNS-Zone wieder gebrauch machen.

Wär super toll wenn jemand vllt eine Idee hätte.



NACHTRAG: Ok mir ist nun folgendes aufgefallen. Ich habe bei der FritzBox ein Update gemacht (7270, Update: 74.04.86) und seit diesem Update treten die EDNS-Fehler andauernd auf.
Für weitere Tests habe ich nun mal den Google-DNS Server als forwarder eingetragen (8.8.8.8) und mit diesem funktionieren die DNS-Lookups ebenfalls perfekt.
Weiß jemand, was sich mit diesem Update an der fritzbox geändert hat?
Mitglied: Pago159
19.10.2010 um 20:01 Uhr
Kannst du nicht einfach die alte Firmware nochmal einspielen,
die solltest du doch bei AVM herunter zu laden bekommen.
Dann sollte doch erst einmal alles wieder laufen,
bis AVM nachgebessert hat.
Bitte warten ..
Mitglied: miggel13
19.10.2010 um 21:25 Uhr
Ja ich hab mir auch schon überlegt ob ich meinen Backup-Restorepunkt einspiele, jedoch hat sich an der Fritzbox sehr viel (komplett neues Menü, ...) geändert. Da bin ich nun eher skeptisch gegenüber einem Restore.
Aktuell benutze ich noch die DNS-Server von google wobei ich mich bei dieser Sache auch nicht ganz wohl fühle (bin wahrscheinlich der einzige, der die DNS-Server von google benutzt;)
Bitte warten ..
Mitglied: Pago159
19.10.2010 um 21:29 Uhr
Naja, die Frage ist natürlich,
brauchst du das neue Design und die Funktionen,
die hinzugekommen sind bei der FritzBox wirklich?
Manchmal muss man eben ein paar Kompromisse eingehen ;)
Du kannst es ja auch mal testweise machen,
dann weist du wenigstens sicher,
ob es an der FritzBox liegt oder doch eher an dem Server ;)
Bitte warten ..
Mitglied: miggel13
20.10.2010 um 08:50 Uhr
Nein, um das Design und die Funktion gehts mir überhaupt nicht ... ich hab eher angst das die FritzBox dann vllt. gar nicht mehr geht ....
Bitte warten ..
Mitglied: Pago159
20.10.2010 um 14:51 Uhr
Wenn du die Fritzbox über das interne Flash-Programm Flashst ist das kein Problem,
du solltest nur nicht im Flash-vorgang den Strom ziehen.
am besten konfigurierst du dann auch die Fritzbox neu,
dann bist du auf der Sicheren Seite, dass alles von der Fritzbox Seite her Konfiguriert ist.
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Ubuntu
gelöst Ubuntu problem bei Aktualisierung (16)

Frage von Philipp711 zum Thema Ubuntu ...

Exchange Server
Problem mit POP3-Abruf eines Exchange-2013-Postfachs

Frage von YotYot zum Thema Exchange Server ...

Multimedia & Zubehör
gelöst BENQ Beamer Fernbedingung Frequenz Problem (4)

Frage von xbast1x zum Thema Multimedia & Zubehör ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...