Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

EDNS-Problem mit Ubuntu und Bind9

Frage Linux Ubuntu

Mitglied: miggel13

miggel13 (Level 1) - Jetzt verbinden

17.10.2010, aktualisiert 12:37 Uhr, 5305 Aufrufe, 5 Kommentare

(OS: Ubuntu 9.04, DNS: Bind9)

Hallo,
seit kurzem habe ich in meiner syslog sehr viele Einträge über einen EDNS-Fehler.
Bei mir werden normalerweise DNS-Anfragen an meinen Linux-Server gerichtet, der auch im LAN eine eigene Zone verwaltet. Kann der DNS-Server eine Anfrage nicht beantworten, so werden die Anfragen an meinen DSL-Router (fritzbox) weitergeleitet. Dies passierte bisher immer über eine WIRED-Verbindung (LAN-Kabel am DSL-Router). Nun habe ich den Server-Standort verändert und der Server ist mit WLAN verbunden. Seit dieser Änderrung habe ich nun in meiner syslog bei jeder DNS-Anfrage (die nicht meine Zone betrifft) folgende Einträge:


Oct 17 09:59:28 weiz named[2571]: too many timeouts resolving 'zb.akadns.org/A' (in 'akadns.org'?): disabling EDNS
Oct 17 09:59:28 weiz named[2571]: too many timeouts resolving 'zc.akadns.org/A' (in 'akadns.org'?): disabling EDNS
Oct 17 09:59:28 weiz named[2571]: too many timeouts resolving 'zd.akadns.org/A' (in 'akadns.org'?): disabling EDNS
Oct 17 09:59:28 weiz named[2571]: too many timeouts resolving 'za.akadns.org/A' (in 'akadns.org'?): disabling EDNS
Oct 17 09:59:28 weiz named[2571]: too many timeouts resolving 'zb.akadns.org/AAAA' (in 'akadns.org'?): disabling EDNS
Oct 17 09:59:28 weiz named[2571]: too many timeouts resolving 'za.akadns.org/AAAA' (in 'akadns.org'?): disabling EDNS
Oct 17 09:59:28 weiz named[2571]: too many timeouts resolving 'zd.akadns.org/AAAA' (in 'akadns.org'?): disabling EDNS
Oct 17 09:59:28 weiz named[2571]: too many timeouts resolving 'zc.akadns.org/AAAA' (in 'akadns.org'?): disabling EDNS
Oct 17 10:00:01 weiz /USR/SBIN/CRON[5432]: (root) CMD ([ -x /usr/sbin/update-motd ] && /usr/sbin/update-motd 2>/dev/null)
Oct 17 10:00:01 weiz /USR/SBIN/CRON[5434]: (root) CMD ([ -x /usr/sbin/update-motd ] && /usr/sbin/update-motd hourly 2>/dev/null)
Oct 17 10:00:12 weiz named[2571]: too many timeouts resolving 'www.freeware.de/A' (in 'freeware.de'?): disabling EDNS
Oct 17 10:00:13 weiz named[2571]: too many timeouts resolving 'ns1.hans.hosteurope.de/A' (in 'hosteurope.de'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:13 weiz named[2571]: too many timeouts resolving 'ns1.hans.hosteurope.de/AAAA' (in 'hosteurope.de'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:13 weiz named[2571]: too many timeouts resolving 'ns2.hans.hosteurope.de/A' (in 'hosteurope.de'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:13 weiz named[2571]: too many timeouts resolving 'ns2.hans.hosteurope.de/AAAA' (in 'hosteurope.de'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:47 weiz named[2571]: too many timeouts resolving 'www.google.com/A' (in 'google.com'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:55 weiz named[2571]: too many timeouts resolving 'www.linuxmint.com/A' (in 'linuxmint.com'?): disabling EDNS
Oct 17 10:00:57 weiz named[2571]: too many timeouts resolving 'ns1.servage.net/A' (in 'servage.net'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:57 weiz named[2571]: too many timeouts resolving 'ns1.servage.net/AAAA' (in 'servage.net'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:57 weiz named[2571]: too many timeouts resolving 'ns3.servage.net/A' (in 'servage.net'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:57 weiz named[2571]: too many timeouts resolving 'ns2.servage.net/A' (in 'servage.net'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:57 weiz named[2571]: too many timeouts resolving 'ns4.servage.net/A' (in 'servage.net'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:57 weiz named[2571]: too many timeouts resolving 'ns2.servage.net/AAAA' (in 'servage.net'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:57 weiz named[2571]: too many timeouts resolving 'ns3.servage.net/AAAA' (in 'servage.net'?): reducing the advertised EDNS UDP packet size to 512 octets
Oct 17 10:00:57 weiz named[2571]: too many timeouts resolving 'ns4.servage.net/AAAA' (in 'servage.net'?): reducing the advertised EDNS UDP packet size to 512 octets



Kann es sein das es über meinen WLAN-Adapter Probleme mit der Packet-Größe auftreten können? Ich habe nämlich bereits sämtliche Firewalls gecheckt und diese auch ausgeschaltet, jedoch ohne Erfolg.

Meine WLan-Information:


root@weiz:~# ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 00:09:5b:ec:ef:a0
inet addr:192.168.77.3 Bcast:192.168.77.255 Mask:255.255.255.0
inet6 addr: fe80::209:5bff:feec:efa0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2308 errors:0 dropped:0 overruns:0 frame:0
TX packets:2460 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2067899 (2.0 MB) TX bytes:516232 (516.2 KB)




root@weiz:~# iwconfig wlan0
wlan0 IEEE 802.11bg ESSID:"meine_ssid"
Mode:Managed Frequency:2.457 GHz Access Point: BC:05:43:16:54:88
Bit Rate=54 Mb/s Tx-Power=20 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:BCA[...]34AA [3] Security mode:open
Power Management:off
Link Quality=48/100 Signal level:-75 dBm Noise level=-106 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0



Eine Auswirkung dieses EDNS-Problems ist es, dass die Anfragen teilweise sehr lange dauern können. Deshalb habe ich die Clients aktuell auf den DNS-Server der fritzbox umgeschaltet. Würde aber gerne von den vorzügen meiner DNS-Zone wieder gebrauch machen.

Wär super toll wenn jemand vllt eine Idee hätte.



NACHTRAG: Ok mir ist nun folgendes aufgefallen. Ich habe bei der FritzBox ein Update gemacht (7270, Update: 74.04.86) und seit diesem Update treten die EDNS-Fehler andauernd auf.
Für weitere Tests habe ich nun mal den Google-DNS Server als forwarder eingetragen (8.8.8.8) und mit diesem funktionieren die DNS-Lookups ebenfalls perfekt.
Weiß jemand, was sich mit diesem Update an der fritzbox geändert hat?
Mitglied: Pago159
19.10.2010 um 20:01 Uhr
Kannst du nicht einfach die alte Firmware nochmal einspielen,
die solltest du doch bei AVM herunter zu laden bekommen.
Dann sollte doch erst einmal alles wieder laufen,
bis AVM nachgebessert hat.
Bitte warten ..
Mitglied: miggel13
19.10.2010 um 21:25 Uhr
Ja ich hab mir auch schon überlegt ob ich meinen Backup-Restorepunkt einspiele, jedoch hat sich an der Fritzbox sehr viel (komplett neues Menü, ...) geändert. Da bin ich nun eher skeptisch gegenüber einem Restore.
Aktuell benutze ich noch die DNS-Server von google wobei ich mich bei dieser Sache auch nicht ganz wohl fühle (bin wahrscheinlich der einzige, der die DNS-Server von google benutzt;)
Bitte warten ..
Mitglied: Pago159
19.10.2010 um 21:29 Uhr
Naja, die Frage ist natürlich,
brauchst du das neue Design und die Funktionen,
die hinzugekommen sind bei der FritzBox wirklich?
Manchmal muss man eben ein paar Kompromisse eingehen ;)
Du kannst es ja auch mal testweise machen,
dann weist du wenigstens sicher,
ob es an der FritzBox liegt oder doch eher an dem Server ;)
Bitte warten ..
Mitglied: miggel13
20.10.2010 um 08:50 Uhr
Nein, um das Design und die Funktion gehts mir überhaupt nicht ... ich hab eher angst das die FritzBox dann vllt. gar nicht mehr geht ....
Bitte warten ..
Mitglied: Pago159
20.10.2010 um 14:51 Uhr
Wenn du die Fritzbox über das interne Flash-Programm Flashst ist das kein Problem,
du solltest nur nicht im Flash-vorgang den Strom ziehen.
am besten konfigurierst du dann auch die Fritzbox neu,
dann bist du auf der Sicheren Seite, dass alles von der Fritzbox Seite her Konfiguriert ist.
Bitte warten ..
Ähnliche Inhalte
DNS
Bind9 Konfig-Problem
gelöst Frage von TiTuxDNS11 Kommentare

Hallo, ich habe hier auf einer physischen Maschine ein CentOS 7.1 mit bind9 installiert, der Dienst läuft, der Check ...

Ubuntu
Ubuntu problem bei Aktualisierung
gelöst Frage von Philipp711Ubuntu16 Kommentare

Hallo Leute, ich habe folgendes Problem bei einem Linux-Server. Eine Aktualisierung des Servers ist irgendwie nicht mehr möglich. "Apt-get ...

Linux Netzwerk
Active Directory mit Bind9 auflösen
Frage von FSX2010Linux Netzwerk9 Kommentare

Hallo, ich habe den Raspbery (2015-09-24-raspbian-jessie.img) als DNS (Bind9) und DHCP (ISC) Server installiert. Funktioniert prächtig. Nun möchte ich ...

DNS
BIND9 Reverselookup falsche Antwort
gelöst Frage von danielr1996DNS2 Kommentare

Hallo Leute, ich hab mir einen eigenen DNS Server eingerichtet um die IPs im eigenen Netz über hostnamen ansprechen ...

Neue Wissensbeiträge
Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 2 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 4 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Sicherheit

Teamviewer Sessions können gekapert werden - Update tw. verfügbar

Information von sabines vor 4 TagenSicherheit6 Kommentare

In bestimmten Konstellationen können Teamviewer Sessions gekapert werden, wahrscheinlich aber ein recht unwahrscheinliches Szenario. Da der Teamviewer gerne für ...

Digitiales Fernsehen

Apple TV: Amazon Prime App ist verfügbar

Information von Frank vor 4 TagenDigitiales Fernsehen4 Kommentare

Die Amazon Prime Video App kann ab sofort auf einem Apple TV ab der 3 Generation installiert werden. Einfach ...

Heiß diskutierte Inhalte
Vmware
Installation Windows 10 VMware
Frage von Ghost108Vmware17 Kommentare

Hallo zusammen, versuche gerade mit Hilfe des vshpere clients eine virtuelle Windows 10 maschine aufzusetzen. 1. virtuelle Maschine erstellt ...

Exchange Server
SBS 2011 E-Mails können gesendet werden, aber nicht von extern empfangen
Frage von andreas1234Exchange Server14 Kommentare

Hallo Community, ich habe das Problem, dass seit knapp zwei Wochen die E-Mails von meinem SBS 2011 einwandfrei gesendet ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Windows Server
Server 2012 über Eingabeaufforderung devmgmt.msc geht nicht
gelöst Frage von achim222Windows Server9 Kommentare

Hallo, ich habe hier einen Server 2012 der im Reparaturmodus startet. Es liegt an einem falschen VirtIO Treiber für ...