Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Einige Clients installieren Netzwerkdrucker (via Printserver bereitgestellt und Script verbunden) plötzlich mit jeder Anmeldung neu (als Kopie).

Frage Microsoft Windows Netzwerk

Mitglied: MontyC

MontyC (Level 1) - Jetzt verbinden

14.02.2011, aktualisiert 15.02.2011, 4965 Aufrufe, 7 Kommentare

Hallo Gemeinde,

als Vorwort kurz ein paar Informationen zu mir. Bisher habe ich mich recht wacker geschlagen und komme seit 1997 ganz gut durchs IT-Berufsleben. Bisher musste ich mich noch nicht wirklich geschlagen geben, aber nun weiß ich nicht mehr weiter und muss mich wenigstens erleichtern und mein Leid klagen. Eventuell kennt ja jemand das Problem und kann mir den einen oder anderen Tipp geben.

Wir haben ca. 150 Anwenderinnen und Anwender auf insgesamt sieben Etagen (Win 2003 Domäne). Auf allen Etagen stehen Etagendrucker und fast alle haben zusätzlich einen Arbeitsplatzdrucker (nobel geht die Welt zu Grunde). Die Drucker (zur Verfügung gestellt über Printserver) werden alle via Script verbunden (Raumnummern und Etagennummern sind das Kriterium). Seit Einrichtung im Jahre 2008 läuft alles bestens und relativ frei von Störungen. Seit einiger Zeit zeigt sich jedoch ein für mich nicht begreifbares Problem. Einige Clients erstellen bei jeder neuen Anmeldung eine Kopie der Etagendrucker. Der Treiber wird neu installiert und es tauchen die Etagendrucker als Kopie auf. Die Kopien zeigen jedoch keinen Hinweis auf den Printserver. Während der Ersteintrag zum Beispiel "pr-000-000 an pr-xxx-01" heißt, nennt sich die Kopie "pr-000-000 (Kopie)".

Wir haben diverse Test vorgenommen und sind auf das folgende Phänomen gestoßen:

Installiert man ein Image auf Rechner A und meldet sich als User A an, funktioniert alles reibungslos und ohne Kopien. Wir haben nun eine baugleiche Maschine genommen und ein Image unserer Grundinstallation aufgespielt und uns als User A angemeldet, was passiert?! Richtig! Bei jeder Anmeldung wird eine Kopie der jeweiligen Etagendrucker angelegt.

Ich glaube, dass ich das ganze Netz durchsucht habe (naja, annähernd oder gefühlt). Entweder ich bin doch zu doof oder es sind keine vergleichbaren Probleme im Netz zu finden.

Irgendwas läuft da verkehrt und wir haben es nicht gemerkt. Jemand eine Idee oder Anregung?

Danke und Gruß

Monty C.
Mitglied: Pago159
14.02.2011 um 17:00 Uhr
Zitat von MontyC:
Installiert man ein Image auf Rechner A und meldet sich als User A an, funktioniert alles reibungslos und ohne Kopien. Wir haben
nun eine baugleiche Maschine genommen und ein Image unserer Grundinstallation aufgespielt und uns als User A angemeldet, was
passiert?! Richtig! Bei jeder Anmeldung wird eine Kopie der jeweiligen Etagendrucker angelegt.

Ich glaube, dass ich das ganze Netz durchsucht habe (naja, annähernd oder gefühlt). Entweder ich bin doch zu doof oder
es sind keine vergleichbaren Probleme im Netz zu finden.

Danke und Gruß

Monty C.

Hi Monty C.,

Du meinst wohl "Installiert man Rechner A" und nicht "Installiert man ein Image auf Rechner A".
Wenn ja, dann wäre meine erste Frage:
  • was für Imaging Software wird genutzt?
  • Schonmal eine andere getestet?
  • Das Image mal zum Test auf dem gleichen PC neu eingespiel? (wenn ja mit welcher Reaktion)

Lg Grapper
Bitte warten ..
Mitglied: 60730
14.02.2011 um 18:04 Uhr
moin,

  • ohne das script, dss die Drucker verbindet zu sehen - kann man nur rätseln.
  • außer das der Clon in einer anderen OU steckt - fällt mir spontan nichts ein, was außer dem Script dran schuld sein könnte.

Gruß
Bitte warten ..
Mitglied: MontyC
14.02.2011 um 18:18 Uhr
Hi,

danke für die Antwort.

Muss mich wohl genauer ausdrücken. Zwei Rechner (baugleich) mit der selben Grundinstallation als Anwender A angemeldet = unterschiedliche Effekte. Auf dem einen Rechner ohne und dem anderen Rechner mit Kopien der Drucker. Das erwähnte ich nur, weil ich den Punkt für sehr merkwürdig halte. Image auf Basis von Acronis. Keine andere Imagesoftware verfügbar im Moment. Was meinst Du mit neu eingespielt? Image vom Ist-Zustand und dann auf die gleiche Kiste? Noch nicht passiert, aber einen Versuch wert.

Wie ich bereits schrieb ist das Problem früher nicht aufgetreten, aber jetzt immer häufiger. Ca. Ein neuer Patient in der Woche zur Zeit. Betrifft neue Anwender/Rechner und bestehende Installationen gleichermaßen. Eine einheitliche Linie, ein klares Indiz oder eine Richtung kann ich im Moment nicht sehen.

Danke und Gruß
Monty C.
Bitte warten ..
Mitglied: MontyC
14.02.2011 um 19:15 Uhr
Mahlzeit,

das Script hat fast drei Jahre wunderbar getan. Macht auch nichts besonderes.

[schnipp]
if /i %computername:~3,1%==2 rundll32 printui.dll,PrintUIEntry /in /n \\server\pr-200-01
[schnapp]

Das Script wird direkt bei Netlogon ausgeführt und wird nicht über GPO initiiert. Alle Anwender (und die Rechner) haben übrigens alle identische Rechte, was den betroffenen Bereich angeht. An dem Clon kann man das wohl auch nicht festmachen, betrifft es letztlich auch Anwender, deren Installation sich seit dem ersten Tag nicht wesentlich geändert hat, sieht man von üblichen Updates ab, die auch bei den anderen installiert wurden (oder zumindest sein sollten).

Um die ständige Kopiererei zu umgehen, schreibe ich nun im Script eine Textdatei in das lokale Profil, deren Existenz ich prüfen lasse. Ist sie da, umgehe ich die Etagendruckerei. Ist sie nicht da, schreibe ich die Datei, installiere die Drucker und schick ist (fast). Hier habe ich nämlich das Phänomen, dass in der Druckwarteschlange "Zugriff verweigert" angezeigt wird, der Drucker aber normal ansprechbar ist.

Bin echt ratlos!

Ein Kollege vermutet (Bauchgefühl) ja als Fehlerquelle einen vor einiger Zeit von einem anderen Kollegen aufgesetzten zweiten AD. Das war so ein Schnellschuss an dem ich nicht beteiligt war. Aber ich habe mir die Konfiguration angesehen und nichts auffälliges entdecken können.

Gruß
Monty C.
Bitte warten ..
Mitglied: 60730
16.02.2011 um 01:57 Uhr
Moin,

ok - das ist halt kein Script (nur ein einfach bedingter Einzeiler) und so kann das durchaus doubletten geben.
Der Weg, eine Dummydatei zu nutzen - ist garnicht so verkehrt - ist aber unschön und im Zweifel auch nicht "sicher"

  • Wurde der Drucker mal vom Script installiert, der User hat Ihn aus Versehen gelöscht - passiert nix - und da gäbe es noch x andere Varianten.

01.
@if /i %computername:~3,1%==2 @reg query HKEY_CURRENT_USER\Printers\Connections\,,server,pr-200-01/v Server >nul || rundll32 printui.dll,PrintUIEntry /in /n \\server\pr-200-01
ist zwar auch nur ein einzeiler, dafür fragt der aber nicht nur ab, ob der Rechner für den Job gedacht ist, sondern auch, ob der Drucker vorhanden ist.
Nur wenn die erste Bedingung zutrifft und die zweite nicht, wird der Drucker installiert.


Gruß
Bitte warten ..
Mitglied: MontyC
16.02.2011 um 15:09 Uhr
Mahlzeit,

vorab mal Dank für die Unterstützung!

Ansonsten absolut korrekt, dass es sich hierbei nur um einen Einzeiler von vielen handelt. Das Auslesen des RegKeys bringt übrigens nicht viel. Habe herausgefunden, dass der Drucker nicht in den Connections aufgeführt wird. Bei den betroffenen Druckern/Anwendern wird etwas in DevModePerUser und DevModes2 geschrieben.

Zwischenzeitlich gibt es einige Neuig- und Merkwürdigkeiten. Da das Niederschreiben der neuen Erkenntnisse im Moment meine zeitlichen Möglichkeiten sprengen würde, beschränke ich mich auf den Hinweis, dass es letztlich ein "Rechteproblem" sein muss. Entferne ich bei der Freigabe des Druckers die Zugriffsrechte und setzte sie anschließend identisch neu, wird der Drucker nicht mehr kopiert und es kann sauber zugegriffen werden.

Sobald Zeit ist, beschreibe ich die neuen Erkenntnisse etwas detailierter.

Gruß
Monty C.
Bitte warten ..
Mitglied: MontyC
17.02.2011 um 12:31 Uhr
Hallo Gemeinde,

ich werde den Beitrag als gelöst markieren, obgleich ich die Lösung nicht kenne.

Für die Interessierten die folgenden Informationen:

Nachdem ich mich gedanklich immer weiter in den Rechtebereich bewegt und bei ausgewählten Druckern die Rechte neu (aber identisch) gesetzt habe, versuchte ich noch was ganz anderes. Ich habe dann das Freigabemenu eines betroffenen Druckers geöffnet, die Rechte nicht neu gesetzt und das Freigabemenu wieder geschlossen, mit der Folge, dass auch das das Problem für diesen Drucker behoben hat. Das Spiel habe ich dann Testweise mit insgesamt 177 Druckern gemacht und siehe da; es lösen sich alle Probleme. Das bloße anfassen der Freigabe auf dem Printserver hat die Zugriffsprobleme behoben. Der Printserver wird regelmäßig aktualisiert und neu gestartet. Insofern verstehe ich im Moment überhaupt nicht was da passiert. Fehlt nur noch, dass das Ändern der Bildschirmfarbe die länge meiner nicht vorhandenen Haare beeinflusst.

Dank an alle Helfer! Sofern jemand Ideen und Anmerkungen hat, würde ich mich sehr freuen.

Gruß
Monty C.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Internet Domänen
gelöst Kein Internetzugriff für einige Clients im Netzwerk (23)

Frage von rapidshare zum Thema Internet Domänen ...

Windows 7
Script zum Installieren und Deinstallieren eines Treibers (3)

Frage von 2Seiten zum Thema Windows 7 ...

Batch & Shell
gelöst Software auf Clients per Skript de-installieren (10)

Frage von ArnoNymous zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...