Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Einmalige Computerabhängige Installation über Gruppenrichtlinien

Frage Microsoft Windows Server

Mitglied: connect55

connect55 (Level 1) - Jetzt verbinden

20.01.2006, aktualisiert 22:51 Uhr, 3956 Aufrufe, 4 Kommentare

Installation bei jedem Neustart abstellen.

Hallo zusammen,
folgendes Problem:

Ich habe einen 2003er Server mit XP-Clients, denen ich via Gruppenrichtlinie ein .msi file zur Installation zuweise.
Wie bekomme ich es nun hin, dass er die Softwarepakete nur einmal installiert und nicht bei jedem Neustart wieder neu anfängt Office, usw. zu installieren.
Schließlich sind die Pakete nach dem ersten Setup ja verteilt.


Bei google & co konnte ich dazu leider nichts finden....
Mitglied: Soldier
20.01.2006 um 13:01 Uhr
Wenn der PC in der gleichen OU bleibt, auf die die Gruppenrichtlinie verweist, dürften beim Neustart eigentlich keine Probleme auftauchen.

Wenn der PC in eine andere OU verschoben wird, deinstalliert er beim Neustart das alte Software-Paket und installiert das Neue.

Hast du in den Unterordnern der OU identische Software als msi-Verknüpfung eingetragen? Wenn das der Fall ist, könnte es sein, dass es zu Problemen kommt, da die Pakete ja grundsätzlich nach unten vererbt werden, wenn mich nicht alles täuscht. Und deshalb doppelte Einträge in untergeordneten OUs nichts bringen, bzw. Fehler hervorrufen.

MfG Soldier
Bitte warten ..
Mitglied: connect55
20.01.2006 um 13:05 Uhr
Nein, daran liegt es leider nicht.
Die Computer wurden nicht verschoben und eine übergeordnete Richtlinie die da greifen könnte existiert nicht.

Danke trotzdem,
noch jemand eine Idee?
Bitte warten ..
Mitglied: laberdasch
20.01.2006 um 18:36 Uhr
Hallo,

passiert das immer - also auch wenn du dich als Administrator anmeldest - oder erfolgt die Anmeldung als "normaler" Benutzer?
Ich frage das, weil wir bei einem MSI-Paket mal das Problem hatten, dass bei bei der Erstinstallation ein Benutzer angemeldet war, der nicht alle nötigen Rechte hatte.
Das Programm meinte nun scheinbar, dass es noch nicht korrekt oder vollständig installiert war und startete ständig das MSI-Paket.
Eine Anmeldung als Admin an der entsprechenden Maschine sollte bei dir ausreichen (falls es daran liegt), wenn das Paket ganz normal über GPO einer Maschine bzw. einer Maschine eines bestimmten Containers zugewiesen wurde.

Schöne Grüße

Achim

P.S.: Falls das nicht klappt, will das MSI-Paket wahrscheinlich etwas ins Profil des Benutzers schreiben.
Abhilfe:
a) Bei uns haben wir einen "User" mit Aminrechten eingerichtet, der das Programm aufruft (dabei werden alle notwendigen Einträge geschrieben) und das Profil dieses Useres nutzen wir als Standardprofil für alle, indem wir das Profil als Standardprofil kopieren.
b) Falls bei euch alle ein unterschiedliches Profil haben, müsstest du mit Regmon und Filemon untersuchen, was beim MSI-Paket alles geschrieben wird und die benötigten Rechte per ExtraGPO verteilen.
Bitte warten ..
Mitglied: connect55
20.01.2006 um 22:51 Uhr
Danke erstmal, aber das wars auch nicht.
Habe jetzt die Antwort gefunden.

Für alle die es interessiert:
Das GPO "Windows Installer- und Gruppenrichtliniensoftware-Installationsdaten belassen" war versehentlich deaktiviert.



Gruß.
Bitte warten ..
Ähnliche Inhalte
Virtualisierung
Installation "Kodi" mit Hypervisor Unterbau

Frage von Spirit-of-Eli zum Thema Virtualisierung ...

Windows 7
USB Tastatur Problem nach ESET Installation (6)

Frage von PharIT zum Thema Windows 7 ...

Windows Installation
Libreoffice nach installation keine menüleiste (6)

Frage von oskarmader zum Thema Windows Installation ...

Batch & Shell
gelöst Powershell net 3.5 Installation silent (2)

Frage von Marabunta zum Thema Batch & Shell ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Windows Systemdateien
gelöst NTFS und die Defragmentierung (29)

Frage von WinLiCLI zum Thema Windows Systemdateien ...