Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Einrichtung VLANs auf 2x HP ProCurve 2530-48g Switch

Frage Netzwerke

Mitglied: MarNo84

MarNo84 (Level 1) - Jetzt verbinden

05.11.2014, aktualisiert 22:17 Uhr, 4231 Aufrufe, 2 Kommentare

Hallo Freunde,

stehe diesmal vor einem recht kniffeligem Problem...

Ich habe hier 2x HP ProCurve 2530-48g Switches die in 2 eigenen Serverschränken (in zwei Gebäuden) verbaut sind.
Der Server steht mit einem Patchfeld in Gebäude 1 und in Gebäude 2 gibts im Schrank auch ein Patchfeld und den Internetrouter.

Physikalisch sind diese mit einer Glasfaserleitung auf dem Port 50 je Switch verbunden.
Nun gibt es da zwei Netzwerke - nehmen wir an, ein Netz im Adressbereich 10.1.10.x und eines im Bereich 192.168.1.x.

Das eine soll das andere Netz nicht sehen (derzeit finden immense Kollisionenstatt, die das netzwerk total lahmlegen).
Aus technischen Gründen müssen auf beiden Switchen beide Netze laufen:

Sagen wir von Port 1-44 das 192.168.1.x (Endgeräte bekommen ihre IP vom DHCP des DC)
und von Port 45-48 das Netz 10.1.10.x (jedes Endgerät hat eine feste IP)

Die Ports 49-52 sind die Glasfaserports und davon ist nur der Port 50 jeweils belegt (Verbindung beider Switches)

Ich stehe da etwas auf dem Schlauch und komme nicht so recht weiter...

Auf beiden Switches habe ich neben dem default VLAN1 je 2 VLANs eingerichtet und wie folgt konfiguriert:

VLAN2 und VLAN3

VLAN2 habe ich die Ports 1-44 untagged zugewiesen
VLAN3 habe ich die Ports 45-48 untagged zugewiesen

Port 50 habe ich unter VLAN2 als tagged markiert.

Unterhalb der Switches kann ich kommunizieren (anpingen, Weboberflächenzugriff, usw.) - die Netze aber sind dicht? Keine Pings oder Ähnliches.
Kann es sein, das ich unter VLAN2 die IP-Konfiguration auf "DHCP/Bootp" setzen muss, damit im VLAN2 weiterhin der DHCP von DC greift?
Im VLAN3 kann ich die IP-konfiguration doch auf "disabled" stehen lassen - da die Endgeräte ja eine feste IP haben?

Da ja die 2 Switches miteinander kommunizieren müssen und beide Netze über den Port 50 (Fibre) laufen müssen - wie und wo stelle ich da die Einstellungen korrekt ein? Ist da das setzen des "Tagged" unter VLAN2 korrekt?Wenn ich gerade so recht überlege . kann/muss ich auch unter VLAN3 dies "taggen" ?

Kann aus meinen Infos jemand ein sinnvolles/funktionierendes Setup erkennen bzw. Tips geben? Das handbuch ist eher dürftig

Im bereich VLAN bin ich noch nicht so fit aber ich sollte diese Aufgabe schnellstens funktionstüchtig abgeben

Danke euch schon mal sehr
Mitglied: stefaan
05.11.2014, aktualisiert um 23:01 Uhr
Servus,

folgende Hilfestellung zur Hausübung:

Zitat von MarNo84:
VLAN2 habe ich die Ports 1-44 untagged zugewiesen
VLAN3 habe ich die Ports 45-48 untagged zugewiesen
Passt soweit.

Port 50 habe ich unter VLAN2 als tagged markiert.
Das VLAN 3 soll auch noch über diese Verbindung, also VLAN 3 auf Port 50 auch taggen.
Untagged auf Port 50 läuft das Default-VLAN (1), damit du administrative Arbeiten übers Netz erledigen kannst (ev. einen Port noch ins VLAN 1, an den du dich für die Konfiguration anhängst).

Unterhalb der Switches kann ich kommunizieren (anpingen, Weboberflächenzugriff, usw.) - die Netze aber sind dicht? Keine
Pings oder Ähnliches.
Die Switches müssen aus den beiden VLANs 2 und 3 eigentlich nicht erreichbar sein, dazu gibt es das Default VLAN. Die Netze sind dann getrennt, sofern du nicht versehentlich einen Router falsch konfigurierst, der beide Netze bedient.

Kann es sein, das ich unter VLAN2 die IP-Konfiguration auf "DHCP/Bootp" setzen muss, damit im VLAN2 weiterhin der DHCP
von DC greift?
Im VLAN3 kann ich die IP-konfiguration doch auf "disabled" stehen lassen - da die Endgeräte ja eine feste IP
haben?
Siehe oben, die Switches benötigen in den VLANs 2 und 3 eigentlich keine IPs, es sei denn, du willst die Switches aus diesen Netzen konfigurieren.

Da ja die 2 Switches miteinander kommunizieren müssen und beide Netze über den Port 50 (Fibre) laufen müssen - wie
und wo stelle ich da die Einstellungen korrekt ein? Ist da das setzen des "Tagged" unter VLAN2 korrekt?Wenn ich gerade
so recht überlege . kann/muss ich auch unter VLAN3 dies "taggen" ?
VLAN 3 auf Port 50 auch taggen, richtig.

Kann aus meinen Infos jemand ein sinnvolles/funktionierendes Setup erkennen bzw. Tips geben? Das handbuch ist eher dürftig

IP/DHCP-Geschichte muss du dir überlegen, sonst schaut die Sache gut aus.
Du hast wahrscheinlich nur den "Quick Start Guide" gelesen, wo drinnen steht, wie man das Stromkabel und die Rackwinkel anbringt. Hilfreicher ist vermutlich der "HP Switch Software Management and Configuration Guide":
http://h20628.www2.hp.com/km-ext/kmcsdirect/emr_na-c04490689-1.pdf

Im bereich VLAN bin ich noch nicht so fit aber ich sollte diese Aufgabe schnellstens funktionstüchtig abgeben
Wird noch, denk dir die Sache nochmals durch.

Grüße, Stefan
Bitte warten ..
Mitglied: aqui
06.11.2014, aktualisiert um 09:16 Uhr
Eigentlich ist das Kinderleicht. Sieh dir das hiesige Tutorial an:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
Dort wird alles zu dem Thema erklärt, inklusive einer laufenden HP Konfiguration !

Nur so viel:
  • Du legst 2 VLANs an z.B. VLAN 10 und VLAN 20 auf beiden Switches
  • Den Port 50 (Glasfaserverbindung) weist du tagged beiden VLANs 10 und 20 zu auf beiden Switches.
  • Beide Switches werden dann mit Port 50 über die Glasfaser verbunden.
  • Auf beiden Switches weist du dann den Endgeräten ihre Ports zu je nach Bedarf diese aber untagged, klar es sind Endgeräte Ports.
  • Fertig !
Eine rudimentäre Switchkonfig mit der es klappt sähe dann z.B. so aus:
HP_Switch-1#

time timezone 60
time daylight-time-rule Middle-Europe-and-Portugal
spanning-tree protocol-version rstp
spanning-tree force-version rstp-operation
exit
interface 50
name "Tagged Uplink zu Switch 2"
exit
vlan 1
name "DEFAULT_VLAN"
untagged 1-9
ip address 172.16.1.254 255.255.255.0
exit
vlan 10
name "VLAN-10"
untagged 10-19
tagged 50
exit
vlan 20
name "VLAN-20"
untagged 20-29
tagged 50
exit

Für den anderen dann analog:
HP_Switch-2#

time timezone 60
time daylight-time-rule Middle-Europe-and-Portugal
spanning-tree protocol-version rstp
spanning-tree force-version rstp-operation
exit
interface 50
name "Tagged Uplink zu Switch 1"
exit
vlan 1
name "DEFAULT_VLAN"
untagged 1-9
ip address 172.16.1.253 255.255.255.0
exit
vlan 10
name "VLAN-10"
untagged 10-19
tagged 50
exit
vlan 20
name "VLAN-20"
untagged 20-29
tagged 50
exit


Ports für Endgeräte sind dann 1 bis 9 im Default VLAN 1, dann 10 bis 19 in deinem VLAN 10 und die Ports 20 bis 29 in VLAN 20.
Verbunden sind beide Switches über den Port 50 und darüber werden transparent die VLANs verbunden.
Die VLANs 10 und 20 sind vollkommen isoliert untereinander...so wie du es haben willst !
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Switche und Hubs
gelöst HP Procurve 2810-48g Firmware download (2)

Frage von MichiBLNN zum Thema Switche und Hubs ...

Switche und Hubs
gelöst HP Procurve Switch 2650 J4899B Hängt, keine Verbindung möglich (7)

Frage von duke1212 zum Thema Switche und Hubs ...

Switche und Hubs
HP 2910al-48G Switch Redundant (Welche Einstellung?) (26)

Frage von mksadm zum Thema Switche und Hubs ...

Festplatten, SSD, Raid
2x HP Raid P420 auf Supermicro MB (3)

Frage von sebastian2608 zum Thema Festplatten, SSD, Raid ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...