Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Einrichtungsproblem: Port-Forward fuer SSH auf Bintec x2302 Router

Frage Netzwerke Router & Routing

Mitglied: 35093

35093 (Level 1)

08.09.2006, aktualisiert 17.09.2006, 9192 Aufrufe, 4 Kommentare

Hallo,

wir haben einen Linux-Server hinter einem Bintec x2302 Router, der per SSH auch von außen erreichbar sein soll.
Intern ist der SSH-Zugriff problemlos moeglich, im Router wurde ein Eintrag im Bereich "Requests from OUTSIDE" eingerichtet (Protokoll tcp, ext. IP, ext. Port, int. IP, int. Port und Hostmasks alles eingestellt...), anschließend die Konfiguration gespeichert und der Router neu gestartet.
Leider klappt der Verbindungsaufbau von außen aber nicht. Der Client bricht dann irgendwann mit Timeout ab, in der Debug-Ausgabe vom Router tauchen diverse Hinweise auf den Verbindungsaufbau auf, aber es tut sich halt nichts.

Gibt es irgendwelche Tricks, wie man das hinbiegen kann?

Danke und viele Grueße
Stephan
Mitglied: nopain
08.09.2006 um 08:14 Uhr
Moin,

evtl. wäre es mal interessant zu wissen was im log genau erscheint.... dann könnte evtl. auch geholfen werden.


Grundsätzlich, du nutzt NAT, d.h. der Router übernimmt Netzanfragen in seinem Namen für die Rechner hinter ihm. Somit kann nur der Router direkt angesprochen werden. D.h. die jeweils gültige externe IP des Routers, welche vom Provider immer wieder neu vergeben wird. Da der Router selber auf Port 22 nicht funkt, muß er wissen an welchen Rechner er sich im internen Netz, also hinter ihm wenden soll, wenn solche Anfragen kommen. Das nennt sich dann Port-forwarding und ist in etwa wohl das, was bei dir "Requests from Outside" heißt.

Nun prüfe doch mal ob die korrekten IPs angesprochen werden und ob Deine Einstellungen logisch richtig und nachvollziehbar sind.

Wenn das alles grün sein sollte, dann mal bitte die Angaben aus den Logs posten.

Gruß
nopain
Bitte warten ..
Mitglied: 35093
08.09.2006 um 08:24 Uhr
Hallo,

erstmal ganz herzlichen Dank fuer die schnelle Antwort!

Der Router bekommt keine neue IP, das ist eine feste von T-Online.
Daher sind die Einstellungen aus meiner Sicht auch alle logisch.
Es gibt auch einen weiteren Eintrag in der Tabelle, der fuer den Webserver im internen Netz bestimmt ist. Den habe leider nicht ich eingerichtet, aber es funktioniert schon seit laengerem.

Was die Logs angeht, so werde ich die nachreichen, wenn ich wieder rankomme. Bin heute leider "extern" und der SSH-Zugang funktioniert ja noch nicht

Gruß
Stephan
Bitte warten ..
Mitglied: nopain
08.09.2006 um 08:30 Uhr
Moin,

Es gibt auch einen weiteren Eintrag in der
Tabelle, der fuer den Webserver im internen
Netz bestimmt ist. Den habe leider nicht ich
eingerichtet, aber es funktioniert schon seit
laengerem.

...na dann gibt es ja Hoffnung! Unter diesen Umständen sollte das Problem doch leicht zu beheben sein.


Was die Logs angeht, so werde ich die
nachreichen, wenn ich wieder rankomme. Bin
heute leider "extern" und der
SSH-Zugang funktioniert ja noch nicht

Interessant wären in diesem Fall Logeinträge die einen erfolgreichen Zugriff auf den Webserver zeigen und diese, die die Fehlersituation beim SSH-Zugang aufzeigen. Es müßte bis zu einem Punkt Gleichnisse geben und an einer bestimmten Stelle die Differenz, bzw. die Fehlersituation. Na dann mal noch viel Spaß und schönes WE.

Gruß
nopain
Bitte warten ..
Mitglied: 35093
17.09.2006 um 11:33 Uhr
Hallo,

etwas verspaetet moechte ich mich nochmal zu dem Problem aeußern.
Ich habe beim erneuten durchsehen der Logs festgestellt, dass da ein Filter (fuer den Webserver) auftauchte, den offenbar jemand von Hand benamt hatte.
Die Suche danach war schließlich refolgreich im Menue "Security -> Stateful Inspection", wo ich ueber "Edit Filters" einen Filter mit der Aktion "accept" fuer den entsprechenden Rechner und den SSH-Port hinzufuegen konnte.
Seit dem laeuft es wunderbar.

Herzlichen Dank fuer die Unterstuetzung!

Stephan
Bitte warten ..
Ähnliche Inhalte
Router & Routing
gelöst PFsense Port Forward und NAT (11)

Frage von m.reeger zum Thema Router & Routing ...

Router & Routing
SSH-Traffic über VPN-Server zu spezifischen Server routen (8)

Frage von Novacean zum Thema Router & Routing ...

Router & Routing
IPv6 über VPN mit Bintec (be.ip) (3)

Frage von lcer00 zum Thema Router & Routing ...

Neue Wissensbeiträge
Ubuntu

Ubuntu 17.10 steht zum Download bereit

(3)

Information von Frank zum Thema Ubuntu ...

Datenschutz

Autofahrer-Pranger - Bewertungsportal illegal

(8)

Information von BassFishFox zum Thema Datenschutz ...

Windows 10

Neues Win10 Funktionsupdate verbuggt RemoteApp

(8)

Information von thomasreischer zum Thema Windows 10 ...

Microsoft

Die neuen RSAT-Tools für Win10 1709 sind da

(2)

Information von DerWoWusste zum Thema Microsoft ...

Heiß diskutierte Inhalte
Monitoring
Netzwerk-Monitoring Software (18)

Frage von Ghost108 zum Thema Monitoring ...

Windows 10
Seekrank bei Windows 10 (17)

Frage von zauberer123 zum Thema Windows 10 ...

Windows Server
gelöst Kopiervorgang schlägt fehl, weil Datei- und Ordnername zu lang sind (14)

Frage von Schroedi zum Thema Windows Server ...

Windows 10
Windows 10 Fall Creators Update Fehler (13)

Frage von ZeroCool23 zum Thema Windows 10 ...