Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Einsatz eines APs in einem bestehenden LAN

Frage Netzwerke LAN, WAN, Wireless

Mitglied: panguu

panguu (Level 2) - Jetzt verbinden

13.12.2012 um 22:36 Uhr, 2950 Aufrufe, 5 Kommentare

Hallo Leute,

ich versuch schon seit längerer Zeit vergeblich folgendes Setup zu erzielen:

LAN zuhause hat 10.0.0.0/24

Fritz-Box ist Internet-Gateway und hat die 10.0.0.11. Auf dieser Fritz-Box ist auch der DHCP-Server aktiv, der leases von 10.0.0.101-124 verteilt. Auch WLAN ist aktiv auf der Fritz-Box, aber für dieses Beispiel irrelevant.

Nun, jetzt möchte ich in dem bestehenden Netzwerk im Hause einen zusätzlichen WLAN-Accesspoint integrieren. Der neue AP (=Linksys WRT54GL mit OpenWRT BackFire) soll jedoch nicht als WDS eingebunden werden. Gründe hierfür sind:

_1.)_ durch WDS wird die Bandbreite halbiert, da die Basis (=FritzBox) mit dem Repeater (=Linksys WRT54GL) die Bandbreite aufteilen müssen zur Kommunikation und Datenaustauscht.

_2.)_ Die Fritz-Box erlaubt bei WDS nur WPA2-Verschlüsselung, wenn der Partner ebenfalls eine Fritz-Box ist. Ansonsten muss WEP gewählt werden, und das will ich natürlich nicht da ratzfatz knackbar.

_3.)_ nehmen wir mal in dem Beispiel an, die Entfernung zwischen Fritz-Box und Linksys-WRT54GL ist auch zu groß, so dass die zwei gar nicht eine Verbindung gegenseitig aufbauen können.

Soweit so gut, bleibt mir also nur übrig, den neuen AP per Kabel in mein bestehendes Netz einzuklinken. Gesagt getan, dabei habe ich folgende Konstellation probiert:

(A) Dem AP (=WRT54GL) habe ich die IP 10.0.0.2/24 verpasst und als default gateway und dns-server die 10.0.0.1 mitgegeben. An mein bestehendes Hausnetzwerk habe ich ihn über einen der 4 vorhandenen LAN-Ports angeschlossen. Das entspricht dem interface eth0.1, das defaultmässig in OpenWRT (switch!) konfiguriert ist. So kann der WRT54GL ins Internet, sich die Zeit holen, Paketupdates holen, oder auch als OpenVPN-Client brav funktionieren. Der WRT54GL ist nämlich auch als OpenVPN-Client aktiv, indem er eine Verbindung zu einem entfernten OpenVPN-Server aufbaut. Das geht soweit ja auch.

Nun zum Problem --> ich aktiviere die Wireless-Funktion und wähle den Modus "Access Point". Das ganze ist dem Network "LAN" zugeordnet. Network LAN ist im OpenWRT das interface mit der Bezeichnung "br-lan" und somit eine Brücke zwischen den interfaces eth0.0(lan) und wireless-network(lan). Das ist auch default so in OpenWRT wenn der virtuelle Switch (default) aktiv ist. Nun kann ein WLAN-Client (Notebook,Smartphone, usw...) sich mit diesem WRT54GL zwar verbinden, die auth und handshake findet erfolgreich statt, aber er gelangt nicht ins Internet. Warum? Weil er immer eine DHCP-Lease von meiner Fritzbox erhält, und zwar aus dem Bereich 10.0.0.101-124. Nun sollte ich meinen, dass er doch eigentlich den 10.0.0.1 erreichen könnte, das geht aber leider nicht. Der WLAN-Client erhält keinen Ping zu 10.0.0.1. Ich hab also versuch in OpenWRT in den LAN-Configs folgendes zu wählen: ich aktiviere einen DHCP-Server für 10.0.0.126-149 und markiere den Haken, dass der DHCP-Server geforced werden soll, auch wenn im Netz ein anderer aktiv sein sollte. Das bringt aber nix, der WLAN_Client erhält nie eine Lease von diesem WRT54GL-DHCP-Server. Ich hab auch versucht DHCP-Option wie folgt zu übermitteln, indem ich das in den Advanced Settings im OpenWRT konfiguriert habe:

3,10.0.0.1
6,10.0.0.1

Damit sollte den DHCP-Clients das default-gw und DNS-Server mit der IP 10.0.0.1 übermittelt werden. Aber wie gesagt, dazu kommts ja erst gar nicht ,weil die WLAN-Clients keine DHCP-Lease vom WRT54GL erhalten.

Selbst wenn ich auf dem WLAN-Client manuell eine IP festlege, z.B. 10.0.0.22 kann ich die Fritz-Box 10.0.0.1 nicht anpingen. Wieso denn nicht? Das wireless interface ist doch mit dem lan interface gebridged. Wieso klappt das nicht?

(B)* Nun versuche ich einen anderen Weg. Ich schliesse den WRT54GL nicht an den LAN-Port an, sondern verbinde dessen INTERNET-Port mit meinem Haus-LAN. Das entspricht im OpenWRT dem WAN-interface. Das WAN-Interface habe ich mal default auf DHCP-Client belassen. Das LAN-Interface stelle ich nun auf IP 192.168.1.123/24 ein, ohne default gateway und DNS-Server. Was passiert nun? Der WRT54GL erhält über seinen WAN-Port automatisch "IP+default gw+DNS-Server" von der Fritz-Box. WLAN-Clients erhalten nun eine funktionierende Lease und können im Internet surfen. Aber hier habe ich jetzt das Problem, dass der OpenWRT quasi nicht von meinem Haus-LAN erreichbar ist, da er ja in einem anderen Netz ist. Durch das WAN-interface verhält er sich quasi so, dass er eine Internetverbindung am WAN-Port erhält, und diese seinen Clients gegenüber maskiert. Ich will aber dass der OpenWRT erreichbar ist.

Kurzum was ich gerne hätte:

- Fritz-Box muss unverändert auf 10.0.0.1/24 bleiben
- WRT54GL sollte ebenfalls in diesem Netzwerk aktiv sein, mit der IP 10.0.0.2/24
- WLAN-Clients sollen sich sowohl auf der Fritz-Box, als auch auf dem WRT54GL per WLAN andocken können und im Internet surfen. Jeder WLAN-Client muss im Heim-LAN anpingbar sein (sofern erlaubt).

Wo genau ist mein Denkfehler, was mache ich hier falsch. Ich kriegs um Verrecken nicht hin. Bin für jeden Tip dankbar.

Bin echt gespannt, wo der Wurm steckt ...
Mitglied: MrNetman
14.12.2012, aktualisiert um 12:19 Uhr
Hi Panguu,

Wofür braucht ein AP ein default Gateway und einen DNS?
Der WRTG54 wird mittels des LAN-Ports mit dem Netzwerk verbunden und der DHCP wird ausgeschaltet.
Keine Routing oder sonstige zusätzliche Funktionen.
Die IP des AP wird nur für Konfigurationszwecke benötigt und muss die LAN-IP sein.
Die SSID, Verschlüsselungsart und Schlüssel müssen gleich wie bei der Fritzbox sein.
Der Kanalraster muss eingehalten (1-5-9-13 oder 1-6-11) und ein von der Fritzbox verschiedener Kanal gewählt werden.

Deine IPs sind zu prüfen:
Fritzbox LAN 10.0.0.11 oder 10.0.0.1?

Wenn du den WRT als Router verwendest musst du in der Fritzbox eine Route für die WLAN-Clients einrichten. Sonst sind die nicht erreichbar. Die Route zeigt auf das WAN-Interface des WRTG, vermutlich 10.0.0.2.
Aber WLAN clients sollen besser nciht erreichbar sein. Das kann auch eine minimale Sicherheit darstellen.

Suche hier im Forum nach Anleitungen von aqui "Kopplung von 2 Routern" ... http://www.administrator.de/wissen/kopplung-von-2-routern-am-dsl-port-4 ...

Gruß
Netman
Bitte warten ..
Mitglied: panguu
14.12.2012, aktualisiert um 01:29 Uhr
Hallo Netman,

du scheinst hier einiges durcheinander zu würfeln, bitte lese dir genau mein Szenario und meine Fragestellung durch.

Wofür braucht ein AP ein default Gateway und einen DNS?
Damit er weiß, wie er ins Internet gelangt. Würde ich ihm nur eine (statische) IP geben, hätte er absolut keine info wie er 'rausgelangt'. Das muss er aber, weil er Verbindung zum Internet benötigt (->OpenVPN-Client!).

Die IP des AP wird nur für Konfigurationszwecke benötigt und muss die LAN-IP sein.
Eben nicht! siehe oben

Fritzbox LAN 10.0.0.11 oderm 10.0.0.1?
10.0.0.11 ist schon richtig. Wer sagt denn, dass der hinten immer die .1 haben muss ? ;)

Wie auch immer. Ich hab meinen Wurm jetzt entdeckt! ich hatte einen Typo in der SSID vom zweiten AP, grrrr. Da die zwei SSIDs verschieden waren, hats nicht geklappt. Nun funktionierts, die zwei Boxen sind quasi über den LAN-Ports miteinander verbunden, und die Clients können sich registrieren und im i-net surfen. So passt es.

Danke und Grüße,
Pangu.
Bitte warten ..
Mitglied: Arch-Stanton
14.12.2012 um 11:38 Uhr
> Fritzbox LAN 10.0.0.11 oderm 10.0.0.1?
10.0.0.11 ist schon richtig. Wer sagt denn, dass der hinten immer die .1 haben muss ? ;)


solltest Deinen eigenen Text mal besser lesen...
Bitte warten ..
Mitglied: MrNetman
14.12.2012 um 12:22 Uhr
Ich findes es aber geil, wenn Dinge funktionieren, obwohl es eigentlich nicht geht.
Da sind die Maschinen wohl klüger als die Menschen.
Und er AP muss ja ins Internet weil er ein kleines Männchen drin sitzen hat, das nach Hause telefonieren will.
Bitte warten ..
Mitglied: panguu
14.12.2012 um 18:01 Uhr
Hast ja sauber und fachlich argumentiert. Prima! *kopfschüttel*
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
LAN, WAN, Wireless
LAN mit 2 APs, Smartphone an AP1 erreicht WLAN Geräte an AP2 nicht (39)

Frage von Pagemaster101 zum Thema LAN, WAN, Wireless ...

Firewall
Vom LAN auf Router über Firewall zugreiffen (5)

Frage von miichiii9 zum Thema Firewall ...

Netzwerke
LAN und WLAN je mit gleicher IP (13)

Frage von dauatitsbest zum Thema Netzwerke ...

Notebook & Zubehör
gelöst HP 8770W - LAN Netzwerkproblem (Aufbau, Geschwindigkeit) (7)

Frage von RiceManu zum Thema Notebook & Zubehör ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...