Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Einstellungen Bildschirmschoner nicht möglich

Frage Microsoft

Mitglied: SpunkEE

SpunkEE (Level 1) - Jetzt verbinden

30.07.2008, aktualisiert 31.07.2008, 30823 Aufrufe, 12 Kommentare

Hallo,

wir haben seit unbekannter Zeit das Problem, dass sich der Bildschirmschoner nicht mehr einstellen / aktivieren lässt.

Folgendes Szenario:
- Server hat als Betriebssystem ein MS Win 2003 (dieser ist nicht betroffen von dem Problem!)
- Clients welche Betroffen sind (und das sind ALLE in der Domäne) haben als Betriebssystem WinXP SP3
- Eigentlich wurden die Bildschirmschoner mit den drei Gruppenrichtlinien "Bildschirmschoner" (aktiviert), "Kennwortschutz für den Bildschirmschoner verwenden" (aktiviert) und "Bildschirmschoner Zeitlimit" (Aktiviert, 600sek.) im Ordner "Benutzerkonfiguration / Administrative Vorlagen / Systemsteuerung / Anzeige" festgelegt.
Welcher Bildschirmschoner verwendet wird (Richtlinie "Programmname des Bildschirmschoners"), haben wir bis jetzt den Benutzern selbst überlassen.

Jetzt ist das Problem, das der Bildschirmschoner nicht mehr einschaltet, das heisst, der PC nicht mehr gesperrt wird nach 10Min. Ändere ich die Werte in den Gruppenrichtlinien, werden diese nach einem "gpupdate /force" (auf Server und Client) korrekt angepasst. Nur das die eine Richtlinie "Programmname des Bildschirmschoners" absolut KEINE Auswirkung auf die dazugehörige Einstellung hat. Als eingestellter Bildschirmschoner wird immer "kein" angezeigt (ich bin mir sicher das es die eingestellte .scr-Datei gibt!). Und selbst wenn ich sämtliche vier Gruppenrichtlinien welche den Bildschirmschoner einstellen auf "nicht konfiguriert" umstelle, habe ich nicht die Möglichkeit den Bildschirmschoner zu ändern da die Optionen grau hinterlegt sind wie auf dem Screenshot:
09ddafe8a333889ced6fa6f07fc1ca4b-bildschirmschoner - Klicke auf das Bild, um es zu vergrößern

Und es kommt noch besser:
Selbst wenn ich ALLE Gruppenrichtlinien(-Verknüpfungen) in unserem Unternehmen deaktiviere / lösche, ein "gpupdate /force" und einen Neustart durchführe, lässt sich diese Einstellung NICHT verändern, die Einstellungen bleiben unveränderbar hellgrau.
Ich vermute also ein grundsätzliches Problem mit den Bildschirmschonern und nicht ein Problem / Fehler in den Gruppenrichtlinien. Aber wo soll ich nun den weitersuchen?


danke und mfG,
SpunkEE
Mitglied: 67369
30.07.2008 um 18:02 Uhr
Hast du mögliche lokale Einträge in der Registry schon überprüft?

http://www.winfaq.de/faq_html/Content/tip1500/onlinefaq.php?h=tip1948.h ...
Bitte warten ..
Mitglied: SpunkEE
31.07.2008 um 09:54 Uhr
Danke für den Tipp, das scheint der richtige Weg zu sein. Mit dem Registry-Eintrag auf den du in deinem Beitrag hinweist (ScreenSaveActive, musste ihn zuerst erstellen) lässt sich der Bildschirmschoner vorübergehend aktivieren / einstellen, leider nur bis die Richtlinien wieder geladen werden. Denn nach aktualisieren der Richtlinien (mit \"gpupdate /force\" oder natürlich nach einem neu anmelden) wird der Schlüssel-Wert automatisch wieder auf \"0\" gesetzt und der Bildschirmschoner ist deaktiviert, selbst wenn die Gruppenrichtlinie \"Bildschirmschoner\" aktiviert ist.

Gemäss Erklärung in den Gruppenrichtlinien müssen zur Gruppenrichtlinie \"Bildschirmschoner\" folgende zwei Bedingungen erfüllt sein damit der Bildschirmschoner auch wirklich aktiviert wird (Zitat aus der Erklärung von Microsoft):

Durch Aktivieren dieser Richtlinie wird ein Desktopbildschirmschoner verwendet, falls die folgenden zwei Voraussetzungen zutreffen. Erstens muss ein gültiger Bildschirmschoner auf dem Client mit der Richtlinie \"Programmname des Bildschirmschoners\" oder über die Systemsteuerung des Clientcomputers festgelegt worden sein. Zweitens muss die Wartezeit für den Bildschirmschoner auf Null mit der Richtlinie oder über die Systemsteuerung gesetzt worden sein.

Punkt eins habe ich bestimmt erfüllt, bei Punkt zwei bin ich mir nicht sicher ob ich die Star-Übersetzer von Microsoft richtig verstehe. So wie ich den Satz interpretiere muss der Wert der Gruppenrichtlinie \"Bildschirmschoner-Zeitlimit\" auf 0 gesetzt sein, aber das macht doch auch keinen Sinn, oder? Jedenfalls ist es egal welchen Wert ich setze, die Gruppenrichtlinien deaktivieren mir den Bildschirmschoner in jedem Fall. Aus irgendeinem Grund will sich diese Gruppenrichtlinie also nicht aktivieren, aber woran kann das noch liegen?
Bitte warten ..
Mitglied: 67369
31.07.2008 um 10:02 Uhr
Ich kenne mich mit den Loginvorgängen auf Servern nicht aus, deshalb kann ich dir dazu leider auch keinen konkreten Tipp geben. Wenn es nicht die Gruppenrichtlinien sein sollten, die dort umherwurschteln, könnte noch etwas im Loginscript verborgen sein, nur so als vage Idee.

Wenn du kannst, probiere es auf einem Rechner mit einer lokalen Anmeldung aus, was damit dann passiert.

Man kann übrigens Regmon dazu veranlassen, die Vorgänge beim Rechnerstart zu protokollieren. Vielleicht hilft das, der Ursache für dein Problem auf die Spur zu kommen. Ob das allerdings auch den Loginvorgang über eine Domäne einschließt, ist mir nicht bekannt.
Bitte warten ..
Mitglied: SpunkEE
31.07.2008 um 10:57 Uhr
Also das LogIn-Script welches in den Richtlinien definiert ist führt bestimmt keine Anpassungen in der Regsitry durch, das kann ich mit Sicherheit sagen da es auch von mir erstellt wurde.

Melde ich mich lokal als Administrator an, so kann ich sämtliche Einstellungen des Bildschirmschoners ohne Probleme vornehmen. Melde ich mich wieder an der Domäne an (mein Domänen-Benutzer ist auf meinem Rechner ebenfalls lokaler Administrator), ist der Bildschirmschoner wieder hellgrau hinterlegt.

Ich vermute nun doch ein Problem in den Gruppenrichtlinien.
Und zwar weil mir der Befehl "gpupdate /force" den Registry-Wert "ScreenSaveActive" immer wieder auf "0" setzt, obwohl er gemäss den Gruppenrichtlinien auf "1" gesetzt werden sollte (Gruppenrichtlinie "Administrative Vorlagen / Systemsteuerung / Anzeige / Bildschirmschoner" (aktiviert)). Jedoch werden alle anderen Registry-Einträge des Bildschirmschoners mit den Gruppenrichtlinien korrekt gesetzt, nur dieser eine will sich einfach nicht aktivieren lassen.
Bitte warten ..
Mitglied: 67369
31.07.2008 um 11:40 Uhr
Das von dir beobachtete Verhalten lässt sich auch lokal reproduzieren.
Ich würde mich auf die Suche nach "Programmname des Bildschirmschoners" konzentrieren.

Ansonsten kann ich dir leider nicht weiterhelfen.
Bitte warten ..
Mitglied: SpunkEE
31.07.2008 um 13:30 Uhr
Vielen Dank, deine Tipps haben mich schon einen grossen Schritt weitergebracht, leider aber scheint es nicht am "Programmname des Bildschirmschoners" zu liegen. Dieser wird mir nach einstellen in den Gruppenrichtlinien korrekt in den Registry-Schlüssel "HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control Panel\Desktop\SCRNSAVE.EXE" (momentaner Wert: %windir%\system32\logon.scr) eingetragen. Und wenn ich dann den Bildschirmschoner aktiviere indem ich den Schlüsselwert "HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control Panel\Desktop\ScreenSaveActive" von 0 auf 1 setze ist auch gleich der gewünschte Bildschirmschoner aktiv. Aber die Gruppenrichtlinien setzen mir nach einem Update den "ScreenSaveActive" wieder auf "0".

Danke und mfG,
SpunkEE (der nun wieder weiss wesshalb er privat auf Linux umgestiegen ist)
Bitte warten ..
Mitglied: 67369
31.07.2008 um 13:34 Uhr
Wenn das eingetragene Programm tatsächlich im angegebenen Pfad vorhanden ist, ist z. B. der Button "Vorschau" anklickbar, der Rest ist ausgegraut. Ist ein falscher Programmname eingetragen, das Programm also nicht oder nicht im angegebenen Pfad vorhanden, ist der gesamte Inhalt der Registerkarte "Bildschirmschoner" ausgegraut. Ob der Wert von ScreenSaveActive dann wieder auf "0" zurückgesetzt wird, habe ich jetzt nicht überprüft.
Bitte warten ..
Mitglied: SpunkEE
31.07.2008 um 14:33 Uhr
Solange "ScreenSaveActive" auf "0" gestellt ist, sehen die Bildschirmschoner-Einstellungen aus wie auf dem Screenshot im ersten Beitrag (alles hellgrau). Dann ist es egal, was für ein Bildschirmschoner eingestellt ist, es wird immer "(kein)" Angezeigt und die Einstellungen lasen sich nicht anpassen. Sobald "ScreenSaveActive" den Wert 1 erhält (durch manuelles anpassen in der Registry), wird der in "Programmname des Bildschirmschoners" festgelegte Schoner eingestellt und die Buttons "Einstellungen" und "Vorschau" sind anklickbar.
Aber wie gesagt, sobald sich die Richtlinien aktualisieren wird für "ScreenSaveActive" wieder "0" gesetzt und somit ist der Bildschirmschoner ausgeschaltet.

mfG,
SpunkEE
Bitte warten ..
Mitglied: 67369
31.07.2008 um 14:49 Uhr
Dann muss ich passen, ich kann dir nicht weiterhelfen, da ich hier keinen Server zum Nachvollziehen zur Verfügung habe.

Ich würde höchstens versuchsweise dem SYSTEM mal den Vollzugriff auf den Key verweigern und ihm nur das Lesen gestatten.
Bitte warten ..
Mitglied: SpunkEE
31.07.2008 um 15:15 Uhr
Also ich hab jetzt mal noch das .adm-File ein bisschen angepasst (ist ein mega-Bastel, aber bei Microsoft nennt man das vermutlich"Standard-Lösung"), und zwar folgendermassen:

POLICY !!ScreenSaverActive
KEYNAME "Software\Policies\Microsoft\Windows\Control Panel\Desktop"
#if version >= 4
SUPPORTED !!SUPPORTED_Win2kSP1
#endif

EXPLAIN !!ScreenSaverActive_Help
VALUENAME "ScreenSaveActive"
VALUEON 1
VALUEOFF 1
END POLICY


wie man sehen kann, sollte nun, egal ob aktiviert oder deaktiviert, der Wert auf 1 gesetzt werden, wird er aber nicht, es wird IMMER "0" gesetzt.

Mit Berechtigungen in der Registry hab ich noch nie gearbeitet, da muss ich mich zuerst noch schlau machen drüber, aber danke für den Tipp.


mfG,
SpunkEE
Bitte warten ..
Mitglied: 67369
31.07.2008 um 15:22 Uhr
Das mit den Berechtigungen in der Registry funktioniert genau so wie mit Berechtigungen auf Dateien/Ordner. Key > Rechtsklick > Berechtigungen.

Wird da bei dir evtl. ein Standardprofil beim Login geladen und kopiert? Nicht dass du da an der falschen Stelle suchst.

Aber jetzt klinke ich mich wirklich aus. Für mich ist das Stochern im Nebel.
Bitte warten ..
Mitglied: SpunkEE
31.07.2008 um 15:49 Uhr
Das mit den Berechtigungen in der Registry lässt sich nicht so einfach testen. Ich kann dem "SYSTEM" zwar die Rechte nehmen (muss dafür zuerst die Verebung ausschalten), aber nach einem "gpupdate /force" sind die alten Berechtigungen wieder gesetzt und die Registry-Einträge ebenfalls angepasst.

Naja, ich such noch ein bisschen weiter...


mfG,
SpunkEE
Bitte warten ..
Ähnliche Inhalte
Windows 7
Bildschirmschoner-Einstellung wird trotz GPO nicht übernommen
gelöst Frage von fox14chWindows 72 Kommentare

Hallo zusammen Ich habe eine 2008R2 AD und 15 Stk Win7Pro Clients. Per GPO verteile ich die Bildschirmschoner-Einstellungen. Bei ...

Windows 7
Bildschirmschoner , Sperrbildschirm
gelöst Frage von ObertKWindows 71 Kommentar

Wir setzen bei uns in der Firma Windows 7 Pro ein. Über eine Gruppenrichtlinie wird nach 30 Minuten der ...

Windows 7
Bildschirmschoner wird nur gelegentlich aktiviert
gelöst Frage von CorraggiounoWindows 77 Kommentare

Hallo zusammen, ich habe Windows 7 64bit. und zudem den Bildschirmschoner aktiviert. Was ich nun beobachtet habe ist, dass ...

Windows Server
Bildschirmschoner per GPO
Frage von playmenWindows Server2 Kommentare

Hallo Zusammen Ich habe eine kleine Frage an euch: Kennt jemand einen Weg einen Bildschirmschoner welcher einen speziellen Text, ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 10 StundenApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 15 StundenWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 15 StundenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 TagInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...

Windows Server
SMBv1 deaktivieren führte zur Katastrophe, keine Domänenanmeldung mehr
Frage von Freak-On-SiliconWindows Server14 Kommentare

Servus; Habe Mist gebaut. Umgebung: Server 2012R2 Domäne 2x DC ~10 Memberserver (2012R2 und 2008R2) ~100 Windows 8 Clients ...

Windows XP
Windows XP Aktivieren geht nicht
Frage von tetikmiroWindows XP13 Kommentare

Hallo Ich habe einen Windows XP mit einen vCenter Converter umgezogen auf eine ESXI. Soweit funktioniert dies auch ohne ...

Grafikkarten & Monitore
2x 4K Monitore an einer GraKa betreiben
gelöst Frage von JollyJumper83Grafikkarten & Monitore10 Kommentare

Hallo liebe IT-Gemeinde, ich bin auf der Suche nach einer kostengünstigen GraKa für meinen Präsentations-PC. Wir möchten in unserem ...