Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Ejabberd - Konfiguration - Keine Verbindung von Clients möglich

Frage Internet Instant Messaging

Mitglied: mabue88

mabue88 (Level 2) - Jetzt verbinden

08.01.2015 um 20:34 Uhr, 2586 Aufrufe, 7 Kommentare

Hallo,

ich habe auf einen Raspberry Pi ejabberd installiert und lasse ihn als Server laufen.
Für den ersten Test habe ich einen User 'test' mit Passwort angelegt.

Bislang scheitert jeder Verbindungsaufbau von Clients obwohl Username und Passwort richtig sind.

Kennt sich jemand mit der Materie aus? Ich bin noch blutiger Anfänger!

Danke
Gruss
mabue
Mitglied: 114757
08.01.2015, aktualisiert um 23:48 Uhr
Moin mabue,
du erwähnst kein Wort zu deiner Firewall? An oder aus ?

Wenn aktiviert, dann folgende Ports freischalten:
5222(tcp/udp) 
5223 * 
5269 * 
5280 * 
5369 * 
53873 tcp
ejabberd installieren (Debian, Ubuntu)

Gruß jodel32
Bitte warten ..
Mitglied: mabue88
12.01.2015 um 14:15 Uhr
Hallo jodel32,

genau diese Anleitung habe ich verwendet.
Die Ports habe ich entsprechend geöffnet.
Aber weder vom Smartphone, noch vom Client auf meinem PC kann ich eine Verbindung zum Server aufbauen...
Bitte warten ..
Mitglied: 114757
12.01.2015, aktualisiert um 14:39 Uhr
Wie lautet die Fehlermeldung ? Welcher Client wird verwendet ? Was sagt Wireshark und die Logs ? Firewall auch mal deaktiviert?
Ohne mehr Info von deiner Seite ist das hier sehr schwer, sorry aber das müsstest du inzwischen hier ja kennen. Hier geht's nämlich nach genau dieser Anleitung.
Bitte warten ..
Mitglied: mabue88
12.01.2015 um 17:16 Uhr
Auf meinem Smartphone läuft Xabber (Android). Dort kommt lediglich die Meldung "Verbindungsfehler".
Auf dem PC verwende ich Pidgin. Dort kommt zwar keine Fehlermeldung, aber es bekommt auch keine Verbindung aufgebaut.

Wie kann ich die Firewall deaktivieren?

Bislang habe ich immer versucht, den Server innerhalb von meinem Netzwerk zu erreichen.

Mein Raspberry Pi besitzt den Hostnamen "rpi1". Entsprechend habe ich in der ejabberd-Konfiguration diesen Name als Hostname eingetragen.
Ist das prinzipiell korrekt? Die jeweiligen Benutzer sind dann zum Beispiel "user1@rpi1" und "user2@rpi1".

Könnte es sein, dass es Probleme gibt, wenn der DNS im Router manchmal Probleme mit den Hostnames hat?
Ist es auch möglich den ejabberd-Server auf die IP-Adresse des Gerätes zu konfigurieren?

Danke
Bitte warten ..
Mitglied: 114757
12.01.2015, aktualisiert um 21:20 Uhr
Zitat von mabue88:
Wie kann ich die Firewall deaktivieren?
http://www.cyberciti.biz/faq/turn-on-turn-off-firewall-in-linux/

Bislang habe ich immer versucht, den Server innerhalb von meinem Netzwerk zu erreichen.

Mein Raspberry Pi besitzt den Hostnamen "rpi1". Entsprechend habe ich in der ejabberd-Konfiguration diesen Name als
Hostname eingetragen.
Ist das prinzipiell korrekt?
Nicht so optimal wenn du nur den Router als DNS-Proxy benutzt, am besten wenn man hier den kompletten Domainnamen angibt. Wenn man z.B. zu Hause eine Fritzbox hat lautet der Domainname dann rpi1.fritz.box. Bei einer Speedport z.B. rpi1.speedport.ip In der Ethernetconfig (/etc/resolve.conf)gibt man ja auch normalerweise immer die SearchDomains mit an.

Die jeweiligen Benutzer sind dann zum Beispiel "user1@rpi1" und "user2@rpi1".

Könnte es sein, dass es Probleme gibt, wenn der DNS im Router manchmal Probleme mit den Hostnames hat?
yip, s.o.
Ist es auch möglich den ejabberd-Server auf die IP-Adresse des Gerätes zu konfigurieren?
hab ich noch nicht probiert, sollte aber funktionieren.

Gruß jodel32
Bitte warten ..
Mitglied: mabue88
12.01.2015 um 17:45 Uhr
Kleine Zwischeninfo: Hab als Hostname einfach mal die IP-Adresse des Raspberry Pis verwendet. Siehe da, innerhalb vom Netzwerk konnte ich mich sofort anmelden.

Den Rest teste ich bei Gelegenheit!

Trotzdem schon mal vielen Dank!
Bitte warten ..
Mitglied: horstvogel
27.01.2016, aktualisiert 16.02.2016
Hallo Mabue,
zwar schon über ein Jahr her,

aber wenn man sich lokal anmeldet bzw. direkt auf dem PC/Raspherry PI, dann muss man nur beim Benutzernamen nur admin eingeben und nicht admin@...... Dann geht das auch. Ich wurde da auch gelinkt.

Wie sind Deine Erfahrungen nach einem Jahr Ejabberd? Die Einstellung der Config Datei, da bricht man sich echt einen ab...

Hast Du http upload und Datei Upload in einer Konferenz umgesetzt?


Gibt es irgendwo deutsche Dokumentation? Eine funktionierende Config Datei mit "allen" Funktionen, wo man vielleicht nur noch den Hostnamen ändern muss.

der Horst
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Hyper-V
Win 10 HyperV Verbindung nicht möglich (3)

Frage von WPFORGE zum Thema Hyper-V ...

Netzwerke
Verbindung mit VPN-Verbindung nicht möglich (2)

Frage von Don-Santo zum Thema Netzwerke ...

Switche und Hubs
gelöst HP Procurve Switch 2650 J4899B Hängt, keine Verbindung möglich (7)

Frage von duke1212 zum Thema Switche und Hubs ...

Exchange Server
gelöst Outlook 2010 und 2013 Clients verlieren Verbindung zu Exchange 2016 (4)

Frage von glenncapri zum Thema Exchange Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (18)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...