Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Keine Emails von extern - SBS2011

Frage Microsoft Exchange Server

Mitglied: scirocco87

scirocco87 (Level 1) - Jetzt verbinden

12.05.2012 um 23:28 Uhr, 5771 Aufrufe, 16 Kommentare

Hallo,

ich habe folgendes Problem. Ich habe vor kurzem einen SBS 2011 Server installiert. Das versenden von Mails über SMTP funktioniert ohne Probleme aber sobald ich versuche eine Email von extern an einen Benutzer in der Domain zu senden, bekomme ich folgende Fehlermeldung:

xxx.xxx.xxx.xxx does not like recipient. Remote host said 550 5.7.1 unable to relay. Giving up on xxx.xxx.xxx.xxx (externe IP-Adresse)

MX Record ist auf die richtige IP gestellt.

Was kann da los sein?

Danke im Voraus,

lg
Mitglied: kaiand1
13.05.2012 um 01:56 Uhr
Moin
Nun die Meldung ist ja schon genau.
unable to relay
Das Problem liegt bei dir WIE du die Mail verschickst.
Von DialUp Verbindung dürfte das nix werden.
Bitte warten ..
Mitglied: scirocco87
13.05.2012 um 06:56 Uhr
Das Versenden funktioniert ja, nur das empfangen geht nicht.

xxx.xxx.xxx.xxx does not like recipient. Remote host said 550 5.7.1 unable to relay. Giving up on xxx.xxx.xxx.xxx (externe IP-Adresse)

Diese Fehler bekommen all die, die versuchen mir ein Mail zu senden.

lg
Bitte warten ..
Mitglied: scirocco87
13.05.2012 um 10:54 Uhr
Jetzt bekomm ich teilweise Mails von extern.

Nur wenn ich über http://www.mxtoolbox.com eine mx abfrage mache, kommt zwar die richtige ip mit dem MX Record mit, aber bei einem SMTP Test sto0e ich auf folgendes Ergenis!

Reverse DNS FAILED! This is a problem..



Reverse DNS FAILED! This is a problem..
OK - Supports TLS.
0 seconds - Good on Connection time
OK - Not an open relay.
5.944 seconds - Warning on Transaction Time
Session Transcript:
EHLO please-read-policy.mxtoolbox.com
250-remote.mydomain.at Hello [64.20.227.133]
250-SIZE 10485760
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-STARTTLS
250-AUTH
250-8BITMIME
250-BINARYMIME
250 CHUNKING [156 ms]
MAIL FROM: <supertool@mxtoolbox.com>
250 2.1.0 Sender OK [156 ms]
RCPT TO: <test@example.com>
550 5.7.1 Unable to relay [5164 ms]
QUIT
221 2.0.0 Service closing transmission channel [156 ms]


Wo soll ich einen Reverse Eintrag setzen?
Bitte warten ..
Mitglied: transocean
13.05.2012 um 11:45 Uhr
Moin,

wie versendest Du? Direkt oder über Relay?

Gruß

Uwe
Bitte warten ..
Mitglied: scirocco87
13.05.2012 um 12:19 Uhr
Direkt. MX Record wurde auf unsere externe IP umgestellt.

Also irgendwo muss ich noch einen Host - Eintrag setzen oder?

Danke lg
Bitte warten ..
Mitglied: transocean
13.05.2012 um 12:25 Uhr
Direkt .

Das ist erstmal schlecht. Schau dir in der Konsole mal die Funktion Smarthost einrichten an und führe die durch.

MX Record wurde auf unsere externe IP umgestellt.


Was aber mit dem Empfang der Mails von extern was zu tun hat.

Gruß

Uwe
Bitte warten ..
Mitglied: scirocco87
13.05.2012 um 12:41 Uhr
Ich hab das noch nicht granz durchblickt wie das mit Smarthost funktioniert.

Der Smarthostserver ist der Mailserver des Providers oder lieg ich da falsch?

Wenn ich diesen konfiguriere muss ich aber den MX-Record wieder umstellen auf Provider Adresse?

Danke für deine Hilfe
Bitte warten ..
Mitglied: transocean
13.05.2012 um 12:49 Uhr
Der Smarthostserver ist der Mailserver des Providers oder lieg ich da falsch ?

Richtig.

Wenn ich diesen konfiguriere muss ich aber den MX-Record wieder umstellen auf Provider Adresse?


Nein.

Gruß

Uwe
Bitte warten ..
Mitglied: GuentherH
13.05.2012 um 14:35 Uhr
Hi.

MX Record wurde auf unsere externe IP umgestellt.

Das kann nicht sein. Ein MX-Record muss immer auf einen Host zeigen.

Reverse DNS FAILED! This is a problem

Das wiederum hat nichts mit dem Empfang zu tun, sondern mit dem Versand. Wenn dieser nicht korrekt konfiguriert ist, werden die meisten deiner Mails die du versendest im SPAM Filter des Empfängers liegen.

Gehe also Schritt für Schritt vor. Verwende für den Versand wie schon empfohlen den Smart Host deines Providers. Damit ist einmal das Reverse DNS Problem erledigt.
Konfiguriere dann den MX-Record sauber.

Und denke immer daran, MX ist für den Empfang zuständig, und hat mit dem Versand absolut nichts zu tun. Lies dir auf jeden Fall einmal die Grundlagen dazu z.B. auf Wikipedia durch.

LG Günther
Bitte warten ..
Mitglied: HubertN
13.05.2012 um 14:49 Uhr
Moin

Sorry, aber hier wird gerade so unglaublich viel Unsinn verzapft... (Damit meine ich sicher nicht dich Günther... Dein Beitrag war erst da, nachdem ich getextet und abgeschickt hatte)

Direkt .
Das ist erstmal schlecht. Schau dir in der Konsole mal die Funktion Smarthost einrichten an und führe die durch.

Mal grundsätzlich: Eine Kombination aus direkter Zustellung und Versand über einen Smarthost macht weniger Sinn als gar keinen. Dadurch wirst du eher Probleme bekommen, als Probleme abzuschaffen. Grundsätzlich gilt, dass du eine saubere DNS-Konfiguration für deine Domäne haben musst. Das hat dann weniger mit dem Empfang zu tun sondern eher mit dem Versand. Andere Mailserver prüfen ggf. diverse Angaben zu deiner Domain, bevor sie sich bereit erklären eine Nachricht mit dieser Absenderangabe zu akzeptieren. In dem Zusammenhang sollte ein Reverse-Lookup für deinen Mailserver schon korrekt funktionieren. Wenn du nun die Maildienste für Versand und Empfang auf mehrere Server auteilst, dann wird es schon einmal deutlich komplizierter eine saubere Konfiguration zu erzeugen.
Und was an einer direkten Mailzustellung nun schlechtes dran sein soll ?

Finger weg davon, einen Smarthost zu konfigurieren. Das hat nun wiklich nichts mit deiner Problematik zu tun. Im Thread ist klar zu erkennen, dass es sich nicht um ein DNS-Probvlem handelt. ich gehe davon aus, dass die im NDR angegebene IP-Adresse um deine eigene öffentliche IP handelt.
Du hast dein Problem mit dem Empfang der Mails. Und im Grunde genommen wird dir der Grund ja direkt mitgeteilt: Unable to relay. Deine Mailserver weigert sich auf der Empfangseite für deine Domain ein internes Relay durchzuführen.

Und nun mal was konstruktives zu Problemlösung:
Die erste Frage, die sich mir dann erst mal stellt ist die, ob du bei der Installation die Assistenten zur Konnektivität in der SBS-Konsole hast sauber durchlaufen lassen. Dabei wird dein Exchangeserver normalerweise so konfiguriert, dass er die Mails korrekt annimmt. Solltest du das also nicht getan haben, dann mache das erst einmal. Wenns dann immer noch nicht geht, dann sehen wir mal weiter.

Gruß

Hubert

edit:
xxx.xxx.xxx.xxx does not like recipient. Remote host said 550 5.7.1 unable to relay. Giving up on xxx.xxx.xxx.xxx (externe IP-Adresse)

ist xxx.xxx.xxx.xxx nun deine eigene IP oder nicht ?
Bitte warten ..
Mitglied: scirocco87
13.05.2012 um 15:54 Uhr
Danke für eure antworten. Im Prinzip weiß ich was ein MX-Record ist. Dieser ist auch auf einen Hostname gestellen. (mx.meindomain.at -> diese verweist auf die öffentliche IP-Adresse unseres Routers Cisco PIX 501.) Port 25 wird über Router auf den Exchange Server weitergeleitet. Soviel zur Konfig.

Desweitern habe ich den Assisten erfolgreich abgeschlossen und auf unsere Domain konfiguriert.

Leider kann ich auch aus welchen Problemen auch immer keine Mails empfangen bzw. senden. Hin und wieder kann zwar ein Mail empfangen werden aber das nur einzeln oder es sind gar nur Spam Mails.

Muss ich DNS bzw. den Port zum Exchange über den Router auch fowarden? Oder muss ich irgendwo im internen DNS meine externe IP angeben?

Danke euch weiterhin für eure Hilfe.

xxx.xxx.xxx.xxx ist die öffentliche IP von unseren Router. (will ich aus sicherheitsgründen nicht in klartext schreiben)

lg
Bitte warten ..
Mitglied: transocean
13.05.2012 um 15:57 Uhr
xxx.xxx.xxx.xxx ist die öffentliche IP von unseren Router.

Und die ist dynamisch oder statisch?

Gruß

Uwe


Nachtrag: Falls Du eine statische (feste) IP Adresse hast, dann solltest Du den A-Record der Domäne auf eben diese feste IP setzen.
Bitte warten ..
Mitglied: scirocco87
13.05.2012 um 16:54 Uhr
Das ist eine statische IP.
Bitte warten ..
Mitglied: HubertN
13.05.2012 um 20:31 Uhr
Zitat von scirocco87:
(mx.meindomain.at -> diese verweist auf die öffentliche IP-Adresse unseres Routers Cisco PIX 501.) Port 25 wird über Router auf den Exchange Server weitergeleitet.

Weshalb du dir eben auch keine Gedanken um die DNS-Konfigutaion oder eine Portweiterleitung machen musst. Dein Exchange ist ja erreichbar.

Leider kann ich auch aus welchen Problemen auch immer keine Mails empfangen bzw. senden. Hin und wieder kann zwar ein Mail
empfangen werden aber das nur einzeln oder es sind gar nur Spam Mails.

Was denn nun ? Oben war es noch so, dass du Senden kannst, der Empfang aber nicht geht ?! Hin und wieder ist eher eine schlechte Voraussetzung zur Fehlersuche.

Muss ich DNS bzw. den Port zum Exchange über den Router auch fowarden? Oder muss ich irgendwo im internen DNS meine externe
IP angeben?

s.o.

Du musst dann wohl mal die Exchangekonsole selbst bemühen müsssen um dem Problem auf die Spur zu kommen. Ist die Domain wirklich autorisierend eingetragen worden ? Gibt es einen Empfangsconnector, der in der Lage ist, Mails aus dem Internet für diese Domain zu empfangen ?
Bitte warten ..
Mitglied: scirocco87
13.05.2012 um 21:07 Uhr
Scheinbar funktioniert das empfangen von Mails immer mehr. Es kommen aufjedenfall genug Spam Mails und auch genug normale Mails durch. Vermutlich dauert das ein wenig bis es funktioniert. Sonst kann ich mir das nicht erklären.

Aber beim versenden bekomme ich hin und wieder folgende Meldung:

Inconsistent or no rDNS record for [externe IP] (see RFC1912 2.1) http://www.ietf.org/rfc/rfc1912.txt Reverse DNS record and matching forward entry must exist. => wrong configuration at sending server [externe IP]

Was soll ich bei dieser Meldung machen? DNS hat sich beim einrichten von selbst installiert. Aufösung intern funktioniert auch.

Danke für eure Hilfe, ich weiß frage ziemlich blöd aber ich kämpf nun schon fast zwei Tage mit diesem Server.

lg
Bitte warten ..
Mitglied: GuentherH
14.05.2012 um 08:15 Uhr
Hi.

Lies dir doch meinen ersten Beitrag durch, da habe ich dir bereits geschrieben, dass wahrscheinlich die meisten deiner Mails im SPAM landen werden. Und ich habe dir auch geschrieben, du solltest einstweilen über Smart Host versenden bis das Problem gelöst ist.

Den korrekten PTR setzt übrigens nicht du sondern der Inhaber deiner externen IP Adresse. An diesen musst du dich wenden.

LG Günther
Bitte warten ..
Neuester Wissensbeitrag
Festplatten, SSD, Raid

12TB written pro SSD in 2 Jahren mit RAID5 auf Hyper-VServer

Erfahrungsbericht von Lochkartenstanzer zum Thema Festplatten, SSD, Raid ...

Ähnliche Inhalte
Exchange Server
gelöst SBS2011 Owa und Activesync funktionieren nach V2V Umzug nicht mehr (2)

Frage von Anulu1 zum Thema Exchange Server ...

Windows Server
WSUS Neuinstallation auf SBS2011 schlägt fehl (3)

Frage von Blongmon zum Thema Windows Server ...

Exchange Server
gelöst SBS2011 - im Exchange mobile Geräte löschen (4)

Frage von MiSt zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...