Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Emails aus einem Verzeichnis automatisch versenden

Frage Microsoft Outlook & Mail

Mitglied: KeiosID

KeiosID (Level 1) - Jetzt verbinden

01.03.2010 um 08:28 Uhr, 3930 Aufrufe, 2 Kommentare

Ich möchte unter Nutzung des SMTP Server von Microsoft Exchange Emials aus einer Applikation versenden, Probleme beim Mailer Daemon

Hallo,

Ich versende aus einer Anwendung(Streamserve) automatisch Mails(Rechnungen).

Allerdings bekomme ich bei fehlerhaften Mailadressen keinen MailerDaemon. Nach einigen Recherechen und Tests bin ich
darauf gestossen, dass das Programm bei fehlerhaften Mailadressen keinen MailerDaemons erhält.

Kann es so auch nicht, da die Applikation selber kein Postfach ist/ hat.

Genutz wird ein Mailfolder auf unserem SMTP Server. Der Versand funktioniert einwandfrei, nur eben die Benarichtigung
bei einer fehlerhaften Adressen landet nicht im entsprechenden Postfach des versendenden Mailfolders.

Alternativ bin ich nun auf der Suche, nach einer weiteren Applikation, die dass umgehen kann.
Diese Applikation sollte bestenfalls.
- Anhand eine XML Datei(oder auch andere Steuerungsdatei) Mails mit Anhang und Body versendne
- Antwortmails sollten im Postfach des angezeigten Versenders landen.
- Die APplikation sollte unseren SMTP Server nutzen


Gibt es hier eine Lösung?
DIes Lösung dürfte auch etwas kosten, im vernünftigen Rahmen.


Danke

Gruß

KEiosID
Mitglied: michaelkrauth
01.03.2010 um 09:12 Uhr
Hallo,

sorry, ich versteh die Frage nicht

Nein, im Ernst...
Du lieferst die Mail per SMTP auf einem Mailserver ein, der sie dann an den Empfänger-Mailserver weiterleitet. Kommt es dabei zu einem Problem sollte der sendeseitige Server eine Fehlermeldung entweder selbst generieren oder, falls der Fehler weiter hinten in der Kette auftritt, eine solche an Dich als den Absender der Mail weiterleiten. In beiden Fällen bekommst Du eine Fehlermeldung ins Postfach. Der Client (Deine Applikation) hat damit erst mal wenig zu tun, der muss sie maximal anzeigen.

Kannst Du vielleicht noch etwas näher beschreiben, welchen Weg die Mail geht und welche Meldung/Aktion Du wo erwartest? Ich begreife das Problem nämlich irgendwie nicht so ganz.

42m
Bitte warten ..
Mitglied: KeiosID
01.03.2010 um 14:25 Uhr
Hi,

das Problem wurde gelöst.

Hier ist es tatsächlich die Applikation, die den Fehler verursacht,
wenn eine fixe ReplyTo Adresse eingetragen ist.

Diese rausgenommen und das Problem hat sich erledigt, da nun der Mailerdaemon tatsächlich an
die versendende Adresse zurückgeht.

Danke

Grüße

Keios
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
Batch & Shell

Batch - ein paar Basics die man kennen sollte

Tipp von Pedant zum Thema Batch & Shell ...

Microsoft

Restrictor: Profi-Schutz für jedes Window

(6)

Tipp von AlFalcone zum Thema Microsoft ...

Batch & Shell

Batch zum Zurücksetzen eines lokalen Profils

Tipp von Mr.Error zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Microsoft Office
Saubere HTML aus Word-Dokument (16)

Frage von peterpa zum Thema Microsoft Office ...

Router & Routing
ASUS RT-N18U mit VPN Client hinter Fritzbox - Portforwarding (15)

Frage von marshall75000 zum Thema Router & Routing ...

Hosting & Housing
gelöst Webserver bei WIX, aber DNS Server wo anders (9)

Frage von laster zum Thema Hosting & Housing ...

Debian
gelöst Plesk php-fpm Fehler (7)

Frage von sebastian2608 zum Thema Debian ...