Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Emailsvesand per blat

Frage Microsoft Exchange Server

Mitglied: Marcys

Marcys (Level 2) - Jetzt verbinden

03.10.2009 um 07:48 Uhr, 11383 Aufrufe, 5 Kommentare

Hallo,

auf meiner virtuellen Testumgebung mit auf einem SBS 2003 und Exchange 2003 möchte ich per blat befehl eine Email senden.

Dazu gebe ich in der Komandozeile folgendes ein:

blat c:\bat\backup.log -subject "Datensicherung " -to meineemailadersse@freenet.de

Doch es kommt die meldung:

Der Befehl blat ist enweder falsch geschrieben oder konnte nicht gefunden werden.

von der Seite http://sourceforge.net/projects/blat/files/ habe ich mir die Version 2.62 herunter geladen und die Datei blat.exe aus dem Zipverzeichnis gestartet.

Nach erneuer eingabe des blat Befehlt kommt wieder sie selbe meldung:

Der Befehl blat ist enweder falsch geschrieben oder konnte nicht gefunden werden.


Habe ich einen Denkfehler oder was mache ich falsch?

Gruß
Maratin
Mitglied: jamie87
03.10.2009 um 08:05 Uhr
Hallo,

probier mal folgendes:

Blat -install %Computername% %Absenderadresse%
Blat %Pfad der Textdatei% -to %Empfängeradresse% -server %IP-Mailserver% -subject "%Betreff%"

Sollte es nicht klappen, einfach nochmal melden.

Gruß Jamie
Bitte warten ..
Mitglied: Marcys
03.10.2009 um 08:33 Uhr
Hi,

habe es irendwie geschaft. Der mailversand funz jetzt mit dem folgendem befehl:


echo Testmail | blat.exe - -server meinserver -to administrator@domäne -f administrator@domäne -s Betreff


Der Mailversand mit Anhang jedoch nicht. Habe mal folgende Varianten ausprobiert:
- Dein Vorschlag von oben: Blat c:\bat\backup.log -to meine@email -server meinservehostname -subject "Betreff"

Darauf hin kam die Meldung:
Failed to open registry key for Blat
To set the SMTP server's name/address and your username/email address for that
server machine do:
blat -install server_name your_email_address
or use '-server <server_name>' and '-f <your_email_address>'
aborting, nothing sent

Dan hab ich maldiese VAriante versucht:

echo Testmail | blat.exe c:\backup.log -to emailadresse -server servehostname -subject "Betreff"
und die selbe Meldung von Oben kam erneut.
Bitte warten ..
Mitglied: jamie87
03.10.2009 um 08:50 Uhr
Hallo,

um den Fehler "Failed to open registry key for Blat" musst du deshalb zuerst diese Zeile schreiben:
Blat -install %Computername% %Absenderadresse%

Der registriert/installiert dir Blat.
Danach kannst du das von dir schreiben.

Gruß
Bitte warten ..
Mitglied: Marcys
03.10.2009 um 10:20 Uhr
prima alles funz. wunderbar...
Bitte warten ..
Mitglied: Marcys
27.12.2009 um 11:36 Uhr
Hallo,

ich würde gerne noch mal auf mein Beitrag zurück kommen.

Mit dem Befehl:

Blat.exe "c:\backup_profile.log" -to administrator@domäne.de -server 192.168.178.60 -subject "Backup Profile"

wird eine Mail per Blat mit dem Inhalt der Datei "backup_profile.log" verschickt.

Das klappt ja soweit gut. Ich möchte jedoch dass die Datei "backup_profile.log" an die Mail angehangen wird und nicht dass der Ihnahlt dieser Datei in die Mail gepackt wird.

Wie kann ich den Datei anhänge per Blat versänden und nicht deren Inhalt?

Gruss
Martin
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
Aufgabenplaner - E-Mail Benachrichtigung mittels blat.exe (7)

Frage von staybb zum Thema Windows Server ...

E-Mail
gelöst BLAT zum Mail versenden. Fehler für mich nicht lösbar (25)

Frage von 130217 zum Thema E-Mail ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...