Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Emailversand unter Debain etch funktioniert nicht

Frage Linux Linux Netzwerk

Mitglied: Notausstieg

Notausstieg (Level 1) - Jetzt verbinden

24.12.2007, aktualisiert 26.12.2007, 6986 Aufrufe, 9 Kommentare

über PHP und dem mail-Befehl gesendete Emails werden nicht vom System verschickt.

Hy,

ich hab seit kurzen einen Debian-Server (Debian 5.0) im Inet hängen. drauf läuft ein Forum welches Emails über die PHP Funktion "mail()" verschickt. nun ist die Sache das die E-mails nicht ankommen. Mein Linux Lehrer meinte das man keine zusätzlichen Pakete benötigt um über PHP mails zu verschicken.

Könnt Ihr mir helfen?

Danke
Mitglied: theton
24.12.2007 um 22:13 Uhr
Ist ein Mailserver oder sonst ein Programm installiert, das den sendmail-Befehl mitbringt?
Bitte warten ..
Mitglied: Notausstieg
25.12.2007 um 11:20 Uhr
der sendmail-befehl existiert. wenn ich den nutze (oder auch den mail-befehl) dan sagt der nix an Fehler.
nur die E-mail kommt nicht an. Das ist mein Problem. und die Log-Dateien sind auch noch leer. kein Eintrag.
Bitte warten ..
Mitglied: Notausstieg
25.12.2007 um 11:24 Uhr
ich hab nochmal nachgeguggt. Der exim4-Dienst gibt mir beim VErsand der Mail flgenes in der Log-Datei aus:

01.
2007-12-24 00:49:19 1J6aZL-0002EK-T4 <= www-data@webserver U=www-data P=local S=1519 
02.
2007-12-24 00:49:20 1J6aZL-0002EK-T4 ** abcdef@gmx.de <Abcdef@gmx.de> R=nonlocal: Mailing to remote domains not supported 
03.
2007-12-24 00:49:20 1J6aZM-0002EM-0i <= www-data@webserver U=www-data P=local S=1740 
04.
2007-12-24 00:49:20 1J6aZM-0002EN-13 <= <> R=1J6aZL-0002EK-T4 U=Debian-exim P=local S=2332 
05.
2007-12-24 00:49:20 1J6aZL-0002EK-T4 Completed
Wie kann ich einstellen, dass er das mailen an Remote Domains "supported"
Bitte warten ..
Mitglied: theton
25.12.2007 um 23:51 Uhr
Offenbar lauscht dein Mailserver nur an localhost und ist nicht an dein Netzwerk-Interface gebunden. Das kannst du in der exim-Konfiguration ändern oder mittels 'dpkg-reconfigure exim4'.
Bitte warten ..
Mitglied: Notausstieg
26.12.2007 um 13:30 Uhr
Hy,

ich hab das ganze jetzt mal auf Basis dieses Tutorials. Jetzt ist auch alles so drinne wie es im tutorial gemacht ist. Hier mal ein Auszug aus der logdatei.

01.
Dec 26 13:21:20 webserver postfix/smtp[16169]: smtp_connect_addr: trying: mx.freenet.de[195.4.92.19] port 25... 
02.
Dec 26 13:21:20 webserver postfix/smtp[16169]: global TLS level: none 
03.
Dec 26 13:21:21 webserver postfix/smtp[16169]: < mx.freenet.de[195.4.92.19]: 220 9.mx.freenet.de ESMTP Exim 4.68 Wed, 26 Dec 2007 13:21:50 +0100 
04.
Dec 26 13:21:21 webserver postfix/smtp[16169]: > mx.freenet.de[195.4.92.19]: EHLO webserver 
05.
Dec 26 13:21:21 webserver postfix/smtp[16169]: < mx.freenet.de[195.4.92.19]: 250-9.mx.freenet.de Hello p57acbbab.dip0.t-ipconnect.de [87.172.187.171] 
06.
Dec 26 13:21:21 webserver postfix/smtp[16169]: < mx.freenet.de[195.4.92.19]: 250-SIZE 104857600 
07.
Dec 26 13:21:21 webserver postfix/smtp[16169]: < mx.freenet.de[195.4.92.19]: 250-ETRN 
08.
Dec 26 13:21:21 webserver postfix/smtp[16169]: < mx.freenet.de[195.4.92.19]: 250-PIPELINING 
09.
Dec 26 13:21:21 webserver postfix/smtp[16169]: < mx.freenet.de[195.4.92.19]: 250-AUTH LOGIN PLAIN CRAM-MD5 
10.
Dec 26 13:21:21 webserver postfix/smtp[16169]: < mx.freenet.de[195.4.92.19]: 250-STARTTLS 
11.
Dec 26 13:21:21 webserver postfix/smtp[16169]: < mx.freenet.de[195.4.92.19]: 250 HELP 
12.
Dec 26 13:21:21 webserver postfix/smtp[16169]: server features: 0x103d size 104857600 
13.
Dec 26 13:21:21 webserver postfix/smtp[16169]: Using ESMTP PIPELINING, TCP send buffer size is 4096 
14.
Dec 26 13:21:21 webserver postfix/smtp[16169]: maps_find: smtp_sasl_passwd: hash:/etc/postfix/sasl_passwd(0,lock|fold_fix): mx.freenet.de = soulshifters:soulshifters 
15.
Dec 26 13:21:21 webserver postfix/smtp[16169]: smtp_sasl_passwd_lookup: host `mx.freenet.de' user `username' pass `passwort' 
16.
Dec 26 13:21:21 webserver postfix/smtp[16169]: starting new SASL client 
17.
Dec 26 13:21:21 webserver postfix/smtp[16169]: name_mask: noanonymous 
18.
Dec 26 13:21:21 webserver postfix/smtp[16169]: smtp_sasl_authenticate: mx.freenet.de[195.4.92.19]: SASL mechanisms LOGIN PLAIN CRAM-MD5 
19.
Dec 26 13:21:21 webserver postfix/smtp[16169]: warning: SASL authentication failure: No worthy mechs found 
20.
Dec 26 13:21:21 webserver postfix/smtp[16169]: connect to subsystem private/defer 
21.
Dec 26 13:21:21 webserver postfix/smtp[16169]: send attr nrequest = 0 
22.
Dec 26 13:21:21 webserver postfix/smtp[16169]: send attr flags = 0 
23.
Dec 26 13:21:21 webserver postfix/smtp[16169]: send attr queue_id = C9758BD47 
24.
Dec 26 13:21:21 webserver postfix/smtp[16169]: send attr original_recipient = root@soulshifters.de.vu 
25.
Dec 26 13:21:21 webserver postfix/smtp[16169]: send attr recipient = root@soulshifters.de.vu 
26.
Dec 26 13:21:21 webserver postfix/smtp[16169]: send attr offset = 176 
27.
Dec 26 13:21:21 webserver postfix/smtp[16169]: send attr dsn_orig_rcpt = 
28.
Dec 26 13:21:21 webserver postfix/smtp[16169]: send attr notify_flags = 0 
29.
Dec 26 13:21:21 webserver postfix/smtp[16169]: send attr status = 4.7.0 
30.
Dec 26 13:21:21 webserver postfix/smtp[16169]: send attr diag_type = x-sasl 
31.
Dec 26 13:21:21 webserver postfix/smtp[16169]: send attr diag_text = no mechanism available 
32.
Dec 26 13:21:21 webserver postfix/smtp[16169]: send attr mta_type = 
33.
Dec 26 13:21:21 webserver postfix/smtp[16169]: send attr mta_mname = 
34.
Dec 26 13:21:21 webserver postfix/smtp[16169]: send attr action = delayed 
35.
Dec 26 13:21:21 webserver postfix/smtp[16169]: send attr reason = SASL authentication failed; cannot authenticate to server mx.freenet.de[195.4.92.19]: no mechanism available 
36.
Dec 26 13:21:21 webserver postfix/smtp[16169]: private/defer socket: wanted attribute: status 
37.
Dec 26 13:21:21 webserver postfix/smtp[16169]: input attribute name: status 
38.
Dec 26 13:21:21 webserver postfix/smtp[16169]: input attribute value: 0 
39.
Dec 26 13:21:21 webserver postfix/smtp[16169]: private/defer socket: wanted attribute: (list terminator) 
40.
Dec 26 13:21:21 webserver postfix/smtp[16169]: input attribute name: (end) 
41.
Dec 26 13:21:21 webserver postfix/smtp[16169]: C9758BD47: to=<root@soulshifters.de.vu>, relay=mx.freenet.de[195.4.92.19]:25, delay=0.22, delays=0.02/0.01/0.19/0, dsn=4.7.0, status=deferred (SASL authentication failed; cannot authenticate to server mx.freenet.de[195.4.92.19]: no mechanism available) 
42.
Dec 26 13:21:21 webserver postfix/smtp[16169]: flush_add: site soulshifters.de.vu id C9758BD47 
43.
Dec 26 13:21:21 webserver postfix/smtp[16169]: match_list_match: soulshifters.de.vu: no match 
44.
Dec 26 13:21:21 webserver postfix/smtp[16169]: flush_add: site soulshifters.de.vu id C9758BD47 status 4 
45.
Dec 26 13:21:21 webserver postfix/smtp[16169]: > mx.freenet.de[195.4.92.19]: QUIT 
46.
 
Dabei stört mich diese Zeile:
01.
Dec 26 13:21:21 webserver postfix/smtp[16169]: warning: SASL authentication failure: No worthy mechs found 
02.
03.
Dec 26 13:21:21 webserver postfix/smtp[16169]: send attr reason = SASL authentication failed; cannot authenticate to server mx.freenet.de[195.4.92.19]: no mechanism available 
04.
 
was soll das. brauch ich noch spezielle pakete die diese authentifizierungsmechanismen haben oder wie?

vielen dank für eure Hilfe

Grüße Notausstieg
Bitte warten ..
Mitglied: theton
26.12.2007 um 13:40 Uhr
Du solltest mal deinen MTA ordentlich konfigurieren. Normalerweise lässt man den Versand über localhost auch ohne Authentifizierung zu. Alternativ machst du die Authentifizierung komplett aus und blockst Port 25 via iptables, so dass nur über localhost ein Zugriff auf den Mailserver möglich ist. Das geht natürlich nur, wenn der MTA Mails wirklich nur versenden, nicht aber empfangen soll.

Eine Anleitung zur Exim-Konfiguration findest du unter http://archiv.debianhowto.de/de/exim3/c_exim3.html
Bitte warten ..
Mitglied: Notausstieg
26.12.2007 um 14:46 Uhr
Hy,

danke für deine Hilfe. MEin Client wird nun ordentlich authentifiziert am Server von frenet.de nur hab ich noch ein kleines Problemchen:

01.
Connecting to mx.freenet.de [195.4.92.19]:25 ... connected 
02.
  SMTP<< 220 9.mx.freenet.de ESMTP Exim 4.68 Wed, 26 Dec 2007 14:41:31 +0100 
03.
  SMTP>> EHLO webserver 
04.
  SMTP<< 250-9.mx.freenet.de Hello p57acbbab.dip0.t-ipconnect.de [87.172.187.171] 
05.
         250-SIZE 104857600 
06.
         250-ETRN 
07.
         250-PIPELINING 
08.
         250-AUTH LOGIN PLAIN CRAM-MD5 
09.
         250-STARTTLS 
10.
         250 HELP 
11.
  SMTP>> STARTTLS 
12.
  SMTP<< 220 TLS go ahead 
13.
  SMTP>> EHLO webserver 
14.
  SMTP<< 250-9.mx.freenet.de Hello p57acbbab.dip0.t-ipconnect.de [87.172.187.171] 
15.
         250-SIZE 104857600 
16.
         250-ETRN 
17.
         250-PIPELINING 
18.
         250-AUTH LOGIN PLAIN CRAM-MD5 
19.
         250 HELP 
20.
  SMTP>> AUTH CRAM-MD5 
21.
  SMTP<< 334 PDIxMTA5LjExOTg2NzY0OTFAOS5teD4= 
22.
  SMTP>> **************************************************************************** 
23.
  SMTP<< 235 Authentication succeeded 
24.
  SMTP>> MAIL FROM:<root@webserver> SIZE=1368 AUTH=root@webserver 
25.
  SMTP>> RCPT TO:<markus-bloch@web.de> 
26.
  SMTP>> DATA 
27.
  SMTP<< 250 OK 
28.
  SMTP<< 550-Verification failed for <root@webserver> 
29.
         550-unrouteable mail domain "webserver" 
30.
         550 verifying root@webserver failed 
31.
  SMTP<< 503-All RCPT commands were rejected with this error: 
32.
         503-verifying root@webserver failed 
33.
         503 Valid RCPT command must precede DATA 
34.
  SMTP>> QUIT
jedoch sagt er dann bei
01.
 SMTP>> MAIL FROM:<root@webserver> SIZE=1368 AUTH=root@webserver 
02.
  SMTP>> RCPT TO:<markus-bloch@web.de> 
03.
  SMTP>> DATA 
04.
  SMTP<< 250 OK 
05.
  SMTP<< 550-Verification failed for <root@webserver> 
06.
         550-unrouteable mail domain "webserver"
wiede rnein. Kann cih den Absender auf eine feste Adresse einstellen? So das alle mails mit diesem Absender ausgestattet werden, da der Server anhand der Absender email nochmal prüft ob ich das wirklich bin.

Danke

Grüße

Notausstieg
Bitte warten ..
Mitglied: theton
26.12.2007 um 14:54 Uhr
Soweit ich weiss, geht das nur über ein Adress-Rewriting. Inwieweit das bei Exim auch für Absender-Adressen untersützt wird, weiss ich allerdings nicht, da ich eher auf Postfix setze. Dein Problem wird nur eher sein, dass deine Mails ziemlich überall als Spam gehandhabt werden, wenn dein Mailserver keine richtige Domain bzw. keinen richtigen MX-Eintrag hat.
Bitte warten ..
Mitglied: Notausstieg
26.12.2007 um 15:22 Uhr
Hy

es geht. HURRA!!!

einfach in der /etc/exim4/email-addresses den Eintrag
01.
root: absenderadresse@freenet.de 
02.
www-data: absenderadresse@freenet.de
hinzugefügt und jetzt sagt er nix mehr.

Vielen Dank für die tolle Hilfe
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Linux
LTSP: PXE Boot funktioniert nicht (15)

Frage von Fenris14 zum Thema Linux ...

Virtualisierung
Drucker aus einer VM heraus funktioniert nicht (5)

Frage von NCCTech zum Thema Virtualisierung ...

LAN, WAN, Wireless
gelöst Netzwerk funktioniert nur in eine Richtung mit Gigabit (28)

Frage von DrChiwago zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...

Exchange Server
DNS Einstellung - zwei feste IPs für Mailserver (15)

Frage von ivan0s zum Thema Exchange Server ...