Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Erfolgreiche Installation eines HotFixes verifizieren

Frage Sonstige Systeme

Mitglied: R00KIE

R00KIE (Level 1) - Jetzt verbinden

18.09.2006, aktualisiert 31.08.2007, 4476 Aufrufe, 5 Kommentare

HotFix Installation via Registry-Eintrag verifizieren, um sie mit Quest Reporter auslesen zu können.

Moin!

Mein Problem ist wie folgt:
Ich möchte mittels einer Software (Quest Reporter) ein Report ziehen, der mir Auskunft darüber erteilt, auf welchem Server der ausgerollte HotFix erfolgreich installiert wurde. Die soll über das Auslesen eines Registry-Keys erfolgen.
Ich weiß, dass alle installierten HotFixes unter [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\HotFix\KB-Artikel] einen Registry-Key anlegen. Dies alleine gibt jedoch noch keine Auskunft darüber, ob der HotFix auch erfolgreich installiert wurde, da der Key auch dann angelegt wird, wenn der HotFix nicht erfolgreich installiert werden konnte.
Nun meine Frage: Wo in der Registry wird geschrieben, welcher Hotfix tatsächlich installiert ist? Ist es ein Value innerhalb des Keys, welches auf einen bestimmten Wert gesetzt wird; oder ein Subkey?

Vielen Dank für Eure Mühe!
-R00KIE
Mitglied: 11078
18.09.2006 um 18:29 Uhr
Hallo,

wenn erfolgreich installiert, dann findet sich folgender Wert unterhalb von [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\HotFix\KB-Artikel]:


Installed DWORD 1

Eventuell wichtig ist vielleicht auch folgender:

Valid DWORD 1


Gruß,
Tim
Bitte warten ..
Mitglied: R00KIE
18.09.2006 um 18:52 Uhr
Danke, Tim!!

Das habe ich mir auch schon gedacht. Ich habe nur nirgends etwas dazu gefunden. Bist du dir sicher, dass es der richtige Wert ist? Ich möchte nämlich damit über 800 Server abfragen. Da wäre es unangenehm für mich, wenn mir da ein Fehler unterläuft! xD
Weißt du das so -also aus Erfahrung- oder hast du dazu eine Quelle für mich?

Noch mal vielen Dank für Deine Hilfe-
Chrissibert
Bitte warten ..
Mitglied: 11078
18.09.2006 um 19:38 Uhr
Hallo,

hier steht ein wenig über diese Registry-Schlüssel:

http://www.microsoft.com/germany/technet/datenbank/articles/600338.mspx ...

Der Schlüssel "Installed" wird noch benutzt, den kannst Du also getrost abfragen. Da die Hotfix-Einträge innerhalb des Hotfix-Installationsvorgangs ganz zum Schluss in die Registry geschrieben werden, sollte es anscheinend auch ausreichen, einfach abzufragen, ob ein entsprechender "kb..."-Eintrag existiert. Wenn das Hotfix aufgrund eines Fehlers nicht fertig installiert wird, dürften eigentlich auch keine "kb..."-Einträge dafür in der Regisry stehen.

Den Schlüssel "valid" kannst Du doch vergessen, der wird laut Microsoft nicht mehr verwendet.


Da hab ich auch wieder etwas mehr gelernt


Gruß,
Tim
Bitte warten ..
Mitglied: R00KIE
18.09.2006 um 21:15 Uhr
Yeah! Super, Tim!

Vielen, vielen Dank für Deine Hilfe!!

Liebe Grüße-
Chrissibert
Bitte warten ..
Mitglied: TerryMcCann
31.08.2007 um 09:57 Uhr
Danke, Tim!!

Das habe ich mir auch schon gedacht. Ich
habe nur nirgends etwas dazu gefunden. Bist
du dir sicher, dass es der richtige Wert ist?
Ich möchte nämlich damit über
800 Server abfragen. Da wäre es
unangenehm für mich, wenn mir da ein
Fehler unterläuft! xD
Weißt du das so -also aus Erfahrung-
oder hast du dazu eine Quelle für mich?

Noch mal vielen Dank für Deine Hilfe-
Chrissibert

800 Server ???? Wow, wo arbeitest Du?
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Windows Tools
gelöst DotNet Installation schlägt fehl (1)

Frage von emeriks zum Thema Windows Tools ...

Ubuntu
gelöst Mailcow Installation schlägt fehlt (4)

Frage von ClepToManix zum Thema Ubuntu ...

Windows Server
TeamViewer 11 MSI Installation schlägt fehl (13)

Frage von Ghost108 zum Thema Windows Server ...

Windows 7
gelöst Notebook - keine Installation eines OS mehr möglich (6)

Frage von mike7050 zum Thema Windows 7 ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (20)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...