Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

erhalte keinen PXE Reply vom PXE-Server

Frage Netzwerke

Mitglied: illematitsch

illematitsch (Level 1) - Jetzt verbinden

24.08.2006, aktualisiert 28.08.2006, 14242 Aufrufe, 3 Kommentare

Hallo Admins,

Habe das Problem, dass ich PXE-Clients nicht üer PXE booten kann. Dazu folgende Vorgeschichte:

Clients gleichen Typs konnten sich bisher ohne Probleme via PXE-Boot mit dem PXE- und TFTP-Server verbinden. Ein Unterschied besteht allerdings: Diese Clients waren nicht durch einen Router bzw. Switch von dem PXE-Server getrennt, sondern nur vom DHCP-Server. Also die Vermutung, dass der PXE-Broadcast nicht weitergeleitet wird. Nun ja, ein Relay Agent für den PXE-Server war schnell eingerichtet, hat das Problem aber nicht behoben, die Fehlermeldung blieb die gleiche (PXE-E53 no filename recieved). Kann es sein dass mich eine Firewall noch hindern kann? Wenn ja welchen Port müsste man freigeben? Habe mich schon durch einige Dokus gekämpft, aber nichts in der Richtung gefunden. Hat jemand von euch eine Ahnung?

Ist-Zustand: - Problem-Clients befinden sich im unterschiedlichem Netz zum PXE-Server und zum DHCP-Server
- Problem-Clients und die anderen Clients werden vom gleichen DHCP-Server mit gleichen Bereichsoptionen bedient
- DHCP Server und PXE Server befinden sich in verschiedenen Netzen
- DHCP- und PXE-Relay-Agents sind eingerichtet
- DHCPREQUEST und DHCPOFFER erfolgreich
- PXE-REQUEST nicht erfolgreich -> Abbruch
- wie gesagt, Clients im gleichem Netz zum PXE-Server haben dieses Problem nicht


Mit freundlichen Grüßen
Mitglied: JohnnyB
25.08.2006 um 12:28 Uhr
PXE-E53: No boot filename received. Der Client hat mindestens ein gültiges DHCP/BOOTP OFFER bekommen, aber er hat keinen Boot-Dateinamen zum Download. Dafür gibt es mehrere Ursachen:

  • Der DHCP Server und der PXE Server waren ursprünglich auf dem selben System, aber einer von beiden wurde auf ein anderes System verelegt. Dies würde zu einer falschen PXE Server Konfiguration führen. Um dieses Problem zu lösen, muß die PXE Server Komponente neu installiert werden.

  • Der DHCP Relay Agent, entweder ein Proxy DHCP Server oder ein mit Hilfsadressen konfigurierter Switch, ist nicht korrekt konfiguriert. Wenn z.B. DHCP und PXE auf unterschiedlichen Systemen sind, so braucht der DHCP Relay Agent beide Adressen in seiner Konfiguration. Um dieses Problem zu lösen, muß die DHCP Relay Agent Konfiguration korrigiert werden.

  • Wenn der Microsoft DHCP Service auf dem PXE Server installiert ist, aber deaktiviert oder unkonfiguriert ist, konfiguriert PXE Setup den PXE Server trotzdem so, daß der lokale DHCP Service verwendet wird (auch wenn der DHCP Service deaktiviert ist). Dies führt dazu, daß der PXE Server nicht auf PXE Clients antwortet, die ihre DHCP-Adresse von einem anderen DHCP-Dienst im Netzwerk erhalten. Um dieses Problem zu lösen, muß der Microsoft DHCP Service vom PXE Server entfernt und anschließend die PXE Server Komponente neu installiert werden.

P.S. Die Verwendeten Ports sind 67/UDP, 68/UDP, 69/UDP und 4011/UDP, welcher Port für was, sowie weiterführende Links: http://de.wikipedia.org/wiki/Preboot_Execution_Environment

HTH, Johnny.
Bitte warten ..
Mitglied: aqui
25.08.2006 um 20:55 Uhr
Wenn dort ein Router zwischenhängt bleiben UDP Brodcasts sowieso lokal. Ich meine das PXE nur Layer 2 fähig ist aber das nur mit Vorbehalt.
Ist da wirklich ein Router zwischen musst du eine "ip helper" Adresse einrichten, die dediziert solche UDP Broadcasts in das Zielsegment forwardet. Sind es außerdem andere Ports als DHCP müssen diese meist noch explizit im Router konfiguriert werden. Bei Cisco und einer Reihe anderer Router Hersteller heisst dieses Kommando "ip forward protocoll xxx".

Du kannst das relativ einfach verifizieren indem du einfach am PXE Bootserver einen Hub mit parallelgeschaltetem Sniffer (Ethereal.com oder Wireshark) nutzt und dir dort die Packetsequenz ansiehst die bei einem Bootrequest dort eingeht.
Das vergleichst du einfach mit demselben Szenario in einem Layer 2 Design (gleiches Netzwerk)
Fehlen Packete, dann weisst du sofort was es ist.
Bitte warten ..
Mitglied: illematitsch
28.08.2006 um 18:57 Uhr
Vorab schonmal Danke! Ich kann das leider nicht direkt testen, da ich über die Router und Switch keine Verfügungsgewalt habe, aber ich werde mich nochmal melden und feedback liefern. Das die Ports da noch eine Rolle spielen, kann ich mir auch gut vorstellen, da eine ip-helper bereits (ohne gewünschten Erfolg) eingerichtet ist. Ob ich das mit dem Sniffer machen darf muss ich noch klären (Security ), aber ich denk der wird erst nötig, wenn das mit den Ports auch net klappt.

THX
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Linux
LTSP: PXE Boot funktioniert nicht (15)

Frage von Fenris14 zum Thema Linux ...

Windows Installation
PXE Boot-Von CD Starten (2)

Frage von STITDK zum Thema Windows Installation ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...