Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

ERLEDIGT - Excel 2000 - In Bereichen suchen

Frage Microsoft Microsoft Office

Mitglied: thecaptain

thecaptain (Level 1) - Jetzt verbinden

04.05.2007, aktualisiert 05.05.2007, 3064 Aufrufe, 2 Kommentare

Hallo,

ich habe eine Tabelle, in der in einer Spalte Kostenstellen und der Bereich ist als "Text" formatiert. Ich möchte mit Hilfe einer Formel überprüfen, ob in dieser Spalte eine bestimmte Kostenstelle vorkommt.

Ich habe mir die Formel ungefähr so vorgestellt:
=WENN(SUCHEN(1050;A1:A8)=1;"Kostenstelle gefunden";"")
=WENN(SUCHEN(1050;A1:A8)=WAHR;"Kostenstelle gefunden";"")

Aber das funktioniert nicht so richtig. In meiner Testdatei habe ich eine Hand voll Kostenstellen, von denen eine die gesuchte ist - er müsste es also finden. Meistens schreibt er aber "#NAME?". Klickt man dann auf die Zelle um z.B. die Formel nochmal zu überprüfen schreibt er beim nächsten Versuch manchmal auch "#WERT!" und gaaanz selten klappt es sogar.
Also meiner Meinung nach ist hinter dem Fehler kein System zu erkennen zumal es ebenso wenig klappt, wenn ich in die Spalte Worte reinschreibe.

Habe ich einen generellen Denkfehler in der Formel oder ist Excel einfach nur buggy?
Mitglied: bastla
04.05.2007 um 15:52 Uhr
Hallo thecaptain!

In diesem Fall warst Du auf dem falschen Dampfer *SCNR*:
SUCHEN dient dem Durchsuchen eines Textes, nicht eines Zellbereiches.

Versuch es einmal so:
01.
=WENN(ZÄHLENWENN(A1:A8;1050)>0;"Kostenstelle gefunden";"")
Grüße
bastla
Bitte warten ..
Mitglied: thecaptain
05.05.2007 um 08:16 Uhr
Super, es funktioniert. Solche Details muss man eben wissen.
Bitte warten ..
Ähnliche Inhalte
VB for Applications
Excel Makro zum Suchen von Spalten und exportieren in CSV (3)

Frage von Raptox zum Thema VB for Applications ...

Microsoft Office
gelöst Excel (2016): Enthaltenen Text suchen (3)

Frage von ralfkausk zum Thema Microsoft Office ...

Microsoft Office
gelöst Excel: Wert aus mehreren Datein suchen und zugehörige Werte ausgeben (11)

Frage von RubyLissy zum Thema Microsoft Office ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Viren und Trojaner
Ransomware .nm4 (15)

Frage von Zyklo92 zum Thema Viren und Trojaner ...

iOS
16 iPads zentrall verwalten (14)

Frage von simonlohr zum Thema iOS ...

Microsoft Office
+1.000 Ordner in Outlook: Wie besser? (11)

Frage von Matsushita zum Thema Microsoft Office ...