Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

ERLEDIGT - Excel 2000 - In Bereichen suchen

Frage Microsoft Microsoft Office

Mitglied: thecaptain

thecaptain (Level 1) - Jetzt verbinden

04.05.2007, aktualisiert 05.05.2007, 3051 Aufrufe, 2 Kommentare

Hallo,

ich habe eine Tabelle, in der in einer Spalte Kostenstellen und der Bereich ist als "Text" formatiert. Ich möchte mit Hilfe einer Formel überprüfen, ob in dieser Spalte eine bestimmte Kostenstelle vorkommt.

Ich habe mir die Formel ungefähr so vorgestellt:
=WENN(SUCHEN(1050;A1:A8)=1;"Kostenstelle gefunden";"")
=WENN(SUCHEN(1050;A1:A8)=WAHR;"Kostenstelle gefunden";"")

Aber das funktioniert nicht so richtig. In meiner Testdatei habe ich eine Hand voll Kostenstellen, von denen eine die gesuchte ist - er müsste es also finden. Meistens schreibt er aber "#NAME?". Klickt man dann auf die Zelle um z.B. die Formel nochmal zu überprüfen schreibt er beim nächsten Versuch manchmal auch "#WERT!" und gaaanz selten klappt es sogar.
Also meiner Meinung nach ist hinter dem Fehler kein System zu erkennen zumal es ebenso wenig klappt, wenn ich in die Spalte Worte reinschreibe.

Habe ich einen generellen Denkfehler in der Formel oder ist Excel einfach nur buggy?
Mitglied: bastla
04.05.2007 um 15:52 Uhr
Hallo thecaptain!

In diesem Fall warst Du auf dem falschen Dampfer *SCNR*:
SUCHEN dient dem Durchsuchen eines Textes, nicht eines Zellbereiches.

Versuch es einmal so:
01.
=WENN(ZÄHLENWENN(A1:A8;1050)>0;"Kostenstelle gefunden";"")
Grüße
bastla
Bitte warten ..
Mitglied: thecaptain
05.05.2007 um 08:16 Uhr
Super, es funktioniert. Solche Details muss man eben wissen.
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Microsoft Office
gelöst Excel VBA Letzte Zelle Suchen dann rechnen und Wert in Zelle Übertragen (3)

Frage von Addi089 zum Thema Microsoft Office ...

Batch & Shell
Powershell - In Textdatei suchen und ersetzen (3)

Frage von Raaja89 zum Thema Batch & Shell ...

Microsoft Office
Prüfung von Intervallen und Textausgabe in Excel (2)

Frage von traller zum Thema Microsoft Office ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...